This is what I see:

GNU GRUB version 2.02~beta2-9ubuntu1

Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completions.

grub> _

What should I do now?

  • 2
    The message means something wrong happened with the bootloader. Nothing else can be said or suggested unless more information is given. Ubuntu release/version? Is Ubuntu standalone or in dual boot with other OS? What happened exactly before the event, what were you doing, etc.?
    – user589808
    Feb 16, 2017 at 12:32
  • 3 days ago i bought a new dell laptop with ubuntu 14.04...it was working fine until yesterday...when starting this new laptop first time i take the dell recovery media (factory settings reset) in image file format in download folder...so today i want to restore to its factory settings...then it started the installation process and stucks in mid and asked me to reboot the system saying that installer has crashed...then i reboot it and i get this above problem... Feb 16, 2017 at 13:38
  • 1
    Please help me...what should i do now Feb 16, 2017 at 13:39
  • If it's a factory installed Ubuntu then you should contact Dell support directly.
    – user589808
    Feb 16, 2017 at 13:39
  • Ubuntu was standalone Feb 16, 2017 at 13:40

11 Answers 11


I copied from eli's answer in Unix forum

Cause: boot process can't find the root partition


Please type ls This will show all partitions, and then type individual

ls (hd0,1)/
ls (hd0,2)/ 

... and so on, until you find like

(hd0,1)/boot/grub or (hd0,1)/grub

In case of EFI,

(hd0,1)/efi/boot/grub or (hd0,1)/efi/grub... now set the boot parameters accordingly, just type this with your number

set prefix=(hd0,1)/grub
set root=(hd0,1)
insmod linux
insmod normal

now it would boot and please open the Terminal and put this command line

sudo update-grub ... it should boot correctly in the next time. If not, you have to go through the steps again. In other case, you might have to repair or install grub again, please look at this article.

My SW: Windows 10 and Ubuntu 16.04 dual boot

HW: HP Pavilion 15t

  • 2
    This works for me, but does not work for subsequent boots (even after running sudo update-grub) Mar 19, 2020 at 15:33
  • 1
    @geoffn91, If not fix in the second booting, please consider Ubuntu solution at help.ubuntu.com/community/Boot-Repair
    – Cloud Cho
    Mar 19, 2020 at 17:27
  • 6
    instead of (hd0,1)/efi/boot/grub ; I see (hd0,1)/efi/boot/ with three things : bootx64.efi, fbx64.efi, mmx64.efi --- no grub dir
    – pyeR_biz
    Oct 1, 2021 at 6:43
  • 1
    @pyeR_biz, Thanks for sharing your case. Please try method at help.ubuntu.com/community/Boot-Repair.
    – Cloud Cho
    Oct 1, 2021 at 16:20
  • 2
    That solution was perfect to me but I had to execute sudo grub-install too
    – FerranB
    Sep 4, 2022 at 0:04

You got a problem with the bootloader. You should initialize kernel. First use command ls, then adjust the following commands according to it. In the place of hd0 write your disk and in 1 write your number.

grub> set root=(hd0,1)
grub> linux /vmlinuz-4.4.0-38-generic 
grub> initrd /initrd.img-4.4.0-38-generic
grub> boot

If you don't know what your version of the kernel is, write:

grub> linux /vmlTab
grub> initrd /inTab

FIRST try only grub> boot

  • linux /vml gives file '/vml' not found on KDE Neon 5.23. Oct 22, 2021 at 9:20

Not a permanent fix, but you should be able to continue just by exiting:

grub> exit

This will continue to either the grub menu (if you have a dual boot system) where you can choose which OS you want to boot, or directly to your primary operating system. This is a common problem with dual booting a system with UEFI bootloader.

  • 3
    In my case this brings me back to the terminal, and the 2nd exit boots to the primary OS. Feb 29, 2020 at 3:09
  • This works for me as a work-around. Is there a permanent fix for this? This is a little annoying because it prolongs booting.
    – Lutosław
    May 24, 2023 at 16:23

For Ubuntu 21.04, after a boot repair from usb, I got

grub> insmod all_video
grub> insmod linux
grub> linux /boot/vmlinuz root=/dev/sda2
grub> initrd /boot/initrd.img
grub> boot

And. . . Booted!!!

  • file '/boot/vmlinuz' not found Oct 22, 2021 at 9:21
  • 2
    Worked. Thanks a lot. Jul 5, 2023 at 7:54

I got into this state by installing ubuntu onto an external USB SSD enclosure. The installer had modified the file in /boot/efi/EFI/ubuntu/grub.cfg to point to the new drive. When I removed the USB enclusure, the machine dropped me to the grub> prompt.

Based on the answers here: I was able to boot the old drive from the grub> prompt by running:

set prefix=(hd0,gpt1)/boot/grub
set root=(hd0,gpt1)/boot
insmod normal

You'll need to select the right prefix/root for your machine (use tab to autocomplete).

I then modified the search.fs_uuid line in /boot/efi/EFI/ubuntu/grub.cfg to point to the old drive, and it booted as it did before.

search.fs_uuid 2cbadaa8-abad-4991-b99d-bbadbad99dbe root 
set prefix=($root)'/boot/grub'
configfile $prefix/grub.cfg

I replaced the uuid by a uuid based on the output of:


I did try some of the procedures suggested above to not avail.I don't believe anyone suggested a simple boot fix tool available out there already so here it is: https://help.ubuntu.com/community/Boot-Repair or just search on the Ubuntu help site for boot repair tool.


When trying to install ubuntu on hp pavilion I got the same. Used ESC + F9 to launch BIOS boot menu, I found both windows and Ubuntu. Both worked fine.


I ran into this issue today, I have Linux installed alongside windows and I wanted to remove ubuntu and I directly deleted the partition from windows from disk management on windows 10 without actually deleting the grub menu. As a result whenever I rebooted the system I would see that black screen with that the grub terminal.This basicall happens when the system couldn’t find a OS to boot from so it would go into that grub terminal. so what you need to do is modify your boot order.

  • boot your system by entering the command “reboot”.
  • keep pressing F2 inorder to go into bios, This key varies based on the make of your device in my case I was using a Lenovo ideapad so it would work.
  • Once you have the bios menu using the arrow keys go to “boot” section then you need to change the boot order under “EFI” by pressing f5,f6 keys in my case I deleted the ubuntu partition so I moved the windows to top.

enter image description here

  • after you change the boot order press f10 to save and exit and your system will boot into your desired OS (windows in my case).

Originally posted here: https://qr.ae/pGDLeh


Diskgenius screenshot of sda

Regarding "and so on, until you find like (hd0,1)/boot/grub or (hd0,1)/grub". The situation can be different as you can see in the figure.

  • 1
    As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Dec 7, 2023 at 6:26

FYI, for anyone stumbling upon this post now - I got stuck in grub >, and grub > ls wasn't producing anything.

grub > boot produced:

error: you need to load kernel first

Unplugging the USB mouse and restarting fixed it.

grub> ls

Get the data members

grub> ls (hd0,gpt2)/
grub> ls (hd0,gpt2)/boot
grub> set root=(hd0,gpt2)
linux /boot/vmlinuz-4.15.0-20
  • 6
    In case the questioner is not as familiar with command line operations as you are, perhaps you could add a few words of explanation as to what these commands do and why you suggest doing them. Jul 30, 2019 at 13:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .