1

I had dual booted my Acer Aspire V with Ubuntu 14 recently to try it out. I followed guides online on how to remove it from my computer. First I deleted the Ubuntu partitions then used a flash drive with Windows 8 on it to fix MBR.

Nothing has worked. Every time I boot I get an error. It says "GNU GRUB version 2.02~beta2-9ubuntu1" at the top the of the screen. Under that it says "Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completions". My laptop came with windows 8 installed on it, which I believe means it's EFI. Any help would be greatly appreciated.

As for now I've been booting into Windows by mashing F12 during boot and selecting Windows Boot Manager in the list that pops up. It shows up twice in the list, and only the second one down works for some reason. Thank you.

1
  • ESP or efi system partition may not be sda1, but you do need to first delete the /EFI/ubuntu folder. IF you moved any other files around in efi partition you must undo that, so you just have clean Windows /EFI/Microsoft folder. Then remove ubuntu from UEFI menu. askubuntu.com/questions/63610/… Make sure system is set for UEFI boot not CSM (BIOS)
    – oldfred
    Commented Apr 19, 2015 at 20:26

2 Answers 2

2

Boot into an Ubuntu Live CD/USB and open a terminal. Run sudo mount -t vfat -o iocharset-utf8,umask=000 /dev/sda1 /mnt/sda1. You'll need to run sudo mkdir /mnt/sda1 first. Once it's mounted, browse the EFI drive in Nautilus and delete every folder called "Ubuntu".

2
  • I tried that and I got this: 'mount: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so'
    – Jonasty
    Commented Apr 24, 2015 at 3:37
  • @Jonasty OK. Run Gparted in the Live CD instead and see which drive is formatted as FAT32 Commented Apr 24, 2015 at 10:37
2

Edit the boot order in your BIOS settings (press F2 during boot) and put the Windows Boot Manager in the top of the list.

1
  • Simplest solution, this worked for me :) Commented Feb 1, 2020 at 13:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .