The title may sound silly, but on Ubuntu 13.10, I'm getting frequent audible notifications using text to speech.

Is this the "speech dispatcher" and how can I disable it?

  • 5
    Settings > Universal Access > Screen Reader > Off/On
    – Pithikos
    Commented Feb 7, 2018 at 22:05
  • There might be a new icon in the top bar. If you click on it you can enable/disable several things, like the screen reader. (the Icon looks like this) Commented Aug 5, 2020 at 12:30

9 Answers 9


Pressing AltSuperS will disable or enable speech dispatcher.

The last thing you should hear is "screen reader off" :-

ps. The Super key is the "windows" key...

  • 2
    many thanks! I'm almost gone nuts already Still didn't manage to find a corresponding setting to disable it completely in Linux mint 19.3 Tried 'universal', 'seeing', 'read', 'speech', 'accessibility' in system search bar.
    – Drey
    Commented Jul 16, 2021 at 5:03
  • 2
    Thank you! My silly cat walked on my laptop and I had no idea what he did!!! LOL Commented Feb 20, 2023 at 18:45
  • Thanks:D ,for a moment I thought my ubuntu got hacked and it seemed I accidently enable it :D Commented Apr 25, 2023 at 3:46
  • Thank you, this thing is really disturb me... Commented May 2, 2023 at 15:08

Go to the Settings application. Select Universal Access. You will see a tab labeled "Seeing". In there should be Screen Reader. Turn that off.


I had the same problem maybe, starting with Ubuntu 15.04. The Screen reader is off, same with the dispatcher setting; but it keeps telling me what I'm typing.

I have running four dispatcher, all at the time that can't be killed because they're starting again directly. To solve my problem, I went to System Settings -> Sound. On Applications, I muted the four speech-dispatcher.

  • Worked. But mine is Ubuntu 13.10 Commented Jul 1, 2015 at 4:23
  • Thanks to your comment, I solved my speech-dispatcher not working issue! espeak was functionning normally but no sound was coming out of spd-say. It was a simple volume issue, went to the settings you mentioned and voila. Thanks.
    – wotter
    Commented Dec 14, 2019 at 16:04

Do you want to change the systemwide settings for Speech Dispatcher? The (yes/no) systemwide settings for Speech Dispatcher can be changed by editing the /etc/default/speech-dispatcher file.

Open the terminal and from the terminal open the /etc/default/speech-dispatcher file for editing in nano text editor:

sudo nano '/etc/default/speech-dispatcher'  

Find the lines in speech-dispatcher that say:

# Set to yes to start system wide Speech Dispatcher

...and change RUN=yes to RUN=no.

This will disable the system wide speech dispatcher audible notifications, if they have been previously enabled. Press the keyboard combination Ctrl+O and after that press Enter to save the speech-dispatcher file. Press the keyboard combination Ctrl+X to exit nano.

You can still toggle enable/disable the screen reader after it has been turned off systemwide by using the keyboard shortcut Alt+Super+S

  • Sorry for the delayed acceptance!
    – ljs.dev
    Commented Jun 26, 2014 at 22:51
  • mine is no and is still talking
    – Mona Jalal
    Commented Feb 15, 2017 at 21:01

Maybe "orca" has bean launched. Kill the "orca" (Screen Reader) process, then you should hear "screen reader off".


Go to universal access under settings then turn off the screen reader


I was also facing same problem with Laptop My solution was simple System -> Sound -> Application and then I muted all four Speech-dispatcher and it solves my issue.


You can disable it in following ways :-

Press Alt + Super + S

or goto System Settings > Universal Access > Turn Off Screen Reader

If you will check your System Setting > Sound > Applications then may be you can find that some instance of Speech Dispatcher is running. You can kill the running instances in this way:-

deepak@SpiritualDixit-PC:~$ ps aux | grep speech
deepak    2593  0.0  0.0 289004  5076 ?        Sl   10:10   0:00 /usr/lib/speech-dispatcher-modules/sd_dummy /etc/speech-dispatcher/modules/dummy.conf
deepak    2599  0.0  0.0 289004  5008 ?        Sl   10:10   0:00 /usr/lib/speech-dispatcher-modules/sd_cicero /etc/speech-dispatcher/modules/cicero.conf
deepak    2603  0.1  0.1 531004  9608 ?        Sl   10:10   0:03 /usr/lib/speech-dispatcher-modules/sd_espeak /etc/speech-dispatcher/modules/espeak.conf
deepak    2632  0.0  0.0 289016  5024 ?        Sl   10:10   0:00 /usr/lib/speech-dispatcher-modules/sd_generic /etc/speech-dispatcher/modules/generic.conf
deepak    2635  0.0  0.0 104284  2320 ?        Ssl  10:10   0:00 /usr/bin/speech-dispatcher --spawn --socket-path /run/user/1000/speech-dispatcher/speechd.sock --port 6560 --communication-method unix_socket
deepak    4708  0.0  0.0  21292   944 pts/9    S+   11:05   0:00 grep --color=auto speech
deepak@SpiritualDixit-PC:~$ kill 2593
deepak@SpiritualDixit-PC:~$ kill 2599
deepak@SpiritualDixit-PC:~$ kill 2603
deepak@SpiritualDixit-PC:~$ kill 2632
deepak@SpiritualDixit-PC:~$ kill 2635
deepak@SpiritualDixit-PC:~$ ps aux | grep speech
deepak    4719  0.0  0.0  21292   944 pts/9    S+   11:06   0:00 grep --color=auto speech
  • Also, mind the shortcut in the menu bar in gnome shell. Universal reader was disabled in my settings but enable in the menu bar
    – MCMZL
    Commented Oct 21, 2019 at 13:53

On my Debian 12 as root

apt remove orca

did the trick.

It probably works the same in Ubuntu.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .