2,250
reputation
18
26

Lambart

The first commands I run when I install Ubuntu 18.04:

gsettings set org.gnome.shell.window-switcher current-workspace-only true
gsettings set org.gnome.shell.app-switcher current-workspace-only true
gsettings set org.gnome.shell.extensions.dash-to-dock isolate-workspaces true
gsettings set org.gnome.desktop.interface gtk-enable-primary-paste true
gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-1 "['<Alt>1']"
gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-2 "['<Alt>2']"
gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-3 "['<Alt>3']"
gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-4 "['<Alt>4']"
gsettings set org.gnome.desktop.wm.keybindings toggle-maximized "['<Super>x']"
gsettings set org.gnome.desktop.wm.keybindings maximize-vertically "['<Super>v']"
gsettings set org.gnome.desktop.wm.keybindings maximize-horizontally "['<Super>h']"

# window buttons on the left, please 
gsettings set org.gnome.desktop.wm.preferences button-layout 'close,minimize,maximize'

gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier '<Alt>'
gsettings set org.gnome.desktop.peripherals.mouse natural-scroll false

gsettings set org.gnome.desktop.wm.preferences num-workspaces 4
gsettings set org.gnome.mutter dynamic-workspaces false
gsettings set org.gnome.mutter workspaces-only-on-primary false

# Custom kb shortcuts
# Super-C
gsettings set org.gnome.settings-daemon.plugins.media-keys.custom-keybinding:/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom0/ binding '<Super>c'
gsettings set org.gnome.settings-daemon.plugins.media-keys.custom-keybinding:/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom0/ command '/snap/bin/gnome-calculator'
gsettings set org.gnome.settings-daemon.plugins.media-keys.custom-keybinding:/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom0/ name "Calculator"

# Super-E
gsettings set org.gnome.settings-daemon.plugins.media-keys.custom-keybinding:/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom1/ binding '<Super>e'
gsettings set org.gnome.settings-daemon.plugins.media-keys.custom-keybinding:/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom1/ command '/usr/bin/gedit'
gsettings set org.gnome.settings-daemon.plugins.media-keys.custom-keybinding:/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom1/ name "Text Editor"

# Register the custom shortcuts
gsettings set org.gnome.settings-daemon.plugins.media-keys custom-keybindings "['/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom0/','/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom1/']"

# fix up some apps
sudo apt install vim-gnome gimp gnome-tweaks clementine
sudo apt remove rhythmbox

# if on a laptop:
gsettings set org.gnome.desktop.interface show-battery-percentage true
14
answers
5
questions
~231k
people reached
  • Portland, OR
  • Member for 8 years, 1 month
  • 274 profile views
  • Last seen May 22 at 16:19

Top tags (32)

Score 8
Posts 2
Posts % 11
Score 8
Posts 2
Score 8
Posts 2
Score 7
Posts 6
Score 6
Posts 4
Score 3
Posts 2

Top posts (19)

View all questions and answers

Badges (44)

Gold

Silver

18

Rarest

Bronze

26

Rarest