Hot answers tagged

554

With a question as weird as this, it's of course impossible to say for sure -- but I'll eat my hat if my first hunch isn't correct. :) The only way I can think of, how such unrelated things could be linked is this: After installing (well, extracting) Dwarf Fortress, instead of going to the directory every time and running it with ./df, you wanted to be able ...


333

I figured out how to get apt-get to work again. Edit gai.conf: sudo vim /etc/gai.conf change line ~54 to uncomment the following: precedence ::ffff:0:0/96 100 write and quit: :wq CAUTION Look out line 50 which looks almost identical: precedence ::ffff:0:0/96 10 This is the wrong line. Go ~4 lines down and you'll find the correct line to uncomment ...


199

Note: this answer is meant to be more of an 'explanation' than providing the best/easiest way to remove old kernels. For the best/easiest way to remove old kernels, please review the other answers. Okay, so from the output of /etc/fstab you posted, it seems that your /boot is mounted on a separate partition, and from the output of df -h, that partition is ...


150

Try these commands (although the third one may not be necessary for you): sudo apt-get update sudo apt-get upgrade sudo apt-get dist-upgrade A reboot may or may not be necessary (sudo shutdown -r 0)


145

I know this question has been answered and is a year old, but I feel this needs to be said. Ubuntu 14.04 and later (and Debian Jessie and later, for those finding this from Google) uses APT 1.0, which allows the command apt instead of apt-get and apt-cache for some operations. apt-get upgrade will not change what is installed (only versions), apt-get dist-...


142

You need to add the Git Maintainers repository in order to get the latest Git version. Please run these commands in order: sudo add-apt-repository ppa:git-core/ppa sudo apt-get update sudo apt-get install git Then, check the version of the installed Git: git --version It's not always necessary to remove the existing Git before upgrading it, but if you ...


129

The instructions @andrew-beerman posted are on the right track, though they aren't quite clear to me and seem to recommend more than is necessary. I pieced together the answer from the above and a helpful post in the bug thread. These are the steps I took to correct this: Back up your my.cnf file in /etc/mysql and remove or rename it sudo mv /etc/mysql/...


106

You could use the ppa for the almost-always latest version sudo add-apt-repository ppa:cwchien/gradle sudo apt-get update sudo apt upgrade gradle or SDKMAN for the latest version curl -s "https://get.sdkman.io" | bash source "$HOME/.sdkman/bin/sdkman-init.sh" sdk install gradle Advantages of the ppa auto-updates with the system no piping of downloaded ...


98

apt-get update updates only the package lists. To actually upgrade the packages you have to run: sudo apt-get upgrade or sudo apt-get dist-upgrade More info here. If you ran the above commands but the packages still were not upgraded, probably you didn't add Ondřej Surý's PHP PPA to your system. Run the following to add the PPA: For PHP 5.5, PHP 5.6 ...


92

Ubuntu 15.04 is not available yet and will be available in April. If you really want to test it you can download the daily build iso from here although this is highly unstable now. After the release you can upgrade from 14.10 to 15.04 by running the following command: sudo do-release-upgrade I would not recommend this but if you really want to upgrade to ...


91

When you ran apt-get upgrade, where there any "not upgraded"? Eg: Reading package lists... Done Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. Looking at 0 not upgraded. If there were ones that were not upgraded, run apt-get dist-upgrade


85

I usually just run the following commands to upgrade both pip2 (=pip by default) and pip3: sudo -H pip3 install --upgrade pip sudo -H pip2 install --upgrade pip You must make sure that you upgrade the version (for Python 2 or 3), which you want to react on the command pip without number, last. Also please note that this keeps the old packaged versions ...


84

See https://discourse.ubuntu.com/t/focal-fossa-20-04-1-lts-point-release-status-tracking/17604 for the current status. On 25 September 2020, the final upgrade-blocking bug was closed. If you are reading this on 25-27 September, just be patient while your local mirror catches up.


82

Just like before, you have to install PHP for Apache. From the Server Guide: sudo apt install php libapache2-mod-php That command will install PHP and the Apache 2 PHP module. Simply configure Apache as before (sudo a2enmod php7.0, I think, will turn on the module). Your mbstring issue is similar - you need to install that extension: sudo apt install ...


80

Try these steps, from the command line: Fix broken dependencies: $ sudo apt-get install -f If it still doesn't work, try this to fix/reconfigure the existing, unpacked-but-not-yet-configured packages: $ sudo dpkg --configure -a Then try the upgrade again. If it fails again, you may want to delete all the already- downloaded packages (they should be ...


78

It appears that sudo screen -D -r will reconnect to a disconnected install in a 12.04 to 16.04 upgrade. This means no killing of packages or anything like that. This assumes that you didn't actively stop the upgrade, just lost access to the session.


78

See this explanation of the origin and purpose of .ucf-dist files. This means you can either ignore the notice (that's what the N: prefix stands for) or remove said file. Before you remove the file, make sure it doesn't contain any packages you might still need. Compare it to the one that is currently active on your system: diff /etc/apt/apt.conf.d/...


76

A good try to ensure that you system is in a good shape and not has problems with aborted installation is to invoke dpkg --configure -a Ensure that the package list are updated and no problem is shown on: apt-get update Optional you can remove all old data before the update with: find /var/lib/apt/lists -type f |xargs rm -f >/dev/null \ Next ...


75

This worked for me: wget https://dev.mysql.com/get/mysql-apt-config_0.8.10-1_all.deb sudo gdebi mysql-apt-config_0.8.10-1_all.deb sudo apt-get update sudo apt-get install mysql-server The 2nd command will ask for input: After picking 5.7 choose "apply" $ mysql --version mysql Ver 14.14 Distrib 5.7.8-rc, for Linux (x86_64) using EditLine wrapper Don' ...


73

Replacing this line LockFile ${APACHE_LOCK_DIR}/accept.lock with this one Mutex file:${APACHE_LOCK_DIR} default in /etc/apache2/apache2.conf solved the problem. Additional Info: It occurs because the upgrade also upgrades your PHP. If you upgrade from PHP5.3.X to PHP5.5.X - and choose to keep your modified files you will find this error.


69

In my case, the apt commands and dpkg command could not finish, and could not remove. The autoupdate had failed on installing 2.6.32-56-server. My first step, was to identify space to be used, cd /boot du -sk *|sort -n I had about 30 kernels and supporting files. I did a uname -a to get the running kernel, I identified that I was on Linux alternate 2.6....


69

Sorted. Using a combination of clues from http://discourse.ubuntu.com/t/remote-desktop-sharing-in-ubuntu-14-04/1640 (which is all about VNC access) and https://bugs.launchpad.net/ubuntu/+source/vino/+bug/1281250 (which discusses the bug introduced into Vino) I have managed to resolve the matter. Essentially you have to disable encryption on remote desktop ...


69

It's still possible to do the upgrade, you just have to hack some files per this blog post in order to upgrade to 19.04 first. I was able to upgrade successfully following his method. Quoting the blog: Run do-release-upgrade on the 18.10 system. This will give you an error about being unsupported. But behind the scenes, the tool will download some ...


68

Open a terminal and enter the following: wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add - That will import Google's updated GPG Key. You should be able to update the system without any errors. Source: Google Linux Repositories


66

You can upgrade smoothly through LTS releases whether it's Server or Desktop. It doesn't matter what you use, you just need to use these commands: For Desktop Version: sudo do-release-upgrade For Server Version: sudo apt-get install update-manager-core sudo do-release-upgrade NOTE: Please always make sure you test the target LTS you're being prompted to ...


63

The short answer is to add the next apt repository to the Third-Party Software (or Other Software in newer versions) in Software Sources (or Software & Updates in newer versions): deb http://old-releases.ubuntu.com/ubuntu code_name main restricted universe multiverse The long answer... GUI Method Well, actually we will do this without to use any ...


63

My hunch is similar to Aleksi's, but I suspect you might have moved the Dwarf Fortress binary to /usr/local/bin or /usr/bin (and hopefully not /bin). Try running sudo which df in your terminal. If it doesn't say /bin/df, try moving the file specified in the which output to /usr/games/ (you'll be able to run the game in the future by running /usr/games/df). ...


62

Yes, you can upgrade from one Ubuntu LTS version to the next one, skipping the non-LTS releases in-between. It's intended to work that way and it gets tested.


62

Today I got the same problem, after trying many solutions i found that the problem was the command sudo systemctl disable mysql.service that i used to disable MySQL auto starting, so to get it working i re-enabled again MySQL server using the command sudo systemctl enable mysql.service and run again the upgrade process and it terminated perfectly.


61

NOTE: As of ~August 2019, openSSL 1.1.1 should be available for installation via normal package upgrades/installations for 18.04. Or, you can download the .deb package directly from here. According to the OpenSSL website: The latest stable version is the 1.1.1 series. This is also our Long Term Support (LTS) version, supported until 11th September 2023. ...


Only top voted, non community-wiki answers of a minimum length are eligible