Hot answers tagged

160

great choice! $ sudo apt-get install ttf-ancient-fonts $ export PS1="\\u@\h \\w 🍔 " enjoy.


53

I use this in my Dockerfile: # Set the locale RUN locale-gen en_US.UTF-8 ENV LANG en_US.UTF-8 ENV LANGUAGE en_US:en ENV LC_ALL en_US.UTF-8 One can also use the ENV one-liner: RUN locale-gen en_US.UTF-8 ENV LANG='en_US.UTF-8' LANGUAGE='en_US:en' LC_ALL='en_US.UTF-8'


43

Putting a cheeseburger on the prompt: Install a unicode font that contains this character: sudo apt-get install ttf-ancient-fonts Try the prompt: export PS1="\\u@\h \\w 🍔 " Make permanent the change (if you don't do that, it will reset once terminal is closed): Run nano .bashrc Go to the 59th line approx. (You can view the current line number ...


42

The Unicode Look of Disapproval (U0CA0) uses the letter ttha from the Kannada language. You can sudo apt install fonts-lohit-knda to provide the correct font. You can then insert the character with Ctrl+Shift+U, then 0CA0 ಠ_ಠ


29

The Symbola font is part of the ttf-ancient-fonts package. You can install it by running this command in a terminal window: sudo apt-get install ttf-ancient-fonts Source


28

That weird character, sometimes displayed as ⌷, is the Ubuntu unicode logo, . Byobu tries to use Unicode symbols, but sometimes those may not display correctly, if you're on a system that doesn't include that character in its font set. All of Byobu's symbols are tested to display properly on on Ubuntu (with the Ubuntu font) within Gnome-Terminal, but your ...


25

I couldn't help but take this probably a step too far. This version updates your prompt to display a different character based on time of day, to illustrate what you should be doing at that time. declare -A pp pp=(["09"]="🍩🍵" ["07"]="🌅" ["08"]="🌅" [10]="💻" [11]="💻" [12]="🍔🍟" [13]="🍔🍟" [14]="💻" [15]="💻" [16]="💻" [17]="🚗" [18]="🚗" [19]="🍷🍸" [...


23

For wget, you can use: wget http://www.example.com/файл.zip --restrict-file-names=nocontrol if your system can handle UTF-8 or other encoding properly. Finally, if you still have those % symbols left in your downloaded file, you can use Python module urllib.unquote(filename) that will replace %xx escapes by their single-character equivalent.


19

The /etc/default/locale file is loaded by PAM; see /etc/pam.d/login for example. However, PAM is not invoked when running a command in a Docker container. To configure the locale, simply set the relevant environment variable in your Dockerfile. Example: FROM ubuntu:trusty ENV LANG en_US.UTF-8 CMD ["/bin/bash"]


18

If you can't install the 'ancient fonts' maybe a sideways ASCII art cheeseburger would work? export PS1="\\u@\h \\w (||]" Of course, there could be different ways of typing this, possibly including lettuce, pickles, etc.


16

[Adding an answer since the accepted one no longer works.] Script I put this together into a script to set the word separators: https://github.com/ab/ubuntu-wart-removal/blob/master/gnome-terminal-word-separators.sh Background GNOME Terminal has flip flopped several times on this subject. This configuration feature was removed in gnome-terminal 3.14 (...


16

For subtitle edition/translation (text-based subtitles, that is), I strongly suggest Gaupol. sudo apt-get install gaupol Besides of gaupol, you can also try Subtitle Editor and Gnome Subtitles. However, from the screenshots, it is clear that your .srt file is not encoded in Unicode. As it turns out, iconv does change the encoding of the file to UTF-8, ...


15

If your current locale is in an utf-8 encoding, Vim will automatically start in utf-8 mode. If you are using another locale, set below in your user ~/.vimrc file: set encoding=utf-8 You might also want to select the font used for the menus. Unfortunately this doesn't always work. Also you have this option to force encoding with :set fileencodings=utf-8. ...


13

This answer to a similar question helped https://askubuntu.com/a/144448/9685 Commenting out SendEnv LANG LC_* in the local /etc/ssh/ssh_config file fixed everything.


11

To help anyone who stumbles here, You need to configure ~/.XCompose (see full file below) and restart X session. To type Greek letters on Latin keyboard: Hold compose key — usually it is right Alt (look for "Compose key location" in "Keyboard" sections in "System Settings"). <Multi_key> in the list below. Type g for small letters or G for CAPITAL ...


10

First, you need a font that contains those characters. According to support information at Fileformat.info, the only font that has them is Symbola, though it is possible that some less known fonts have them too. Symbola can be downloaded from http://www.fonts2u.com/search.html?q=symbola or http://users.teilar.gr/~g1951d/ (the latter is for the author’s site, ...


10

For Ubuntu 64 bit, you would need to download This package instead. I guess you were having a dependency problem. You would need also to install the apps stated above with this command. sudo apt-get install libfribidi0 libfribidi-dev Hope that this could help


9

try this: sudo apt-get install libfribidi0 libfribidi-dev, install THIS package, then vim /usr/share/applications/gnome-terminal.desktop and add this code to the document: Terminal=true Exec=/usr/bin/bicon.bin


9

If you also want to convert the double quotes, and perhaps other characters, you could use GNU iconv: $ iconv -f utf-8 -t ascii//translit < a We're not a different species "All alone?" Jeth mentioned. The //TRANSLIT suffix tells iconv that for characters outside the repertoire of the target encoding (here ASCII), it can substitute similar-looking ...


8

I'm afraid not. U+F200 is in the Private Use Area. These are not official Unicode characters.


8

To get a triangle, type Ctrl + Shift + u, then type 25b2, then press Enter To get the space, type Ctrl + Shift + u, then type a0, then press Enter Edit: To answer the comment below: Ctrl + Shift + u, then type a0, Ctrl + Shift + u, then type a0, type Ctrl + Shift + u, then type 25b2, then press Enter. type Ctrl + Shift + u, then type 25b2, type Ctrl + ...


8

Use CharacterMap With Character Map, you can select a large range of non-standard and international characters (including math symbol which you need) to put in your documents. No need to install it, because it was part of the default ubuntu installtion. How to launch ? If you using gnome, go to Accessories --> Character Map If you using unity, search "...


8

You can use Character Map. Select the font and select Character Details To find your character, use the view View > By Unicode Block. In All you have a very large list and in this list, you should find your character. But the font has 10FFFF (111411210) characters. Without knowing the code, it's a little bit hard to find your needed character. You can also ...


7

Use Mlterm, It's has great support for Arabic and other non-latin characters. You can download it from Ubuntu repositories


7

Try ENV LANG C.UTF-8 If you get the unsupported locale setting error and don't want to install any new locales.


7

When you click on save as, on the lower left corner you will get some encodings to choose from, choose add and remove (the last entry) and you will get to a list of available encodings including various unicode encodings.


7

So, I gave Bruni a screenshot for their answer to show what they meant. But then I tested the result. You can indeed select UTF-8 encoding in gedit, or any other text editor. However, unless these files contain non-ASCII characters**, they will be detected as ASCII. Indeed, the same holds if you create a "plain text" (dubious term*) file by any method, and ...


7

The prefix 0 already makes the file to be sorted at very first in Nautilus. What can come before the very first file? No files could, except directories. This is true regardless of locale in use. File naming In the following example, I first created an empty text file named apple.txt then made multiple copies and rename each of the files by adding single ...


6

Update: I searched a bit and found that you can use any monospaced font in vim but if you choose a non-monospaced font, the results will be ugly because vim has a fixed character cell. So, you can't use Devanagari fonts in gvim. It seems to me that gVim treats every font as monospaced and that is creating the problem. You can try other editors which can ...


Only top voted, non community-wiki answers of a minimum length are eligible