228

You may have accidentally removed some packages (or some dependencies which caused the package to uninstall). In any case, you may try installing (or re installing) the package ubuntu-desktop. Correct any accidental package uninstallation by: sudo apt-get install ubuntu-desktop


85

Uninstall and then reinstall System Settings (unity-control-center) from the Ubuntu Software Center application. Or run this command in terminal sudo apt-get remove unity-control-center sudo apt-get install unity-control-center


60

Try this, sudo apt-get remove unity-control-center sudo apt autoremove sudo apt-get install unity-control-center It worked for me.


56

Your Gnome-Control-Center might need reinstalling. Open your terminal and enter these commands: sudo apt-get update sudo apt-get install --reinstall gnome-control-center And then the commands for opening the display and system settings, respectively, would be: gnome-control-center display gnome-control-center These commands will change the desktop ...


50

I had exactly the same problem - same icons missing as well. I had stupidly uninstalled gnome-bluetooth, and nothing was fixing it. So I did what user282306 (r00t) suggested - sudo apt-get install ubuntu-desktop And I've got them all back again. Kudos @user282306 (previously r00t) for the suggestion.


49

And if you are trying to do this with Ubuntu 18.04, try this: sudo apt-get remove gnome-control-center sudo apt autoremove sudo apt-get install gnome-control-center This is because Ubuntu decided to switch their user interface from Unity to Gnome.


47

Finally I found the option. I had to install Tweaks and go to Keyboard and mouse > Additional layout options > switching to another layout The strange thing is that there is that the default shortcut super+space was not selected in that window, only the alternative shortcut.


44

dconf-editor uses schema path to show settings data tree. Same structure used to store data in GVariant database. gsettings (from glib-2.0) uses schema id to show/get settings data. Same way as any other application should do which uses GSetttings API. It's up to the application developer to set both as he/she would like. (with some restriction for canonical ...


36

Reinstall Settings (aka gnome-control-center) by running sudo apt-get install --reinstall gnome-control-center in Terminal.


24

You have to install a few packages first with: sudo apt install openvpn network-manager-openvpn network-manager-openvpn-gnome then, restart network-manager sudo service network-manager restart and try again. If it doesn't work, then try logging out and back in, if not, then try rebooting.


22

Try to run unity-control-center in a terminal, since gnome-control-center is not the default in Ubuntu 14.04 anymore.


21

If reinstalling ubuntu-desktop still doesn't cut it for you, you may be accessing system settings in a wrong way. Try to open them directly from a terminal (rather than a bogus shortcut like I was): gnome-control-center


20

You can try to reinstall gnome-control-center from terminal: sudo apt-get update sudo apt-get install --reinstall gnome-control-center


20

Pressing the Super key or the key only for 2-3 seconds brings up the "Keyboard Shortcuts" window that shows the system's keyboard shortcuts. Combinations shown using Super key:


18

Given that changing the permissions accomplishes your goal, check out this magic: dpkg-statoverride --update --add root root 640 /usr/share/applications/gnome-printers-panel.desktop dpkg-statoverride --update --add root root 640 /usr/share/applications/gnome-info-panel.desktop dpkg-statoverride --update --add root root 640 /usr/share/applications/gnome-...


17

Using dconf editor To disable alert sounds on Ubuntu 19.04 you could install dconf editor, either from terminal or from activities/software center. From terminal sudo apt install dconf-editor Next, launch dconf editor and navigate to org/gnome/desktop/sound/event-sounds and flip the switch to off - alternatively, click on event-sounds and set custom value ...


16

The solution for me was to install that specific package that was missing: sudo apt-get install unity-control-center-signon gnome-control-center-unity


16

This solution did not work for me for Ubuntu 18.04. But as I executed pactl load-module module-detect the missing built-in Audio Analog Stereo suddenly appeared in the sound settings menu. As I chose it, I was able to hear the sound. If you want this setting permanent, add the line load-module module-detect to the default modules in /etc/pulse/default.pa


16

I've found 2 ways to do this. from the command line dconf write /org/gnome/desktop/interface/clock-show-date 'true' or Install gnome-tweaks and in it there is a setting to show the day/date along with the time in the top bar. To install, do: sudo apt install gnome-tweak-tool After the install, when you run tweaks, you will see on the far left column "...


15

Please verify if system-config-printer-gnome is installed. It provides the config-gui you are missing. By standard you can access your cupsbackend also via http://localhost:631/admin


14

Try reinstalling gnome-control-center by opening a terminal (Ctrl+Alt+T) and type sudo apt remove --purge gnome-control-center sudo apt autoremove sudo apt install gnome-control-center


13

This issue was resolved for me by (re-)installing unity-control-center apt-get install unity-control-center. I didn't want to re-install the whole ubuntu-desktop because it was going to install a bunch of packages I didn't want/need and use another 100MB of space. Compared to just 4MB with unity-control-center


13

After a long struggle I have been able to fix this with the help of previous answers and trial and errors. I booted into Advanced mode while booting Ubuntu press F2 when you see grub2 bootloader. On some systems you may need to press Shift to get to advanced boot menu. In my case since I was in a VMware Workstation environment I pressed Shift or F2 to get to ...


12

So I ran sudo apt-get install hidpi-daemon and it fixed the settings issue so weird but it popped into my head after this and I fixed it.


11

Strange, but I found answer first! You use $ xrandr --output $monitorName --rotate $direction where $monitorName can be found in output of $ xrandr and $direction is left for counter-clockwise or right for clockwise. Edit: Using grep, it is possible to write a script like this: #!/bin/bash screen="HDMI1" descr=$(xrandr | grep "$screen") if echo "$...


11

I found the answer: sudo apt-get install ubuntu-desktop This gave me the following: The following NEW packages will be installed: apturl apturl-common nautilus-share software-properties-gtk ubuntu-desktop I have no idea how these got deleted, but they're back now.


10

The Language Support utility is provided by the language-selector-gnome package sudo apt-get install language-selector-gnome Once you install that package, you'll see the language option in the System Settings again.


10

GNOME's background customisation option is very limited. Along with system background images and solid colours, it allows the user to choose images only from Pictures, not even from any subfolder of Pictures. You may do one on the following: Place the image you want to set as background in Pictures folder, not inside any subfolder. Recommended option: Use ...


9

I managed to solve this, although not a optimal solution, it'll work. I installed PulseAudio Volume Control. Then went to "Configuration" and under the correct sound card, I chose the correct output (Analog 5.1). Then it shows up in sound settings again. Although, if I change the device in Sound Settings, I sometimes have to open PulseAudio Volume Control ...


9

First reinstall locale package: sudo apt --reinstall install locales Open this file: sudo nano /etc/locale.gen Find this line: # de_DE.UTF-8 UTF-8, uncomment it so it's now: de_DE.UTF-8 UTF-8. Save the file and run: sudo locale-gen see if you have German now.


Only top voted, non community-wiki answers of a minimum length are eligible