Hot answers tagged

13

Open Steam Go to the "Library" Right-click the game which needs to be reconfigured Select "Properties" from the menu Click the "Set launch options..." button type: -full and save That's all.


6

I have had a similar issue (not identical though). I had to remove both steam and my Nvidia drivers. Rebooted. I then reinstalled my Nvidia drivers with sudo ubuntu-drivers autoinstall, rebooted, and then installed Steam.


3

This might be a nvidia driver issue, according to a steam-for-linux issue. In my case, I installed SuperTuxKart through flapak, when I ran it, I met following errors: ..:: Antarctica Rendering Engine 2.0 ::.. Linux 4.15.0-52-generic #56-Ubuntu SMP Tue Jun 4 22:49:08 UTC 2019 x86_64 libGL error: No matching fbConfigs or visuals found libGL error: failed to ...


3

I had the exact same issue. I found an easy fix for me: Instead of putting the "no cef sandbox..." in the Arguments field, just type: wine steam.exe -no-browser +open steam://open/minigameslist That did the trick for me! Hope it works for you too.


2

2019 Steam binary is 32 bits. Recent versions of Nvidia drivers dropped support for 32 bits applications. To fix this on Ubuntu 18.04: sudo add-apt-repository ppa:graphics-drivers/ppa Run nvidia-settings and check your Nvidia driver major version. Mine, for instance, is: NVIDIA Driver Version: 430.26 (so, 430) sudo apt install libnvidia-gl-{{MAJOR VERSION ...


2

I just faced a similar problem. In my case, the initial window height was too big, so that part of the lower UI was cut off, including the "Apply Changes" button. I had to set a smaller height in the game's launch options (-h 700 for my 1366x768 screen). Aftwards I could switch to fullscreen in the video settings. After removing the launch options again, ...


2

On my system the package is steam-launcher (I installed it from the Steam repos). See if that's what you have by issuing apt policy steam-launcher in a terminal. If so, that's what you should uninstall.


2

In Steam settings in the category "Steam Play" check "Enable Steam Play for all other titles". Then right-click on the game in question, open "Properties", and on the bottom of the "General" tab, check "Force the use of a specific Steam Play compatibility tool". That will tell Steam to run the game via Proton even if there is a native Linux version ...


2

Looks like I found the issue. Thanks to abu-ahmed al-khatiri for pointing me in the right direction. I had to install the following package: sudo apt install libnvidia-gl-410:i386 But changed 410 to 430 which is my current driver version. Steam started up and I was able to login. thank you guys!


2

Alternatives Another possibility is to create a Live USB with Rufus, UNetbootin or Universal, and add the word persistent to txt.cfg, (Rufus), or syslinux.cfg, (UNetbootin), and to grub.cfg for UEFI boot in either. Then format a second drive ext4 and label that partition casper-rw. This persistent partition can also be located on the computers HDD. I ...


2

Solution with a persistent live USB pendrive and Ubuntu 18.04 LTS This method should work for you because mkusb is designed to work with all current versions of Ubuntu. If you have two USB pendrives, you can make a live-only system i Windows using Rufus with 18.04.1 or 18.04.3 LTS. This could be in a smaller and/or slower drive. Boot into this live drive. ...


1

In Ubuntu steam://open/minigameslist can be used as an argument with steam command, i.e., steam steam://open/minigameslist


1

As documented at Steam doesn't see network in ubuntu 16.10 on GitHub, people have had this problem for a while. It can often, though not always, be solved by installing the libnss-resolve:i386 package. Note that this is the libnss-resolve package for the i386 architecture, even if you're using the 64-bit version of Ubuntu (which is the amd64 architecture). ...


1

To remove this residue from the steam configurations, just remove the hidden .steam folder: rm -r ~/.steam (no sudo needed, don't use it, just type the command as it is)


1

If you download the steam_latest.deb from the official website and install it (using gdebi if you like) you will end up with steam-launcher installed and a Steam ppa added.


1

It Depends Either way is fine in my opinion. Mounting the second drive at ~/.steam If you want to dedicate the whole drive (or one whole partition) to stream, this is the way to go. This is the best approach under the following conditions: You plan to use the whole drive (or one whole partition) just for steam games and nothing else. You are the only ...


1

Steam supports external library folders that allow you to setup game install folders on multiple drives, and then when you install a game you can choose which Steam Library Folder to install it to. With this functionality you don't need to use any magic to accomplish what you want.


1

Nevermind. I just wrote "steam" and it autoruns. See you in another question.


1

Does this happen with other hard drives and flash drives, or just the one? For me, all external media (hard drives, flash drives) caused slowdown on Ubuntu 18.04 but worked fine on Windows 10. This persisted on two machines, across three filesystems (UDF, NTFS, and exFat). I found two pages that were instrumental in fixing this: https://bugs.launchpad.net/...


1

I solved the issue by installing newer version of Mesa with the oibaf's PPA: https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers Probably the issue was generated to begin with because i left the Paulo's PPA for Mesa after upgrading to 19.04, i'm not sure. I hope it helps someone else.


1

The issue was due to not being inside the Arma 3 Dedicated Server folder, where arma3master is located. Despite running the executable with the absolute path, you still need to be within the folder that the executable is in. The solution was to change directory to the executable folder. $ cd /home/steam/arma3/arma3master/ $ /home/steam/arma3/arma3master/...


1

You can install Ubuntu. Recommended system requirements: 2 GHz dual-core processor or better 2 GB system memory 25 GB of free hard drive space Either a DVD drive or a USB port for the installer media Internet access is helpful https://www.ubuntu.com/download/desktop


1

Apologies for the hasty post. It seems the issue was with SSL certificates as suggested by the log. Fixed by inserting sudo apt-get install --reinstall ca-certificates into the terminal.


1

In the end, I found out the reason for the problem. Steam (or at least my version of Steam) is installed with Flatpak. Flatpak does not actually have access to the /home directory filesystem. it creates a sandbox environment in Home/user/.var/app/com.valvesoftware.Steam To manually override this, I created a mount point outside of /home (IT IS IMPORTANT ...


1

You can run glxinfo | grep OpenGL shading language version string will show you version of shaders. E.g. OpenGL shading language version string: 4.60 NVIDIA Your system doesn't support shaders version 3.


1

Better to use the official repositories: sudo dpkg --add-architecture i386 sudo apt update sudo apt install wget gdebi-core libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 sudo apt-get install lib32gcc1 Then, you are ready to go. EDIT This only works for Ubuntu For any raspberry devices (not 100% sure if it works or not), better to compile the steamCMD (check ...


1

Kind of an alternative and unresourceful answer, but I used the Rotation Lock (2nd icon in image) to change my screen to portrait mode, change settings accordingly, and then back to landscape.


1

This is a known Steam issue: the symlink is created and is intentionally broken for compatibility with older Steamworks SDK that some games are still built with. There is a bug report on this issue, and also a tracking list of games that need to be updated.


1

Ubuntu 18.04: Once you successfully uninstalled your current Steam (all directory related to steam) please open a terminal and type the following in order to have a fresh and clean installation: sudo add-apt-repository multiverse Once you're right the output should be: 'multiverse' distribution component enabled for all sources Then install steam (...


1

just got this error despite already having uid and gid set up properly as @delf answer; in my case windows left the "dirty bit", so i had to unmount it, run sudo ntfsfix -d /dev/sdb1 where sdb1 is your disk, and remount it.


Only top voted, non community-wiki answers of a minimum length are eligible