34

Follow these steps to automatically mute your speakers when plugging in headphones: Open Terminal (Ctrl+Alt+T) Type: alsamixer and press Enter/Return Select the correct sound device by pressing F6 Navigate to the right with → (Right Arrow key) until you highlight Auto-Mute Press ↑ (Up Arrow key) and select Enabled (or Line Out) Press Esc to exit


26

There's an option in /etc/bluetooth/audio.conf called aAutoConnect=truewhich is hashed out. sudo nano /etc/bluetooth/audio.conf Delete the "#" at the start of the AutoConnect=true line I found enabling this option by removing the # and got things connecting properly with my bluetooth headset Restart the bluetooth service for the change to take effect: ...


25

Add the following line to /etc/bluetooth/audio.conf: [General] Disable=Headset and then run this command: sudo service bluetooth restart Thread: (Natty) Connect only A2DP profile for bluetooth headset.


23

Original Solution Go to Realtek official site, accept the disclaimer, then download the audio driver for linux/unix. You need to select version 3 for Kernel 3 or later. Setup necessary tools to compile this driver. sudo apt-get install build-essential gcc make Extract the downloaded file, run sudo ./install file from a terminal after going to the extracted ...


20

One way to solve the problem is to: unpair the device run the following command on terminal: sudo pkill pulseaudio and then pair again the speaker via bluetooth. The speaker is now displayed on the output audio list, which needs to selected for obtaining output sound. Remember to, under Sound Settings, change Mode to High Fidelity Playback (A2DP Sink).


11

This is what is working for me for Bose QuietComfort 35 on Ubuntu 16.04. pauvcontrol didn't do it for me, and neither did the numerous settings changes and module loadings recommended elsewhere. So give this a try: Install blueman sudo apt install blueman Delete the paired device in the bluetooth settings. Run these commands in terminal: bash sudo pkill ...


10

Howto detect an unplug Basically what worked for me was: # When plugged in: cat /proc/asound/card0/codec#0 > pluggedin.txt # When not plugged in: cat /proc/asound/card0/codec#0 > notplugged.txt # Then compare the differences diff pluggedin.txt notplugged.txt For me the difference was in 'Node 0x16' under 'Amp-Out vals': Node 0x16 [Pin Complex] ...


9

Open a terminal and run: alsamixer -c0 Press F6 and select your sound card (in my case HDA Intel PCH). Go towards the right and disable Auto-Mute M. This worked with a Lenovo Y 410P.


9

You need only to install Pulse Audio Volume Control sudo apt-get install pavucontrol Open Pulse Audio Volume Control, navigate to the Recording tab and select your application that is recording sound. Then it should provide you with a drop down menu with source options. Enjoy!


9

For those wondering, I found in Ubuntu 16.04 there is a slight difference to the answer: sudo gedit /etc/bluetooth/main.conf And update the following line #AutoEnable=false to AutoEnable=true Followed by sudo service bluetooth restart For me, this defaulted the audio profile to A2DP Sink when connecting a bluetooth audio device.


9

Takkat provided the answer as a comment, so I am writing this "answer" to close out my question. Basically, AirPlay is not currently functioning with Pulseaudio without hack. BUT if DLNA is available on your speakers, which they are on any old Android phone connected to speakers, you can do this: sudo add-apt-repository ppa:qos/pulseaudio-dlna sudo apt-...


8

Check this out too if the above answer doesn't work for you. This is the actual method that the link contains: Run this command (providing you have nano installed, per default you have): sudo nano /usr/lib/pm-utils/power.d/intel-audio-powersave Find the line: INTEL_AUDIO_POWERSAVE=${INTEL_AUDIO_POWERSAVE:-true} Comment it out using "#". Underneath add ...


7

I also had this problem on my HP laptop. I found a post and take one of the advice, which suggests adding two lines to the bottom of the file /etc/modprobe.d/alsa-base.conf: options snd-hda-intel model=laptop options snd-hda-intel position_fix=1 enable=yes save it and reboot. It works for me!


7

Personally I use the command line: List your sound card(s) aplay -L Test your speakers: speaker-test -Dplug:surround51 -c6 -l1 -twav You may also specify a speaker speaker-test -s left-front -twav See also Ubuntu Community Wiki Surround Sound Manpage speaker-test You can also test your speakers from the mixer (mixer varies with window manager) In ...


6

I've found a bug report with exactly the same problem as well as audio devices. It's not a fix, but rather a workaround, but it seems to have worked for at least two users with HP's DV6s. To try the workaround, open a terminal window (ctrl-alt-t), and copy/paste the following: gksudo gedit /etc/modprobe.d/alsa-base.conf ...then add the following lines to ...


6

Install the alsa-tools-gui package (13.10) to get the hdajackretask command: sudo apt-get install alsa-tools-gui hdajackretask will allow you to completely ignore the broken headphones output: Visit omgubuntu if you need to install it for older releases.


6

Go to Sound Settings, select your Bluetooth audio device and check that the device is set to A2DP not HSP/HFP (which is mono and has very low quality). Edit: If Bluetooth audio stops working after you do that in 16.04 you need to apply the following workaround: https://askubuntu.com/a/817926/40581


5

On my Oneiric system I had to do the following to get XBell/XkbBell working again: Load the module pcspkr (like you already did via /etc/modprobe.d/blacklist.conf) Remove the package pulseaudio-module-x11 (that seems to absorb all XBell events) Put options snd-hda-intel beep_mode=2 into /etc/modprobe.d/enable-beep.conf (you only need that case you own a ...


5

I placed: options snd-hda-intel model=hp-dv5 options snd_hda_intel model=hp-dv5 In my /etc/modprobe.d/alsa-base.conf I don't know which syntax is the correct one, but I left them both in for good measure. I did NOT restore my heaphones option, however it did mute the speakers when I plugged in my headphones and that was good enough for me.


5

I had the same problem: I plug in headphones, and sound comes out of the headphones and my laptop speakers. Here's how I fixed this problem: Go to Sound Preferences [click on the Sound icon in the top-right, on the bottom of the menu, you'll see sound preferences] Next, go to the Output tab. Here, look at the bottom, where it says "Connector:" I think ...


5

It is often better to research your subject before posting it on Askubuntu. Here is an article that answers directly your question : Creative D200 on Linux. Here is a detailed tutorial based on that article : Scan for bluetooth devices Press the bluetooth button behind the speaker during the search for 3 seconds Once it shows up on the list, choose PIN ...


5

First, use alsamixer to find out which mixer controls must be changed to get the desired effect. Then write a script that runs amixer to set those controls. For example: amixer set "Headphone" mute amixer set "Speaker" unmute In this case, it's likely that you also need to disable Auto-Mute Mode.


4

The popping is not a result of your computer not being muted; it's probably a result of capacitor discharge being sent to your speakers. From what you've said, it sounds like you have a set of external speakers? If this is the case, turn them off before booting down; this will prevent any discharge from being amplified, and therefore being heard.


4

You can try following steps: First,open up a terminal window (Applications->Accessories->Terminal) and run this command: sudo head -1 /proc/asound/card0/codec#0 it outputs your audio card type. Edit the configuration file by this command: sudo gedit /etc/modprobe.d/alsa-base.conf find out this section: > # Keep snd-pcsp from being loaded as first ...


4

Turning down the mic boost using alsamixer fixed it for me. To do that, open a terminal (Alt-Control-T will do this) and enter the alsamixer command. Pressing the Tab button brings up "Capture" screen. Use the left and right arrow keys to select the mic boost slider and reduce it with the down arrow key. Press the Esc key to quit alsamixer.


4

Had this issue on XUbuntu 12.04, reviewed this page, installed the gnome-alsamixer package, ran gnome-alsamixer, checked the "Headphone Jack Sense" option in the gnome-alsamixer GUI screen that came up, verified the problem is resolved. Thanks!


4

First, you should define in ALSA that you have 6 channels. You can refer to this post. Basically, you launch alsamixer and you define (for the right soundcard) the number of channels to 6. Then you store the configuration in order to be reloaded on reboot: sudo alsactl store Then pulseaudio should be configure (pulse is the sound layer that will be used by ...


4

I'm using Gnome3 and after some time my headset no longer connected at A2DP again. I had to stop Gnome creating a pulseaudio daemon by creating the file /var/lib/gdm3/.config/pulse/client.conf (as root) and adding the following lines to it: autospawn = no daemon-binary = /bin/true Then set the owner to gdm: sudo chown gdm:gdm /var/lib/gdm3/.config/pulse/...


4

In a terminal type alsamixer, go to Automute via navigation keys, press up or down and set it to disable. Unfortunately, you will still hear sound from your headphones.


4

It doesn't seem possible I looked on HP website and found this: How to install Bang and Olufsen Audio drivers on Ubuntu 16.04 The so-called "HP Expert" there said it's like trying to put a jet engine in a car and make it fly like an AirBus A380. So not very promising. He did reference another question here in Ask Ubuntu: How to install Bang and Olufsen ...


Only top voted, non community-wiki answers of a minimum length are eligible