Podcast #128: We chat with Kent C Dodds about why he loves React and discuss what life was like in the dark days before Git. Listen now.

Hot answers tagged

33

All right, so blacklisting the sound related modules worked. Thanks to this post: http://www.pc-freak.net/blog/disabling-sound-kernel-modules-debian-ubuntu-gnu-linux-servers/ The details of the fix: edit /etc/modprobe.d/snd-blacklist.conf and add these entries (from a Dell standalone pc with 18.04) blacklist soundcore blacklist snd blacklist snd_pcm ...


16

A hardware solution: insert a mini-jack connector in the sound output port, but only a connector, without any wire or speaker on it. This has worked for me since the 80's to silence the Mac's otherwise beautiful power-on ding.


14

Similar instance of problem here on a v18.04 box; alsa output works, but pulse is just Dummy Ouput. This seems to bring back pulseaudio without rebooting. First close any programs using pulseaudio, then as a regular user run: pulseaudio --kill; sleep 2s; sudo alsa force-reload ; pulseaudio --start Then play a sound file.


12

1. Open terminal Ctrl + Alt + T 2. Install PavuControl sudo apt install pavucontrol 3. Open PulseAudio Volume Control pavucontrol 4. Output devices Set to 100% (0dB) the port are you using (Speakers / Headphones etc)


10

Same problem. Disabling Noise Suppression on Discord's settings seems to unmute the microphone for some reason.


10

Inspired by @kenn, I decided to go deeper into dbus and d-feet tools. Eventually I reached my goal using the following command: dbus-send --system --print-reply --dest=org.bluez /org/bluez/hci0/dev_44_78_3E_85_9D_6F org.bluez.MediaControl1.Play which of course triggered playing music on my mobile device connected to my PC over bluetooth. Generically for ...


9

To make Singrium's answer work, I had to comment out this line from my /etc/pulse/default.pa by adding the #: # load-module module-switch-on-connect Otherwise, on startup my audio device would be set to my default device, but then would switch to my USB hub once it was detected. This prevents that switch and ensures your chosen audio device is the output.


9

Asked and answered here. The solution is to add this to /etc/modprobe.d/alsa-base.conf options snd-hda-intel power_save=0 power_save_controller=N


8

I have an asus zenbook 14 ux433FN. Faced the same issue with Ubuntu 18.04 (it comes with the kernel 4.15). I upgraded to kernel to 4.20 through the "ukuu" utility and the sound/headphones seem to work fine. Here are the commands that in case you need to update the kernel Check your kernel version uname -r install ukuu by following this link: https://...


7

I fixed with this $ rm -rf /tmp/pulse* ~/.pulse* ~/.config/pulse $ pulseaudio -k $ pulseaudio --start


7

Using dconf editor To disable alert sounds on Ubuntu 19.04 you could install dconf editor, either from terminal or from activities/software center. From terminal sudo apt install dconf-editor Next, launch dconf editor and navigate to org/gnome/desktop/sound/event-sounds and flip the switch to off - alternatively, click on event-sounds and set custom value ...


7

Better OSD is what you're looking for. It works very well on Ubuntu 18.04. It is a Gnome extension, that is available via Ubuntu Software too. After installing it via Ubuntu software, you can access to its settings via Gnome tweaks>Extensions (if you don't have Gnome Tweaks, you can install it from Ubuntu Software too). Here are some screenshots of what I ...


6

Here is the solution that worked for me on Debian 9 (menu impossible to apply) Important: you will have to restart bluetooth before each reconnection ! Source: https://unix.stackexchange.com/a/415928/325467 I am using a SoundBuds Curve headset in Debian 9, and have had the same problem, I was unable to switch from the HSP/HFP profile to the A2DP profile. ...


6

I had the same problem. It seems related to speech-dispatcher (some text-to-speech utility). try : killall speech-dispatcher If the sound comes back to normal you can remove it completely (if you don't need it) with : sudo apt-get remove speech-dispatcher


6

I fixed it by modify /etc/pulse/default.pa. Find and replace: load-module module-udev-detect by load-module module-udev-detect tsched=0 Then restart PulseAudio using this command: pulseaudio -k && sudo alsa force-reload


6

Looks like opening the terminal preferences and deselecting the terminal bell does the trick.


5

For Ubuntu 18.04: sudo apt-get install pavucontrol Start playing music or whatever you want. (You still hear nothing) pavucontrol Go at: playback You will see there that the playback for the app is set to HDMI. Redirect it. This implies that each app might need to be manually changed :-/ Other solution, replug HDMI and choose the correct output device. ...


5

run: rm -r ~/.config/pulse; pulseaudio -k This will clear hdmi settings and settings will be back to default. Hope this help :-)


5

The solution in 16.10 is: $ sudo apt install bluetooth pulseaudio-module-bluetooth This answer was originally posted as an edit to the question.


5

The simplest solution is to install pavucontrol sudo apt install pavucontrol. Then you launch it and the gui will let you chosse the output for each application.


5

Just wanted to add to this, I followed similar instructions to have sound work briefly after a reboot with a dell XPS 13 running Ubuntu cosmic (18.10). Switching between 'auto' and 'generic' didn't change much sudo alsa force-reload worked for me.


5

I had this same problem and it was driving me nuts trying to fix it because whenever I booted into Windows 10, sound worked fine. Meanwhile, on Ubuntu 18.04, I found a number of helpful web pages with suggestions for troubleshooting audio problems. The suggestion that worked for me was running 'sudo alsamixer' in a terminal window. I didn't even have ...


5

There is an application in the Official Ubuntu Software Repository callled Kazam, which works great. It will record internal sound, external sound, and the screen. It has pretty good video quality, as well. It can be installed with: $ sudo apt-get install kazam


5

A simple one is simplescreenrecorder which can be found in the 18.04 repo. Install it with sudo apt install simplescreenrecorder start it > Continue > choose size of screen to record > tick the box for audio. For Backend choose pulseaudio. For source choose built in audio analogue stereo which would record the mic instead of the internal audio > choose ...


5

This question has been answered here To disable alert sounds on Ubuntu 19.04 you could install dconf editor, either from terminal or from activities/software center. From terminal sudo apt install dconf-editor Next, launch dconf editor and navigate to org/gnome/desktop/sound/event-sounds and flip the switch to off alternatively, click ...


5

The "ambient noise" you're hearing is a loopback from your computer's mic coming out through your headphones. This is apparently due to a bug with A2DP's implementation. I fixed this in Ubuntu 19.04 by installing Blueman and pairing my headphones as an Audio Sink rather than a headset: Unpair your headphones, if they're currently paired. sudo apt install ...


5

You can use the -map option to choose specific streams. To get a list of the available streams, run ffmpeg -i INPUT_FILE.EXT (Do not forget -i!), which gives e.g.: … Input #0, EXT, from 'INPUT_FILE.EXT': Metadata: encoder : VirtualDubMod 1.5.10.2 (build 2542/release) Duration: 01:35:35.88, start: 0.000000, bitrate: 1029 kb/s Stream #0:0: ...


5

OP Edit: In my case, I needed a few more steps. You might not need to do this bit. When I went to uninstall the offending kernel(s) - I was not able to because I was currently booted into it - thus, apt/dpkg threw an error during removal. If you run into that, this is the remedy: First, edit /etc/default/grub from GRUB_TIMEOUT_STYLE=hidden ...


4

Try bluetoothctl command. If you then enter help, you'll see the commands to be used. 'list' (devices) 'trust 78:44:aa:bb:cc:dd' (MAC address of device) 'info 78:44:aa:bb:cc:dd' (MAC address of device) 'paired-devices' Try, it worked for me.


4

Do like in this AskUbuntu question: Update: The following seems to prevent the problem from reappearing in the future: Edit /etc/pulse/default.pa, find the line that starts with load-module module-stream-restore and add restore_device=false at the end, so that the line looks like this: load-module module-stream-restore restore_device=false Then do a ...


Only top voted, non community-wiki answers of a minimum length are eligible