New answers tagged

0

I now was able to apt purge the packages which I tried to install instead of running the above command. This resolved the issue. This was not possible before but probably it was due to a running process. So, there is no need to run dpkg --configure -a, just if you really want to finalize the installation.


9

The command is add-apt-repository, you're missing the second hyphen.


1

For most common things, you won't need to compile. But, depeding on the version of ubuntu that you have and/or the version of php that you want, you may have to install ondrej/php ppa.


0

As another option all the Jetbrains IDEs are in Java, have installers for Linux, and are excellent. They are also free if you are a student or teacher. (Its ironic how much of a boon to Linux java has been given all the hate directed at it by Linux C snobs back in the day.) I use Rider for C# and Webstorm for all the Web stuff including TypeScript, and ...


0

To install Scratch 2 Offline version it is necessary to: install Adobe Air install Scrath 2 with Adobe Air But it is a nightmare to install Adobe Air. Luckily I've found here (in last part of the page) a small script that runs perfectly and does everything on 18.04.2 LTS for me. So the solution is : create this script #!/bin/bash if [ $EUID -ne 0 ]...


0

This worked for me: $ sudo chown -R root /home/$USERNAME/.cache/pip/ $ sudo chown -R root /home/$USERNAME/.cache/pip/http/ Note: Use this way only if you always use pip as root. Otherwise pip may not use the cache directories since they are owned by root.


1

According to the link in your question everything including caffe itself is packaged in 17.04 and higher versions, but you are currently using Ubuntu 16.04 which does not contain these packages in its default repositories. caffe-cuda is not available from the default Ubuntu 16.04 repositories. Ubuntu 16.04 can be upgraded directly to Ubuntu 18.04 which is ...


0

The above answers didn't change anything for me. What worked was sudo dpkg --purge <package>. This also worked for broken packages which weren't installed, e.g. pB libnspr4-0d Note: dpkg threw a warning, but the broken package disappeared from the list (if another one appears, repeat until done).


1

To install the dissenter browser on Ubuntu, you need to have Snaps installed. Snaps are applications packaged with all their dependencies to run on all popular Linux distributions from a single build. They update automatically and roll back gracefully. Enable snapd If you’re running Ubuntu 16.04 LTS (Xenial Xerus) or later, including Ubuntu 18.04 LTS (...


-1

I installed it by using: gdebi mysql-workbench-community_8.0.16-1ubuntu18.04_amd64.deb It looks up dependencies and installs them, see http://manpages.ubuntu.com/manpages/bionic/man1/gdebi.1.html for more info


0

I was searching and trying a few ways, undervolt and c60-tweak-master aren't working under the current Ubuntu / xUbuntu LTS release 18.04 (in my case). The performance of this cpu without tweaking it is awful (fixed between 0.8 and 1 GHz), I'm running a nextcloud server on it. So I found this one: https://github.com/johkra/amdmsrtweaker-lnx 1. Download the ...


2

Rufus developer here. Most likely, you are seeing this because you forgot to properly select the ISO in Rufus or changed the Boot selection field to FreeDOS after you picked the file. You need to make sure Boot selection says something like ubuntu-19.04-desktop-amd64.iso (or whatever the name of the ISO you selected is) before you press START. If you don't ...


0

Do you still want to proceed with this installation? [no] This asks for an answer to the question. If you press Enter at this point, the script will choose the default answer, which is shown in brackets. Sometimes it is written as [YES/no] or [y/N], then the default value is the uppercase one. To overrule the default, you simply have to type yes or most of ...


0

software-properties-gtk Change download source to main server. sudo apt update && sudo apt-get clean and try again. Forgot, and unlock for other sources deb-src


0

I managed to install v2.1.14 following the instructions here: http://www2.macaulay2.com/Macaulay2/Downloads/GNU-Linux/Ubuntu/index.html Summarized: Add this line to /etc/apt/sources.list.d/macaulay2.list: deb http://www.math.uiuc.edu/Macaulay2/Repositories/Ubuntu xenial main (create the file if it does not exist) run sudo apt-key adv --keyserver hkp://...


0

What about using Terraform deb repository, you can than install and update Terraform using apt. https://tjend.github.io/repo_terraform/ Like this: wget -q -O - https://tjend.github.io/repo_terraform/repo_terraform.key | sudo apt-key add - sudo echo 'deb [arch=amd64] https://tjend.github.io/repo_terraform stable main' >> /etc/apt/sources.list.d/...


0

You don't have proper permission access on global packages. Uninstall node js completely Install node (i prefer snap) sudo snap install node --channel=10/stable --classic Follow this guide to allow your global packages correct permission. Steps here cd mkdir ~/.npm-global npm config set prefix '~/.npm-global' nano .profile # add at the end of .profile ...


0

Use this command: sudo npm cache clean --force --unsafe-perm Then after that repeat the process.


0

Let's fix the issues one by one. Remove r-base-core: Run sudo apt autoremove r-base-core W: Target CNF (non-free/cnf/Commands-all) is configured multiple times The easiest way to solve this issue is following David's Script. But if you don't want to follow that script and since you have issue in single line, you can simply run, sudo sed -i '4d' /etc/...


0

A mix between bionic xenial artful and ppa packages. Remove under /etc/apt/sources.list.d/ any file with xenial or artful in name. Control in /etc/apt/sources.list That every row leads to a bionic source. sudo add-apt-repository -r ppa:marutter/rrutter3.5 removes that ppa. You have another on cloud.r-project.org/bin/linux/ubuntu bionic-cran35 for ...


0

This virtualbox-version is to old for Kernel-line 5. you need virtualbox-6 from oracle. VirtualBox 6.0.4 (released January 28 2019) This is a maintenance release. The following items were fixed and/or added: Virtualization core: support Shanghai/Zhaoxin CPUs. User interface: handle command line arguments to VirtualBox correctly (bugs #18206 and #...


0

Using sudo -H pip install requests solved the problem: Collecting requests Downloading https://files.pythonhosted.org/packages/51/bd/23c926cd341ea6b7dd0b2a00aba99ae0f828be89d72b2190f27c11d4b7fb/requests-2.22.0-py2.py3-none-any.whl (57kB) 100% |████████████████████████████████| 61kB 1.3MB/s Collecting urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 (...


0

If you are a non-C++ user and/or don't want to compile it yourself, the simplest way to install the current version of protoc is to download a pre-built binary from the release page. https://github.com/protocolbuffers/protobuf/releases To install, simply place this binary somewhere in your PATH (e.g. /usr/local/bin). (If you intend to use the included ...


1

Your system-level Java is still configured as OpenJDK 11. To manage multiple Java installations properly, you should register the Oracle/Open JDK 12 that you have manually downloaded so that Ubuntu can recognize it. After that, you can configure the specific Java version that you want using update-alternatives. The commands below will register the new Java ...


0

With respect to the error console reported earlier in the QT5-based installation: An unhandled error occurred. Sorry for the inconvinience. Please copy the following text into a bug report: Traceback (most recent call last): File "/home/opt/Downloads/ldoce5viewer-pyqt5/ldoce5viewer/qtgui/utils/soundplayer.py", line 114, in need_data appsrc....


0

You are trying to install a 32-bit package, so you should first run sudo dpkg --add-architecture i386. After this, repeat the process again and reply if it still doesn't work :).


0

after starting the setup when it asks "Installation type", look for the option "Something else" and continue. Then on the next screen you will see your created partition. Format/"New Partition Table" the new partition/freespace to ext4 format and set the mount point to "/". Select the primary hard drive for "Device for boot loader installation:". In case you ...


0

The reason for the error is that your /boot partition is full. That is most probably due to many linux kernels being installed. The process to fix this is as follows: open a terminal and become root or use sudo find list of installed kernels dpkg -l | egrep 'linux.*(image|header)' and save it someplace safe to refer to it. Find your current kernel version ...


2

Kitware now has an APT repository and currently supports Ubuntu 16.04 and 18.04 Install Instructions: Remove old version of cmake sudo apt purge --auto-remove cmake Obtain a copy of the signing key wget -O - https://apt.kitware.com/keys/kitware-archive-latest.asc 2>/dev/null | sudo apt-key add - Add the repository to your sources list a. For Ubuntu ...


0

Here are two issues: Kernel does not support PIC mode for compiling, details could be traced at this post. As @Joy noted, currently apt installed gcc5+ has PIE enabled by default, we need to add -fno-pie in to gcc option. Here I am following this fix, add following lines start from L774 of Makefile under the git repo you have cloned. # force no-pie for ...


0

Find the .bashrc file in Home. Open it with any text editor. Add a line at the end: cd $PWD Save it. Close all instances of Nautilus Now, when you open Nautilus you will get to see the "Open in terminal" option in the right-click menu and it loads the current directory path when clicked.


0

In addition to Mitch's answer: If you are not best friends with your shell (yet), you can also just visit the home page of vscode ( https://code.visualstudio.com that is ) and click on their download link. When downloaded, you can double click the .deb file which will open the software center and let you install vscode using a graphical interface.


0

Had to add ppa:canonical-kernel-team/ppa to get the armhf packages in version sync with amd64 (bionic-security). Then zlib1g-dev installed fine.


1

From the comments... re: Sudo apt-get install php7.0-mcrypt mysql-server phpmyadmin The correct command would be sudo apt-get install php7.0-mcrypt mysql-server phpmyadmin... small s in sudo, but the php7.0-mcrypt package doesn't exist in the Ubuntu repositories, so you can't install it. Maybe you obtained it elsewhere. And since the latest php is 7.2, you ...


0

try this commands in your terminal: sudo apt update sudo apt install software-properties-common apt-transport-https wget wget -q https://packages.microsoft.com/keys/microsoft.asc -O- | sudo apt-key add - sudo add-apt-repository "deb [arch=amd64] https://packages.microsoft.com/repos/vscode stable main" sudo apt install code


2

The celestia package was removed from Ubuntu before 16.04 due to lack of interest by the community. The previous community volunteers who had packaged the software from upstream found new interests, and no community volunteer has stepped to resume packaging in either deb or snap format. Anybody willing to put in a small amount of effort can do the deb or ...


0

Note this message in the error output DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. You should use pip3 to install spyder.


0

This should point you in the right direction. Packages often come with pre- and post-install scripts. These integrate the package into the host system and are usually distribution-specific. AFAIK, (by default) alien does not setup these files to be run when the package is installed because they usually break things when run on another distro. This appears ...


1

I added /snap/bin to $PATH. That worked for opening VS Code from the CLI.


1

from: https://www.linuxquestions.org/questions/debian-26/apt-get-dpkg-error-files-list-file-missing-final-newline-271118/#post1375972 Well, with a big help from #debian at freenode, I found the solution (thanks justin!!): the file /var/lib/dpkg/info/smbfs.list was corrupted, it was all binary crap. Dunno how this could happen, but it was. So justin ...


0

The reason why anbox.appmgr is not running is not related to the message about libgtk3-nocsd.so.0. Instead you need to make sure that: The necessary kernel drivers are installed. You can test this by running: ls -1 /dev/{ashmem,binder} and if these are missing, do the kernel module install process as described in https://docs.anbox.io/userguide/...


0

Looking into this more, I think the error message is at least misleading. x11proto-dri2-dev is in bionic and later a transitional package for arch all. It is superseded by x11proto-dev. x11proto-dev, is in bionic and later a package containing headers for arch all. So following me issuing a non-fulfilling install command, it seems that apt is only ...


1

Install the libccp4-dev package. The package should be available for whatever Ubuntu release you're using. One good way to install it is to run: sudo apt update sudo apt install libccp4-dev The libccp4-dev package directly provides the header files for the CCP4 libraries, which you need in order to compile software that uses them, and also declares ...


0

The output of cat /etc/apt/sources.list was quite short, containing only two non-blank lines. It revealed that /etc/apt/sources.list has the bionic repository but is missing the bionic-updates and bionic-security repositories, which are typically present and enabled. Adding them should fix the problem. The package you're trying to install, linux-tools-4.18....


1

Package g77 is not available in any currently supported version of Ubuntu, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source. The fort77 utility is the interface to the Fortran compilation system. It will accept the full Fortran 77 language defined by the ANSI X3.9-...


0

Or a GUI method would be to: Right-click on the installer file. Select "Properties" from the pop-up menu. Click on the "Permissions" tab. Check the "Execute: __ Allow executing file as program" box. Click on the installer program again and select "Run" from the pop-up menu. As a matter of preference, in windowing operating system interfaces, I ...


0

The correct command to install linux-tools for actually used kernel (from official repository) is: sudo apt install linux-tools-`uname -r`


1

The site of ftpmirror.gnu.org/gsl your provide is eror:404 . The latest of gsl link available on https://mirror.freedif.org/GNU/gsl/gsl-latest.tar.gz and extract it. To compile and buildin the package follow: cd ~/yourFolderOf_gsl/gsl-releaseVersions ./configure && make && make install If you have the error output that ./autogen.sh: 10: ./...


0

For some reason, as @fkraiem describes within the comments, the package libssl1.0.0 is missing in the Ubuntu 19.04's repository. Probably this should be reported as bug to Ubuntu's team. Fortunately, the good news is: you can download and install this package from 18.10's repository. Go to the download page and click on the link security.ubuntu.com/ubuntu (...


0

I got a pretty similar problem with Ubuntu 19.04 can see Canon LBP6030/6040/6018L (as a wireless device) but printing does not happen. Eventually I got this working: (1) initial state. Ubuntu sees the printer but drivers could not be found automatically or pick up from the Ubuntu db manually. (2) once I installed 2 deb packages from the archive downloaded ...


Top 50 recent answers are included