645

google-chrome-stable is available on a 3rd Party Repository: Google Chrome (for Stable). Follow the instruction for installation: Add Key: wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add - Set repository: echo 'deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main' | sudo tee /etc/apt/sources.list.d/...


609

Ubuntu 14.04 (Trusty) and 16.04 (Xenial) If you are using Ubuntu 14.04 or 16.04, you can use Felix Krull's deadsnakes PPA at https://launchpad.net/~deadsnakes/+archive/ubuntu/ppa: sudo add-apt-repository ppa:deadsnakes/ppa sudo apt-get update sudo apt-get install python3.6 J Fernyhough's PPA (at https://launchpad.net/~jonathonf/+archive/ubuntu/python-3.6) ...


448

How to know the version of installed package? apt-cache policy <package name> The above command will shows installed package version and also all the available versions in the repository according to the version of Ubuntu in which you are running.It doesn't display the package version which was intended for another version of Ubuntu(not your's). ...


422

Using a PPA (Obsolete) Note: WebUpd8 team's PPA has been discontinued with effective from April 16, 2019. Thus this PPA doesn't have any Java files. More information can be found on PPA's page on Launchpad. Hence this method no longer works and exists because of historical reasons. You can use WebUpd8 PPA (this will download the required files from ...


408

For Ubuntu 14.04 or later you need to install the software-properties-common package: sudo apt install software-properties-common I found the solution in this blog: Ubuntu Server 14.4 (Trusty Tahr) – add-apt-repository: command not found


298

The problem is that the teamviewer_linux_x64.deb, the package that was aimed to 64-bit systems, uses a obsolete package that tried to achieve multiarch previously in Debian based systems called ia64-libs. Although, that package scheme changed and now Teamviewer distribute the native build for both i386 and amd64 architecture, as they don't need anymore ...


297

The most common situation is when you want to install the latest version of cmake, but your Operating System's repositories are not updated. For example, in my case I have a laptop running Ubuntu 16.04, and when I executed the command sudo apt install cmake the installed version was 3.5.1; instead of 3.21.1 which is the current version at cmake.org. How can ...


293

If you want to use the latest development/staging version of Wine, please make sure to follow the guide in the Official WineHQ Guide for Ubuntu, basically covering: If you are using a 64-bit Architecture, then enable 32-bit for better compatibility sudo dpkg --add-architecture i386 Add the Wine Key, Wine Repository & Update Repositories wget -nc ...


268

Fresh installation Use the NodeSource PPA. For details look at the installation instructions. First, choose the Node.js version you need and add the sources for it: v=8 # set to 4, 5, 6, ... as needed curl -sL https://deb.nodesource.com/setup_$v.x | sudo -E bash - Then install the Node.js package. sudo apt-get install -y nodejs P.S.: curl package must ...


262

Latest news WEB UPD8: FFmpeg Returns To The Official Ubuntu Repositories With Ubuntu 15.04 Vivid Vervet FFmpeg and libav libav from the Ubuntu repositories Ubuntu started shipping the libav fork instead of FFmpeg in recent releases. If you installed the ffmpeg package, then you actually installed the libav-tools package and a program that told you to use ...


259

Video Demonstration Go to https://www.google.com/intl/en-US/chrome/browser/ Click Download and a small window will pop up with some download options. We want the ".deb" for Ubuntu. Make sure this box is checked. Note: Google no longer provides 32-bit versions for Linux - you are only able to get 64-bit versions for Linux as of at least February 2016 ...


241

I was able to install npm by doing following: sudo apt-get install nodejs-dev node-gyp libssl1.0-dev and sudo apt-get install npm


240

Try these: sudo apt-get install software-properties-common and/or sudo apt-get install python3-software-properties and/or sudo apt-get install python-software-properties


236

Step 1: Remove previous version. sudo apt-get remove skype skype-bin:i386 skype:i386 sudo apt-get install sni-qt:i386 It is Important if you installed older version of Skype on your Ubuntu, Clear the old Skype folder before installing latest version. Then clear that by using: rm -rf ~/.Skype Step 2: Preparing to Installing Skype. Users of 64-bit Ubuntu, ...


230

Felix Krull runs a PPA offering basically any version of Python (seriously, there is 2.3.7 build for vivid...) for many Ubuntu releases at https://launchpad.net/~deadsnakes/+archive/ubuntu/ppa. Do the usual: sudo add-apt-repository ppa:deadsnakes/ppa sudo apt-get update sudo apt-get install python3.5 It will not overwrite your existing python3.4 which is ...


230

Snap is probably still working on something in the background (or at least it thinks so). Open a terminal and run snap changes so see a list of ongoing changes. $ snap changes ... 123 Doing 2018-04-28T10:40:11Z - Install "foo" snap ... You can abort ongoing change(s): sudo snap abort 123 Then you should be able to successfully install VLC ...


222

For the following Ubuntu versions, you can install with the given commands, as per the official PostgreSQL Apt Repository. Ubuntu 17.04 - 17.10 Version 9.6 comes with the distribution. sudo apt-get install postgresql-9.6 Ubuntu 14.04, 16.04 sudo add-apt-repository "deb http://apt.postgresql.org/pub/repos/apt/ $(lsb_release -sc)-pgdg main" wget --quiet -...


216

The best way to correctly install gcc-4.9 and set it as your default gcc version use: sudo add-apt-repository ppa:ubuntu-toolchain-r/test sudo apt-get update sudo apt-get install gcc-4.9 g++-4.9 sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.9 60 --slave /usr/bin/g++ g++ /usr/bin/g++-4.9 The --slave, with g++, will cause g++ to be ...


206

Use the PPA from the maintainers of git on Ubuntu: sudo apt-add-repository ppa:git-core/ppa sudo apt-get update sudo apt-get install git If you don't know what PPAs are, first read What are PPAs and how do I use them? If you receive an error about add-apt-repository command not found you need to install software-properties-common, and then redo the above ...


196

Either use a PPA or compile it yourself: Installation by a PPA (Upgrade to 3.2) sudo apt-get install software-properties-common sudo add-apt-repository ppa:george-edison55/cmake-3.x sudo apt-get update When cmake is not yet installed: sudo apt-get install cmake When cmake is already installed: sudo apt-get upgrade Compile it yourself Currently, the ...


184

Open a terminal and execute: sudo apt-get install virtualbox which should work. Once you have installed it you probably want to install guest additions in the guest OS. Also you probably want the extension pack which you can get from here: https://www.virtualbox.org/wiki/Downloads Make sure you get the correct version. As of Xenial 16.04, you can ...


171

Generally speaking, loading arbitrary data from a URL into a root shell session is not a good idea and I wish people would stop peddling it as a solution for everything - "Please just run this script I'm sending you, and also while we're at it - I have a bridge you'd probably be interested in purchasing". As an alternative, here's the "Ubuntu Way" of doing ...


169

First be warned, installing files from outside of Ubuntu repository may compromise the system. VMware is probably safe, but it still should be mentioned. You need to change permission of the file to make it executable: chmod a+x VMware-Player-6.0.3-1895310.x86_64.bundle Start the file. You will most probably need root privileges to install VMWare, but ...


165

For pgAdmin 4 v4.21 on Ubuntu, according to the download page: Install dependencies, create a virtual environment, download, install & configure Using Python2.x sudo apt-get install virtualenv python-pip libpq-dev python-dev cd virtualenv pgadmin4 cd pgadmin4 source bin/activate pip install https://ftp.postgresql.org/pub/pgadmin/pgadmin4/v4.21/pip/...


157

Update VSCode is now available as DEB file. You can download it and then run: sudo dpkg -i ~/path/to/code_1.XXX.deb In case dpkg complains about missing dependencies, run: sudo apt -f install afterwards to fix the problem. Old answer Download Visual Studio Code for Linux Extract it: unzip VSCode-linux-x64.zip -d ~/path/to/VSCode Run the code ...


152

I would recommend pyenv to solve your woes. It doesn't use Aptitude, and does involve "building it yourself", but it's fully automated. You can build and install a new (or old) version of Python by simply saying pyenv install 3.6.0. Everything runs as your user, so you don't have to worry about messing up the Python used by Ubuntu itself. Plus, the answer ...


151

All Ubuntu releases as of July 2017 To install the Skype for Linux application (version 8+): Download the Deb package for Skype for Linux with your favourite web browser or HTTP client. For a terminal-based solution use: wget https://repo.skype.com/latest/skypeforlinux-64.deb Install the Deb package with your favourite package manager, ...


150

Steps to install terraform on Ubuntu / Ubuntu cloud server : Install unzip sudo apt-get install unzip Confirm the latest version number on the terraform website: https://www.terraform.io/downloads.html Download latest version of the terraform (substituting newer version number if needed) wget https://releases.hashicorp.com/terraform/0.12.18/terraform_0....


145

Here are the steps: Go to the geckodriver releases page. Find the latest version of the driver for your platform and download it. For example: wget https://github.com/mozilla/geckodriver/releases/download/v0.24.0/geckodriver-v0.24.0-linux64.tar.gz Extract the file with: tar -xvzf geckodriver* Make it executable: chmod +x geckodriver Add the driver to ...


144

2018 Update: This is still attracting upvotes which worries me. 12.04 has been unsupported for about a year now. The best way you can install pip3 is by upgrading to a newer, supported version of Ubuntu. You have 3 LTS versions to pick from. While on more modern versions of Ubuntu you could just sudo apt-get install python3-pip (and then use pip3), a ...


Only top voted, non community-wiki answers of a minimum length are eligible