Hot answers tagged

10

The apt source code has no mention of SOCKS whatsoever: /tmp/apt-1.0.9.1ubuntu1$ grep -ir socks . /tmp/apt-1.0.9.1ubuntu1$ It's also possible to have extension plugins for apt, such as apt-transport-https. These add files to /usr/lib/apt/methods/. So I used apt-file find to look for any other packages that provide files into this directory. This also did ...


7

I have to use a proxy everyday at work in order to connect to servers on the other side of a firewall. I also use Firefox, Chrome and Ubuntu 16.04. EDIT: I forgot one part of this. I have had to add a timeout to a ssh config file or my tunnel will timeout and I lose my connection. Once I added the following stuff, my connection stays open: In ~/.ssh/...


5

as @taifwa said, Systemwide proxy settings in ubuntu was the solution. and here is my script: ssh -D ${LOCAL_PORT} -f -C -q -N ${REMOTE_USER}@${REMOTE_HOST} -p ${REMOTE_PORT} #set socks setting in System settings > Network > network proxy gsettings set org.gnome.system.proxy mode 'manual' gsettings set org.gnome.system.proxy.socks ...


4

You can not make an application use socks proxy if it doesn't support it. Firefox supports socks proxy that's why you can simply change the proxy settings in Firefox to make it work. However, for apps that don't support Socks proxy, you can use Proxychains instead. It is very easy to setup and use. It comes pre-configured for use with Tor. Debian family: ...


4

You would do a lot better to "forward" the remote network's proxy server over SSH rather than using the built-in SOCKS server (which just expects a bare gateway-addressable network at the other end). ssh -L 8080:internal_ip_of_proxy:8080 user@ssh_server This exposes the proxy server locally, allowing you to set your browser's proxy settings to localhost:...


3

You could use this command on Linux: slack --proxy-server='socks5://localhost:1080' Obviously, you could use this for http proxy: slack --proxy-server='http://localhost:3128'


3

I found the problem was nothing to do with Tor being used as a relay. When you create a new tor instance it downloads about 8.5MB of data to the specified data directory. If you are creating multiple tor processes at once, this will cause a lot of bandwidth to be used. But once you have a data directory established, it does not download these files again. ...


2

If you are using Firefox or Google Chrome or Chromium browser, you could use FoxyProxy (free as of 26-Oct-2015) to use a manually configured proxy for specific URLs. To configure which sites you want to access using the proxy, click on the FoxyProxy Standard icon besides the address bar, click on "Add New Proxy" and then configure your host, port no, ...


2

man wget suggests wget doesn't support socks proxies. In any case, the term 'socks' doesn't show up in the man or info docs.


2

Although it's already given an answer I want to share what worked for me, using Ubuntu 14.04: sudo apt-get install tsocks Then open /etc/tsocks.conf and add your server to server and port to server_port, also add your socks server's range as local, like Example if your ip address is 90.70.60.5 then write: local = 90.70.60.0/255.255.255.0 (Note the .0 as ...


2

You are using the wrong tool to test your SOCKS proxy settings. wget does not have built-in support for SOCKS, it has support for HTTP / HTTPS. curl on the other hand has built-in support for SOCKS and thus you should use it instead. See man curl for information and usage.


2

If I understand correctly I think you're describing a SOCKS proxy. Those are very straightforward on Ubuntu. Secure the server (optional but recommended) I would recommend hardening the server a couple ways Set a strong password on the server (ideally use a key and disable passwords) Assuming your username on the server is "proserver1", add the line ...


1

These settings solved my problem of calls Dante Server 1.4.2 (Ubuntu 16.04) /etc/sockd.conf logoutput: /var/log/socks.log internal: 192.168.1.14 port = 8912 external: 192.168.1.14 socksmethod: username user.privileged: root user.notprivileged: nobody client pass { from: 0.0.0.0/0 to: 0.0.0.0/0 log: error connect disconnect } client ...


1

Unfortunately, this problem is intermittent and that has confounded my troubleshooting efforts. The answer @Terrance gave above, which I marked as The Answer, is actually not a solution to the problem for me. It seemed to work, and actually worked for a while. Then I ran into problems again. Sometimes stopping my ssh session and restarting it would cure ...


1

Per the answer given by @creveti-mihai, I looked at the sudoers man page. Unfortunately, as the man page says, it is not possible to preserve LD_* variables. Here is what the man page says: Note that the dynamic linker on most operating systems will remove variables that can control dynamic linking from the environment of setuid executables, including ...


1

The problem here is the SSH tunnel setup in PuTTY. Based on a web tutorial, I set up my 5900 SHH tunnel with the LAN IP adress of the server 192.168.1.110, so it looked like L5900 192.168.1.110:5900 in PuTTY. Target host was also 192.168.1.110. As we know this worked fine. Then I configured my SSH session with PuTTY for use abroad. Shame on me, I used ...


1

Here is my log from ssh -vvv -D 1080 user@IP OpenSSH_6.6.1, OpenSSL 1.0.1f 6 Jan 2014 debug1: Reading configuration data /etc/ssh/ssh_config debug1: /etc/ssh/ssh_config line 19: Applying options for * debug2: ssh_connect: needpriv 0 debug1: Connecting to 107.000.000.000 [107.000.000.000] port 22. debug1: Connection established. debug1: could not open ...


1

Okay, I think I've found out whats going on here: The socks5 proxy has a connection limit and when there are too many requests, the proxy throws these messages. This message also appears when the proxy server does not respond at all.


1

Proxy Toggle for Firefox 57+ works with Socks5 proxy authentication: https://addons.mozilla.org/en-US/firefox/addon/proxy-toggle/


1

The external server certainly give options but I'd like to explore direct connections first. They're faster and generally more reliable. They do however require an IP to connect and the routing at the other end to get your connection from router to server. You say you don't have these but I think you might be overlooking options. I find it hard (not ...


1

I'd suggest that you install the package apt-transport-tor. This allows you to download packages anonymously.


Only top voted, non community-wiki answers of a minimum length are eligible