New answers tagged

0

The special apt-get subcommand exists for such purpose - it is called build-dep. See man apt-get online or from your system: build-dep build-dep causes apt-get to install/remove packages in an attempt to satisfy the build dependencies for a source package. By default the dependencies are satisfied to build the package natively. If desired a host-...


1

As was said comments, we can remove MongoDB with the following command: sudo apt-get purge mongodb-enterprise* Then for most of the use-cases you can use Remmina from main pocket of repositories. So you have to remove the PPA with sudo apt-get update sudo apt-get install ppa-purge sudo ppa-purge ppa:remmina-ppa-team/remmina-next and install Remmina ...


0

Delete /usr/share/mime/packages/gnuradio.xml. Symlink gnuradio-grc.xml to gnuradio.xml: sudo ln -s gnuradio-grc.xml gnuradio.xml


0

I have written a Python 3 script which uses Python functions as well as some Bash commands. Pre-requisite: Ubuntu should be installed. Script isn't modified for Kubuntu, Lubuntu or other flavors. curl should be installed. If not installed, install it using: sudo apt install curl User must be using a version that is currently supported, i.e., it should ...


0

I think execution permission is needed, try to run the following command: sudo chmod +x /etc/apt/sources.list.d


1

So what happened was that there was conflicting packages. Nothing to do with Firefox and not a duplicate of other posts thank you though :) I went into synaptic and completely removed the broken package and manually downloaded the latest version of the package that was specificed by the Ubuntu website that was trying to download. The auto commands did not ...


0

The issue was caused as a result of unknowingly adding Opera Stable apt-repository to the sources list. Here's how I fixed it Solution 1 Open your terminal or command line, and type the following sudo nano /etc/apt/sources.list This will open your sources list in the nano editor Simply scroll down the list and comment out the line that is causing the ...


0

I have found a solution, there may be a better one but this worked for me... Part 1 Instead of doing: sudo apt upgrade by itself you have to use the tag --fix-missing and it will fail at first but then discover all the packages you set up using the normal method of apt-offline and it will update as expected. Short story use this command: sudo apt ...


0

I had exactly the same problem and just solved it as follows (origin of my problem was update to docker from older version to latest): 1.- Stop docker service (which is trying to start w wrong daemon command): systemctl stop docker.service 2.- Modify docker daemon command syntax in (which changed from old to latest version): /etc/systemd/system/docker....


0

If you would care about a gcolor2 alternative, I am recommending Gpick. It's easy to use and has a lot of features, which you can find in Gpick's website. You can install it by running: sudo apt install gpick


1

This solved my problem: sudo apt-get update sudo apt-get install dos2unix


-1

Since you can still run dpkg, at least part of the dpkg package is still present. To restore dpkg-deb, you should try re-installing dpkg: download the appropriate package file (Mint 18.3 is based on Ubuntu 16.04, so look for Xenial on this page to get the appropriate links; the download link I’m giving here assumes you’re using amd64) wget https://...


0

You can edit the (PPA) repo file directly, and delete the entry(s) that you want to remove: sudo nano /etc/apt/sources.list Or use the add-apt-repository command, with the -r switch to remove: sudo add-apt-repository -r ppa:<repo name> "repo name" - The apt repository source line to add. This is one of: a complete apt line in quotes, a repo url ...


1

Have you created a package.json file? Maybe I Think run this command first again. LPB_Tandn_IT:~ tannetto$ npm init This is command creates a package.json file in your folder. Then run, LPB_Tandn_IT:~ tannetto$ npm install redis --save The --save ensures your module is saved as a dependency in your package.json file. I hope you will find this article ...


0

While upgrading via apt-get, one usually gets a prompt of what to do with the config file (Install new version, Keep the old version, etc). If we choose to keep the current version, the new config files get stored with an extension (.dpkg-dist). The following command can be used to list the new files: find /etc -type f -name "*.dpkg-dist" And to take ...


4

It's very different for different apps. You can find good and well maintained apps - https://snapcraft.io/pycharm-community, https://snapcraft.io/telegram-desktop But there are many garbage, outdated or insecure apps - https://snapcraft.io/ghex-udt, https://snapcraft.io/electrum Before install app you have to check author, current version/last update for ...


13

Snaps have the https://snapcraft.io/ repo - this is run by Canonical, the same people that build Ubuntu. Flatpaks have an official repo at https://flathub.org/ . Flatpaks were developed by Redhat but I don't know if they manage the flathub repo or not. Stability: The stability of the individual packages, of course, rely on the quality of the build and ...


0

You can use: wget http://mirrors.kernel.org/ubuntu/pool/main/libp/libpng/libpng12-0_1.2.54-1ubuntu1_amd64.deb sudo dpkg -i libpng12.deb


0

I see that you have kpsewhich in /usr/local/bin/kpsewhich. Consider to remove it with sudo rm /usr/local/bin/kpsewhich along with miktex cache: sudo rm -rf /var/cache/miktex-texmf Then rerun texmaker installation: sudo apt-get install -f sudo apt-get install texmaker


0

First try this command: apt --fix-broken install And then: sudo apt update


2

To temporarily fix the issue you can force package installation with sudo dpkg -i --force-all /var/cache/apt/archives/emacs25-common_25.3~1.gite0284ab-kk1+18.04_all.deb


1

Let's take a look at the key part of the error message: Los siguientes paquetes tienen dependencias incumplidas: libgail-3-0 : Depende: libgtk-3-0 (=3.22.30-1ubuntu4) pero 3.22.30-1ubuntu1 está instalado libgtk-3-bin : Depende: libgtk-3-0 (>= 3.22.30-1ubuntu4) pero 3.22.30-1ubuntu1 está instalado It says that you are trying to upgrade newer ...


2

Upon digging around some more, I found apt-fast. There is an Ubuntu PPA that can be used for installation. The apt-fast command is able not only to download packages in parallel but also to download using multiple connections per package and from multiple mirrors. Documentation is all available on the GitHub page linked above.


1

Despite the problem no longer being reproducible, I'd suggest that this is the kind of message you'd get if you were trying to install a package with a massive incompatibility -- for instance, if the version of Wine you were attempting to install needed to uninstall KDE Desktop, you'd get a warning that it was going to uninstall everything that depended on ...


1

The proposed solution described above didn't work for me on Ubuntu 19.04 with Cisco PacketTracer 7.2.2: ./PacketTracer7: /lib/x86_64-linux-gnu/libpng12.so.0: version `PNG12_0' not found (required by ./libQt5WebKit.so.5) ./PacketTracer7: /lib/x86_64-linux-gnu/libpng12.so.0: version `PNG12_0' not found (required by ./libQt5Gui.so.5) What did work for me was: ...


0

Try to install this package with this command: sudo apt install libcanberra-gtk-module libcanberra-gtk3-module


7

If you run sudo apt install gcc you will get a prompt showing the packages to be installed and required space, asking if you want to continue. To see the download size of a specific package you can run e.g. apt show gcc


0

There are two different pip packages in Ubuntu 18.04: python-pip (for Python 2.x) and python3-pip (for Python 3.x). To install packages that are compatible with the default Python version in 18.04 you need to install python3-pip. sudo apt install python3-pip You can also install numpy with either: sudo apt install python3-numpy # for Python 3.x or sudo ...


0

Your output shows this error: pycompile: not found pycompile is provided by minimal subset of the Python language (version 2.7) ie. python-minimal or more precisely libpython2.7-minimal Please read here. To fix it you need to reinstall libpython2.7-minimal or python-minimal by running the following command in the terminal: sudo apt install --reinstall ...


0

Running the commands separately as shown below should solve the problem as the commands are munged together with "&&" sudo apt update Then sudo apt -y install ca-certificates wget net-tools Thanks to user535733 for his comment.


0

See the complete solution here. Simply purging the offending kernels works. It turned out I had three more unwanted kernels: azure, aws, and lowlatency. No idea how I got those - I am sure I never explicitly installed those. Anyway - simply purging them, making sure to keep the generic one, did the trick.


0

Hm, try the "windows-way" sudo apt install --reinstall python3-commandnotfound command-not-found


2

I solved the problem by reinstalling the correct package from the correct version: wget http://fr.archive.ubuntu.com/ubuntu/pool/main/g/glibc/libc6_2.27-3ubuntu1_amd64.deb sudo dpkg -i libc6_2.27-3ubuntu1_amd64.deb sudo apt upgrade Thanks to 'guiverc'


0

I also had this exact problem! (And this post is now the first hit on Google.) I solved it by building sslscan myself, with static linking; this puts the SSLv2 and SSLv3 support into the executable itself. It might be dangerous to have the global openssl library support old vulnerable protocol versions. The source code repo for sslscan is here: https://...


0

Well, I ended up reinstalling Ubuntu: no matter how many solutions I found, the causing problems were too diverse, even if all resembled the fact of somehow messing with the Python default version. I guess Python truly is something that you should be extra-careful when handling with Ubuntu. Lesson learned the hard way.


0

Short Answer: I guess it's safe. Longer Answer: Using the information from the comments to the question, I deleted all rc packages on my system. Even after the deletion the system remained stable. Therefore I guess it's ok to say it's safe.


1

Use update-alternatives to put the default python version back to what it was. I am also running Ubuntu 18.04 my python version is 2.7.15 $ python --version Python 2.7.15+ Then I would recommend looking into setting up virtual python environments using venv (venv in python3 and virtualenv for python2) for testing or running programs that require python 3. ...


1

First, fix any dependency problems by running: sudo apt install -f and update: sudo apt update Then, uninstall Vivaldi: sudo apt remove vivaldi-browser Download the Vivaldi .deb package from the Vivaldi website and save it on your computer. cd to the directory where you downloaded the .deb package and then install Vivaldi by running: sudo apt install ...


0

I see 2 errors. software-properties-gtk choose download from main server. grep -r nodesource /etc/apt/sources.list /etc/apt/sources.list.d/ shows you where https://deb.nodesource.com/ comes from. remove it. And then run sudo apt update


2

First let's try to "help" with the second topic, but it should work to open the keyboard shortcut settings and setup a new shortcut CTRL+ALT+T for the executable gnome-terminal this doesn't fix the issue why it's not working anymore as it used to do, but at least it's recovering functionality. To the first question: What is the current output of: which ...


0

This error is not since yesterday. Make a backup from your important data. wget -c http://security.ubuntu.com/ubuntu/pool/main/i/initramfs-tools/initramfs-tools_0.122ubuntu8.14_all.deb Install the package directly with dpkg. sudo dpkg -i initramfs-tools_0.122ubuntu8.14_all.deb Control with dpkg -l | grep initramfs-tools If the package is correct ...


0

As I'd suggested in the comments, if you are looking for a simple way to have the same environment for everyone and easily revert to a predefined state, I'd suggest virtualization. A full Howto would probably exceed the frame of an answer here, so here aresome hints and links: KVM Install KVM Install KVM (a bit outdated) Debian Wiki Page for KVM I'd ...


0

Using apt from command line Just use the command sudo apt-get remove package_name If you want to also remove user data and configuration files 1 sudo apt-get purge package_name Using --auto-remove parameter will also remove package dependencies.


0

There is no policykit agent running. sudo apt install --reinstall policykit-1-gnome Make a reboot. I could swear the agent would startup with your desktop-session, after reboot. sorry for link add application on startup I don't use gnome3 for about 2 years.


0

I think your best alternative for you is https://www.vagrantup.com/ (Their motto is "Development Environments Made Easy") The following paragraphs are copied (with some editing) from their web site: What is it for? Vagrant is a tool for building and managing virtual machine environments in a single workflow. With an easy-to-use workflow and focus on ...


1

I fixed it uninstalling nvidia drivers using: sudo apt purge *nvidia* sudo apt autoremove *nvidia* I had the same issue and I read that the problem is caused for old packages or dependencies of another nvidia driver previously installed. Once you run the above commands you can do the installation again.


1

When an ordinary application (like apt) start segfaulting, and it seems like nothing has changed that might otherwise account for the problem, then try reinstalling the package. sudo apt install --reinstall the_package_name In this case, since apt is the problem, you can't do that. Instead, use dpkg to reinstall apt. This is usually pretty easy: The ...


1

zenity --color-selection provides a no-frills color-dialog. In 19.04, but not in 18.04, the "dropper" in the top-left corner allows you to click on any item on your desktop.: There's also yad which is said to offer more features than zenity. And the version in 18.04 comes with a dropper to allow you to pick a color from any item on the desktop: yad --color


1

You can’t resolve it, because openjdk-8-jre-headless breaks ca-certificates-java versions older than 20160321. However I don’t think you need to resolve it: apt-get install -y -t jessie-backports openjdk-8-jdk works fine, and the resulting setup does have a /etc/ssl/certs/java/cacerts file.


Top 50 recent answers are included