New answers tagged

0

According with the git commits in linux kernel, the device was added on Apr 14 [1] ("Valeu luca!") and is available only in kernel 5.13[2]. Not yet on Ubuntu 21.04. [1] https://github.com/torvalds/linux/blob/62fb9874f5da54fdb243003b386128037319b219/drivers/net/wireless/intel/iwlwifi/pcie/drv.c#L622 [2] https://github.com/torvalds/linux/blob/v5.13/...


-1

vi /etc/ssh/ssh_config KexAlgorithms diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1


1

It turns out that on Ubuntu20.04, you have Netplan and Systemd to contend with. It also turns out that systemd-networkd will remove any routes not under someone's control. The way to resolve this is to add an "unmanaged" rule in /etc/systemd/network. In this case, since there are two network devices to "protect", then create two files ...


0

One problem that could be blocking is the path where the rule is pointing out. My error message was complaining about name=/var/run/NetworkManager/private-dhcp and the rule was /run/NetworkManager/private-dhcp rw, I've solved this problem adding and alias in /etc/apparmor.d/tunables/alias alias /run/ -> /var/run/, then rebooted the apparmor : service ...


0

Maybe that little script can help you. That can even be called as intended by netplan (systemd) from the routable.d folder if you uncomment #NETDEV=${IFACE}. Of course it's not final and needs a bit of work but you are free to use it as a basis. #!/bin/bash NETDEV=enp0s3 #NETDEV=${IFACE} TMP_FILE=/tmp/link_state-${NETDEV} OLD_STATE= HAS_CARRIER="...


0

There is a built-in config for that. Just add all your servers like this: remote XX.XXvpn.xxx port remote XX2.XXvpn.xxx port ... then add this line remote-random That's all.


1

It turns out my dad unplugged the lan cable from the router, cleaned it (???) And plugged it back into an analog phone port. Anyway thanks everyone for trying to help me.


-1

Your WLAN speed is slow because you don't have a good driver (also happens for some Apple devices) And I think there isn't any driver for that ethernet card... Or not installed at least. I think this is a duplicate of Ubuntu 20.04, Killer E3100/AX1650i working on MSI GS75 10SGS But I am not sure. Sometimes Linux has basically just bad driver support which is ...


0

You do not need to tell netplan to ignore an interface. It only changes the configuration of interfaces that it's told to. But it sounds like what you want here is to use netplan to add a route to an interface that netplan does not manage, and that is not supported. For one thing, if at any point your tunnel drops, netplan is not in a position to readd the ...


0

Reinstalling the kernel module and restarting worked for me: sudo apt install rtl8821ce-dkms


1

I am using a Raspberry PI 4 with Ubuntu Server 20.04 and installed ubuntu desktop. Servers usually use netplan to manage networking. Desktop installs use Network Manager. You have netplan all set up nicely but want Network Manager to work properly. I suggest that you amend your netplan file to: # Let NetworkManager manage all devices on this system network: ...


0

Adding libreoffice-gnome GNOME Integration worked from me, Kali Linux.


0

I stumbled across this post while researching netstat -> ss conversion. Outstanding table but I wanted to point out one thing in particular... the man page description for the netstat -s command option states, "Display summary statistics for each protocol". ss -s option in the man page states, "Print summary statistics. This option does ...


0

Your output clearly states: 系统中 libnm0:amd64 的版本为 1.22.10-1ubuntu2.2 Your other Network Manager packages must match this version (1.22.10-1ubuntu2.2). Instead, you downloaded network-manager_1.22.10-1ubuntu1. That's a lower version. See the difference? The version of the network-manager package that you must download is NOT in the focal repository (focal = 1....


1

Your wireless may be dropping because of power management; that is, the feature where the card partially powers down to save battery power during periods of inactivity and then, ideally, powers back up seamlessly when activity resumes. Let's disable power saving to see if it helps. From the terminal: sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/* Your ...


0

I think ubuntu server uses netplan by itself so it should be: sudo nano /etc/netplan/01-netcfg.yaml or whatever .yaml resides in there. Assuming you use DHCP to allocate IP to your server, then: network: version: 2 renderer: networkd ethernets: eno1: dhcp4: yes Close and save and run from the terminal: sudo netplan apply then check your ...


0

Your wireless may be dropping because of power management; that is, the feature where the card partially powers down to save battery power during periods of inactivity and then, ideally, powers back up seamlessly when activity resumes. Let's disable power saving to see if it helps. From the terminal: sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/* Your ...


2

Create a cron job to check the connectivity every 1 min. sudo vi /etc/crontab then add the following line * * * * * root /usr/bin/ping -c2 8.8.8.8 || /usr/sbin/modprobe -r ath9k_htc && sleep 0.5 && /usr/sbin/modprobe ath9k_htc


0

it is strange, the speed problem was solved automatically, but that question mark still exists.


2

Please do: sudo apt update sudo apt install dkms git git clone https://github.com/awesometic/realtek-r8125-dkms.git cd realtek-r8125-dkms sudo ./dkms-install.sh You should be all set.


0

I had this same problem. The appropriate driver, bnx2, is a part of the linux-modules-extra package, which accidentally got removed on my server; bnx2x and tg3 are in linux-modules. If you have another means of network, try downloading the linux-modules-extra package, or you could boot into a live-usb to add it.


1

See if this makes any difference... Note: Confirm no tabs, just spaces Note: Normal indentation is two spaces network: version: 2 renderer: networkd ethernets: eth0: dhcp4: true optional: true wifis: wlan0: addresses: [192.168.1.12/24] gateway4: 192.168.1.1 ...


0

There is also sudo hostnamectl cat /etc/mailname If cloud-init is installed you also need to change /etc/cloud/clound.cfg Set preserve_hostname: true Consider also to change machine-id and ssh-key.


1

I had this issue. I was due to a known bug. This workaround worked for me: add this to /etc/network/if-up.d/globalprotect: #!/bin/sh # Hacky workaround bug in NM not setting the default routes. if [ "$IFACE" = "vpn0" ]; then ip route replace default via 0.0.0.0 dev vpn0 fi


0

There is a bug filled for this: https://bugs.launchpad.net/ubuntu/+source/isc-dhcp/+bug/1918410 and fix in AppArmor https://gitlab.com/apparmor/apparmor/-/merge_requests/730 with a good string: "owner @{PROC}/@{pid}/task/[0-9]*/comm rw,"


0

I do not know what was the problem. But after spending around 12 hours trying out every and any solution I could find in forums and here and there, this fixed the issue: sudo apt remove --purge network-manager sudo apt install network-manager


0

On a 1Gbps NIC and the right CPU, ovs vs ovs-dpdk will not show much difference for the basic port to port forwarding testing. But one 10gbps, 25Gbps, 40Gbps and 100Gbps OVS (kernel bridge) forwarding vs OVS-DPDK (userspace bridge) forwarding because impactful because DPDK-OVS mitigates the performance issue by reducing copy between port forwarding Since ...


0

I can't really explain why but the issue was: I had an internal wifi card on this machine the antennas for that card were not plugged in Never had to care about that because I never used the wifi. Must have unplugged them by accident in the past. For some reason when I plugged them in I was suddenly able to use USB wifi.


-1

got into the same issue - it seems to me related to wifi-power-save-on feature, if i turn it off, the wifi interface goes to airplane mode, which means no wifi at all... NICE :( So, the simplest and stupidest solution was - to run the endless ping to the router in background - it's enough to make wifi alive... :)


1

@Chili555 Gave the correct answer in one of the chats in the answers above. I have MSI 76GE Raider. With AX210 lspci -nnk 31:00.0 Network controller [0280]: Intel Corporation Device [8086:2725] (rev 1a) Subsystem: Bigfoot Networks, Inc. Device [1a56:1674] Kernel driver in use: iwlwifi Kernel modules: iwlwifi Had to download and install sudo ...


-1

I'm going to try a powershell script. route shows the current routing tables as a table with these columns: Destination,Gateway,Genmask,Flags,Metric,Ref,Use,Iface So I saved that output to a file, and copied it to the new host. I converted the raw output to a csv file by removing the first line, and replacing the spaces with a comma. I also replaced the ...


0

You have to setup ip forwarding. Data received on eth1 must be forwarded to eth0 using the routing table of your linux box. You have to change the content of the file /proc/sys/net/ipv4/ip_forward to 1 and then add some rules to the linux firewall via iptables. Search the web, it is full of tutorials. Probably, inside your router, there is a little linux ...


1

Don't touch the MTU setting unless you're in total control on that network! The MTU has to be equal on all devices connected to a network, otherwise you'll quickly face weird connectivity problems, where a host suddenly doesn't see parts of the traffic. Furthermore, it doesn't make sense on the Internet. MTU is likely to be limited to 1500b or smaller anyway ...


2

The next step in troubleshooting is to contact the eduroam WIFI helpdesk and ask them whether they are blocking DNS requests to external resolvers, and which DNS resolver you are supposed to use while on their network. Rationale: It is quite common for educational institutions to limit the acceptable use of their network and to enforce this on the DNS level. ...


3

Correct, if the answer section is missing, there is no record on that subdomain/DNS entry you are looking up, e.g _dmarc.domain.com If I were to do checks for myself, I would probably just check if the command outputs v=DMARC1, like: dig TXT _dmarc.domain.com | grep v=DMARC1 However, this does not mean that the DMARC is valid. Dig does not check this in ...


0

To reply to betatester988 Jul 19 at 16:53. I also found that protonvpn was stopping all my connections even when switched off. nmcli connection show - - active Output showed ipv6leak-protection which I deleted using nmcli connection delete [name of connection] I don't know if I needed to uninstall and remove old files as per proton vpn instructions but I did....


0

The DNS server doesn't magically generate hostnames. Something has to configure DNS with those hostnames. Both forward and reverse hostnames have to be configured in DNS to get full functionality. DNS doesn't generally support automatic dynamic hostnames. Protocols like mDNS/DNS-SD implemented by avahi try to do this, but it only works for participating ...


-2

uuuhm, so it turns out there's some kind of new bug somewhere in IPTABLES or even the kernel, no idea where specifically, but the work around is to manually add accept all, anywhere, ctstate ESTABLISHED, on the INPUT chain, because apparently this is needed now for v4 connections to work properly, even though you could connect into the server just fine ...


0

I have the same issue and use this little script: #!/bin/bash sudo pkill -9 -f nordvpn sudo iptables --policy INPUT ACCEPT sudo iptables --policy FORWARD ACCEPT sudo iptables --policy OUTPUT ACCEPT sudo iptables -t nat --flush sudo iptables -t mangle --flush sudo iptables --flush sudo iptables -X It kills the nordvpn process and resets the iptables. After ...


2

According this support topic How to Use dig/nslookup to Find SPF, DKIM and DMARC Records for a Domain? from CISCO, the syntax to use dig to look up DMARC status is: dig _dmarc.domain txt Substitute domain with the domain you want to look up.


1

From ifconfig and netstat outputs you provided, it looks that both your connections are assigned IP addresses from the same network - 169.254.0.0 with netmask 255.255.0.0. That may be the reason why they can't be used simultaneously. The network 169.254.0.0 is the so called autoconfiguration network. It is used when you don't specify manually any IP address ...


1

The issue isn't a 'wrong' server getting set, it's the fact that 18.04 and later use ResolveD by default now, similar to how 14.04 and older used dnsmasq to provide a DNS caching client. 127.0.0.53 is added by systemd-resolved at reboot and startup. ResolveD gets its DNS configured by however you configured your Internet configuration on Netplan or Network ...


0

This solved my problem in Ubuntu 20.04.3: https://www.google.com/search?channel=fs&client=ubuntu&q=how+to+resolve+printing+problems+in+ubuntu+20.04 I did the following: Run the following command in Terminal sudo apt purge ippusbxd Reinstall the printer by going to Settings → Printers. Then remove all existing printers. Switch on the printer, ...


1

Your wireless may be dropping because of power management; that is, the feature where the card partially powers down to save battery power during periods of inactivity and then, ideally, powers back up seamlessly when activity resumes. Let's disable power saving to see if it helps. From the terminal: sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/* Your ...


0

Kernel driver in use: rt2800pci Kernel modules: rt2800pci This is actually not the correct driver (I'm not 100% sure) This post may fix your problem. There it is described how you can install the correct driver. I did not test this - so if it's not working comment this answer please edit: you have to use another ppa INFO: you might have to try: 'sudo apt-...


0

There are various bots trying to scraper servers every now and then, this is just one of them trying to hit an endpoint on your server expecting to get some valuable data without you knowing, if you have a request tracking setup in place, you can consider blocking that server's IP address so they won't be able to request again. But that doesn't solve the ...


1

I suggest a GUI alternative to remove the connection. I presume you are using the GNOME environment. Go to: the System status area; Click the Wifi connection; Go to WIFI settings from the drop-down; Click the icon that resembles three dots arranged vertically; Select known Wi-Fi networks; Select the Wi-Fi connection and Click 'Forget' to remove the ...


1

Try : git clone https://github.com/RinCat/RTL88x2BU-Linux-Driver.git cd RTL88x2BU-Linux-Driver/ make sudo make install sudo modprobe 88x2bu After each kernel update, you must recompile: cd ~/RTL88x2BU-Linux-Driver/ make clean git pull make sudo make install sudo modprobe 88x2bu


0

The configuration required to offer your wifi as an AP is: wifis: wlan0: mode: ap Then include your access-point information as before (name and password). You need to have the network-manager package installed in order to use AP mode, as documented at https://netplan.io/reference/#properties-for-device-type-wifis%3A. It is not installed by default ...


0

Based on what I'm seeing in the info you provided it appears that the problem is that your connection is being dropped upstream. In this case, by something in the networking infrastructure at Tsinghua University in Beijing, China. Of course the NIC cable, networking hardware or something in the data closet could be the culprit. I see no evidence that ...


Top 50 recent answers are included