Hot answers tagged

181

I just had this problem myself, and the solution I found in reading the autoconf manual which states autoreconf runs autoconf which I did not have installed. sudo apt-get install autoconf and the autogen script I am using now works.


122

Run this command to install make and all the packages needed to build your code. sudo apt-get install build-essential


56

TL;DR checkinstall is your friend ;) sudo apt-get install checkinstall After a installation with sudo make install your package manager knows absolutely nothing about this installation. But it knows all about a package with the same name in the Ubuntu repositories or in a PPA. Use sudo checkinstall instead of sudo make install and use a higher version as ...


38

This means that you don't have the gtk headers to build stuff using GTK+. Is really weird that the error didn't showed up at ./configure step. To solve this just do: sudo apt-get install libgtk2.0-dev or libgtk-3-dev. That should do it.


34

If you want to see the full command line for every instance of make that is running on your computer, open a new terminal and try: pgrep -a make pgrep is a program that searches through all processes on your computer. In this case, it is looking for programs named make. The option -a tells pgrep to list both the process ID and the full command line for ...


32

My guess would be that you have the basic C compiler installed, but not the headers for the standard library. Try: sudo apt install libc6-dev [Edit: this produces similar symptoms, but wasn't the case here. The CFLAGS answers appear to be correct.]


28

While the terminal window is active you can pause (suspend) the process by pressing Ctrl+Z. You can then push the job in the background by typing bg (your job will now continue in the background and you can at the same time work on the command line; this is equivalent to starting a job with & at the end of the command line). Then use cursor-arrows (up ...


27

ref. https://facebook.github.io/watchman/docs/install.html#installing-from-source git clone https://github.com/facebook/watchman.git cd watchman/ git checkout v4.9.0 sudo apt-get install -y autoconf automake build-essential python-dev libssl-dev libtool ./autogen.sh ./configure make sudo make install Make sure to run git checkout v4.9.0. That is, check ...


25

From the config.log: configure:3478: gcc -03 conftest.c >&5 gcc: error: unrecognized command line option '-03' The option is -O3 with the letter O, not the number 0 (zero). So, you should run, as given in the README: ./configure CFLAGS="-O3"


24

You were almost there with your ln command - except you probably needed to include the -f flag ('force') in order to overwrite the old link - also it's preferable to use a relative path for the target sudo ln -sf bash /bin/sh When you're done with the install, you can revert to the system default with sudo ln -sf dash /bin/sh There should be no need to ...


24

Maybe simple... sudo apt-get install gcc ... could be enough?


22

Make a symbolic link to libcuda where ld is searching it. sudo ln -s /usr/local/cuda/lib64/libcudart.so /usr/lib/libcudart.so


18

It has to be enabled in debian/rules. If the package uses dh, there is a line like this in debian/rules: dh $@ Change that to dh $@ --parallel Then your commands will work, at least DEB_BUILD_OPTIONS="parallel=4"


17

You have spaces where you should need a tab (and no: 4 spaces do not equal a tab). This will show tabs (shown as ^I) and spaces: cat -e -t -v {Makefile} 4th line: 1 CFLAGS=-Wall -g 2 3 clean: 4 rm -f ex1 Remove the spaces in front of rm and make it a tab.


17

GNU radio uses libusb. $ apt-file search /usr/include/usb.h libusb-dev: /usr/include/usb.h That is probably the file you need, to install the package do sudo apt-get install libusb-dev


17

The error: make[2]: *** No rule to make target '/usr/lib/x86_64-linux-gnu/libpcl_common.so', needed by 'range_image_visualization'. Stop. means that make cannot find the file /usr/lib/x86_64-linux-gnu/libpcl_common.so that it needs to finish the compilation. First check if the file exists: $ stat /usr/lib/x86_64-linux-gnu/libpcl_common.so stat: ...


16

Over here is an install script, that nicely explains all dependencies and stuff, I'll just copy that for you ;) Install dependencies sudo apt install -y g++ libgtk-3-dev gtk-doc-tools gnutls-bin \ valac intltool libpcre2-dev libglib3.0-cil-dev libgnutls28-dev \ libgirepository1.0-dev libxml2-utils gperf build-essential Get and install vte-ng git ...


15

Edit the lines as shown below in the makefile and it should compile: FLAGS = -L /lib64 LIBS = -lusb-1.0 -l pthread


14

Do an reinstalation of the build-essential package: sudo apt-get install --reinstall build-essential This should fix it.


14

No, there is no developer ISO. Yes, you do have to manually install them. Ubuntu is made to be a distribution aimed at ease of use on the desktop meaning that the main use is word processing, etc. To install basic development tools, run: sudo apt install build-essential Any other tools can be installed with: sudo apt install tool-name


14

You need to put then in next line or use semicolon if [ ! -d upload-api/app-router/ ] then or if [ ! -d upload-api/app-router/ ];then


13

sudo apt-get install build-essential gnome-devel That is also needed so that you can do cool things like: g++ main.cpp -o base `pkg-config --cflags --libs gtk+-3.0` It allows you to use pkg-config to save a whole lot of time


13

Three options: create a fake package for progA: How to fake a package version installed? (there is an extensive example for TeXlive). create a package for progA, easier if it has a checkinstall option: How to trick apt dependencies? Build also progB from sources.


12

$ apt-cache search makedepend xutils-dev - X Window System utility programs for development So you have to install xutils-dev package(which includes the program makedepend) .Install xutils-dev package by running the below command on terminal, sudo apt-get install xutils-dev


12

The best way to build the ATLAS library customized to your particular processor is to follow the instructions in /usr/share/doc/libatlas3-base/README.Debian (also available for reading online here). The instructions tell explicitly how to rebuild the atlas source package for Debian/Ubuntu in a way that will give you custom-built packages that can be ...


12

LD_LIBRARY_PATH is used to modify the behaviour of the ldconfig and related tools when looking for the libraries, at execution time. The ld linker tool doesn't use this variable. If you want to use a library located in a non-standard directory, you have to use the -L parameter of the command, like this : ld -lcuda -L/usr/local/cuda/lib64 If you have ...


12

Seems like the user who found the solution never shared it later. For guys who are trying to find the solution just add the math library explicitly and also add -ldl So -lm and -ldl in the gcc line you are compiling and it should go just fine. Alternatively, in most cases you can also explicitly define CFLAGS and alleviate the issue that way. These are ...


11

You haven't installed Emacs with the package manager. As you have installed it from source tarball, try this way. Check emacs version. $ emacs --version Download the same emacs version you have installed in the past. $ wget https://ftp.gnu.org/gnu/emacs/emacs-$VERSION.tar.xz Extract tarball. $ tar xJvf emacs-$VERSION.tar.xz Run ./configure to generate ...


11

I was able to satisfy the dbm requirement via this module sudo apt install libgdbm-compat-dev It looks like the older "dbm" files are moved to "gbdm-compat" package.


10

With debhelper 10, you no longer need to supply the --parallel option in debian/rules; it now runs parallel builds by default. See the release notes The answer, is therefore, just to set the contents of debian/compat to 10 and to update the debhelper version to >=10 in debian/control.


Only top voted, non community-wiki answers of a minimum length are eligible