New answers tagged

0

I had the same thing and tried a lot of different fixes. What i think fixed it was updating my kernel. wget https://raw.githubusercontent.com/pimlie/ubuntu-mainline-kernel.sh/master/ubuntu-mainline-kernel.sh chmod a+x ubuntu-mainline-kernel.sh sudo ./ubuntu-mainline-kernel.sh I restarted the PC and it didnt initially work so i turned the machine off. When i ...


0

Finally, after surfing a lot through the net and reading about options of alsa for NVIDIA aound controller I got the following solution 2 files are to be changed /etc/modprobe.d/blacklist.conf and /etc/modprobe.d/alsa-base.conf Changes in File 1. open the file using root add the following line to the bottom of the file options snd-hda-intel dmic_detect=0 ...


0

acpi-call was supported until Ubuntu 16.04, but not any longer. And Thinkpads newer than TP 410 can't use the tp-smapi module, but the tpacpi.bat package - both relying on acpi-call, but: Starting with kernel 4.17 tpacpi-bat gets superseded by a new, native kernel API called natacpi (contained in the ubiquitious kernel module thinkpad_acpi). tlp-stat -b ...


-1

You have not given the details on How you tried to install, why you were not able to install (error message, etc), what exactly is the difference in performance that you noticed. It is always a good practice to provide as much (relevant) info as possible. It will help you get a quick & proper solution (or) at least, more closer options - besides helping/...


-1

Am having the same issue over here, upgraded from 18.04 to 20.04 and am having trouble with virtual box, it says the same thing as the original post says


0

Another place to look at is "lsof" apart from unloading the dependent modules. # lsof | grep < relevant str to module > This should list the files that are opened via the module. Try killing those processes that opened the files and check the module reference count is getting reduced through the "lsmod" command.


-2

I think You have problem with your bios/uefi boot configuration . bios/uefi interface is not same for all device but i try to coverup change boot priority in bios/uefi -> boot menu        make sure ubuntu-loader / grub is in first place / higher priority in uefi        if you have old bios you have to prioritize your harddisk since bootloader / grub ...


0

BIOS In terminal, do sudo dmidecode -s bios-version to determine your current BIOS version, and then go to the laptop manufacturer's web site to see if there's a newer BIOS available. Nvidia You have Nvidia version 440.100. There's a newer Nvidia driver available for Nvidia RTX 2060. Either open Software & Updates and see if driver 450.57 is available ...


0

So Droidcam is working now. First, I uninstalled Droidcam. Second, Using the answer by Earl Sablo I tried the following: sudo update-secureboot-policy --enroll-key It asked to create a password for the secure boot menu, which I created. Then I restarted my PC and the secure boot menu asked threw a number of options. Choose "Enter MOK key", and use ...


0

Hello and welcome to askubuntu, your problem looks like a kernel panic. See this blog If possible, then start your last kernel which is possible to run. Try to generate with update-initramfs new initramfs images for your kernel. If it doesn't work, start Linux live distro and try it there.


0

The question was how update-initramfs tool has the idea of these "versions" (how it managed to "generate" them is another :D)? To find... cd (go to) into the directory: lukas@OMEN:/etc/initramfs-tools$ cd /var/lib/initramfs-tools ls (list) the files in current directory: lukas@OMEN:/var/lib/initramfs-tools$ ls '-r)' -r} '(uname' {...


0

You could try DConf graphical configuration editor. The path to look for in this tool is '/org/gnome/settings-daemon/plugins/power/power-button-action'... There you can choose the action that the power button should excert... It's also possible in the terminal but more cumbersome imo.


0

It's possible this error could be related to the initrd image being too large. A solution to this can be accomplished by changing the compression method and removing debug symbols from object files: # Strip unneeded symbols of object files $ cd /lib/modules/5.4.5-rt3 # or your new kernel $ sudo find . -name *.ko -exec strip --strip-unneeded {} + # Change ...


0

Removed armhf from archs in the else branch of linux-raspi-5.4.0/debian.raspi/etc/kernelconfig. Now... if [ "$variant" = "ports" ]; then archs="" family='ports' else archs="arm64" family='ubuntu' fi


1

Environment Modules works with modulefiles, which are scripts written in Tcl that describe environment changes (like the addition of a directory to an environment variable). You could look at /usr/share/modules/modulefiles/dot on your setup to see an example of modulefile. In your situation, you install Perl modules, but once installed there is no modulefile ...


1

Switching from iptables legacy to nftables fixed my problem. You can do that by running: # update-alternatives --set iptables /usr/sbin/iptables-nft # update-alternatives --set ip6tables /usr/sbin/ip6tables-nft # update-alternatives --set arptables /usr/sbin/arptables-nft # update-alternatives --set ebtables /usr/sbin/ebtables-nft You can switch them back ...


1

You are installing lowlatency modules with a generic kernel. It won't install this way. You need to download all generic, or lowlatency packages.


2

I downloaded and installed the latest VMWare Player from VMWare and now everything works. I had been running 15.5.1, now I am on 15.5.6. You get a .bundle file - I just chmod +x reallylongfilename it and sudo ./reallylongfilename and Bob's your uncle. If updating VMWare Player isn't an option, you might wish to look at this thread: https://communities.vmware....


1

Seems that the problem was in the static electricity. A reboot occured one more time at the moment I sat on my chair. There was a corresponding blink of keyboard lights. I connected the PC case to ground to check if it helps.


0

Prayag Sangode's answer on Before you can run VMware several modules must be compiled - Unix & Linux resolved the issue on Ubuntu 18 (VMware version 15.5). git clone https://github.com/mkubecek/vmware-host-modules cd vmware-host-modules git checkout workstation-15.5.6 sudo make ; sudo make install


0

Eventually, I installed nvidia-driver-440 instead of 435, and the Nvidia driver vs kernel version issue can be finally settled without the need to downgrade the kernel version.


0

if your system freezes at the DELL logo, that is presumably before the bootloader (grub) even gets to load your kernel, i.e. you might have misconfigured your grub.


0

Like @databoy2k it looks like there is some bug in how DKMS gets called to compile the wireguard module. I haven't gotten locked out of any systems, though. Remediation that works for me on Ubuntu 16.04: (Consider rebooting first.) apt-get remove linux-headers-$(uname -r) apt-get remove wireguard apt autoremove -y apt-get install linux-headers-$(uname -r) ...


0

I also had this problem after installing Ubuntu Studio 20.04 alongside Win10 on a refurbished HP Pro 6200 pc. I tried a few things from the answers to this question but that did not work. But I have sound now from the onboard audio by disabling auto mute in alsamixer with my scroll wheel. (view: all (F5) )


3

I had the same issue with ubuntu_18.04, kernel 5.4.0 and displaylink driver 5.2 after updating to displaylink driver 5.3.1 it started working again. apparently 5.3.1 is also for ubuntu 18.04 although not mentioned in the overview page.


1

You have to install the corresponding meta-package by: sudo apt-get update sudo apt-get install linux-image-generic and then to be completely sure install all newest dependencies for 20.04 LTS by sudo apt-get dist-upgrade


0

I wouldn't expect to find any software to deal with such a hardware issue. Your best bet is to work around it by using a combination of Keyboard shortcuts such as Ctrl+W to close windows & many others to deal with common tasks. Using mouse right-click on links to both open up the context menu & select the menu item (Tested to work on Chrome) ...


0

Go to Settings → Universal Access and set the Double Click delay there. Adjust the slider to suit your preference. If on the other hand you are seeking to apply a single click then refer to this answer


0

I've got the same problem as mentioned. Recent kernel update was definitely the case. First step you should try to do is to boot ubuntu using previous kernel version. To do this, go to Advanced options for Ubuntu and pick first kernel version under one marked with *. When system starts, reinstall displaylink drivers like you tried before. In my case, this ...


0

It works for me renaming pulseaudio (autospawned parameter does not work): sudo mv /usr/bin/pulseaudio /usr/bin/pulseaudiodisabled killall pulseaudio then apply the HDAjackretask modification without reboot (you have to run alsamixer and unmute and raise master volume after apply ). Close alsamixer before testing another setting. As pulseaudio is disabled,...


2

For some reason, the headers for 5.4.0-42 weren't installed by apt automatically. (I did the original offending kernel update as part of a prompt from the "Software Updater" GUI.) Installing the headers with: sudo apt install linux-headers-5.4.0-42-generic caused apt to automatically recompile the nvidia kernel module for the new kernel. After a ...


0

TL;DR: @insider's answer, along with the comments by @Antonios Hadjigeorgalis led me to find that I had Unattended-Upgrade::Automatic-Reboot "true" in /etc/apt/apt.conf.d/99custom-unattended-upgrades I was experiencing sudden reboots, mostly soon after turning my laptop on in the morning. I'm running Ubuntu 18.04. Running last reboot showed that ...


0

This answer is possibly more of a comment, but it would not fit as such. So this is my five cents to try helping. I have recently faced an issue with sound in 20.04, and it was painful to solve it. Only "Dummy output" (sound) in Ubuntu 20.04 after reboot - Broken driver / module At the bottom of the question I list just a few of the sources I read. ...


2

Go to https://github.com/teejee2008/ukuu/releases and download the .deb version according to your CPU platform (64 or 32 bit). Install and enjoy it. That's the only way to install that still works.


0

You could try installing Grub Customizer; this gives you a range of other things you can tweak and might fix your problem: How to Install Grub Customizer in Ubuntu 18.04 LTS - Tips on Ubuntu.


1

Try to check if all dependencies are correct: modprobe --show-depends snd_hda_intel And check if the kernel module exists: find /lib/modules/$(uname -r)/kernel/sound -name snd-hda-intel.ko BTW the right forum for alsa/sound problems would be alsa forum (alsa-project.org/wiki/Main_Page). BTW: There exists a beautiful script that uploads all necessary info ...


1

Summary: I managed to Learn which files my system were missing. This was my main hurdle, solved with the help of this comment, now posted as an answer. The rest was easy. Learn which package holds them. Install it. After trying many things, I have solved the problem. It was essential to have, in addition to my broken system S1, a similar working system S2 ...


0

BIOS DELL Inspiron 13 (i13-5378) You have a very old BIOS, at version 1.6.1. There's a newer BIOS available, version 1.30.1, and can be downloaded here. This should solve the problem of running the newer Ubuntu kernels. Unless you can update the BIOS from your current BIOS, you'll need Windows to install the new BIOS. Note: Verify that I have the correct web ...


0

I ran into this sound problem with Ubuntu 20.04 after a recent hardware upgrade. Making the following change sorted it out, perhaps it will for you as well. Append the line options snd-hda-intel model=auto at the end of file /etc/modprob.d/alsa-base.conf.


0

What worked for me: To run vboxconfig to rebuild virtualbox kernel drivers sudo /sbin/vboxconfig


0

This seems to be a common problem with Ryzen CPUs freezing in the C6 sleep mode. This mode can be disabled, eg. using the ZenStates-Linux script via the msr kernel module. Check these for more information and how to fix it: https://forum.manjaro.org/t/fix-ryzen-lockups-related-to-low-system-usage/39723 https://utcc.utoronto.ca/~cks/space/blog/linux/...


0

You should not be getting any notifications from Ubuntu about kernel versions that aren't yet available for your version of Ubuntu. Ubuntu does not ship a "bleeding edge" kernel because more testing is required before it is considered stable enough for Ubuntu. It's generally not wise to use the most recent kernel version unless you are testing. ...


0

You will need to enable nested virtualization which for a long time wasn't possible at all with the default provider for vagrant being virtualbox. Once you enable nesting your reported issue should be resolved. You'll find plenty of howto's on the internet, here a few to give you a start: virtualbox libvirt vmware workstation


2

Ubuntu 16.04 provides two supported kernels, the GA (general availability) kernel is 4.4, and the HWE (hardware enablement) kernel is 4.15 (ie it progressed using the 16.10 kernel, 17.04, 17.10 before finally settling on 18.04 or the next LTS GA kernal). For details on HWE (hardware enablement) see https://wiki.ubuntu.com/Kernel/LTSEnablementStack https://...


0

Another option for a RAM Disks is zram. When you place a file onto a zram RAM disk, the file gets quickly compressed during the transfer and it is transparently decompress during the retrieval. This can be helpful in circumstances where your system doesn't quite have the amount of RAM you desire for your RAM disk. Here's how to create a zram RAM disk: Make a ...


0

The main issue with running a real-time kernel is that it poses a serious security issue. RT processes have the potential to completely take over a machine. There are also other reasons not to run RT, among them: Since Linux 2.6, the real-time stack has been part of the Linux kernel, having a kernel patched with a real-time stack is no longer necessary. ...


0

To run the file, you first must make it executable. Extract the file and then open the containing folder in your terminal. Run: chmod +x ./displaylink-driver-5.3.x.x.run (Change the name to match the file downloaded.) Then just run the file from the terminal with: sudo ./displaylink-driver-5.3.x.x.run (Again changing the name to match the file downloaded.) ...


0

I was also having this problem, and figured that RAID services weren't being used in my case, given that Ubuntu 20.04 is running in a KVM environment. (A quick look in Webmin showed me that no RAID was configured.) On a hunch, I ran apt remove mdadm, and was then able to run update-initramfs manually. I'm now able to use apt to install kernel packages again.


0

It does not work . If you are using 18.0.4 LTS then expect major system problems as simple things like networking,distorted display (GPU acceleration) to be very unstable as i found out. You are better of not upgrading directly to 5.4 without a clear migration path that Ubuntu recommends. This is speaking from a personal experience


0

I see that the driver is listed as ehci. You might need to enable xhci support in your BIOS to get USB 3 working.


Top 50 recent answers are included