Podcast #128: We chat with Kent C Dodds about why he loves React and discuss what life was like in the dark days before Git. Listen now.

Hot answers tagged

4

Likely an unexpected encoding: >cat ISO-8859-15.txt d�j� emp�ch� Thefile command can tell you the encoding used: >file ISO-8859-15.txt ISO-8859-15.txt: ISO-8859 text With this information you can use iconv to convert to another encoding (usually UTF-8): iconv -f ISO-8859-15 -t UTF-8 -o UTF-8.txt ISO-8859-15.txt Check: >file UTF-8.txt UTF-8....


1

In gedit there is no bash or script highlighting mode. The closest that they have is the sh highlight mode. Plaintext mode: View -> Highlight Mode -> sh then select: sh highlight mode selected:


1

Probably this has to do with a different character encoding (see https://en.wikipedia.org/wiki/Character_encoding) being used when the file was created, and the gedit editor is not able to guess that. One way to solve it could be to try opening the file using some other program, like emacs or libreoffice -- from there you can then hopefully save the file ...


1

A more detailed answer from: How to debug c programs by gedit? Gedit Plug-ins Use gedit external terminal plug-in You can use gedit with terminal plugin. The steps are fairly straight-forward: Enable "Universe" repository Install gedit-plugins Activate "Embedded Terminal" Use Ctrl+F9 to open terminal Other gedit plug-ins Step 1. Enable "Universe" ...


Only top voted, non community-wiki answers of a minimum length are eligible