Hot answers tagged

13

TL;DR: It's an issue with fontconfig before version 2.13. It can be fixed by upgrading the package to 2.13 or higher (though I couldn't find a suitable provider). Alternatively, examine all your fonts-related folders and config files in your home directory and test if removing any of them resolves your issue. For me, renaming ~/.fonts did the trick. After ...


11

I encountered the exact same problem after upgrading Kubuntu 18.04 to 18.10 ! Trying to figure out what is this weird font, I browsed and found out that Telegram is using KacstArt font (probably because this is the first font in the list when it fetches all system fonts). I solved my problem by limiting telegram font search-paths into a single isolated ...


11

The fix: sudo nano /etc/fonts/conf.avail/69-language-selector-ja.conf change on line 8 family to lang <test qual="all" name="lang" compare="contains"> TL;DR: I began the test with replacing all Ubuntu *.conf files in the /etc/fonts/conf.d directory with Manjaro's to test whether it was a config bug (I thought it was in the freetype library). New ...


9

You have to install "fontconfig" package: sudo apt install fontconfig Now you should be able to use fc-cache.


7

The PostScript language defines 35 core fonts in PostScript 2. Among them is the Helvetica family. A properly configured system should automatically substitute one of the following fonts, if available: Microsoft commissioned a copy of Helvetica – The well-known Arial. (ttf-mscorefonts-installer) Google commissioned the Croscore fonts, designed to be ...


7

I just installed the latest version of Acrobat Reader DC (2019) in Wine using this guide by user filozofio here : install wine and winetricks execute these commands in a terminal: winetricks atmlib winetricks riched20 winetricks wsh57 winetricks mspatcha Get the Windows 7 fonts, especially the sego* fonts. I got them from here: https://www.w7df.com/7/...


7

I was going to comment buuuut I don't have enough reputation 😢 (hey look, here's an emoji to check if it is working or not!) This solution worked for me "partially", it did fix the emojis in Discord and in the Terminal, but in Firefox it was still a mix of "some of them works, some of them doesn't", I also found this but that didn't fix the issue in ...


6

Here is how I fixed this issue for Persian: Close Telegram Create directory: ~/.fonts Add a font with its different weights [I used Vazir] Create file: ~/.fonts.conf and add these lines to it: <?xml version='1.0'?> <!DOCTYPE fontconfig SYSTEM 'fonts.dtd'> <fontconfig> <match target="pattern"> <test name="family" qual="any"> ...


6

As noticed by @steeldriver, the problem is specific to Wolfram Mathematica. I solved the issue by following some of the steps from this question: Can't launch Mathematica 11 on Fedora 29. For the record, I write down here what I did. Go to MathematicaInstallationDirectory/SystemFiles/Libraries/Linux-x86-64/ (for me it is /usr/local/Wolfram/Mathematica/11.3/...


5

Just install ttf-dejavu: sudo apt-get install ttf-dejavu


5

Check which Inkscape you use: snap or apt. In the Ubuntu 18.04 AppCenter, there are two different versions of Inkscape, one from the Snap Store, one from ubuntu-bionic-universe. If you have the first one, you’re in trouble, there are no fonts you have installed and a Windows XP-like interface. Remove this version and get the second one and you'll be ...


5

Since the ttf-mscorefonts-installer mechanism mentioned in the accepted answer is still broken in Ubuntu 18.04 and I could not find a suitable mirror server for it to fix it, I propose to use this manual mechanism instead to install the very same fonts: Install cabextract, a tool needed to unpack self-extracting .exe archives: sudo apt install cabextract ...


5

sudo apt install fonts-roboto There's also fonts-noto which is also from Google and has way more characters


4

Just remove it and install from Ubuntu archive. sudo apt install snapd sudo snap install telegram-desktop


4

Atom is not in the official repositories, so I assume you're installing it from a PPA. As the unofficial Atom PPA does not provide a version for Cosmic (18.10), you're probably installing the Bionic (18.04) package, so it's most likely a compatibility issue. I compared the dependencies between the PPA package and the downloadable DEB (dpkg -I filename.deb), ...


4

You can run winecfg in npp snap like this notepad-plus-plus winecfg then change your screen resolution dpi.


4

To set this beautiful fonts up use the following steps Download the fonts from here Unzip and in the ttf folder double click each file and select install from the dialogue box that appears Setup VSCode: Open File -> Preferences -> Settings Top right click on {} and the user settings (settings.json) will open up Add the following lines: "editor....


4

That font is included in the gsfonts package. You can install it like this: sudo apt install gsfonts If you don't want to install that package, you can download the font from ttfonts.net. Execute this in a terminal: wget --no-check-certificate "http://ttfonts.net/sfonts/2/27260_NimbusSanL.ttf" gnome-font-viewer 27260_NimbusSanL.ttf Then click 'Install'.


4

I think it's provided by the gsfonts package in the Ubuntu archive. sudo apt install gsfonts On my machine I see these Nimbus fonts: $ fc-match -a | grep -i nimbus n019003l.pfb: "Nimbus Sans L" "Regular" n019043l.pfb: "Nimbus Sans L" "Regular Condensed" n019004l.pfb: "Nimbus Sans L" "Bold" n019044l.pfb: "Nimbus Sans L" "Bold Condensed" n019023l.pfb: "...


3

You can download the .ttf files from the git repo for Google Fonts and put them in /usr/share/fonts/truetype/robotomono with this command: sudo wget --content-disposition -P /usr/share/fonts/truetype/robotomono https://github.com/google/fonts/blob/master/apache/robotomono/RobotoMono-{Bold,BoldItalic,Italic,Light,LightItalic,Medium,MediumItalic,Regular,Thin,...


3

You can add the following as an example to your ~/.Xresources file: ! Use a truetype font and size. xterm*faceName: Monospace xterm*faceSize: 14 Then run the following: xrdb -merge ~/.Xresources


3

I installed fonts-noto $ sudo apt-get -y install fonts-noto Restarted Chrome, and then changed the Standard Font in Chrome to Noto Naskh Arabic UI. Urdu fonts appear much better and clear now. You can find the 'Font Settings' at: chrome://settings/fonts


3

The most comprehensive font package I have found is font-noto. Installing this has always fixed whatever font-display issues I was having: sudo apt install fonts-noto Then, restart your browser and everything should work as expected.


3

The problem occurs in a specific fontconfig version; the new one shipped with Ubuntu 18.10 is fontconfig-2.13.0, and rolling back to fontconfig-2.12 by manually downloading is a workaround. I found out that the exact difference is made by fontconfig-config which has the right configs at version 2.12.6. After you download and install, you can copy the files ...


3

The answer @randomlogin by worked for me, but I can't list the detailed commands I used as a comment to help clarify what to actually do. So, as an answer with extra detail instead of a comment, here is what worked for me: Go to https://packages.ubuntu.com/bionic/all/fontconfig-config/download and download the .deb file Check the .deb file downloaded ...


3

Short answer: gsettings get org.gnome.desktop.interface text-scaling-factor You can usually find out the dconf key of these settings by running in a terminal: dconf watch / ...and play with the settings you want to get. The corresponding dconf key will show. The gsettings api is also available in the GLib library (look for GSettings in the manual).


3

Your character-set is UTF-16. I think you use a wrong charset. Probably UTF-8 is the right one. Or the csv file uses Big Endian (UTF-16 BE) and you Little Endian (UTF-16 LE) or the other way round. Try some different charsets and it should work.


3

To make the desired font the default for rendering Phoenician characters, this is a way: Open a terminal window with Ctrl+Alt+T Create the directory ~/.config/fontconfig/conf.d: mkdir -p ~/.config/fontconfig/conf.d Open the Text Editor: kate ~/.config/fontconfig/conf.d/10-prefer-phoenician.conf and copy the below contents and paste it into the Text ...


2

I got the same problem with my Macbook today. The cause of that is a simple one. convert uses only known fonts. All known fonts to convert are listed with this command. convert -list font My desired font was in ~/Library/Fonts. convert didn't list it. I followed the instructions from Mark Setchell and was capable generating my type.xml. The entry for ...


2

Consider the following options: Purchase WOFF2 font files to use on your site via CSS. Find a suitable typeface on Google Fonts. After selecting some that you like, "Customize" to select the weights you want. Then follow the "Embed" instructions to use on your site. Hope that users have sane defaults for serif, sans-serif, and monotype. The default font ...


Only top voted, non community-wiki answers of a minimum length are eligible