Podcast #128: We chat with Kent C Dodds about why he loves React and discuss what life was like in the dark days before Git. Listen now.

Hot answers tagged

40

This fixed it for me: sudo apt-get install fonts-symbola but turns the icons b/w! From https://ubuntu-mate.community/t/thunderbird-with-huge-icons-emoticons-mate-18-04/16249/23 Here's a way of getting colored icons: sudo apt-add-repository ppa:eosrei/fonts sudo apt-get update sudo apt-get install fonts-twemoji-svginot I did not have to uninstall fonts-...


33

I fixed it - I had to follow these instructions from 2016 😧 I had to create ~/.config/fontconfig/conf.d/01-emoji.conf with the following text: <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE fontconfig SYSTEM "fonts.dtd"> <fontconfig> <alias> <family>serif</family> <prefer> <family>Noto Color ...


32

I'm the creator of that font. Sorry, there is not way to see SVGinOT (SVG-in-OpenType) color fonts in anything other than Gecko-based applications such as Firefox and Thunderbird right now. I made these fonts to solve the "chicken or the egg" problem: there were no color fonts and so no reason to support them. Now there are color fonts... Next steps: ...


23

Our wait is finally over guys! This is default terminal in $ lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu Bionic Beaver (development branch) Release: 18.04 Codename: bionic playing with https://www.npmjs.com/package/gulp-emojify You may have to sudo apt install fonts-emojione


20

On needs to run ibus-setup and in the "Emoji" tab ....change the shortcut (click on the three dots that are focused in the screenshot). I had to restart my computer after that so that the change would take effect (not sure how to restart IBUS).


16

On Ubuntu 18.04+ you can now simply install a single package: fonts-noto-color-emoji. After that, restart Chrome and it will take effect. No need for creating a manual font configuration. This package is supposed to be installed on the regular Ubuntu 18.04+ desktop flavor (on a 'Recommended' level of dependency - check for yourself with apt rdepends fonts-...


13

With the release of Ubuntu 18.04 LTS you can use emoji on Ubuntu right out of the box 👍, so you already have everything you need for the native GTK Linux apps like Gedit, Corebird, Rhythmbox, Geary and Terminal (Source: OMG Ubuntu). All you have to do to access the emoji picker in a native Linux app is right-click (or ctrl + .) in a text-field and select ...


13

Just a small hint: In case you don't find the IBus Preferences dialog, open a Terminal shell and type ibus-setup A dialog like this will appear on your screen:


11

Installing the fonts-symbola package fixes the problem. sudo apt-get install fonts-symbola


8

Yes, 18.04 supports colour emoji by default. The Ubuntu desktop now ships with a full set of color emoji. Previously, emoji support was inconsistent and emojis appeared as black-and-white in some applications. Source: What’s New in Ubuntu 18.04 LTS “Bionic Beaver” - How to Geek


7

I know this question is very old, but I've also been interested in this matter for a while, so I've developed a simple emoji picker tool for Ubuntu. The main issue with this approach is that you need to paste the emoji where you want it after choosing it.


7

I guess you are quoting this OMG Ubuntu article. Ubuntu (18.04) "supports colored emojis" means you'll be able to see system-wide coloured emojis out-of-the box, not just in some specific applications. Currently in Ubuntu 17.10 or older versions you get to see coloured emojis without any extra modifications in for example, Firefox: But the same emojis may ...


7

Color Emojis are not currently supported. Apparently there is a patched WIP version of libcairo that allows rendering colored emojis but it isn't stable yet. https://github.com/googlei18n/noto-emoji/issues/36#issuecomment-168209204 Support for this will likely come down to something that needs to be implemented on a per-app or per-UI-lib (GTK, Qt etc) ...


7

I was going to comment buuuut I don't have enough reputation 😢 (hey look, here's an emoji to check if it is working or not!) This solution worked for me "partially", it did fix the emojis in Discord and in the Terminal, but in Firefox it was still a mix of "some of them works, some of them doesn't", I also found this but that didn't fix the issue in ...


5

I just tackled this on my machine (running 16.04). I don't like that I had to do this since Firefox 50 suppose to have native emoji support for operating systems that do not have them. Download the latest version do you desired location (I did to my Downloads folder) https://github.com/eosrei/emojione-color-font/releases/download/v1.3/EmojiOneColor-SVGinOT-...


5

Turned out it was the new ibus version that included the emoji package, I was able to change the shortcut in the ibus settings.


4

The problem here is that we are making the Noto Color Emoji the default font for serif and sans-serif fonts, and Noto Color Emoji font doesn't have glyph for numerals. We have to remove those lines from the fonts.conf file, and add the lines which makes the mentioned font as "preferred" font, which can be overridden when it can't render other text properly: ...


4

Install the Emoji One Color font from: https://github.com/eosrei/emojione-color-font Full disclosure: I created it and just made it live a few days ago. The font works in all operating systems, but will currently only show color emoji in Mozilla Firefox and Thunderbird. This is not a limitation of the font, but of the operating systems and applications. ...


4

Use the following keyboard shortcuts: Hit Control-Shift-E, then press Space. You should see the Emoji Choice popup where you can select your unicode character. Note: To cancel the selection, press Escape few times. Tested on Ubuntu Cosmic (18.10). It should work in editors, terminal, web browsers and other applications.


3

To change on the command line in Ubuntu 19.04, you can use gsettings. For example, to remove the shortcut, you can do: gsettings set org.freedesktop.ibus.panel.emoji hotkey "@as []" To re-enable to the default shortcut: gsettings set org.freedesktop.ibus.panel.emoji hotkey "['<Control><Shift>e']" To change to a different shortcut, run the ...


3

According to this link, the logic behind Kubuntu not "supporting" color emoji is that Qt doesn't fully support them. The reason that some apps show them (like Nautilus) is because they are GTK+ apps or something else that fully supports color emoji.


2

Noto Color Emoji from google.com/get/noto/#emoji-qaae-color is only usable in Android. On Windows, that font will not install (it is considered broken.invalid), because the Windows text renderers do not support colors in fonts. To display those colorful emojis, you'll need a plugin in your browser that will substitute SVG images (if the browser supports SVG),...


2

Try using Fonts view of the Firefox Developer Tools. In my case it's DejaVu Sans from fonts-dejavu-core package but I see some differences from your screenshot.


2

If I understand your question, I don't think you can resolve the problem on social sites like Facebook or Twitter as Twitter & Facebook use their own emoji-replacement-images for users of the desktop website. This works around issues of emoji compatibility and also gives a chance for branding in the emoji set. Further, removing fonts will not extend the ...


2

IBus runs by default on Ubuntu 16.10, so there should be no need to install it or do anything special to make it launch at login. To add IBus input methods, use System Settings -> Text Entry, not IBus Preferences. (If you for some reason still would need to access the latter, you can use the command ibus-setup. As regards ibus-uniemoji: Download the ZIP ...


2

Color emoji fonts won't be available in Ubuntu 17.10. Missing requirements are: cairo 1.15.8 fontconfig 2.12.5 a color emoji font The top two requirements are low-level libraries and therefore are not good candidates even for a PPA for 17.10, but they will likely be available in Ubuntu 18.04 LTS. Source: Ubuntu Desktop Trello Card


2

One way to set Noto Emoji as the default emoji font in Ubuntu is to setup some local font config files. Create the directory and the file itself with: mkdir -p ~/.config/fontconfig/ touch ~/.config/fontconfig/fonts.conf And then populate the created file with the following text: <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE fontconfig SYSTEM ...


2

It seems this problem can be caused by having multiple incompatible emoji fonts installed, and/or having wrong default font selected in Chrome. Make sure you have fonts-noto-color-emoji package installed. sudo apt install fonts-noto-color-emoji Create/Edit font config files as in @N3dst4's answer. Note: While @N3dst4 put his config file in ~/.config/...


2

Having fonts-noto-color-emoji was not enough also for my Ubuntu 18.04 system. However, there is another answer to the question you linked to: https://askubuntu.com/a/1029675/188679 Create a file ~/.config/fontconfig/conf.d/01-emoji.conf and put the following content inside: <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE fontconfig SYSTEM "fonts....


Only top voted, non community-wiki answers of a minimum length are eligible