Questions tagged [dpkg]

Questions about using dpkg or errors with dpkg should use this tag. Dpkg is the Debian package management utility that performs lower-level tasks in software installation and removal.

Filter by
Sorted by
Tagged with
0 votes
0 answers
9 views

Unable to install steam on Ubuntu running in parallels on my M1

I tried following the guide as per lubuntu installing steam "steam has no installation candidate" But the error message I get is as below: Reading package lists... Done Building dependency ...
0 votes
0 answers
12 views

I want to deploy k8s 1.26 on ubuntu22.04, but apt install kubelet fails

I want to deploy k8s 1.26 on ubuntu22.04, but apt install kubelet fails $ apt-get install kubelet kubeadm kubectl You might want to run 'apt --fix-broken install' to correct these. The following ...
10 votes
1 answer
2k views

Removed apt as package manager

Nala is a recently-introduced package manager which also uses dpkg for managing packages in Ubuntu. I installed nala and I'm getting a very decent experience. Now, I wanted to remove apt from my ...
0 votes
0 answers
22 views

ubuntu-advantage-desktop-daemon [duplicate]

Is removing ubuntu-advantage-desktop-daemon really removing so much ? Will the removal result in ubuntu 20.04 GNOME failing to work ? Aspire-E5-523G:~$ sudo apt remove ubuntu-advantage-desktop-daemon ...
  • 9
0 votes
0 answers
42 views

unable to install new software - Ubuntu 22.04

Install Brasero from Ubuntu Software failed: Error while installing package: installed linux-image-5.13.0-23-generic package post-removal script subprocess returned error exit status 1 sudo apt -f ...
  • 41
0 votes
1 answer
49 views

How to reinstall (a large group of) packages

My main system (Xubuntu 20.04.) is in deep trouble. I see no hardware problems, but only very basic things are working. Web is down. My RAID is down. Several other things are flakey. I don't know ...
-1 votes
1 answer
50 views

module 'collections' has no attribute 'Mapping' how to safely reinstall update-notifier-common?

When running app upgrade I get the following errors: $ sudo sudo apt upgrade [sudo] password for admin-federico-dostuni: Hit:1 http://azure.archive.ubuntu.com/ubuntu bionic InRelease Get:2 http://...
  • 105
0 votes
0 answers
28 views

Error in installed packages

what can be done here? as the omsagent has dependency on scx and scx does not like dpkg --configure -a.
0 votes
1 answer
45 views

dpkg was interrupted - need help to fix [duplicate]

dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem Here is some of the processes I tried: robterri@system76-pc:~$ sudo apt upgrade [sudo] password for ...
  • 1
0 votes
0 answers
41 views

How to replicate the list of installed packages on another installation [duplicate]

I'm actually trying to diagnose a partly-broken system -- several symptoms have recently arisen. Odd combinations -- Ctl-Alt-F1 no longer works, my web page is down, I can no longer mount FAT thumb ...
0 votes
2 answers
22 views

I got an error with a dkms file

So I was trying to fix my obs studio and had a snap version installed from the store and tried installing it from the website simultaneously. When i installed its prerequisite, it started throwing and ...
0 votes
1 answer
25 views

How can I install the dialog package? [duplicate]

How can I install the dialog package? I try these commands, but it doesn't work: sudo apt-get update sudo apt-get install dialog Reading package lists... Done Building dependency tree... Done Reading ...
-1 votes
1 answer
39 views

I installed some software like Docker, Jenkins etc on my PC but it's not working, all it's showing is that Docker-Desktop depends on qemu-system-86

I've being trying to install it but this is what I've been getting as response ife@ife-HP-ProBook-6560b:~$ sudo apt-get install qemu-system-x86 Reading package lists... Done Building dependency tree ...
0 votes
0 answers
15 views

Error while installing firefox during the process of installing ubuntu_desktop

I am using Ubuntu server 22.10 on Apple M1, and using UTM to assemble the vm. During the process of installing ubuntu-desktop, the firefox cannot be installed automatically : errors were encountered ...
  • 1
-2 votes
0 answers
35 views

Errors were encountered while processing when running sudo apt-get upgrade

I haven't been able to upgrade for a week. When I run sudo apt-get upgrade in Ubuntu 20.04 I get this error. sudo apt-get -f install and dpkg -C do nothing. The results of sudo dpkg -i --force-...
0 votes
0 answers
27 views

Can't install Firefox

First all Firefox tabs crashed, then I closed it and wanted to restart it. Clicking on Firefox did nothing, trying to open it via terminal gave me these errors: /bin/bash: /lib/×86_64-linux-gnu/libdl....
0 votes
0 answers
43 views

i am trying to install apache2 on ubuntu but i`m getting an error [duplicate]

Reading package lists... Done Building dependency tree Reading state information... Done The following packages were automatically installed and are no longer required: chromium-codecs-ffmpeg-...
0 votes
0 answers
28 views

How do I build and install Radiotray-NG from source?

I am trying to learn how to install from source code. I want to move to Spiral Debian but there are some packages that I need to use that are not in the repos. I am on an Ubuntu install 18.04 LTS and ...
0 votes
0 answers
31 views

How to solve the error 'unmet dependencies'? [duplicate]

How do I solve the problem of 'unmet dependencies error' in Ubuntu 20.04? I have tried sudo apt clean and all the other commands but for every package command it gives me the same unmet dependencies ...
  • 1
2 votes
1 answer
178 views

Configure bash instead dash on Ubuntu 22.10

On a brand new Ubuntu 22.10 installation I tried the command sudo dpkg-reconfigure dash That he did nothing I learned from this post that this feature has been removed. So what is the right and clean ...
1 vote
2 answers
235 views

Gnome's Software ignores apt's "kept-back" package status

Problem description The application Software (that is, Gnome Software 41.5) shows available updates, while sudo apt update && sudo apt full-upgrade finds no updates, apart from some kept-back ...
  • 11
0 votes
0 answers
28 views

error cp: cannot overwrite directory '/usr/bin/dpkg' with non-directory [duplicate]

Go to this url http://security.ubuntu.com/ubuntu/pool/main/d/dpkg/ and you will see a list of dpkg packages. You need to find the dpkg version you need than open new terminal. Anywhere your machine I ...
0 votes
1 answer
36 views

Upgrade from Ubuntu 16.04 to 18.04 - improper use of do-release-upgrade

I started an upgrade from Ubuntu 16.04 to 18.04 but did not follow the proper procedure. The sequence of commands I executed are: sudo apt-get update sudo apt-get upgrade -y sudo apt-get dist-upgrade ...
  • 1
-3 votes
0 answers
27 views

Termus error anyone know how to fix? [duplicate]

The following packages have unmet dependencies: ncurses-ui-libs : Depends: ncurses (= 6.3-5) but 6.4-1 is to be installed E: Unable to correct problems, you have held broken packages. Reading package ...
  • 1
0 votes
0 answers
49 views

How to install libapt-pkg.so.5.0 on Ubuntu 20.04

I have a dynamic library that I want to use. However, one of its dependencies is not available on my system: $ ldd redacted_name.so | grep 'not found' libapt-pkg.so.5.0 => not found I ...
1 vote
0 answers
40 views

Why the system doesn't recognize python3.7 as the python3 installed? (for distutils)

The ubuntu version is 18.04. The pc is in a environment which can't access internet, but can acess to a limited storage with apt and pip packages. I am trying to install distutils_3.7 on it (I use ...
  • 11
0 votes
0 answers
27 views

I can't install any package using apt install [duplicate]

I tried to install apktool recently using sudo apt install apktool but I keep getting this error, I am using kali linux release 2022.4 dpkg: error processing package python3-protobuf (--configure): ...
0 votes
1 answer
32 views

Cannot install or uninstall software

I’ve been trying to remove some software on my Ubuntu 20.04.4 LTS machine and have been receiving errors like this: Reading package lists... Done Building dependency tree Reading state ...
1 vote
0 answers
28 views

how to fix unmet dependencies [duplicate]

04 I tried to install obs-studio but it doesnt work I updated node before this which also didnt work I think that is what causes the error Reading package lists... Done Building dependency tree... ...
1 vote
0 answers
53 views

Cannot use dpkg or update anything due to kernel

since today I have noticed that I cannot install gparted or even check for updates because of unknown error. All I understand is that kernel does not allow to be removed and stops any process that I ...
-1 votes
0 answers
26 views

Can´t update due to broken package system [duplicate]

Im kind of new to Linux and Im struggling with this issue. When I try to update through the updater. Im given this message The Package system is broken Check if you are using third party repositories. ...
1 vote
1 answer
49 views

Force apt or apt-get to return error code on warning [duplicate]

apt-get and apt are exiting with 0 instead of an error code when they cant resolve a repository. I'd like to get a non-zero in this case (and for warnings generally). e.g. # apt-get update Err:1 https:...
0 votes
0 answers
16 views

dpkg was interrupted - every time I restart my computer

Every time I start up my laptop (OS: Ubuntu 22.04) it always complains when trying to download a new package or update I get this error: E: dpkg was interrupted, you must manually run 'sudo dpkg --...
  • 1
0 votes
0 answers
17 views

issue installing tmux vlc using WSL on Windows [duplicate]

I'm using WSL 18.04 on windows 10, and I'm trying to install the following but I get errors: sudo apt-get install tmux vlc Reading package lists... Done Building dependency tree Reading state ...
0 votes
2 answers
80 views

How to fix Error while install with apt-get?

Hello since yesterday i got a problem. Everytime when i try to install something on my terminal with "sudo apt-get", I run in the same Error-Message. I also checked this Error on much ...
  • 1
-3 votes
1 answer
30 views

Unmet depedencies and not enough free space (eventhough i have plenty) [duplicate]

I'm super new in this Ubuntu world, so i have been having a hard time looking for solutions( also English isnt my first language so please be kind). I recently tried installing TeXLive but the ...
1 vote
0 answers
34 views

Title app name in Snap Store is strange

I created a *.deb file using dpkg. When I try to open my file using Snap Store the name of my app is strange, for example instead of display "My New App", appear "mynewapp", it's ...
0 votes
0 answers
35 views

Libreoffice new version instead of upgrade

When I try apt remove libreoffice I get no libreoffice installed. But I have installed new one with recommended dpkg -i *.deb And now I have old version 7.0 which starts when I type libreoffice and ...
0 votes
0 answers
62 views

How can I resolve the error "installed gdm3 package post-installation script subprocess returned error exit status 10" [duplicate]

How can I resolve the package installation error of the gdm3 package? I got an error message whenever I install Debian packages by using apt; sudo dpkg --configure -a Setting up gdm3 (42.0-1ubuntu7) .....
  • 1
1 vote
0 answers
128 views

apt install return /lib/ld-linux-armhf.so.3 but i'm on x86_64 machine

I'm running on x86_64 machine uname -a return 5.4.0-135-generic #152~18.04.2-Ubuntu SMP Tue Nov 29 08:23:49 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux when I'm using apt or apt-get i get error message ...
  • 111
0 votes
0 answers
36 views

How to resolve: dpkg: error processing archive /tmp/apt-dpkg-install-52WhMe/7-python3-distutils_3.10.6-1~22.04_all.deb (--unpack)?

Preparing to unpack .../7-python3-distutils_3.10.6-1~22.04_all.deb ... Unpacking python3-distutils (3.10.6-1~22.04) over (3.10.4-0ubuntu1) ... dpkg: error processing archive /tmp/apt-dpkg-install-...
0 votes
0 answers
24 views

Configure exim4 in home directory

I recently installed exim4 to use sendmail via smart host. Everything works fine, but I had to edit these two system files: /etc/email-addresses: myuser: mymail@provider.tld /etc/exim4/passwd....
2 votes
0 answers
31 views

How to change the version 1.21.x of dpkg tool of Ubuntu22.04 to the version 1.19.x of dpkg tool of Ubuntu20.04?

I met a problem when making .deb in Ubuntu22.04, because the target environment does not support .deb made by dpkg version of 1.21.x. So I need to install dpkg tool with version 1.19.x just the same ...
1 vote
1 answer
37 views

How can I remove all my possible broken packages or duplicate sources at Ubuntu? [duplicate]

I am looking to remove all possible broken packages because yesterday I tried to download VM and also lutris, but now it is not working. How can I improve it? I did this check: sudo apt-get check And:...
1 vote
0 answers
136 views

Can't update ubuntu after closing computer while updating kernel

What can I do to normally update my system (Ubuntu). By acident I shutdown my PC while updating a linux-kernel package, also I think at time of update my Ubuntu start to updating from old 18 vesion to ...
2 votes
1 answer
318 views

Linux Kernel update error causing package management to grind to a halt!

I recently went to update my system (Ubuntu Studio 22.10) and new Linux Kernels were available. On Ubuntu Studio you receive updates for both the generic and low latency kernels, with the low latency ...
  • 506
0 votes
0 answers
52 views

dpkg issue: Too many levels of symbolic links

so I've had this issue on a chromebook running KDE Ubuntu 18.04. problem is whenever I try to install an app with sudo apt or attempt to use sudo autoremove. Whenever I run these commands, I get this ...
0 votes
0 answers
69 views

Unable to install any software or upgrade in ubuntu 20.04 (unmet dependencies error)

When I am trying to upgrade/ install(any software). I am facing below error $ sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done You ...
0 votes
0 answers
243 views

error with nvidia 460-470 drivers when upgrading system

I tried to upgrade my system, but I got this error messages: Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done # # News about ...
0 votes
0 answers
326 views

Cant upgrade linux kernel

I have a fresh install of Ubuntu 22.04 and there is almost nothing I can do. If I want to install something via terminal, it will automatically try to update the kernel to linux-image-5.15.0-56-...

1
2 3 4 5
81