66

I had the same problem because I had changed the icon size in a window. So I fixed it back from top-right of an open file browser window! Changing icon size in any file browser window will affect all your windows including Desktop!


43

Up to Ubuntu 18.10 You may use (GNOME) Tweaks (aka GNOME Tweak Tool) to do that. First install it (if it is not installed) by running the following command in Terminal sudo apt install gnome-tweaks or sudo apt install gnome-tweak-tool Launch Tweaks and go to Desktop section. Then toggle off (or uncheck) the Trash (or Rubbish bin or Wastebasket) option ...


33

The .desktop link files are stored in /usr/share/applications for software installed for all users, and $HOME/.local/share/applications for things you have installed only for yourself. The actual icon (image) files are a bit more scattered (since a .desktop file can specify their absolute path), but /usr/share/pixmaps and /usr/share/icons contain a good ...


18

gsettings set org.gnome.nautilus.icon-view default-zoom-level 'small'


17

Run this command from a terminal: gsettings set org.gnome.desktop.background show-desktop-icons false Or to do it with GUI open dconf-editor and go to org -> gnome -> desktop -> background and uncheck "show-desktop-icons."


10

Since some previous versions of Ubuntu.. Desktop Icons are handled by desktop-icons gnome-shell extension. you can achieve the sizes and spacing you mentioned in Question by editing the extensions prefs.js file. Take backup of the file before editing. the extensions directory is /usr/share/gnome-shell/extensions/desktop-icons@csoriano Original Content: ...


9

Arrange desktop icons alphabetically by command The script below will rearrange a desktop like: ...into an alphabetically ordered desktop like: Ordered: directories first, then files from top to bottom, from left to right Set the number of items vertically Furthermore, you can set an arbitrary number of items vertically (rows); the horizontal spacing ...


9

Unfortunately, desktop icons are completely broken (which is quite unexpected in a LTS release of Ubuntu) as instead of the file-manager (Nautilus) handling the desktop items, now a GNOME Shell extension handles them. See this bug report: https://bugs.launchpad.net/ubuntu/+source/gnome-shell-extension-desktop-icons/+bug/1813441 A workaround involving ...


8

Open a Terminal (with Ctrl+Alt+t) and type the following command to hide icons and disable right-click on the desktop: gsettings set org.gnome.desktop.background show-desktop-icons false To restore the default settings: gsettings set org.gnome.desktop.background show-desktop-icons true Tested on 12.04, 14.04 and 14.10.


8

I wrote a small script, which changes this option: #!/bin/sh if $(gsettings get org.gnome.desktop.background show-desktop-icons); then new="false"; else new="true"; fi gsettings set org.gnome.desktop.background show-desktop-icons $new You can save the script /somewhere/as/somewaht.sh (with permission to execute) and then add in your keyboardsettings an ...


7

Ok, I tried a whole bunch of things to my own question, over the course of about 2 hrs, so I'm not 100% sure something I did before this wasn't part of the solution, but this worked for me: In a terminal, do: rm -R ~/.cache/sessions/* xfdesktop sudo reboot Source: Desktop icons not showing up in xubuntu (and I cant right click on the desktop) Once I did ...


7

You can install nemo (Linux Mint's default file manager, which still supports desktop icons) with sudo apt install nemo Then, open the Startup Applications program in your Applications menu. Click Add, and enter nemo-desktop into the Command: field. Click Save, then Close. Restart. You should have desktop icons!


6

The cause Most likely, the issue is the result of a bug (related to the video driver). I assume the second screen is not remembered somehow, and "virtually" re- connected in a rather late stage in the start up (log in) process. Work around As often, even if it is a bug, it doesn't mean we cannot find a work around. If we: can make some kind of a snapshot ...


6

Open the gnome-tweak-tool and navigate to the desktop tab as shown in the picture below and activate 'Show Icons'. If you don't have gnome-tweak-tool installed you can install it by opening a terminal and typing: sudo apt install gnome-tweak-tool


5

open a folder (any folder) go to menu -> preferences in the file explorer, change default zoom level to 100%.


5

After following Exien's answer on Ubuntu 20.04, the GUI became extremely slow and unresponsive. I had to reinstall Ubuntu even after reverting the value to true which did not fix the problem it generates. In Ubuntu 20.04 It is actually easy: Search for Extensions (preinstalled) in the Activities overview. Click on the Settings gear icon next to the ...


5

Since Ubuntu 19.04, Nautilus doesn't handle desktop icon management, rather it is handled by a GNOME Shell Extension called 'Desktop Icons' (package name: gnome-shell-extension-desktop-icons). The extension doesn't support the drag-and-drop feature yet. However, you can replace Nautilus with Nemo as your file manager and get the traditional desktop icon ...


5

The reason behind this change in experience compared to older Ubuntu releases is that the GNOME developers have relieved recent versions of Nautilus (aka (GNOME) Files, the default file-manager application) from handling the the desktop and the items on it. The rationale behind this decision can be found here: https://gitlab.gnome.org/GNOME/nautilus/-/issues/...


4

I wrote iconic to solve this problem by letting you define a grid size larger than the icons. Additionally it will: Allow you to move icons to any of three monitors Not suffer the "lost icon syndrome" that occurs when monitors of multiple resolutions are used Sort icons alphabetically, alphabetically with "Link to" prefix ignored, sort by modified date ...


4

This is at least a partial answer to my question. It turns out that I have dropbox in use (for some years now). Since 15.04 if I click on dropbox and click "Open Dropbox folder", it will reproducibly remove the shortcuts on my desktop. I have been using this click for a long time and only since 15.04 has the problem appeared. I think I need to report the ...


4

The problem in your case is that when you are connecting the external monitor, it is by default being taken as the primary screen which is in left and you have to move your cursor to right of your extended monitor to get it on the laptop screen. This is problem is easily solved when you are using the light environments like LXDE. They have it on their ...


4

I fixed this in in Display settings (System Settings --> Display). The three monitors I use are different sizes, but after dragging the monitors so that they were aligned along the bottom axis, my icons returned my primary monitor on the left Like this


4

Ubuntu 19.04 and later The following terminal command works: gsettings set org.gnome.shell.extensions.desktop-icons show-trash false


4

The simplest method is to execute these two commands in a terminal: gsettings set org.gnome.shell.extensions.desktop-icons show-home false gsettings set org.gnome.shell.extensions.desktop-icons show-trash false


4

The mechanism by which desktop icons has fundamentally changed since Ubuntu 19.04. Previously, desktop icons were provided by the file manager Nautilus. That functionality was stripped out of more recent versions of Nautilus. Because of this, Ubuntu shipped with an older version of Nautilus. In Ubuntu 19.04, nautilus ships with an up to date version of ...


4

as a Admin or for system-wide edit the file /usr/share/gnome-shell/extensions/desktop-icons@csoriano/stylesheet.css .name-label { text-shadow: 1px 1px black; color: green; text-align: center; font-size: 40px; } I have already edited above part. I have added the line font-size: 40px; and changed the color to green. Another Customization ...


4

Most text files are associated with a text file editor such as Gedit. This means that if you double click on such a file in the File Manager, the file will be opened in Gedit. If that is the case in your system, you could enter this command: ln -s ~/Documents/my-text-file.txt ~/Desktop/my-text-file.txt It is called a symbolic link. This will give you an ...


4

So, in the Ubuntu .desktop configuration file, the target is Exec. Start in does not have an equivalent value in Ubuntu .desktop file. In Windows, the "Start in" field is only valid if the target is a console application or it is command prompt/Powershell. So in Ubuntu, the equivalent of Start In is usually the location of .desktop file. I hope ...


3

Even though this is a bit old I'd like to answer this for other people who found this thread when trying to fix this issue, like me. I found the fix is extremely simple. Open the file manager and navigate to the desktop folder located in your Home folder. (The file manager will show all your desktop icons there) Now simply drag and drop the icons you need ...


3

In extended desktop mode, the computer sees multiple monitors as a single large desktop. If your window manager places desktop icons on the left, then they will jump to the far left-hand monitor. However, if you use KDE as your desktop manager/window manager, you can use "FolderView" as your desktop setting. This way, you can arrange icons exactly as you ...


Only top voted, non community-wiki answers of a minimum length are eligible