9 votes
Accepted

Cannot install docker-desktop on ubuntu 22.04

You can fix this by running the following commands: sudo apt-get update sudo apt-get install ca-certificates curl gnupg lsb-release sudo mkdir -p /etc/apt/keyrings curl -fsSL https://download.docker....
user avatar
3 votes

Unable to locate package libssl1.1

Although I think the advice given by Artur is good. I managed to resolve this for a legacy app (specifically easytether-usb) by grabbing libcrypto.so.1.1 from the 1.1 install as referenced by @Nishant ...
user avatar
  • 2,366
3 votes
Accepted

libssl3 >= 3.0.2-0ubuntu1.2 required but only 3.0.2-0ubuntu1.1 is available on the internet and installed

I encountered this exact problem, but for libssl-dev (depending on libssl3), and this is on a fresh system which does nothing other than apt-get update && apt-get dist-upgrade && apt-...
user avatar
  • 46
1 vote

Why libudev version ubuntu3.1 doesn't exist?

The initial install comes with libudev1 version 249.11-0ubuntu3. After you get updates of your system, you receive 249.11-0ubuntu3.3. Probably before there was an update to 249.11-0ubuntu3.1. So ...
user avatar
  • 81.4k
1 vote

Unable to locate package libssl1.1

Ubuntu 22.04 uses libssl3, and thus libssl1.1 is deprecated at this point. Creating a new package for Ubuntu 22.04 that uses an obsolete libssl version seems like a very bad idea. Also, messing with ...
user avatar
1 vote

Unable to locate package libssl1.1

https://packages.ubuntu.com/bionic/amd64/libssl1.1/download here you go! use this link if you want to download libss.
user avatar
1 vote

Unable to correct problems, you have held broken packages when trying to install PHP

After installing the add-apt-repository ppa:ondrej/php PPA and updating the repositories (sudo apt update), I was not able to install PHP 8.1 on Ubuntu 20.04.4 LTS: The following packages have unmet ...
user avatar
1 vote

MongoDB Install Fails on Ubuntu 22.04 - Depends on libssl1.1 but it is not installable

@yehuda suggested libssl1.1_1.1.0g which does not meet the dependency criteria >=1.1.1. Expanding on that approach, I tried the below and it worked. Based on the packages provided by ubuntu for ...
user avatar

Only top scored, non community-wiki answers of a minimum length are eligible