169

It seems the Bose Quiet Comfort 35 does has issues with pairing with Bluetooth LE (Low Energy). Get back to a clean state I would recommend to clean up you past attempts to pair: On Ubuntu, remove the headphones from the Bluetooth paired list. On the headphones, hold the switch in Bluetooth pairing position for 10 seconds to delete all paired devices (You'...


49

The accepted answer did not work for me. This blog entry worked: http://erikdubois.be/installing-bose-quietcomfort-35-linux-mint-18/ Create /etc/bluetooth/audio.conf [General] Disable=Socket Disable=Headset Enable=Media,Source,Sink,Gateway AutoConnect=true load-module module-switch-on-connect In /etc/bluetooth/main.conf set ControllerMode = bredr ...


29

I had to unpair/pair my device again. Restarting bluetooth service didn't help.


8

I had the same issue. In this post is pointed this solution. Basically, you have to create/edit the file /var/lib/gdm3/.config/pulse/client.conf And add the following configuration lines autospawn = no daemon-binary = /bin/true And give to GDM the ownership sudo chown gdm:gdm /var/lib/gdm3/.config/pulse/client.conf Retart GDM and it is solved


8

I finally found a solution (in fact several one): Add threadirqs to my kernel params was better, but this was not enough, I also had to install rtirq-init I then had an (almost) perfect bt sound playback. Another option seems to use linux-lowlatency kernel. I still have to test this, but it should work. What is unclear is the drackbacks (power consumption ...


7

run this to reset its configuration. turn off and on bluetooth and connect bluetooth headphone again. i had same issue on ubuntu 16.10 and it solve it! in this case you don't need blueman. run this and in Sound setting select your headphone rm -r ~/.config/pulse; pulseaudio -k


6

First make sure the following is correctly working: The BIOS / UEFI has Bluetooth enabled (Just in case) Your host (Ubuntu in this case) detects the Bluetooth correctly You have tested the Bluetooth with a bluetooth device and can confirm it is working correctly. This 3 points are to avoid issues with the guest that might not be the guest at all. Then make ...


5

I would try this: wget https://www.dropbox.com/s/owropuric6iz898/BCM20702A0-05ac-21e1.hcd sudo cp BCM20702A0-05ac-21e1.hcd /lib/firmware/brcm/BCM20702A0-0a5c-21e1.hcd sudo modprobe -r btusb sudo modprobe btusb Then check dmesg | tail for any info: sudo apt-get install linux-headers-$(uname -r) build-essential wget https://www.dropbox.com/s/xu80svavlazttaf/...


5

I have the Bose Quietcomfort 35 II on Linux Mint 19.2. None of the solutions here worked for me. The only thing that worked was downloading the Bose Connect app on my Android phone and: Connect your headphones to the phone Connect your headphones to the Bose app Go to "Connections" and make your headphones ready to connect Pair with blueman or blueberry Now ...


4

I often have this issue: blueman.bluez.errors.DBusFailedError: Resource temporarily unavailable with blueman on Ubuntu Mate 18.04 when waking the machine up from suspension. Simply restarting the bluetooth service with: sudo systemctl restart bluetooth and rescanning usually resolves the issue quite easily.


4

I tried to load the module first but I got a Failure: Module initialization failed so you have to unload the module first: pactl unload-module module-bluetooth-discover and then load it again: pactl load-module module-bluetooth-discover After that I was able to see the audio device in audio settings.


4

According to the quick start guide the code is 0000, so you must have other problems with your connection. Edit - that link appears to be for a Charge, this link for the Charge 2 does not show any code at all. Edit 2 - neither does this manual for the Charge 2+.


3

Another way may help: install blueman sudo apt-get install blueman; connect the headphone using blueman; remove blue once the headphone is connected successfully, sudo apt-get purge --remove blueman.


3

I had the same issue here with Ubuntu Gnome 15.10 and 16.04. What helped me was adding read permissions for the gdm user on the pulseaudio bin. sudo setfacl -m u:gdm:r /usr/bin/pulseaudio after that restart pulseaudio (or restart your system) pulseaudio -k your bluetooth device should now be listed in the audio device list.


3

UPDATE 2019-10-31: I am no longer experiencing this issue, might be the result of a kernel update or something else in 19.10. If anyone knows more, please comment and I'll include it here! UPDATE 2018-09-20: My original solution no longer works reliably for me. I now see one of three cases on resume from suspend: Bluetooth and WiFi both disabled (no ...


3

I just solved this problem (on Ubuntu 20.04) by buying a dual band router. When I connect the notebook wifi in the 5GHz band together with my sound box in the notebook Bluetooth and play music videos in YouTube, everything works fine, with top performance. The problem is that Bluetooth generates interference in the 2.4GHz wifi, as it also operates on this ...


3

Work Around Note: Below Procedure Tested with my JBL Xtreme OS: Ubuntu 18.04 at your present Situation that is you have already paired your BT device and while booting your BT device is On, after login try this.. Open Terminal and run bluetoothctl The Output will be similar to this Output: pratap@i7-4770:~$ bluetoothctl [NEW] Controller xx:xx:xx:xx:xx:...


2

Blueman has a bug that will unload module-bluetooth-discover if it is loaded during boot so that you will likely need to unpair the audio device and then pactl load-module module-bluetooth-discover Then pair your device and see if it appears in sound settings


2

This happens to me too and is very annoying. Fastest manual solution is go to Sound settings, switch to Built-in-Audio, wait 3 seconds, switch back. I wrote a small script that is doing exactly this for me. I put it as a keyboard shortcut, so it's quicker. #!/bin/bash internal="1"; bluez=$(pactl list sinks short | grep -Po "^[0-9]+(?=.*?bluez)"); if [ ! -...


2

I just fixed that exact same issue but on Mac. I am pretty sure you can fix it too using the same trick on Ubuntu as it seems to be an issue with the UE rather than the OS. It is about the UE's microphone (input, not output). When your OS is (automatically) set to use the UE's input, the sound is awful: However it is all great when the input is set to the ...


2

I had the same problem when first connecting mine to my laptop. I had to change one thing in Sound settings (Volume control) then Configuration (not sure it's the good translation, my xubuntu is not in english). There for UE Boom, I changed "Headphones" to "High Quality ... A2DP". Hope it works for you.


2

I used the following command and it solved my problem: sudo apt-get install pulseaudio-module-bluetooth pactl load-module module-bluetooth-discover Then try to reconnect your bluetooth headset.


2

In the sound settings, use High Fidelity Playback (A2DP Sink) mode for the headphones. The hissing will stop. One caveat is that the headphone's microphone won't work in this mode. This might be an issue with the headphones themselves. I experience the same issue with android when I get a call (android uses A2DP by default and switches to HSP when you get a ...


2

I had the same issue with a bluetooth usb dongle, but it was an issue with my rights. Solved from this solution : No USB devices available in VirtualBox In short : sudo adduser $USER vboxusers then logout/login


2

Forget the old Windows key. when you re-pair the bluetooth device in Ubuntu, a new key will be generated. If the bluetooth device is not even seen, maybe there is a driver problem - what bluetooth hardware/driver are you using? Please post the output of:" dmesg |grep -i blue


1

One very easy thing you have to try before anything else, is check that there isn't any other device that is already connected to the device via bluetooth. For me it was my phone, which was connecting to a bluetooth speaker automatically. Once I disconnected it and restarted bluetooth adapter on my machine it worked out.


1

Try restarting Pulse Audio, as also mentioned above. These commands worked for me. pulseaudio --kill pulseaudio -vvv --start


1

I received this error as the headset was already connected to another device (my phone). Check that the device you are wanting to connect to your Ubuntu instance is not already connected to another device, such as a mobile telephone, and then try to connect again.


1

The solution above didn't work for me. I got it to work, but you need to set it up manually every time you reboot. First close bluetooth and bluez by effectively stopping them (not restarting), then starting them again using systemctl start bluetooth and sudo /etc/init.d/bluetooth start. Start bluez manager and connect the device using setup with the audio ...


1

Copied from Question owner's comments from the question. I solved in this way. I have installed pavucontrol. In terminal: sudoedit /etc/bluetooth/audio.conf Add these lines: [General] Disable=Socket Enable=Media,Source,Sink,Gateway Save and exit from the editor Then: sudo service bluetooth restart Cancel bluetooth speaker ...


Only top voted, non community-wiki answers of a minimum length are eligible