Hot answers tagged

21

I couldn't get Rinzwind's suggestion to work, because it complained that the user account already exists. Instead, I used this command to add an existing user (terrik) to an existing group (dialout), as described on the Ubuntu Help Wiki. sudo adduser terrik dialout Also useful is this command for listing your current groups, although as Rinzwind says, you ...


21

Connect your Arduino hardware.Open Arduino IDE. Go to "Tool". Go to "Port". Select the port to which Arduino is connected.(If no other external drive is connected except Arduino,there will be only one port) This will tell Arduino IDE the port to which your hardware is connected. After that,you will be able to upload your sketch successfully


20

Arduino IDE is installable with Ubuntu Make: Install Ubuntu Make for Ubuntu 14.04 LTS, 16.04 LTS from official PPA ppa:lyzardking/ubuntu-make: sudo add-apt-repository ppa:lyzardking/ubuntu-make sudo apt-get update sudo apt-get install ubuntu-make PPA is needed because of two facts: Ubuntu 14.04 LTS does not have such package, package for 16.04 LTS does ...


16

I had a similar issue when I tried to upload a sketch to Arduino. The issue was connected to the lack of permissions to read/write to the serial port. I was able to fix by using the following command: To confirm the port exists enter the following from the root directory. ls /dev/ttyACM0 To set read/write permissions, enter the following sudo chmod a+rw ...


13

This is from notes I took when installing an Arduino. It was very helpful when I had to go through the same thing with other computers. Install Sketch which is used to program Arduinos. Use one of the following methods. sudo apt-get install arduino or sudo apt-get install arduino-core or Open "Ubuntu Software Center" Search "arduino" Set up ...


13

Another possibility is to make a rules file in /etc/udev/rules.d/ directory. I had similar problem and I have created 50-myusb.rules file in the above directory with this content: KERNEL=="ttyACM[0-9]*",MODE="0666" Note that this will give any device connected to ttyACM socket read/write permissions. If you need only specific device to get read/write ...


12

I had this problem too, it turns out it was caused by the Serial Monitor being set to speed 14400. Since you can't change the setting without having a working serial port, the only way to do it is to exit the Arduino UI and edit the preferences.txt file (in Unix, it's in ~/.arduino/preferences.txt). Look for Serial.debug_rate and change it to 9600. Restart ...


11

I couldn't get Terrik's answer working, but I could if I made this slight adjustment to the path for ttyACM0. sudo chmod 666 /dev/ttyACM0 Would post as a comment but I don't have the privileges for that yet...


11

Arduino IDE from Ubuntu's repo are usually outdated. There are two main ways to install the latest Arduino IDE: with umake and from arduino.cc tar.gz. In both cases you may need to add your user to dialout group (if it doesn't work add it also to tty group): sudo adduser $USER dialout Install latest version from Ubuntu Make (on GitHub) Ubuntu Make is a ...


10

Install the snap in classic mode to allow access to ports $ snap install arduino-mhall119 --classic It's that simple. You should now have access to your serial ports! Happy Hacking! Note: info below are needed for old Arduino 1.6.10. Some interesting links that helped find the answer Auto connected serial port interface Lundamar says: Until the ...


8

If you run Arduino IDE on Ubuntu (Arduino 1.5.7 and Ubuntu 14.04 in my case), most possibly you cannot upload to Arduino board, caused by the error of: avrdude: ser_open(): can't open device "/dev/ttyUSB0": Permission denied ioctl("TIOCMGET"): Inappropriate ioctl for device To fix it, enter the command: $ sudo usermod -a -G dialout <username> $ sudo ...


8

Reinstall your arduino installed from Ubuntu software center: sudo apt install --reinstall arduino Reinstalling is necessary since your which avrdude command according to your comment returns nothing, but should be /usr/bin/avrdude. Check again: which avrdude Run your Arduino IDE after reinstalling and close it. Check your arduino configuration. Open /...


4

Suggesting this is a dupe assumes adding Arduino to the sudoers file is a good idea, which it isn't. Never add an application that potentially ruins your system, or edits code to ruin your system to the sudoers file, simply because it as a security risk. Only add applications or scripts to the sudoers file if: the code cannot be edited (stored in a ...


4

As far I see you are using the version 1.0.5 of arduino IDE, I assume that you installed the one in the apt repositories. You can either try to install one from the snapcraft or the one from arduino's website. Personally I used the latter one and anything worked like a charm. Also either the case you can try to loon on Tools->Port if exists a port that is ...


4

Since you downloaded and installed it without using apt you cannot remove it using apt, but instead need to use the uninstall.sh script that was provided with the Arduino download.


3

Problem solved, Once I ran the program as root I was able to get it to work. In Terminal sudo arduino


3

I'm not sure there is a way to set the user and group for a symlink with udev. I don't see one either. I'm also doubting whether one should be needed. I signed on to tty6 and as root, created a symbolic link/tmp/tty6 to /dev/tty6. After I did its user and group were both root, but /dev/tty6 was owned by me. I was able to use echo hi >/dev/tty6 but ...


3

add yourself to the dialout group, as described in thread you mentioned, then log out and back in. Now it should work. This is because the modification won't take effect until your current session is closed and a new one is started.


3

According to the information found at https://communities.intel.com/thread/48053?start=0&tstart=0 and thanks to sulamita and digver I could finally install and run the intel galileo gen2 board on Ubuntu 16.04 The steps I have followed are: Install the board through the arduino IDE. This was accomplished through the Board manager which appears on the ...


3

If you are struggling at this early point in compiling your software, I can't recommend enough, that you install the version from the repositories Open a terminal and run sudo apt-get install arduino


2

Try going into System / Users and Groups and checkeing the box on your username in the TTY Group.


2

As of Ubuntu 16, my best luck has come with the software center, but don't install Arduino IDE if it comes up. You will want to install arduino-mhall. It should look something like this: I tried various other methods here, and had all sorts of problems. This one just worked and I've been happily making stuff with my Arduino ever since.


2

That's the way you get the latest version of a package. What happens is that Eclipse 3.8 is the latest version available from the repos, in this case universe. Many software projects do not maintain packages for Ubuntu and you end up relying on voluntaries for the job. Eclipse is one of such cases and is usually lagging a good deal from the official release. ...


2

Packages in the official Ubuntu repositories are not always the current release versions from the developers. If the developers have their own repository you can always add that repository to your software sources and apt will pull the current version from there. Otherwise you will have to download the current version from the developer source and follow ...


2

I had the same problem as you described, where the Bluetooth applet would generate a random pin for me to enter on the HC-05 and then just say connection failed. This tutorial worked for me though: Bluetooth Serial Communication with HC-05 it's for the raspberry pi, but works on my ubuntu instance just as well. it basically tells you to add the 1234 pin to ...


2

If you want to run it locally, create a desktop file in ~/.local/share/applications: option 1: Make sure the file is executable (in this case it is when you downloaded it). Paste the text below in an empty textfile, fill in the right path to the script file (arduino), to the icon, the comment (optional) and the categories (optional): [Desktop Entry] Name=...


2

I was getting the same error on Ubuntu 14.04 with Arduino Uno. What worked for me was first selecting the appropriate port under Tools > Port and then changing the permission of the port using command like: sudo chmod a+rw /dev/ttyUSB0 Then the error disappeared and I could upload fine.


2

Why not just install from the repositories? sudo apt-get install arduino Otherwise download the package, then in the directory of the download: tar -xf arduino-1.6.5-r5-linux64.tar.xz cd arduino-1.6.5-r5/ ./arduino To install it permamently (sort of) copy the contents of "arduino-1.6.5-r5" directory to somewhere (maybe $HOME/arduino") and then copy the ...


2

The workaround is to use a powered USB-Port, as well as simply another USB-Cable. Sadly, no one seems to have a look at why with some cables the device is added and immediatly removed, while with other cables the device stays. I don't get behind this conduct.


2

It looks like you are trying to download and install the i386 version when you are running 64 bit ubuntu. To correct this, run the following commands. First, purge any existing version and then install gdebi: sudo apt-get purge apmplanner2 sudo apt-get update sudo apt-get install gdebi Next, download the correct version: wget http://ardupilot.com/wp-...


Only top voted, non community-wiki answers of a minimum length are eligible