Questions tagged [apt]

Questions about using any of the apt tools should use this tag. Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu.

Filter by
Sorted by
Tagged with
0 votes
0 answers
10 views

Failed to fetch linux-headers-hwe

I don't understand why I can't sudo apt-get upgrade. I get this error: Get:198 http://security.ubuntu.com/ubuntu focal-security/main amd64 libreoffice-pdfimport all 1:6.4.7-0ubuntu0.20.04.6 [6,344 B] ...
  • 1
0 votes
0 answers
17 views

Packages being held back for long [duplicate]

I'm trying to update-upgrade for almost a week, but specific packages are being held back for too long does anyone know how to update them? If you open the Gnome Software there is OS Updates and ...
  • 3
0 votes
0 answers
15 views

Console Welcome Message no Longer Updating Itself

I have the following problem; After logging into my Ubuntu instance via SSH, the usual welcome message does not refresh itself any longer and I don't know why this happens. Additionally to that I get ...
1 vote
0 answers
28 views

Ubuntu apt upgrades increasing and getting skipped [duplicate]

I've been using ubuntu as my daily driver for a while already (since version 18 LTS). It's very useful and I personally love it. I've recently installed ubuntu desktop 22.04.1 LTS on a brand new ...
  • 11
0 votes
1 answer
33 views

How to reinstall (a large group of) packages

My main system (Xubuntu 20.04.) is in deep trouble. I see no hardware problems, but only very basic things are working. Web is down. My RAID is down. Several other things are flakey. I don't know ...
-1 votes
1 answer
27 views

module 'collections' has no attribute 'Mapping' how to safely reinstall update-notifier-common?

When running app upgrade I get the following errors: $ sudo sudo apt upgrade [sudo] password for admin-federico-dostuni: Hit:1 http://azure.archive.ubuntu.com/ubuntu bionic InRelease Get:2 http://...
  • 105
0 votes
1 answer
37 views

I possibly installed a malware by a misspelled java installation command in the terminal

I was trying to download java, more specifically, JDK version 16. The right command was sudo apt install openjdk-16-jdk, but I end up typing sudo apt install open-jdk-11 instead, the funny thing is ...
0 votes
0 answers
10 views

N: Skipping acquire of configured file 'main/binary-i386/Packages' [duplicate]

After this command : "# add-apt-repository cloud-archive:yoga" I get this at the end of every apt update: N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository '...
0 votes
1 answer
28 views

Accidentally downgraded libstdc++6:amd64 from 12.1.0-2ubuntu1~22.04 to 10-20200411-0ubuntu1

Why trying to get debug symbols for gcc/g++, I accidentally downgraded libstdc++6:i386 and libstdc++6:amd64 from 12.1.0-2ubuntu1~22.04 to 10-20200411-0ubuntu1 by running the following commands wget ...
  • 539
0 votes
0 answers
30 views

Package 'dotnet-sdk-7.0' has no installation candidate on Xubuntu / Ubuntu 22.04

I followed the instructions from here to install .NET 7 SDK after having installed .NET 6 SDK from the Ubuntu feed. wget https://packages.microsoft.com/config/ubuntu/22.04/packages-microsoft-prod.deb -...
0 votes
0 answers
27 views

In a dockerfile, what is the purpose of "#APT::Get::Install-Recommends"?

Inside a Dockerfile I have the lines: RUN echo '#APT::Get::Install-Recommends "0";' >/etc/apt/preferences.d/99recommends RUN echo '#APT::Get::Install-Suggests "0";' >>/etc/...
2 votes
1 answer
145 views

How do I install linux-tools for a mainline kernel?

I have kernel 5.19.2-051902-generic on ubuntu 22.04.1 jammy and need linux-tools-generic. However the version that is downloaded after sudo apt-get install linux-tools-generic is linux-tools-5.15.0-58-...
-1 votes
0 answers
23 views

How to install libmkl-rt package into a Docker container via a non-interaction Docker file installation script?

I am installing the libmkl-rt package into a Docker container, via a non-interaction Docker file installation script. I get the following message during installation: Intel MKL's Single Dynamic ...
2 votes
1 answer
40 views

How can I add gtk+3.0 from launchpad to 20.04?

Sorry, fairly n00b with Ubuntu. I've searched and tried a few results but not sure how I could add the repo into my Ubuntu 20.04 in order to install gtk+3.0. I've read: https://www.jamescoyle.net/how-...
0 votes
1 answer
34 views

Ubuntu Studio update will remove fwupd-signed; is this ok?

Ubuntu Studio 22.04. System updater just said: "The following packages will be removed: fwupd-signed (1.44+1.2-3) in order to install (a whole ton of packages)." I'll decline this for the ...
-1 votes
0 answers
19 views

Ubuntu 18.04 LTS with Kernel 4.15.0-204 will not accept Kernel 5.4.0-138.?

I'm Running Ubuntu 18.04 LTS with the Kernel 4.15.0-204. A Problem arises when the update indicates that a new Kernel is available 5.4.0-138 for upgrade after the introduction of the Ubuntu Pro(Infra ...
0 votes
0 answers
40 views

How to replicate the list of installed packages on another installation [duplicate]

I'm actually trying to diagnose a partly-broken system -- several symptoms have recently arisen. Odd combinations -- Ctl-Alt-F1 no longer works, my web page is down, I can no longer mount FAT thumb ...
2 votes
1 answer
367 views

What are the services 'apt-news' and 'esm-cache', and how do I disable them?

Recently, I've noticed that when I run sudo apt update, an extra 6 lines are written to my syslog each time: Jan 29 21:17:01 xb systemd[1]: Starting Update APT News... Jan 29 21:17:01 xb systemd[1]: ...
10 votes
1 answer
1k views

What are ESM Apps, and how do they relate to Ubuntu Pro?

Lately there have been some questions mentioning ESM Apps, that seem to have caused confusion among myself and others (one example here). It seems there is a relation between ESM Apps, the universe ...
-1 votes
0 answers
21 views

How to fix a 404-error when using apt-get update on 22.04.1 [duplicate]

It shows like this: Err:82 http://archive.ubuntu.com/ubuntu jammy-backports/main arm64 Packages 404 Not Found [IP: 185.125.190.39 80] Ign :83 http://archive.ubuntu.com/ubuntu jammy-backports/...
0 votes
1 answer
23 views

How can I install the dialog package? [duplicate]

How can I install the dialog package? I try these commands, but it doesn't work: sudo apt-get update sudo apt-get install dialog Reading package lists... Done Building dependency tree... Done Reading ...
0 votes
1 answer
32 views

Install packages on systems with secured /tmp and /var (noexec)

I have a group of Ubuntu servers that needs to secured to the DISA (or USGCB) baseline. Part of that process is to set the /tmp and /var mounts to noexec and nosuid. It looks like once I do that, the ...
0 votes
2 answers
31 views

Installed a package with apt-get but cannot remove

Fresh install of Ubuntu 20.04... $ which emacs Was empty. I installed emacs from apt and it found a very old version. However, I cannot uninstall it as it says it no longer exists. $ sudo apt-get ...
  • 1,590
0 votes
1 answer
26 views

Errors when running "sudo apt update" Ubuntu 18.04 Bionic with Hetzner

When I run sudo apt -y update I get Hit:1 http://mirror.hetzner.de/ubuntu/packages bionic InRelease Get:2 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB] Hit:...
  • 3
-1 votes
1 answer
32 views

I installed some software like Docker, Jenkins etc on my PC but it's not working, all it's showing is that Docker-Desktop depends on qemu-system-86

I've being trying to install it but this is what I've been getting as response ife@ife-HP-ProBook-6560b:~$ sudo apt-get install qemu-system-x86 Reading package lists... Done Building dependency tree ...
-4 votes
0 answers
45 views

How to fix this issue for nautilus [duplicate]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/n/nautilus/nautilus_42.2-0ubuntu1_amd64.deb 404 Not Found [IP: 2620:2d:4000:1::16 80]
0 votes
1 answer
26 views

Unable to resolve unmet dependencies [closed]

It seems I have gotten my packages in a dependency loop, I'm not sure to be honest. Can anyone help me resolve my dependencies issues please? lsb_release -a No LSB modules are available. Distributor ...
0 votes
0 answers
7 views

Google Cloud mirror that works without external IP address

Is there a Google Cloud mirror of Ubuntu that works without an external IP address? I have a Cloud VM instance which I want to keep updated. I tried australia-southeast1.gce.archive.ubuntu.com and ...
  • 395
-1 votes
0 answers
33 views

How to downgrade mysql-client to previous point release? [duplicate]

I need to downgrade from mysql-client 8.0.32 back down to 8.0.31. I tried uninstalling mysql-client, and then doing apt install mysql-client=8.0.31-0ubuntu0.20.04.2 but it returns E: Version '8.0.31-...
0 votes
1 answer
98 views

Can't Upgrade from 22.04 to 22.10? [duplicate]

I'm currently trying to upgrade from 22.04 to 22.10 (just because I'd like to), and for some reason, I have 20 packages that no matter what I try, they will not update, which is holding me back from ...
-2 votes
0 answers
34 views

Errors were encountered while processing when running sudo apt-get upgrade

I haven't been able to upgrade for a week. When I run sudo apt-get upgrade in Ubuntu 20.04 I get this error. sudo apt-get -f install and dpkg -C do nothing. The results of sudo dpkg -i --force-...
-1 votes
1 answer
54 views

how can i remove waydroid repositories?

I couldn't find the waydroid repository in Software & Updates > Other Software So where is the waydroid repository stored?
0 votes
0 answers
38 views

Cannot add PPA: ''This PPA does not support jammy''. While installing Anbox on LM [closed]

Recently I tried to install Anbox on Linux Mint, but when adding the PPA to install the required parts of the kernel, I got this error: Cannot add PPA: ''This PPA does not support jammy . I never had ...
0 votes
1 answer
21 views

Jetbrains Toolbox and fuse2

I have set up Ubuntu 22.10 and trying to install jetbrains-toolbox on it. After kicked toolbox included in the archive file, it says it requires fuse, so I have installed it with apt install fuse and ...
  • 101
0 votes
1 answer
42 views

How can I figure out which package currently provides a command?

I'm trying to run a Java program and I'm getting the error "xxx has been compiled by a more recent version of the Java Runtime (class file version 61.0), this version of the Java Runtime only ...
0 votes
0 answers
76 views

Lost the graphical environment of Ubuntu 22.04 [closed]

I lost the graphical environment in Ubuntu 22.04 after having tried to solve broken dependency problems. It seems that I have uninstalled the graphical environment, and now I cannot install anything ...
0 votes
0 answers
43 views

i am trying to install apache2 on ubuntu but i`m getting an error [duplicate]

Reading package lists... Done Building dependency tree Reading state information... Done The following packages were automatically installed and are no longer required: chromium-codecs-ffmpeg-...
0 votes
1 answer
71 views

How to install mingw-w64-x86_64-gtk3 in Ubuntu 22.04?

I am using MingW32 and am trying to install the package mingw-w64-x86_64-gtk3, however, that's not available via the apt install and it looks like you could only install it via pacman. Could someone ...
0 votes
1 answer
43 views

Install old libg2c i386 and amd64 on 22.04 LTS

I have been fighting for a while now with some old softwares which requires libg2c.so.0. One software requires the i386 version while the other requires the amd64 version. I added the old-releases to ...
  • 109
0 votes
1 answer
23 views

How to wait on /var/lib/apt/lists/lock availability on unattended execution? [duplicate]

Please note: there're similar questions around, but this specific scenario is unanswered. Don't close this as a duplicate of 335794 or 1340943. This is always reproducible, and this is about apt lists ...
0 votes
1 answer
24 views

Service restarted at every apt upgrade

Everytime I run apt upgrade and there is an actual upgrade, a service that I have created gets restarted. Typically, I get this message ┌────┤ Daemons using outdated libraries ├─────┐ │ ...
  • 160
0 votes
0 answers
32 views

File policy-rc.d in WSL1 not found

I am trying to resolve the udev issue in my WSL, and I am following the "Apt-get upgrade errors" troubleshooting steps in the WSL docs. To fix issues related to udev, follow the following ...
-1 votes
1 answer
27 views

Ubuntu Server 22.04 automatically installs open-vm-tools

When I apt update and apt dist-upgrade the process installs open-vm-tools package. Why is open-vm-tools being installed on a bare-metal server? Could it be a dependency that I am not aware of? Is this ...
  • 66
0 votes
0 answers
22 views

E: The repository 'https://ppa.launchpadcontent.net/xorg-edgers/ppa/ubuntu jammy Release' does not have a Release file. Ubuntu 22.04 [duplicate]

I have had this error since last month and I haven't found a way to solve it until now. Whenever I run the sudo apt update command it shows E: The repository 'https://ppa.launchpadcontent.net/xorg-...
-1 votes
0 answers
44 views

Problem with h5py (error: libhdf5.so: cannot open shared object file: No such file or directory)

I have a problem with h5py. I'm trying to install a package (P.E.P.P.E.R), but when trying to install, it will give an error. error: libhdf5.so: cannot open shared object file: No such file or ...
0 votes
0 answers
20 views

Latest upgrade broke connection

So I ran sudo apt upgrade from my terminal (Ubuntu 22.04.1 LTS) and I had some hash mismatch issues with some kernel upgrades (5.15.0-58 i think). I didnt think much them, tried to solve the by ...
  • 1
0 votes
0 answers
10 views

Key is stored in legacy trusted.gpg keyring after installing mongoDB in ubuntu 22.04 [duplicate]

W: https://repo.mongodb.org/apt/ubuntu/dists/focal/mongodb-org/6.0/Release.gpg: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for ...
-1 votes
1 answer
91 views

How to make the default ubuntu repositories trustable again?

So the other day some of my repos(including PPA's) started throwing signature. Every time I try to update my repos I end up with this error sudo apt update Get:1 http://archive.ubuntu.com/ubuntu ...
0 votes
0 answers
20 views

CAELinux How to Update TeXLive from 2017 to 2022? [closed]

This is my tex --version: TeX 3.14159265 (TeX Live 2017/Debian) kpathsea version 6.2.3 Copyright 2017 D.E. Knuth. There is NO warranty. Redistribution of this software is covered by the terms of both ...
-3 votes
1 answer
52 views

apt error on WSL caused by libc-devtools, libc6 [closed]

I'm using WSL, and when I try to install or update anything, the I get a message that I should try: apt --fix-broken install screenshot of error This is the error: Reading package lists... Done ...

1
2 3 4 5
335