Episode #125 of the Stack Overflow podcast is here. We talk Tilde Club and mechanical keyboards. Listen now
22

MS-C fonts embedded bitmaps Per comments to this answer, the most common problem with MS C-fonts (Cambria, Calibri...) is that they use embedded bitmaps. To change this disable them. Either in ~/.fonts.conf or ~/.config/font-manager/local.conf in 14.04; Font Manager reserves the right to manage the ~/.fonts.conf file, thanks @Alain) or ~/.config/...


16

There is a workaround is available to this problem. Just turn off the anti-aliasing. But the font look very ugly if we turn off that. Another Solution is just create a file in sudo gedit /etc/gimp/2.0/fonts.conf Paste the lines <fontconfig> <match target="font"> <edit name="rgba" mode="assign"> <const>none</const> &...


13

I fixed the font rendering on my system after reading this topic. Removing/renaming the home (profile) directory and starting over didn't make any difference. You need to open the xfce4-settings editor and set the /Xft/Lcdfilter string in the xsettings channel from lcdnone to lcdlight. Other options to try are lcddefault and lcdlegacy as seen here under ...


11

Install gnome-tweak-tool from the Software Center. Or the Terminal sudo apt-get install gnome-tweak-tool if you feel adventurous ;). Open it. Then select Font. Anti aliasing. It's in Spanish but you get the idea.


11

I wrote a little manual howto fix this. wget http://urshulyak.com:8001/index.php/s/P4afbWaX3mvyjP7/download && tar -zxvf jdk-8u5-tuxjdk-b08.tar.gz && sudo mv jdk-8u5-tuxjdk-b08 /usr/lib/jvm && rm jdk-8u5-tuxjdk-b08.tar.gz Script to start Intellij Idea *only note that need to change IDEA_HOME location for your path of idea #!/bin/...


8

If the reason for bad looking fonts is disabled anti-aliasing, then there are few things you could try: In LibreOffice: Go to Tools in the top menu -> then Options. In the left treeview go to LibreOffice -> View (4th from top). Here are some settings for LibreOffice (like "use Anti-Aliasing"). If your whole system lacks of Anti-Aliasing (what I don't think ...


7

So, I actually figured it out with some research and playing around; heres how you can do it on your side: Requirements: Stable Internet connection Root access to your system Steps: We first need to install TuxJDK: Go on the link above and download the JDK; Once downloaded the JDK extract the folder named jdk-8u5-tuxjdk-b08; We're now going to move the ...


5

You can make chrome use it's own theme (without kwin borders) simply by changing some chrome configs (I do not remember exactly which ones, but I've done it before). Furthermore you can look for kwin(and other) themes on kde-look.org. AFAIK fonts in kubuntu are configured exactly the same as in ubuntu. But if you would like exact match make your settings ...


5

My guess is that you see this behavior only for some documents, right? In that case I think that you see output from an old LaTeX version with standard LaTeX bitmap fonts. I have found the document that you are showing and the fonts are non-aliased also on my system -- although I know that regular documents look perfect. It's also non-aliased under Windows, ...


4

You have conflicting directives in your .Xresources. Try removing one of the two lines: Xft.hintstyle: hintfull Xft.hintstyle: slight And see if that works. I used exactly your .gtkrc-2.0 and .Xresources on a relatively unmodified Xmonad setup on Ubuntu 12.04, and the setting worked correctly once I removed one of those lines.


4

I have spent lots of time mucking with font and system configurations to get a decent non-anti-aliased font in Ubuntu Terminal. One solution was to install a dedicated non-anti-aliased TrueType font, such as Terminus. Set your Terminal preferences to use the Terminus 8 font, or use the Ubuntu Advanced Settings tool to set the global console font to Terminus ...


4

Just adding details to Oli's answer for those who need it: what winetricks settings fontsmooth=rgb actually does is creating and importing a registry file with the following content: REGEDIT4 [HKEY_CURRENT_USER\Control Panel\Desktop] "FontSmoothing"="2" "FontSmoothingGamma"=dword:00000578 "FontSmoothingOrientation"=dword:00000001 "FontSmoothingType"=dword:...


4

I found a solution to the problem linked to in this reddit post. Add the following line to /etc/environment as root: FREETYPE_PROPERTIES="truetype:interpreter-version=35 cff:no-stem-darkening=1 autofitter:warping=1" Then restart the XServer (Xorg or XWayland) or reboot. It works.


4

You'd have to configure your displays as separate X screens, not a shared desktop. Ubuntu should then let you adjust the sub-pixel order for individual X screens. Otherwise, what would happen with a window that spans two display devices with differing sub-pixel orders? Or even trickier, two displays in clone mode with different physical orders (RGB vs BGR). ...


3

Like Rmano guessed I had to delete ~/.config/fontconfig/fonts.conf which included (wrong) settings for the antialiasing of fonts. Any problematic program started after deleting that file, rendered the fonts right again.


2

Seems to worked its way out, but only after adjusting the pixel format to RGB Limited and changing the GPU scaling under adjustments to maintain aspect ratio in the Catalyst Control Center. However, when testing the settings back to default the fonts still look great. Something must have been stuck.


2

Rename or delete file ".fonts.conf" in your home directory (switch on "display hidden files" to find it), log off and log on again. This helped me (with ubuntu 12.10).


2

I've found that if you enable the "FXAA" setting in the NVIDIA X server settings, fonts in Ubuntu look terrible, especially in Chrome. Disabling OpenGL in Compiz also fixes it, but then Unity won't load. After chasing the issue for some time, I finally figured out that it was the FXAA setting. Yes, I've tested it numerous times and it is definitely that ...


2

Yes, this is possible using nvidia-settings. Launch this application, and then on the left hand side, you should see all your XScreens listed. Find the xscreen corresponding to the monitor and go to antialiasing settings. From there you can override application settings and turn off antialiasing for everything.


2

Have you tried running it on full screen or seamless instead of scaled (Virtual Box Settings, not Ubuntu settings)? If you are still getting badly scaled fonts when running full screen, see the following link and try changing the hinting and anti-aliasing options. How do I change fonts and adjust their size? *Edited to remove Vbox guest additions ...


1

Is indeed an electron app... I found that launching it with this command line options the rendering looks better. skypeforlinux --disable-gpu --enable-lcd-text


1

Firefox can render PDF via pdf.js - and uses excellent subpixel rendering.


1

Ok, after a while I think I found the cause of my Perl-Tk fonts problem: a reinstallation of Ubuntu 14.04 plus Perl-Tk made the problem disappear. So why did it appear in first place? One thing that very likely caused problems in the old installation was that at one point I changed the user name and the name of the home directory (!) using the bash command ...


1

This is an antialiasing bug only in the top bar of the Unity environment when using the Radiance theme instead of the default theme Ambiance. In all other places the text will be fine. You can install gnome-tweak-tool and try different fonts for using in the titlebar, change antialiasing, hinting, etc. to see better results.


1

Solution: First create a file in .config/fontconfig/conf.d/ directory with 20-no-embedded.conf name. Then put the below lines in the file to disable embedded bitmaps for all fonts.(If you don't want to disable for all fonts, but for some fonts, skip this to the next) <?xml version="1.0"?> <!DOCTYPE fontconfig SYSTEM "fonts.dtd"> <fontconfig&...


1

I had this same problem. I found a work around that is not really practical. (I am using Intel i7 + good HD screen.) Normally I use hint full, antialias ticked. When Quetzal was released I installed a new Precise and updated to Quetzal without any modifications, except disable overlay scroll bars and global menu. Then installed xfce from repository. (I did ...


1

I'm not sure if it applies to xubuntu, but in Ubuntu standard I've had this crop up. Solved it like this: cd /etc/fonts/conf.d sudo mkdir orig sudo mv 10-hinting-slight.conf orig (close and reopen affected apps)


1

Matty, This occurs because your sub-pixel order is incorrect. Go to the Settings > Appearance. And then play with the sub-pixel order. If you are on a newer laptop, switching from RGBA to None does the trick. See the attached screen shot.


1

This does have to do with the anti-aliasing in Windows. It expects you to have it on in the OS, so they don't bother re-creating anti-aliasing in the Office Suite. If you disabled the anti-aliasing in Windows, it would look the same. If wine's own font smoothing does not work, then I don't think it will. Here's a test to make sure its just the display that'...


1

The default Sans font, is Ugly, imho. The Arial, Tribuchet MS and some other MS fonts, don't render properly, Tribuchet MS has a problem with e. An extra line on top. I hate it. The good windows fonts Tahoma, Segoe, Callbiri, Cambria all render poorly, due to lack of cleartype. Trying to use this xml, in .fonts.conf that is supposed to magically make ...


Only top voted, non community-wiki answers of a minimum length are eligible