2 of 3 I fixed It myself

Grub Error 15. Can't boot - I FIXIED IT MYSELF <3

I made a partition with Windows disk management (40GB) for the purpose of installing Ubuntu. It worked fine and I saw it next to the C drive so I turned of the computer and grabbed my USB with Ubuntu on (ubuntu-12.10-desktop-i386) and I used LinuxLive to make the USB Ubuntu "ready" (LinuxLive USB Creator 2.8.19) I got everything working and all but Then I was going to start my laptop again (The same one that I made a partition on) but after the Dell logo I got this Message: "GRUB Loading stage1.5.

GRUB loading, please wait... Error 15"

I thought that it was strange that I couldn't boot my windows so I look in the boot options (F12 on my dell) but I could only find a Legacy boot list and other options, I couldn't choose which partition I wanted to boot so I tried to reboot the computer with my Ubuntu USB.

FYI I didn't put anything on the new made partition, I've only tried Ubuntu in vmWare player.

I got thru the setup and I choose to delete the 40gig partition I made and created a new one with Ubuntu. I thought everything was fine so I restarted the computer (when the setup told me to) and removed the usb.

But then I booted my computer I still hade the same Error :/

I hope someone can help me //Oskar

EDIT: I was surfing on google and found another post on this forum that helped me, I wasn't sure if it was going to work but it did! :D I used this tutorial http://ubuntuforums.org/showthread.php?p=10871917#post10871917

The part I used, I wrote this in the Terminal

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update && sudo apt-get install -y boot-repair && boot-repair

Then followed the guide and rebooted and then GRUB2 worked :)

And I'm sorry for posting before reading :(