Questions tagged [zlib]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
1answer
119 views

GCC warning: This configuration is not supported in the following subdirectories. What does it means?

After running configure of GCC 9.2.0, I get this warning: *** This configuration is not supported in the following subdirectories: gnattools gotools target-libada target-libhsail-rt target-...
1
vote
1answer
88 views

b2 doesn't recognize zlib

I have a hard time compiling some program. error: undefined reference to 'boost::iostreams::zlib::best_speed So I am trying to build boost 1.72.0 on Ubuntu 19.10 $ ./b2 Building the Boost C++ ...
0
votes
1answer
309 views

How can I install, using apt, python3 with zlib? Or cani I not use apt for this?

I have installed python2 and python3 using apt. I have tried to use $ virtualenv -p python3 testenv1 and get Running virtualenv with interpreter /usr/local/bin/python3 Traceback (most recent ...
1
vote
1answer
85 views

Help! zlib-1.2.9 - Killed AppArmor and all network connectivity, cannot fix

So I was installing Flexihub (https://www.flexihub.com/download.html) and I had an error noting that the package "zlib-1.2.9" was unavailable, so I tracked it down from proper sources, installed it, ...
0
votes
0answers
1k views

Ubuntu Bionic 18.04 — fatal error: zlib.h: No such file or directory #include <zlib.h>

I am relatively new to Ubuntu. I have set up a Ubuntu 18.04 subsystem on my Windows 10 PC for bioinformatics applications. During multiple application installations, I have received the following ...
1
vote
1answer
201 views

Lubuntu boots into Terminal. Xorg cant connect to Zlib

My Lubuntu 18.04 boots strait into the terminal. When I try to start the GUI with startx I get the following error message: xauth: timeout in locking authority file /home/jonathan/.Xauthority xauth: ...
1
vote
0answers
1k views

zlib1g-dev installation

I have been having issues with installing zlib1g-dev (I need it for rbenv to work). Apt will not install it, saying that I don't have the required dependencies (it doesn't say exactly which zlib1g i ...
1
vote
0answers
538 views

Version conflict in zlib1g, Ubuntu 16.04 LTS

as a dependency for a software I wanted to update ZLIB from 1.2.8 to 1.2.9, following this comment, but I realised too late, that there is no 1.2.9 for Ubuntu 16.04, so I broke things and the first ...
0
votes
1answer
3k views

zlib_1.2.9 not found required by /usr/lib/x86_64-linux-gnu/libpng16.so.16

After downloading zlib-1.2.9 on Ubuntu 18.04 I have these problems opening one of my softwares (Schrodinger suites). ImportError: /opt/schrodinger2017-1/mmshare-v3.7/lib/Linux-x86_64/libz.so.1: ...
0
votes
1answer
6k views

zipimport.ZipImportError: can't decompress data; zlib not available in spark(ubuntu 16.04 LTS) [closed]

I am trying to use the countbyvalue() function and it gave me the following error: File "/usr/local/lib/python3.5/runpy.py", line 174, in _run_module_as_main mod_name, mod_spec, code = ...
3
votes
2answers
5k views

Error installing zlib1g-dev

I am an Ubuntu newbie and would like to install zlib1g-dev on Ubuntu 16.04.3 LTS. The command: sudo apt-get install zlib1g-dev ressults in the following error: Reading package lists... Done ...
0
votes
0answers
297 views

Avogadro 1.2.0 installation

I get this error message: Could NOT find ZLIB (missing: ZLIB_LIBRARY ZLIB_INCLUDE_DIR) Call Stack (most recent call first): /usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:388 (...
1
vote
1answer
3k views

Zlib import error on python 3.5

I started with web development in python(ver:3.5.3) with flask. But when I tried importing zlib getting import error Python 3.5.3 (default, Mar 20 2017, 16:01:17) [GCC 5.4.0 20160609] on linux Type "...
1
vote
1answer
496 views

I have a few versions of Python on ubuntu 16.04 LTS -> how to remove some and not to break down the system

I've installed a few version of Python on ubuntu 16.04 LTS, please see a screenshot. When I tried to delete/uninstall one (not 2.7.12)-> I broke my system, then recovered again. Is there any way to ...
0
votes
0answers
93 views

gzip functions in python2 but python3 doesn't recognize zlib

I have python2 by default and I use python3 instlled via apt-get, I import gzip in python2 without problem, but in python3 don't recognize zlib. I am a newbie in linux and don't have ideia what to do. ...
0
votes
1answer
519 views

how to run program using png library

I installed libpng and zlib and want to run this program using png.h. I have Code::Blocks and I'm completely new in IT. I don't know why it doesn't run. I get the following: undefined reference to ...
2
votes
0answers
3k views

How do I get the zlib library and headers?

I want to install a program from a tar.gz file and when I write ./configure I obtained this error: checking whether zlib support suffices... configure: error: zlib library and headers are required ...
2
votes
6answers
31k views

Install Python package locally

I'm a newbie to Ubuntu, so I'm sorry if question is too dumb. How can I install Python package to already installed local version of Python? Ubuntu 14.04, Python 2.7.10 /usr/local/bin/python2.7, ...
7
votes
1answer
26k views

Need help getting and intalling zlib1g-dev on Ubuntu 14.04. Error Couldn't find any package by regex

I use sudo apt-get install https://launchpad.net/ubuntu/trusty/+package/zlib1g-dev and this is what ensues: Reading package lists... Done Building dependency tree Reading state information.....
2
votes
2answers
3k views

Abort class-pclzip.php : Missing zlib extensions

Since I recovered from some mess that I was having after upgrading my Ubuntu server to 14.04, the two Wordpress websites that I have hosted on the server have been randomly displaying the following ...
1
vote
1answer
2k views

How to install zlib in ubuntu 12.04

I have just started (as in 30 minutes ago) to use Ubuntu 12.04 (all my previous experience is with windows) and I just started to learn how to program a couple of weeks ago so this is probably a ...
1
vote
1answer
435 views

Getting PIP on Local Install of Python

Background: I was trying to get a particular Python program to work (http://mrbell.github.io/pyrmsynth/ specifically), but I got an error that seemed to indicate that Python 2.6 was required (or at ...
0
votes
1answer
603 views

Problem compiling a C file

I was trying to install Xmame 0.103 on Ubuntu 14.04. I had some problems installing it. It says that *.c zlib.h: no such file or directory I opened that file and I saw that zlib.h file was written ...
1
vote
1answer
2k views

php zlib gzopen not exists

I'm using Ubuntu 14.04 and php 5.5.9-1ubuntu4 (cli) (built: Apr 9 2014 17:08:27) var_dump(extension_loaded('zlib')); => true var_dump(function_exists('gzread')); => true var_dump(...
1
vote
1answer
915 views

Running python3.3 using virtulenv

I am using Ubuntu server 12.04. The default python version is 2.7. I have installed python 3.3 in /opt directory. When I tried to create a virtualenv to use python 3.3, I get the following error: $ ...
2
votes
1answer
5k views

/lib/x86_64-linux-gnu/libz.so.1: could not read symbols: Invalid operation [closed]

I installed Ubuntu Desktop 13.10 64-bit in VMware. I am trying to compile PHP 5.4.14 on the machine. Here's the bit where make stops due to an error: /usr/bin/ld: ext/mysqlnd/.libs/mysqlnd_net.o: ...
3
votes
1answer
786 views

Gimp crashes on JPEG save

Sometimes different applications crash, and the system notifies me that the crashed application uses a third party library (libz) and suggests trying without it. I can always reproduce it by ...
1
vote
2answers
950 views

zlib error webkit

I downloaded the WebKit source code and I am building the source code on ubuntu 10.04 After executing below command, i got errors related to glib-2.31.2. ./autogen.sh --prefix=/usr I solved those ...