Questions tagged [yelp]

In the GNOME desktop, Yelp is the help browser that appears when F1 is pressed. It provides a simple gui to view program information, manpages or anything else that the user desires. It uses simple html formatting and has been based on the webkit rendering engine since version 3.

Filter by
Sorted by
Tagged with
2 votes
1 answer

Not Able To View HTML Using GNOME Yelp

In the GNOME Yelp docs, it says that Yelp supports viewing HTML. But when I run yelp file:///home/myusername/Desktop/test.html, it displays "The URL can't be shown." How can I resolve it? Actually I ...
  • 782
5 votes
1 answer

yelp cannot find GNOME help files

tl;dr The summary of all the following is roughly this: Remove or move the directory /usr/share/help/C/gnome-help. Run the command sudo apt reinstall gnome-user-docs gnome-getting-started-docs ...
  • 7,044
2 votes
0 answers

Yelp line is too wide for man pages

I am generally using yelp (the life preserver icon on the desktop) to view system man pages. After I open yelp, I can press Ctrl+L and enter man:man for example to view the man page for the man ...
  • 7,044
5 votes
2 answers

How to run full text search on help pages offline (from Yelp / gnome-help or something other)?

I have both Ubuntu 16.04 LTS and Ubuntu 18.04 LTS installed. I want to search for documentation and read it off-line (as it is included to the installed packages in /usr/share/help and other ...
  • 91.7k
2 votes
1 answer

Yelp help browser and the scrollkeeper catalogue

I need some help in understanding how the Yelp Help Browser works. When I start Yelp in Ubuntu 17.10 I get the Ubuntu Desktop Guide, and when I search for terms that should definitely be contained in ...
4 votes
1 answer

Can I browse and search man pages in Yelp?

I can open Yelp to a specific man page as follows: yelp man:bash & But how can I use Yelp to browse (view a list of all man pages and open them one by one) and search (find all man pages that ...
  • 19.7k
1 vote
1 answer

yelp displays blank (real) help pages

Newish user of Lubuntu 16.10 trying desperately to shed MS Windows. HELP button on more than one utility launches yelp with correct title in title bar, but help window is blank. HOWEVER, mouse pointer ...
2 votes
1 answer

From where Ubuntu help(yelp) reads its files?

I tried to remove Ubuntu Desktop Guide from Yelp(Ubuntu help).. sudo apt-get purge ubuntu-docs But still shown whenever I open help?! From where are those files? and how yelp treat them? and how to ...
  • 79.9k
1 vote
0 answers

How can I search GNU info pages with Dash?

There is a scope for searching manual pages but I fail to find a scope for searching GNU info pages. I can launch { yelp 'info:coreutils'; } from the command line but not from the Dash.
1 vote
2 answers

Yelp package building problem

I'm using Ubuntu12.04 lts. When I built the yelp package from it's source with dpkg-buildpackage command, It shows me following message, and It fall a sleep. gtk-doc: Scanning header files (...
  • 11
1 vote
1 answer

Man command does not work with yelp

When I was introduced with Ubuntu 8.04, the Yelp (Ubuntu documentation) was aware of man command: simply type man:<manpage> into the search string showed the desired man page in HTML look and ...
  • 13.3k
1 vote
1 answer

Where to save Yelp files?

I've written some yelp pages using Mallard. Now I would like to know where to save them correctly in the file system (packaging). The saved Yelp files should be displayed when opening Yelp -> Go -&...
1 vote
1 answer

YELP does not work right

When I click on DashHome then click on the questionmark, It brings up the help system. However when I enter a command to search on it tells me this does not exist. From what I understand the engine is ...
3 votes
0 answers

How to get Yelp to open the docs?

quickly tutorial Result: An empty Yelp window with the XML file opened in gedit. yelp /usr/share/quickly/templates/ubuntu-application/help/tutorial.xml --> Exactly the same problem. Worked fine a ...
  • 8,558
0 votes
2 answers

gnotime help hogs my system

In Gnotime, when I open help, the help system hogs my system resources and simply displays an empty Yelp screen. If I run Gnotime in Terminal, I get this message: GTT: GConf: Warning: get /apps/...
  • 1
6 votes
1 answer

Why is it taking so long to open the Ubuntu Help Center?

When I click on the Help Center Icon in the 'System' menu, it takes more than a minute to launch the program. More than a minute, for a text only program seeming like a website! All my other programs ...
  • 15.2k
11 votes
3 answers

Why documentation says release is 11.04 instead of 10.10 [closed]

I went to the desktop menu and opened System->About Ubuntu to read more. It says You are using Ubuntu 11.04 when I am using 10.10. Why is that so? Update: This has been fixed!
's user avatar