Skip to main content

Questions tagged [webkit]

Webkit is the browser rendering engine behind many modern browsers and web components.

Filter by
Sorted by
Tagged with
1 vote
0 answers
46 views

Authentication with Bearer token with wpe-webkit-mir-kiosk

I'm running wpe-webkit-mir-kiosk in ubuntu-frame on Ubuntu 22.04. This setup will be used on several sites and will display information related to that location. The web server backend needs an ...
Jan Ikkik's user avatar
2 votes
0 answers
160 views

wpe-webkit-mir-kiosk Network Disconnect Unrecoverable

I am using wpe-webkit-mir-kiosk on Ubuntu Core 22 on a raspberry pi 3b like the following: snap set wpe-webkit-mir-kiosk url=https://www.mysite.com My use case is a digital dashboard that loads a ...
Justin's user avatar
  • 71
1 vote
0 answers
66 views

Using client certificates with wpe-webkit-mir-kiosk?

I'm running wpe-webkit-mir-kiosk in ubuntu-frame on Ubuntu 22.04. I'd like to use a client certificate for accessing content on my server. I can't find any documentation on how to install a client ...
doncoleman's user avatar
0 votes
0 answers
51 views

Can wpe-webkit-mir-kiosk support window.confirm?

I'm running wpe-webkit-mir-kiosk in ubuntu-frame on Ubuntu 22.04. I have a form using window.confirm to show a confirmation dialog. e.g. confirm("Are you sure?");. When running in ubuntu-...
doncoleman's user avatar
1 vote
1 answer
759 views

What does this WebKit problem indicate? How do I fix it on Ubuntu 22.04.3 LTS?

I'm having a webkit issue on Ubuntu 22.04.3 LTS. I get the following errors when running a Photino app (dotnet dev framework which implements webkit). KMS: DRM_IOCTL_MODE_CREATE_DUMB failed: ...
raddevus's user avatar
  • 1,878
1 vote
0 answers
828 views

GNOME Control Center freezes when trying to add a Gmail account

I want to add a Google account on my gnome-control-center online-account. The popup OAuth window for connecting GNOME to Google loads the first page (email), but when I validate, the window freezes ...
geriwald's user avatar
  • 111
0 votes
1 answer
149 views

Using epiphany-browser via a remote xdmcp session

Epiphany-browser works fine when I am on my physical machine running Xubuntu 22.04, however when remotely accessing the machine via an xdcp connection using vcxsrv I get the following error message: (...
Hymcode's user avatar
  • 21
2 votes
2 answers
3k views

Error while installing Remarkable Editor

I downloaded the .deb file of Remarkable Markdown editor in Ubuntu 20.04. As soon as I started to run the .deb file, it is showing the following error: Error: Dependency is not satisfiable: gir1.2-...
Yellow Yak's user avatar
2 votes
1 answer
403 views

Fix WebKit font rendering in 20.04

I use cutycapt to make screenshots of web pages. When I switched from Kubuntu 16.04 to Kubuntu 20.04 I noticed that font rendering quality degraded significantly. I made several screenshots of the ...
whtyger's user avatar
  • 5,830
3 votes
2 answers
2k views

Display the contents of an HTML file on my desktop

I found a very old post on Display the HTML content on desktop as a widget. This is an updated answer with the help of these two answers Answer-1 and Answer-2. I tried to run this as a python script &...
sai's user avatar
  • 33
2 votes
0 answers
475 views

Midori Browser as alternative for Safari testing

A webpage that I am developing currently has been reported to not display correctly in safari by some users. Unfortunately, I only have Windows 10 and Fedora 20 on my laptop. I saw on internet that ...
StanGeo's user avatar
  • 121
1 vote
1 answer
3k views

is the package of gir1.2-webkit-3.0 gonna be inUbuntu 20.04

Is gonna be possible to get the package of gir1.2-webkit-3.0 in Ubuntu 20.04 or newer?? I am trying to use the plugin of cover art browser for Rhythmbox, and keeps failing cause is missing the package ...
yop's user avatar
  • 91
0 votes
1 answer
1k views

Ubuntu 18.04 wired ethernet connection not working

I have a linux machine, running Ubuntu 18.04, and my wired connection is no longer working. (I can only connect with Ethernet - no wifi card), and I have checked the Ethernet cable on another device ...
penguinsRus's user avatar
0 votes
1 answer
752 views

Where is the gtk+-quartz-3.0 package located? (Trying to compile webkitgtk)

prompt:> cmake -DPORT=GTK -DCMAKE_BUILD_TYPE=RelWithDebInfo -GNinja CMake Warning: No source or binary directory provided. Both will be assumed to be the same as the current working directory, ...
urmish's user avatar
  • 3
0 votes
0 answers
3k views

Ubuntu 19.04 and WebKitGtk

I'm trying to install WebKitGtk on Ubuntu 19.04, and I'm not having any luck. The instructions I found on https://help.ubuntu.com/community/WebKit says "If your ./autogen.sh command runs without any ...
JohnG's user avatar
  • 1
1 vote
0 answers
48 views

How to implement WebKitWebFrame(Webkit1 Class) in Webkit2

WebKitWebFrame is a class in webkit1. But as webkit1 support is removed we have to use webkit2. But in webkit2 there is no class called WebKitWebFrame. Kindly help how to implement the same feature ...
Amit Anand's user avatar
2 votes
0 answers
1k views

Ubuntu is stuck on the loading phase when connecting an online account

Whenever I attempt to add Google as an online account through the settings, it gets stuck with Loading "accounts.google.com" in the bottom-left corner of the window that appears. This behaviour seems ...
VortixDev's user avatar
  • 253
1 vote
3 answers
7k views

How to install lightdm-webkit-greeter2 on ubuntu

I was wondering if anyone knew how to install the lightdm-webkit-greeter 2 on ubuntu 17.04. I have looked at the github page, and I can't install any of the dependencies it needs as they all return ...
Tyler's user avatar
  • 43
1 vote
0 answers
219 views

Color change in Chrome and Opera after resuming from suspend

I have noticed several times that the color handling on one of my monitors were a bit off from time to time and thought it was the monitor itself, until today. When I "accidentally" dragged a tab out ...
carestad's user avatar
  • 993
0 votes
0 answers
111 views

How to display Swfs in GTK3 Apps that is made out of html

view = WebKit.WebView() uri = 'transformice.html' uri = os.path.realpath(uri) uri = urllib.parse.ParseResult('file', '', uri, '', '', '') uri = urllib.parse.urlunparse(uri) view....
NekoTony's user avatar
12 votes
3 answers
19k views

Webkit - how to test your website on Safari 10?

I am on Linux - Ubuntu/ Kubuntu 17.04 and I need to test my website on the latest Safari browser. I found this answer so I downloaded the release from this site. This is what I downloaded webkitgtk-2....
Run's user avatar
  • 2,658
4 votes
0 answers
2k views

Continuous crashes of WebKitWebProcess

My kern.log file has large number of log entries as below. I could not figure out who is embedding webkit. Only WebkitWebProcesses I could find were started by upstart, but I am not sure if it's the ...
user871199's user avatar
0 votes
0 answers
77 views

Super+L shows Unity-Greeter, not webkit2-greeter

I have installed webkit2-greeter for lightdm. When I boot, or run dm-tool switch-to-greeter I get the webkit2 greeter. However, when I use the keyboard combination Super+L, it sends me to the unity-...
IronManMark20's user avatar
2 votes
2 answers
3k views

libqt5webchannel.so.5 missing or not found in Ubuntu 16.04

I am trying to create deb of QT 5.5 app which uses QT5 webkit and webkitwidgets in it. When I am trying to create deb with command "debuild -kMYGPGKEY" then it gives me below error. /usr/bin/ld: ...
User2546's user avatar
  • 179
1 vote
1 answer
948 views

Using lightdm webkit greeter in 14.04

All guides indicate I need to change a setting in /etc/lightdm/lightdm.conf, and that's how I did it last time, but there seems to have been some changes since that was written. lightdm.conf doesn't ...
Juicy's user avatar
  • 905
0 votes
2 answers
2k views

Error while installing lightdm-webkit-greeter

I can't install the package lightdm-webkit-greeter on Ubuntu 14.04 sudo apt-get install lightdm-webkit-greeter Reading package lists... Done Building dependency tree Reading state information.....
afeefa's user avatar
  • 15
0 votes
1 answer
2k views

How do I install WebKitGTK+ in Ubuntu14.04

I want to build a web interface for my GTK+3 application but I have some problem in installing WebKitGTK+. What are the dependencies that I need to install?
Prince's user avatar
  • 101
1 vote
0 answers
91 views

Guest login support in lightdm webkit greeter

I'm having trouble getting the guest login option to work in the Webkit LightDM greeter, which is a shame as it's otherwise a superb tool for developing custom greeters. Looking through the source on ...
Jeremy's user avatar
  • 11
2 votes
1 answer
419 views

Midori and webkit2

How can I compile Midori to use webkit2 and will it work in Ubuntu 14.04? I've tried the option --enable-webkit2, but it doesn't seem to be recognised.
Adam Smith's user avatar
0 votes
1 answer
300 views

Is Lightdm-webkit-greeter necessary to run Ubuntu 14.04 LTS?

I want to get rid of lightdm-webkit-greeter due to the errors when I boot into Ubuntu 14.04LTS. Is it possible to run Ubuntu without lightdm? I don't want to mess up my system by removing it. I have ...
C S's user avatar
  • 13
0 votes
1 answer
233 views

Build libqtwebkit4.so from sources

I'm trying to build libqtwebkit4 from sources : https://launchpad.net/ubuntu/+source/qtwebkit-source Everything goes right: I have instilled all dependencies (gtk3, glib, pango,...) ./autogen.sh make ...
user2532835's user avatar
2 votes
1 answer
529 views

Execute Javascript Code in Oxide

I'm Looking for an oxide equivalence to this QtWebKit Function: WebView.experimental.evaluateJavaScript() Or WebKitGtk WebView.execute_script() I'm having problems to find documentation about ...
J.Serra's user avatar
  • 571
2 votes
0 answers
702 views

Why does Ubuntu's webkit inspector look (and work) just like Safari?

In older Ubuntu, the python-webkit inspector looked like Chrome, as you can see in these screenshots: https://stackoverflow.com/questions/13132459 (It had some annoying bugs, too.) I see Midori's ...
NoBugs's user avatar
  • 1,410
1 vote
1 answer
3k views

autogen.sh not found for webkit

I'm trying to install Webkit in ubuntu 12.04 following this instructions: https://help.ubuntu.com/community/WebKit When I get to this instruction: ./autogen.sh --prefix=/usr I got an error message: ...
Trouble-lling's user avatar
1 vote
1 answer
851 views

How to open GTK apps at center of screen?

How to code this using Quickly? Will frameless GTK apps work the same?
Archisman Panigrahi's user avatar
0 votes
1 answer
58 views

Cannot open application in Quickly

I'm creating web browser in Quickly. When I am running my application (quickly run) I have errors about gtk. Without the WebKit code it can run. Sorry about my english. Errors: /usr/lib/python2.7/...
Piesek64's user avatar
1 vote
1 answer
1k views

How do I add Webkit webview to the Ubuntu SDK?

I'm trying to do this tutorial for learning and it seems that I have to keep adding things for it to go smoothly. http://developer.ubuntu.com/apps/html-5/tutorial/ I don't have the "rss-sample.qml" ...
HRM's user avatar
  • 63
0 votes
2 answers
1k views

How do you solve the glib.h not found error when building webkit?

I follow the instructions at: https://help.ubuntu.com/community/WebKit I get an error when running ./autogen.sh --prefix=/usr stating that: conftest.c:28:18: fatal error: glib.h: No such file or ...
BrianW's user avatar
  • 1
1 vote
1 answer
592 views

How can I use pygi Webkit on a headless server install?

I have a set of scripts that works on my laptop that works fine as long as I'm booted in to an X session, but if I'm running on a headless server install I get loads of critical fails from Gtk. I'm ...
RobotHumans's user avatar
  • 29.7k
0 votes
1 answer
502 views

Using Quickly to build a web browser

I've taken my first crack at building apps for Ubuntu. I created a simple web browser using a video made by Jono Bacon. I was wondering if there is a list that I can download that has all of the ...
Larrie Fish's user avatar
7 votes
2 answers
35k views

How to install libqtwebkit5?

How can I install libqtwebkit5 library? I need it for a Qt project. I tried with: $ sudo apt-get install libqtwebkit5 Reading package lists... Done Building dependency tree Reading state ...
Ionică Bizău's user avatar
1 vote
1 answer
91 views

How to enable chameleonic background using GTK webkit?

I have written the code and Chameleonic background is working with Node Webkit. But it is not working with GTK webkit.
Archisman Panigrahi's user avatar
0 votes
1 answer
9k views

How to add a back button to go back to previous page [duplicate]

I'm currently new to Ubuntu programming, and learning the basic's of it. I've been following this tutorial as some of you might know in previous questions asked about it I've made before. Now, I've ...
Shaun's user avatar
  • 55
3 votes
1 answer
1k views

Receiving drag events in a WebView in a QML application

I'm working on an app using QML and the Ubuntu SDK. One of the Pages contains a WebView. While the WebView receives click events just fine, it doesn't receive drag events, as I would like it to. I ...
Robert Schroll's user avatar
0 votes
2 answers
14k views

Can't use lightdm-webkit-greeter

I'm trying to use lightdm-webkit-greeter instead of the default unity-greeter on Ubuntu 13.04. First I installed the greeter: sudo apt-get install lightdm-webkit-greeter Then I ran this command to ...
gsgx's user avatar
  • 522
2 votes
0 answers
968 views

Store cookies with WebKit (python)

So I was watching the "Create Your First Ubuntu App"-Video from Jono Bacon and got the idea, to create a simple app. That creates a window with a WebView und opens the URL to Google Keep. Everything ...
a2r's user avatar
  • 114
6 votes
1 answer
5k views

Building webkit from source

I tried to install the webkit applicaion from sources using this manual: https://help.ubuntu.com/community/WebKit When I type: ./autogen.sh --prefix=/usr the following error occurs: checking for ...
Sashko Lykhenko's user avatar
2 votes
1 answer
1k views

Webkit2.h, what package does it reside in?

I'm trying to compile gThumb from source and enable all extensions, and I cannot get the webkit dependency resolved. I've installed all of the webkit development libraries I can seem to find to no ...
Chad's user avatar
  • 121
1 vote
1 answer
252 views

Upgrade Webkit PyGTK Libraries

I'm developing a PyGTK-HTML5 Application (Using Quickly), but the webkit libraries (WebView) are a bit old, at least for using some of the latest HTML5 APIs (like IndexedDB) is it possible to upgrade ...
victorhqc's user avatar
  • 339
6 votes
1 answer
9k views

How can I make my own custom desktop widgets?

A simple solution like HTML widgets and a transparent Webkit window would be ideal. I'm trying to make a simple background widget framework such that I can easily customize my desktop with some CSS ...
RobotHumans's user avatar
  • 29.7k