Questions tagged [versions]

Versions are sequence-based states of softwares, usually, they increment based on significant changes like bug fixes, implementation of new functionality or changes in the existing program.

Filter by
Sorted by
Tagged with
0
votes
0answers
11 views

i cant install libmagickcore-dev,libmagickwand-dev in ubuntu 20.04 [duplicate]

I tried to install them buy sudo apt-get install libmagickcore-dev libmagickwand-dev it gives Reading package lists... Done Building dependency tree Reading state information... Done Some ...
2
votes
1answer
32 views

Can I install and use two versions of a program?

Say I have an application and it has two versions, 1.0 and 1.1. 1.0 has much more features while 1.1 has a new design and better optimization. Is there anyway I can have both versions, 1.1 and 1.0 and ...
0
votes
1answer
65 views

Which Ubuntu version to choose [closed]

Actually I wanted to ask u all that which Ubuntu flavour should I choose?? I have a 2gigs ram 32bit lappy. I want to learn Linux with Ubuntu And want to choose a performance beast flavour of GOAT ...
0
votes
1answer
43 views

From the GUI, how can I tell which version of Xubuntu I'm running?

Doing this from the command line isn't hard, but I was shocked to find that I couldn't find a GUI way to do it. Where should I be looking?
0
votes
1answer
22 views

how to change the existing path name in ubuntu 18.04

while installing the ubuntu 18.04 .I have set a name and i want to change the name again . I tried using bash.rc.I have changed username but i can't change userpath while using the command pwd
1
vote
0answers
65 views

CMake 3.14 or higher is required. You are running version 3.13.4

When I set up a development environment using the following command: docker build -f Dockerfile.buster -t egot-dcs . I always get the error that "CMake 3.14 or higher is required. You are ...
1
vote
0answers
18 views

Will default gcc version change in 20.04 [duplicate]

I'm writing a book that discusses the assembly language generated by gcc. I'm using Ubuntu 20.04. The default version of gcc is 9.3.0. The latest version of gcc in the repositories is 10.2.0. It's an ...
1
vote
0answers
101 views

Problems with the Minecraft Launcher

Each time I am trying to run a version of Minecraft below 1.13, the game crashes, and it says that they are sorry for inconvinience and if you would like to report the problem. I tried restarting my ...
0
votes
0answers
174 views

Stable and latest version of Ubuntu Mate 18.04 for Raspberry Pi

I have been looking for several days for a stable version of Ubuntu Mate 18.04 Desktop which I will use on my Raspberry Pi 3B. In August, I was able to get Ubuntu Mate 18.04 from ubuntu-mate.org/...
0
votes
0answers
45 views

Update PHP latest version

How to Update PHP latest version on Ubuntu 18.04. I Installed LAMP stack on my PC. Is this possible for this? Install the latest version of PHP Switch the new version PHP
0
votes
1answer
98 views

HPLIP: “hp-setup -i” won't ask to setup plugin for HP LaserJet Pro MFP M428fdw

I'm trying to add a HP LaserJet Pro MFP M428fdw printer/scanner to a few Ubuntu 16.04 PCs, they all have HPLIP ver 3.20.0 which is higher than the compatible version for this printer model. When ...
0
votes
0answers
56 views

Paraview-Transparent Background

Urgent When I use sudo apt install paraview, and do a simulation the layout section shows me the background. Any ideas how could overcome this, I asked me my instructor he told me to install another ...
-1
votes
1answer
55 views

INSTALL MULTIPLE VERSIONS OF SOFTWARE FOR DIFFERENT ACCOUNTS

Good Morning, I am wondering if there is a possibility in Ubuntu to have different users with different softwares versions. The problem is, even if I am able to install the different versions in the ...
1
vote
2answers
70 views

How do I create a bootable USB when my packages are broken?

I don't know what happened, but somehow I can't update my system. apt-get update returns broken package errors. And because I haven't been able to do this, I can't upgrade the release either. So it ...
0
votes
0answers
59 views

Does software that has been built for older versions of Ubuntu run on newer versions? [duplicate]

On the list of downloads for some software that I want to install they have the options: Ubuntu 18.04 LTS Ubuntu 16.04 LTS Ubuntu 14.04 LTS But I am using Ubuntu 20.04. If I download the version for ...
1
vote
2answers
750 views

How can I install Zoom on Ubuntu 20.04.1 LTS? [duplicate]

I am a new Linux user, so today I decided on trying Ubuntu as my first Linux distribution. After updating and upgrading, I decided to start installing my usual applications, such as VLC, Skype and ...
-1
votes
1answer
86 views

How can I solve a “Version Error” when trying to run rdiff-backup between the latest Ubuntu release and the latest Security Onion release?

Background information / previous post available here: Need to try to install a specific package version -- however apt-cache madison, apt-cache policy only seem to list the latest version, though I ...
0
votes
1answer
88 views

apt - install old versions of databases, e.g. mysql

I am working on ubuntu 20.04 and I need mysql in version 5.6 or postgresql version 9.6. I Know that I can specify a version using: apt-get install mysql-server=<version> And I can see the ...
1
vote
3answers
116 views

How to know library version?

Suppose I was told, that libx265-dev version should be ≥ 68. I have $ sudo apt list libx265-dev Listing... Done libx265-dev/bionic,now 2.6-3 amd64 [installed] where 2.6-3 looks completely ...
0
votes
1answer
23 views

dpkg: problems with creating packages

I use dpkg to create package and distribute my app. Please, look at the example of my 'DEBIAN/control' file: Package: myapp Version: 1.0.1 Section: base Priority: optional Architecture: amd64 Depends:...
0
votes
0answers
153 views

Downgrading MongoDB from 4.4 to 4.0

So I need to downgrade MongoDB from v4.4 to v4.0 on Ubuntu 16.04 Following installation instructions I've done: wget -qO - https://www.mongodb.org/static/pgp/server-4.0.asc | sudo apt-key add - then ...
0
votes
1answer
138 views

Different versions of the operating system?

The current version of Kubuntu is 20.04. In the opera browser when i open about Opera it appears to me that i have system : Ubuntu 20.04.1 LTS (x86_64; KDE). Why does this version appear to me and to ...
0
votes
2answers
2k views

Why I can't install Python 3.8? [duplicate]

When I try to install Python 3.8 terminal says it done but when i run python --version it say Python 3.7? (base) user@admin:~$ sudo apt-get install python3.8 Reading package lists... Done Building ...
0
votes
1answer
28 views

How can I install a package with specific PHP versions if the package itself does not contrain it?

My package does not define specific PHP version in its dependency, but only works with older PHP versions (7.2). On Ubuntu 20.04 the apt install <my-package> will want to install php7.4-mysql, ...
0
votes
1answer
46 views

deb package dependency versions a bit useless?

I'm creating a deb package for the first time (using CPack, but I don't think that's relevant), and I'm confused by dependent package versioning. My application depends on 2 Boost libraries and I ...
1
vote
0answers
800 views

How to check the version of libssh-dev installed and update to newer version?

I tried to check my libssh-dev version by running the following command: user@client56:~$ dpkg -l | grep libssh ii libssh-4:amd64 0.6.3-4.3ubuntu0.5 ...
1
vote
1answer
57 views

Versioning in Python [duplicate]

I'm just starting to learn python. For this I want to install the latest version on Ubuntu 18.04. I have accessed the page https://www.python.org/downloads/. Python 3.8.3 should be the current verison,...
0
votes
0answers
62 views

Downgrade Openmpi 4.0.3 to 2.0.2-2

How can i degrade openmpi from 4.0.3 to 2.0.2-2. its because in order to run lights its the requirement its asking for. Also, I am getting this error when i try to wrtie make auto, its as follows ...
1
vote
1answer
241 views

Ubuntu 18.04 Terminal, Software & Updates, Software Updater not working

I'm new to Linux/Ubuntu. It's been a few days since I was on my computer, but the Terminal, Software & Updates, Software Updater not working when I fired it up. (Ubuntu 18.04) I have been using ...
0
votes
0answers
44 views

/usr/src/linux-header version mismatch [duplicate]

I'm new to Linux and have a problem. After sudo apt-get upgrade && update, the funny behaviour started. For instance, Youtube videos don't play anymore, Youtube suggests restarting the device (...
0
votes
0answers
18 views

Best Ubuntu Version [duplicate]

**With Due Respect To the Open Source Community I am new to Ubuntu so please suggest me Best Ubuntu Version for my old sysytem with specs below Processor-Intel(R) Core(TM) i3-2120 CPU @ 3.30GHz, 3300 ...
0
votes
0answers
58 views

Ubuntu for an Intel Core Duo on an iMac?

I'am trying to put Ubuntu into my 19" iMac (mac OS 10.6.8) Intel core duo 2Mgh. Created a USB flash startup with Ubuntu 20.04; received that this kernel needs x86-64 and only found i686. Which is the ...
0
votes
0answers
20 views

Ubuntu Version update cyclic dependencies [duplicate]

I wanted to install a package: ▶ sudo apt-get install sensors Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package sensors I ...
0
votes
1answer
66 views

Older Version(s) Available Still…? [duplicate]

New group member here, and potential Ubuntu user :) I have an older notebook that can only run WinXP. Is there a version of Ubuntu I can DL to a bootable flash drive to meet these sys reqs? Can't get ...
0
votes
0answers
216 views

Wrong kernel version with driver, how do I adapt it?

that's my third question about a driver installation... So, I've bought a wi-fi key, and I'm trying to install the driver with a simple make. But it looks like the kernel version is the wrong, because ...
0
votes
0answers
143 views

conflicting shared libraries versions

Ubuntu OpenCV-3.4.10 C++ Compillation throws warning: /usr/bin/ld: warning: libopencv_core.so.3.4, needed by /home/a/Downloads/installation/OpenCV-3.4/lib/libopencv_imgcodecs.so, may conflict with ...
14
votes
4answers
17k views

What's the default Python version in Ubuntu 20.04?

What's the default Python 3 version in the new Ubuntu 20.04? Is it still 3.6 or the latest Python 3.8? I'm developing a Python program that I later want to run on the new Ubuntu 20.04. I'm unsure if ...
1
vote
1answer
102 views

When to choose an older Ubuntu Server version

What are the differentiating factors between different version numbers? In what circumstances would an older version (for example, 18.04) make more sense as the choice over the most recent version (...
0
votes
0answers
341 views

Unable to update the Curl on ubuntu 18.04

I am trying to uprade my curl version from 7.46.0, however, after numerous try the version still remains the same. root@Ubuntu:~# curl --version curl 7.46.0 (x86_64-pc-linux-gnu) libcurl/7.46.0 ...
11
votes
2answers
24k views

Should you upgrade to ubuntu 20.04LTS from ubuntu 18.04LTS [closed]

I'm considering upgrading to lastest LTS even though my LTS version works fine. Wondering if those security patches are worth the upgrade.
8
votes
2answers
2k views

How do I download old Ubuntu versions?

I want to create VMs of old versions of Ubuntu, such as 10.10, 8.04, 4.10 and more. But how do I download old versions of Ubuntu? My main idea is The Wayback Machine. But is there anything more easier ...
0
votes
4answers
135 views

How to know the version of Thunderbird Mail in Ubuntu 18.04 LTS?

I had a problem with logging in the Thunderbird Mail on my PC that has Ubuntu 18.04 LTS. I checked in the internet about this issue and got to know that the Thunderbird Mail version must be 38 or ...
0
votes
1answer
103 views

Update packet fontconfig to newer version in ubuntu 18 LTS [duplicate]

I would like to update my packet fontconfig to the last release 2.13.1. My machine is running Ubuntu 18.04 and this packet is only available in bionic in version 2.12.6 (ubuntu packages fontconfig): ...
0
votes
0answers
27 views

How to gnu grub version 2.02 on MacBook

i have MacBook but when wanna go to my linux see the gnu grub version 2.02 How can I fixed,please help me And I don't install my Linux on the Hard or flashy installed on my MacBook Thanks.
0
votes
0answers
46 views

Wrong kernel Ubuntu 19.10 with kernel 4.10

I have a system that is about 10 years old with 5 disks. This has slowly been build with boot been moved around as new disks came in. The oldest boot I find is about 9.10. At the moment I boot from ...
0
votes
1answer
355 views

Wordpress uses wrong PHP version

WordPress appears to be using PHP7.1 despite 7.3 being installed. Seems to be a lot of questions about this problem, but no cohesive way to deal with it… I have just setup a new server on AWS (Ubuntu ...
1
vote
2answers
277 views

How do you upgrade Skype to the latest version?

My Skype does not automatically upgrade to the latest version and it is not obvious how to upgrade it. Can someone explain how to do this? I use Ubuntu 18.04 and my Skype version is 8.56.0.103. ...
0
votes
1answer
349 views

Switch between different versions of a Program (R)

I have installed R couple years ago and yesterday I compiled a recent version from source. I now have version 3.4.4 installed, and it's launched with R. Accordingly, I have these command returning ...
1
vote
2answers
129 views

How do I obtain the latest and greatest Debian package files for Ubuntu?

How do I obtain the newest stable Debian package files? sudo dpkg -i ~/Downloads/libgoocanvas3_1.0.0-1_amd64.deb sudo dpkg -i ~/Downloads/libgoocanvas-common_1.0.0-1_all.deb sudo apt-get -f install ...
0
votes
0answers
40 views

Suitability of CUDA version for Ubuntu 18.04 and K1200

Could anyone please explain me how to identify the proper version of CUDA for Ubuntu 18.04 and K1200 GPU. $ uname -sr gives Linux 5.3.0-28-generic and $ gcc --version gives gcc (Ubuntu 7.4.0-1ubuntu1~...

1
2 3 4 5
11