Questions tagged [versions]

Versions are sequence-based states of softwares, usually, they increment based on significant changes like bug fixes, implementation of new functionality or changes in the existing program.

Filter by
Sorted by
Tagged with
145
votes
7answers
94k views

How do I find out which version and derivative of Ubuntu is right for my hardware in terms of minimal system requirements?

For a given hardware configuration, how do I find out if Ubuntu will run on it? What considerations should I take into account when choosing an Ubuntu version and flavour such as: Xubuntu with a ...
229
votes
5answers
317k views

How to install specific Ubuntu packages, with exact version?

I want to setup a new virtual machine with some specified packages (name and version), that are provided. For example apache2 in version 2.2.20-1ubuntu1 with all dependencies. Even if there is a new ...
13
votes
4answers
66k views

How do I decide what version of Ubuntu to install?

This question is here just to avoid you choosing the wrong Ubuntu version number. So, this is not about: Which flavour of Ubuntu to choose? nor about choosing the Server or Desktop version... nor ...
314
votes
6answers
490k views

How to downgrade a package via apt-get?

How can I downgrade a package to an older version via apt-get? Other tools are also acceptable but apt-get is preferred.
215
votes
16answers
187k views

How can I find the version of Ubuntu that is installed?

I installed some version of Ubuntu on my VMware, but I don't know what version exactly it is. How can I find it out?
68
votes
4answers
127k views

List of Ubuntu Versions with Corresponding Linux Kernel Version

Is there a list of Ubuntu versions with default corresponding Linux kernel versions somewhere? I would specifically like to know the most recent version of Ubuntu that still used Linux Kernel 2.x.
70
votes
2answers
16k views

Why is OpenJDK 10 packaged as openjdk-11-*?

While looking to compile OpenJDK from source, the newest General Availability version (OpenJDK 10.0.1) insists on OpenJDK 9 or 10. JDK 11, however, is not due to be released until September 2018. ...
19
votes
4answers
4k views

Why does Ubuntu only support versions for a limited time (and what does it mean)?

Why is it that Ubuntu only support a version for a limited time? Since I have been on this site I have seen many references to particular versions not being supported. What does it actually mean? ...
50
votes
4answers
154k views

How to find architecture of my PC and Ubuntu?

When running uname -a, I get as output 41-Ubuntu SMP Mon Aug 13 17:59:54 UTC 2012 i686 athlon i386 GNU/Linux Can someone please explain to me why both i386 & i686 ? What exactly is my PC ...
7
votes
2answers
3k views

What does 'Lock Version' do?

Having installed an experimental version of dropbox and installed in manually, i dont want the deb in synaptic to download any updates (as theyll over write the changes ive done manually i assume). ...
28
votes
2answers
4k views

Why do some packages have extra numbers before a colon on the front of their version string?

I have just noticed that Wine (and a number of other packages) have shifted their versioning scheme to something like: 1:1.6.2-0ubuntu3 I understand everything after the 1:... But what does the 1: ...
20
votes
4answers
43k views

How do I get the version of an application from the command line?

I would like to know how to get the version information of an installed program that doesn't have the --version or -version method implemented.
7
votes
3answers
4k views

How to install Firefox 3.6 and 4.0+ in parallel?

Up until last week, I had both Firefox 3.6 and Firefox 4.0 installed, which was good for testing web applications. But now the nightly channel contains Firefox 6 instead of Firefox 4. I tried using ...
7
votes
5answers
20k views

Which version of Ubuntu can I install on these specs? [duplicate]

I want to install Ubuntu on my PC. Which version would suit a desktop and these specifications? My specs :- AMD Atholon 64 3000+ 1GB DDR RAM 750GB ASUS K8V-MX main board Thanks in advance!
4
votes
1answer
1k views

Why does Ubuntu 14.04 LTS use a non-LTS kernel version?

I only recently became aware that LTS wasn't just an Ubuntu thing - there's LTS kernel versions too. Yet the kernel version used (3.13) in Ubuntu 14.04 LTS is not an LTS kernel version. Is it ...
57
votes
5answers
122k views

Is there a way to know which GTK version is installed using the command line?

Is there a way to know which GTK version is installed using the command line? I am working on Ubuntu 11.10.
6
votes
0answers
2k views

Scrolling and display problem (bug?) in LibreOffice 3.6 and above [closed]

This problem started with a new version of LibreOffice, 3.6.2.2. (the one with the new green splash screen instead of the old white one) and continued up to the latest 4.x versions. My documents are ...
10
votes
0answers
10k views

How to “clean” previous kernels after update? [duplicate]

Possible Duplicate: How do I to remove or hide old kernel versions, to clean up the boot menu? I know this topic was brought up many times but I didn't really found an answer that would satisfy ...
4
votes
2answers
3k views

On 14.04, my kernel version is 3.11.0-18?

After upgrading to 14.04, my kernel is not upgraded! it's like before: Linux Boxi 3.11.0-18-generic #32-Ubuntu SMP Tue Feb 18 21:11:14 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux Here's what I did: ...
3
votes
2answers
11k views

How can I install a specific older version of Firefox and keep it from automatically updating?

I wrote a bash script to configure a suite of tools for continuous integration on top of Ubuntu 10.04.2. The script recently stopped working and I tracked the problem down to the newer version of ...
11
votes
3answers
384 views

Why documentation says release is 11.04 instead of 10.10 [closed]

I went to the desktop menu and opened System->About Ubuntu to read more. It says You are using Ubuntu 11.04 when I am using 10.10. Why is that so? Update: This has been fixed!
10
votes
2answers
28k views

Update GCC to the 6.3 version [closed]

I want to use some C++ features only available in more recent versions of the language. The problem is Ubuntu 15.04 (Vivid Vervet) has 4.9.2 installed and looking at the output I get from apt-get ...
3
votes
2answers
6k views

Installing Python 3.4 from source

I am running Xubuntu 13.10 i386 with the python (2.7) and python3 (3.3) packages installed. I have downloaded and compiled the source code for Python 3.4 but the binary file is named python. How can I ...
3
votes
2answers
4k views

How to search for an official PPA?

Some applications in Ubuntu don't update automatically, for example VirtualBox, GCC and Git. I'm afraid of using unofficial PPAs, but I can't find PPAs from official sources.
1
vote
4answers
798 views

What are the differences between -v an -V to get the Version of software in Ubuntu?

I'm always confused to get the version of software installed in Ubuntu. To prevent from full typing to get the version like <software> --version instead I always use some thing like <software&...
10
votes
4answers
289 views

How are applications selected as defaults?

Whenever I install Ubuntu there are certain applications I automatically install, instead of using Ubuntu's default (VLC comes to mind). My question is about how some software is chosen over others ...
7
votes
0answers
11k views

Downgrade from one version to a previous version? [duplicate]

Possible Duplicate: How to roll back Ubuntu to a previous version? Is it at all possible to downgrade from one version of Ubuntu to a previous version without doing a re-install similar to the ...
6
votes
1answer
4k views

apt-get cannot install specific version listed in apt-cache policy

I'm trying to install a particular version of redis-server from a third-party repo using apt-get, that's listed in apt-cache policy, but cannot be installed. For example: $ apt-cache policy redis-...
4
votes
1answer
9k views

Change disk ssd. How check which SATA version is supported?

I hava Lenovo g580 laptop. I want to change disk to SSD drive, but I'm not sure if my laptop support SATA 3 (6Gbps). I write following output: dmesg | grep SATA [ 3.190743] ahci 0000:00:1f.2: ...
0
votes
2answers
3k views

upgrade gone bad, no ubuntu, no upgrade, no windows

I have a hand me down laptop that I don't know the windows password for. Ubuntu worked fine until I allowed it to update. Sadly, it got stuck for hours then shut off and when I turned it on it will ...
27
votes
5answers
21k views

Will python2.7 be available for 10.04 in the future?

Since Ubuntu 10.04 is an LTS release will it support python 2.7 as a default package maintainer version or at least have a python2.7 package in future? Since it will be the last major python 2.x ...
9
votes
1answer
2k views

How to install gitg version 2.7 under 15.04? [duplicate]

I updated to Ubuntu 15.04. The shipped version of gitg is 3.15.1 - in Ubuntu 14.10 it was 2.7.3. I really like to install the old version again, since the new version is very inconvenient to handle. ...
10
votes
4answers
2k views

How to install multiple versions of LibreOffice?

Because of a problem reported here, possibly a bug, I have to use LibreOffice 3.5. But I would like to keep an eye on the latest version, which might even solve that problem. I would like to use ...
2
votes
1answer
10k views

How can I check the version of libusb-1.0 running on ubuntu 14.04?

I have ubuntu LTS 14.04. libusb-1.0 is installed in my system. How can I check the version of this libusb-1.0?
16
votes
4answers
531 views

How do I tell which was the original version of Ubuntu installed on a machine?

I've got a few machines which I'm upgrading from version to version for a few years. I'm curious to find out what was the original version of Ubuntu installed on the machine. Is there a way to do ...
11
votes
4answers
10k views

Check if Bash version is >= given version number

I need to test if Bash version number is >= to a specific number. For example I have: $ bash --version GNU bash, version 4.3.48(1)-release (x86_64-pc-linux-gnu) Copyright (C) 2013 Free Software ...
5
votes
1answer
561 views

How does the Ubuntu kernel version relate to the upstream version?

On Oneiric, uname -r prints "3.0.0-14-generic". Does this mean that I am running an Ubuntu kernel based on the upstream (Linux) 3.0.0? Or is it actually based on Linux version 3.0.14? I have tried ...
3
votes
2answers
18k views

How to install PHP 5.2.x on ubuntu 14.04?

I want to run a version specific code on php 5.2.x which I have tried by many ways but not got any successful attempt. Please let me know that how I can install PHP 5.2 on ubuntu 14.04
0
votes
1answer
3k views

Is it possible to get deb packages of older VLC versions?

I need to use v. 2.0.8 for a VLC extension that does not work with the latest releases of the player. I would like to keep the deb of this version for further use, and also to learn how is it ...
4
votes
1answer
1k views

Why doesn't Perl use latest version by default?

When I try to use new perl features (like "say" instead of "print") the code fails until I put in the line "use 5.014;" and then everything runs. My installed version of perl is 5.14.2, and it looks ...
3
votes
2answers
324 views

How to know what version of PHP is shipped in a release version?

Is there a page or Wiki listing for each Ubuntu release what is the default associated PHP version? 10.04 LTS => PHP 5.3.2 And so on...
1
vote
4answers
21k views

Install PHP 5.3 on Ubuntu 13.04

How I could install an old PHP version on Ubuntu 13.04 (Raring Ringtail) -preferably version 5.3.3?
1
vote
1answer
5k views

How can I install a previous version of Firefox as if it was the default?

I noticed that Firefox 21 doesn't work in Ubuntu 12.04 (I upgraded Ubuntu recently). It pops up a message which says: "Your Firefox profile cannot be loaded. It may be missing or inaccessible". I was ...
21
votes
0answers
8k views

How do I determine if I am running 32 bit or 64 bit? [duplicate]

Possible Duplicate: How do I check if I have a 32-bit or a 64-bit OS? This question seems to come up quite regularly. The answer I know is to go to terminal and type uname -m if it says "x86_64" ...
7
votes
1answer
623 views

Package version updates policy

Not sure if here it's the right place to ask, if not - please point me to the right direction. Let's say there's a package, for the sake of real-world example - bind9. In Precise and in Quantal it's ...
7
votes
1answer
1k views

Ubuntu Gnome 14.04 shows 13.10

I'm running Ubuntu Gnome 14.04 and when I open "Details" it shows 13.10. In "Software & Updates" it shows 14.04 and all the repos are "trusty". I installed 14.04 when it just became a beta if ...
6
votes
5answers
7k views

how do I check coreutils version?

How do i check the version of coreutils? gnu coreutils says they are at version 5. Im sure Ubuntu is a variation on that. I tried: info coreutils File: coreutils.info, Node: coreutils invocation, ...
3
votes
1answer
1k views

Set different java version for different programs

I use some programs that have known bugs when using Java 1.7.x (default on my computer), issues that would be fixed using Java 1.6. However I also use program that works fine with the default Java and ...
3
votes
2answers
3k views

Is it possible to install OpenOffice and LibreOffice in parallel?

Because of this bug I was forced to use an older version of LibreOffice. But I would like to have the latest LibreOffice - keeping in this way an eye on a possible future fix to the bug. And, when ...
3
votes
3answers
15k views

What Version of Ubuntu should I install? [closed]

I'm fairly new to Linux and I'm not sure which version of Ubuntu Linux I should install.