Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange
Join us in building a kind, collaborative learning community via our updated Code of Conduct.

Questions tagged [versions]

Versions are sequence-based states of softwares, usually, they increment based on significant changes like bug fixes, implementation of new functionality or changes in the existing program.

-3
votes
1answer
33 views

What version do you recommend? [on hold]

What version do you recommend for a beginner to create sites HTML/CSS
1
vote
0answers
11 views

what is the difference between node and nodejs version being shown in my terminal ubuntu 17

When I type node -v result: v.10.8.0, npm -v result: v 6.2.0. and finally nodejs -v result: v.6.14.2. I read in other forum saying that node and nodejs are same. If it's true, did I installed two ...
-1
votes
1answer
209 views

How to find current version of Gnome for Ubuntu 18.04 from internet? [duplicate]

I'm writing this in Ubuntu 16.04.5 LTS. I'm looking at Gnome Extensions for Ubuntu 18.04 that work with Gnome version 3.24 and breaks with version 3.26. How can I find out using browser (google ...
0
votes
0answers
61 views

How do software versions are ported (or not) in a LTS version?

I run 18.04 on my main server and I have a hard time to exactly understand what "LTS" means: does "Long Time Support" mean that whatever software is installed on day one, at that "version", will be ...
1
vote
1answer
31 views

How to run two different versions of Gmsh on Ubuntu 16.04 and related issues

I want to have two versions of Gmsh: 2.10.1 (http://gmsh.info/bin/Linux/gmsh-2.10.1-Linux64.tgz) and 3.0.6 (the latest) on my Ubuntu 16.04 LTS machine. Both of which I seem to have installed ...
1
vote
0answers
77 views

Cannot install package, probably because a dependency is deprecated. How to get around this? [closed]

I want to install the esl-erlang package on Linux Mint 18.3 (technically not ubuntu, but this place still seemed the closest to an appropriate place to ask this question), but I can't install 3 ...
0
votes
1answer
171 views

How to update kernel version without upgrading kernel? [duplicate]

I installed Ubuntu 16.04 LTS with linux kernel 4.13. However I had to manually install linux kernel 4.4 to support local legacy software and hardware. I'm currently running $uname -r 4.4.0-128-...
0
votes
1answer
105 views

what are the different between live server and Ubuntu Server also Ubuntu Desktop? [duplicate]

I was read this part of the official documentation about ubuntu The basic steps to install Ubuntu Server Edition are the same as those for installing any operating system. Unlike the Desktop ...
5
votes
1answer
6k views

Plasma 5.13 in Kubuntu 18.04?

Plasma 5.13 is said to have better Kwin performance and many other improvements. Can it be installed and can it run in Kubuntu 18.04? The upgrade doesn't sound very abrupt, it should be from 5.12 to ...
0
votes
1answer
111 views

How can I find out the version of mysql package?

In Lubuntu 18.04, I found mysql-client-core-5.7 in default repositories. I was wondering which version of mysql it provides? I don't find any such information in https://packages.ubuntu.com/xenial/...
5
votes
1answer
1k views

What are the GCC and clang versions available in Ubuntu 18.04? [duplicate]

In the new Ubuntu 18.04: What's the default GCC version (with which the binaries were built)? What GCC versions are available as separate packages (and what minor version is installed if I install ...
0
votes
0answers
33 views

APT Repo - same package for multiple/all codenames

I need to create a .deb package and use reprepro to create the repository. I am managing a large group of Ubuntu desktops with diferent Ubuntu versions. I don't specify the codename on my /DEBIAN/conf ...
-6
votes
1answer
33 views

where to find previous versions in official website [duplicate]

i cant find how to install the .ISO file of ubuntu 16.04. it shows me only the 18.04 version. thank you.
1
vote
1answer
41 views

What's the “right thing to do” when latest version of some gnu software is not available via apt-get [duplicate]

I run Ubuntu 16.04 and need to use ddrescue from the gddrescue package. (NB: this is NOT the same software at all as dd_rescue from the ddrescue package). The latest version available via apt-get is 1....
0
votes
1answer
101 views

upgrading ubuntu 16 to 18 : how to keep a specific version of a library?

I have ubuntu 16 and I would like to upgrade to the last one, 18. but I installed sikulix and it requires a specific version (2.4) of a library( opencv) I know, having tested, that on a fresh ...
0
votes
1answer
165 views

wifi problems in ubuntu 16.04

In ubuntu there is no option for wifi display .I saw your previous answers but here in my ubuntu the coulumn of additional drivers is empty.How to fix it?
10
votes
1answer
2k views

Why is OpenJDK 10 packaged as openjdk-11-*?

While looking to compile OpenJDK from source, the newest General Availability version (OpenJDK 10.0.1) insists on OpenJDK 9 or 10. JDK 11, however, is not due to be released until September 2018. ...
0
votes
0answers
14 views

get version from windows executable from within ubuntu

I have a mono app that is a .net developed application. It runs within linux and I'm trying to write a script that will extract the version number of the file from the executable itself. I've done a ...
1
vote
1answer
145 views

Is there way to install two instances of the same application?

What if I would like to have different versions of the same application ? Or even the same version twice ? I heard there some new technology ("Modularity") in Fedora 28 that allows to do that. Are ...
1
vote
1answer
2k views

How do I upgrade from Ubuntu 16.04.4 to 16.04.5? [closed]

I have done sudo apt-get update sudo apt-get upgrade sudo apt-get dist-upgrade Then I checked lsb_release -a which showed, still: No LSB modules are available. Distributor ID: Ubuntu ...
0
votes
0answers
54 views

Keep Ubuntu version

Is there any way to block the update of the Ubuntu version? I have version 16.04.3 and I want it to not update to 16.04.4. I do this: sudo apt update sudo apt upgrade sudo apt dist-upgrade and my ...
2
votes
1answer
2k views

Ubuntu 16.04 - PHP 7.1.11 to 7.1.3

How can I upgrade my PHP version from PHP 7.1.11 to 7.1.3 on my Ubuntu 16.04 server? I've tried the following: sudo add-apt-repository ppa:ondrej/php sudo apt-get update sudo apt-get upgrade sudo apt-...
1
vote
1answer
2k views

How to know which version of Certbot is installed?

I use a Ubuntu 16.04 with Nginx and Certbot. I tried to execute, for example: certbot -v certbot -V certbot --version man certbot none gave any relevant output. How could I know the version ...
6
votes
1answer
3k views

How easy is it to upgrade from 18.04 beta 1 to 18.04 final release? [duplicate]

I have a new ASUS Vivobook laptop and am wondering which version of Ubuntu to install given that 18.04 LTS is scheduled for release at the end of this month. I took a look at the Ubuntu releases page ...
0
votes
0answers
45 views

Linux starts Netbeans 8.1 instead of 8.2 when I start with “netbeans”

In /usr/local I can only see the folder netbeans-8.2 but it starts 8.1 every time which results in an exception because 8.1 isn't compatible with JDK-9.
0
votes
0answers
43 views

Messed up Ubuntu versions and now can't upgrade to 16.04.4

Long story short, I installed the lastest "base-files" package to fix an unrelated mess. It worked, except for the point that now my system ("old" 16.04 from 2016) think it is already upgraded to 16....
1
vote
1answer
164 views

Installing KDE on Ubuntu, fails to fetch files because of versions mismatches [duplicate]

Trying to install KDE on Ubuntu 16.04 with the following commands: sudo add-apt-repository ppa:kubuntu-ppa/backports sudo apt-get update && sudo apt-get dist-upgrade sudo apt-get install ...
9
votes
2answers
173 views

Find which versions of Ubuntu a package in a 3rd-party repository is available for?

I have a link to a 3rd party package repository, for example something like this: http://eddie.website/repository/apt stable main There is a particular package available from this repository (for ...
0
votes
0answers
56 views

I need a password bypass on an old version of Ubuntu

I have an old laptop running at Ubuntu Linux Specific versions: Linux 4.4.0-59generic GNU GRUB version 2.0~beta2-36unbuntu3. I need to access this laptop because it has really important files such ...
0
votes
1answer
121 views

Why does Ubuntu 18.04 come with rustc 1.18? [closed]

I'm aware of the fact that Ubuntu 18.04 isn't released yet and things can change. However, all versions < 18.04 provide rustc 1.21 whereas 18.04 comes with 1.18 which already is quite old (recent ...
0
votes
0answers
37 views

Can I set up an environment (not a VM) with an old version of Ubuntu?

I want to install a package that depends on an old version of libgtkmm that conflicts with the current version on Artful. It also needs to access a set of drivers that are already installed on my main ...
0
votes
0answers
51 views

How to upgrade Openstack version

my current Openstack is Mytaka and now I want to upgrade it to Ocata but I don't know exactly how to do so someone can show me or send me link. Thank you so much!
1
vote
2answers
253 views

Ubuntu implementation of Windows “Previous Versions” tab?

I have implemented a FreeNAS solution and setup SMB sharing. I have also setup regular snapshots. I was pleased to find that Windows was able to see these snapshots in it's "Previous Versions" tab: ...
0
votes
1answer
33 views

update manager failed, use previous version to recover

I have an old hardware x86 PC running 12.04.5. I had been ignoring the Update Manager and using the CLI for updates till recently when I decided to use Update Manager, BIG MISTAKE!!!! It hung my ...
0
votes
2answers
451 views

Is it possible to install old version of NoMachine?

My NoMachine on remote PC was auto-updated to 6 version. But my host machine require 5th (there are some specific issues with the newer one). And now it is not possible to connect from 5th to 6th. Is ...
0
votes
0answers
37 views

Upgrading to the not quite newest version of Firefox without losing bookmarks/prefs

I'm trying to upgrade to Firefox 56 from 54 (I don't want 57 but I need at least 55 to install certain add-ons) and I don't want to lose any bookmarks or preferences etc.. I have the tar.bz2 file and ...
1
vote
1answer
2k views

Why is my 16.04 LTS showing Kernel version 4.10.0-42 - related to Meltdown Patch

I just read this in answer on another question asked by member 4.10 (=17.04) will not be patched: 17.04 went end of life last week (:)) and if you updated the kernel from 4.4 (initial kernel for 16....
0
votes
1answer
33 views

Can unattended-upgrades upgrade from Ubuntu 16 to 17 (major upgrade)?

Can unattended-upgrades upgrade from Ubuntu 16 to 17 (major upgrade)? I assume the current term is "major upgrade" (just as you would go from WordPress 3.x.x to 4.x.x or Drupal 7.x.x to 8.x.x).
0
votes
1answer
66 views

Version agnostic PHP-FPM restart

This is how I restart PHP-FPM in Debian oriented systems: /etc/init.d/php7.0-fpm restart Is there a version agnostic way? All ways I tried from here (besides the one above), failed.
0
votes
0answers
41 views

Which type of installation to choose? [duplicate]

I recently downloaded ubuntu 17 64 bit AMD for my laptop but whilst trying to install, it would just freeze. And so I need to know which type I should download. I use a Packard Bell Acer brand, 2 GB ...
0
votes
2answers
254 views

No fix to kernel that stopped updating on its own

I finally created an account here ! I have a 2015 macbook pro running Ubuntu 16.04, with the kernel 4.4.0-72-generic. I have been using this computer on linux for about two years and I don't ...
0
votes
1answer
282 views

Ubuntu 16.04.3 LTS - LINUX_VERSION_CODE seems incorrect

I found that LINUX_VERSION_CODE defined in /usr/include/linux/version.h on my Ubuntu 16.04.3 LTS machine is (equivalent to) 4.4.90, whereas it is expected to be 4.10.0. bash% lsb_release -a No LSB ...
0
votes
0answers
25 views

Error installing imagemagick on Ubuntu 14.04 [duplicate]

Trying to install imagemagick and getting the below error: Package imagemagick is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, ...
0
votes
0answers
29 views

Adding more distros to my laptop [duplicate]

This question sounds noob to me but I am confused after being away from computing for some time (maybe I have had serious concussions or a brain tumor). I bought a laptop some while ago and thought ...
1
vote
0answers
35 views

Can I run an application for a certain version of Ubuntu in a virtual machine with different Ubuntu version?

I have installed Ubuntu 17.10 in my Windows machine using the MV workstation player. Now I need to install the OpenMS proteomic software in my Linux virtual machine. There are 2 Open MS versions for ...
0
votes
0answers
59 views

Ubuntu 14.02 suddenly skype issue

We have suddenly skype issue in Ubutnu 14.02. Once logged in then close skype. Is this any version issue or any other issue. EDIT: After installed new version of skype. I can received messages but ...
0
votes
0answers
62 views

How do i verify an older .deb package Version

I would like to downgrade a package one version below the latest version available to apt. i need it: a security update in some xenial-updates/main package broke something i need i want to do it: the ...
0
votes
0answers
15 views

How can I update a program installed through software centre? (eclipse) [duplicate]

I installed eclipse through the software centre and the version is old. How can I update it? Will I need to install it again from some other source?
-1
votes
1answer
356 views

Update my Ubuntu version from Ubuntu 13.04 to Ubuntu 17.04 [duplicate]

I do not know how to update my Ubuntu version from 13.04 to 17.04 I tried using software center but I could not do it.
0
votes
2answers
448 views

How do I check whether I'm using two different version of cmake?

I've been having some problems with Qt not being able to use the newest version of cmake. I recently upgraded the version using apt-get cmake --version cmake version 3.2.2 But Qt somehow still ...