Questions tagged [upgrade]

Questions about upgrading packages, systems or hardware.

2,882 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
9
votes
0answers
2k views

libc6 failed biotic upgrade

While upgrading from Xenial to Bionic on a VPS server based on a 64bit, I get the following error: Could not install the upgrades The upgrade has aborted. Your system could be in an unusable ...
8
votes
3answers
6k views

Flash doesn't work in firefox after upgrade Kubuntu to 14.10

I upgraded Kubuntu 14.04-x64 to 14.10. Now flash does not work in Firefox. Now flash is an empty area which sometimes is black when cursor is under it. But flash still works in Chromium.
7
votes
0answers
3k views

Permanently solve “GRUB was previously installed to a disk that is no longer present”

I have an Ubuntu 16.04 virtual machine (local, no cloud) which was created as a clone of another computer. Each time GRUB packages are upgraded using apt upgrade, I get the following message:1 The ...
7
votes
1answer
2k views

libMagickWand-6.Q16.so.2: cannot open shared object file

After upgrading Ubuntu 16.04 to 18.04, I can't run php commands. php -v shows me this: php: error while loading shared libraries: libMagickWand-6.Q16.so.2: cannot open shared object file: No such ...
7
votes
0answers
3k views

Plasma Could Not Correctly Use OpenGL 2 after upgrading to 18.04

After I upgrade Kubuntu from 17.10 to 18.04, and restarted it, all I'm seeing is my mouse cursor, which responds to my movements, and that's pretty much it. I tried to see if I can start up sddm, but ...
6
votes
1answer
2k views

Swap problems after upgrading from 14.04 to 16.06

After upgrading Ubuntu from 14.04 to 16.04 booting started to be very slow. It seems to be a problem with swap partitions. Bellow I attach some details. cat /var/log/boot.log [FAILED] Failed to ...
6
votes
0answers
4k views

How can I upgrade to the latest wpa_supplicant?

I have (more precisely, my employer has) a machine running Ubuntu 14.04 LTS, which comes with wpa_supplicant version 2.1. There are improvements in wpa_supplicant 2.5 which I believe may help with ...
6
votes
3answers
312 views

ZFS doesn't allow me to follow kernels with updates

I installed ubuntu 20.04 sometime in june. by now I'm updated to ubuntu 20.04.1 LTS there's been a few kernel updates. end everytime I run updates Zsys tries to put new kernel version as the first ...
5
votes
1answer
3k views

What is wrong with new upgrade

Recently i upgraded to Ubuntu20.04 Kernel: 5.4.0-26-generic This is the error msgs i get at every startup: [ 0.852002 ] Initramfs unpacking failed: Decoding failed [ 1.034932 ] integrity: Problem ...
5
votes
0answers
2k views

desktop pc crashed on ubuntu 20.04 LTS release upgrade from 19.10

Have a Dell laptop pc dual booting windows 10 pro and Ubuntu 19.10. It was working fine for past few months. I tried to do a release upgrade to ubuntu 20.04 LTS. The upgeade was happening smoothly ...
5
votes
1answer
132 views

After 19.10 upgrade I have an extra frozen cursor

I recently upgraded from 19.04 to 19.10. Ever since, there has been an extra (large) cursor in the lower right of my screen. It is frozen and does not move. It returns on the lockscreen, sleep and ...
5
votes
0answers
216 views

Update Manager terminal output tiny after upgrade to 16.10

When I use the update manager to update packages after upgrading to 16.10, if I show details during the updates, the area of the window that displays the terminal output is so small I can only see one ...
5
votes
1answer
62 views

How can I use a local package mirror at system installation time?

I would like to use a local mirror of the Ubuntu repositories when I'm completing an Ubuntu Server installation. I have a mirror already created to serve the repository over the LAN using http, this ...
5
votes
0answers
415 views

problems with deamontools-run and SV after upgrade to 16.04

i just upgraded to Kubuntu 16.04 from 14.04. However, installer warns me, it can be in unusable state. I haven't restarted yet and am afraid to do so. sudo dpkg --configure -a Setting up daemontools-...
5
votes
0answers
3k views

After 16.04 upgrade install systemd-sysv failed, how can I check that I fixed it?

I updated to 16.04LTS from 15.10. It has been reported as a bug that the message 'not installed systemd-sysv' appears, which it also did on my machine and the installation aborted with the suggestion ...
5
votes
0answers
404 views

After closing the lid, no screen display and computer hangs. Have to restart everytime.(14.10)

When I lock my laptop and close the lid, and again after sometime,when I open the lid, their is a blank screen with no display and even if I press any key(s), my system does not wake up.I have to ...
5
votes
1answer
1k views

After upgrading to Ubuntu 15.04 system freezes and compiz usage 100% CPU

After upgrading to Ubuntu 15.04 system freezes than I run something in fullscreen (Kodi.tv, Steam in Big Picture mode). In htop I'm seeing 99%-102% cpu usage from compiz. sudo lshw -C video *-...
5
votes
0answers
9k views

Failed to load ZFS module stack

Have been using zfs on linux (zfs-native/stable) raidz on 14.04 for several months without hitch and decided to move across some more important files as considered it trustworthy or I guess "stable" (...
5
votes
2answers
9k views

bluetooth problem after upgrade from ubuntu 14 to 16.04

after upgrade to ubuntu 16.04 i can't turn on bluetooth on my laptop . try reinstall bluez and other bluetooth application same as blueman and bluetooth but don't solve problem service bluetooth ...
5
votes
2answers
2k views

“The software on this computer is up to date” while upgrading 12.10 to 13.04

Before you guys close this question as duplicate, I did go through How do I upgrade from 12.10 to 13.04? and nothing solves my problem there. When I try to upgrade my ubuntu 12.10 installation it ...
4
votes
1answer
2k views

Upgrade from ubuntu 18.04 to 20.04 resulting in error

I tried to upgrade from ubuntu 18.04 tp 20.04 using the below command sudo update-manager -d I am getting the below error An unresolvable problem occurred while calculating the upgrade. This was ...
4
votes
0answers
133 views

Cannot upgrade EC2/Ubuntu to 18.04.4 with do-release-upgrade. Maybe it's python?

I'm trying to upgrade my Amazon EC2 instance from Ubuntu 16.04.6 to 18.04.4. I've already performed the cleanups like apt clean, apt autoremove etc... Then I start do-release-upgrade, I confirm to ...
4
votes
1answer
3k views

apt update shows available packages, but full-upgrade shows none upgraded

I just noticed this while updating: hiigaran@hiigaran:~$ sudo apt update [sudo] password for hiigaran: Hit:1 http://archive.canonical.com/ubuntu disco InRelease Hit:2 https://dl.winehq.org/wine-...
4
votes
1answer
251 views

I am unable to save files from LibreOffice and Web Browser

Update: It has been marked duplicate of another fstab question which I have checked. There it is about external drive but for me, write permission from Browsers and LibreOffice is not working on any ...
4
votes
0answers
2k views

Recover from aborted do-release-upgrade

I executed do-release-upgrade on desktop 18.04 and then realized that this command is for servers. But it started the upgrade process anyway without any prompt, rewrote configuration files and only ...
4
votes
5answers
9k views

Black screen after rebooting following upgrade to 18.10

To upgrade from 18.04 to 18.10 I executed the following commands: "sudo apt-get dist-upgrade" and "sudo do-release-upgrade" Upgrade proceeded normally until the system reached the reboot phase. ...
4
votes
0answers
3k views

unable to start lightdm after upgrade to 18.04

I updated my ubuntu 16.04 machine a few days ago to 18.04. I had a few issues upgrading but I've delt with those. only one issue remain: no GUI. I've spent days troubleshooting and googling the issue ...
4
votes
0answers
555 views

How to install cryptsetup 2.x to Ubuntu 16.04?

I came across with encrypted container created with LUKS2, but as a user of Ubuntu 16.04, which comes with 1.7.2, this container can't be opened. It seems I'd need a newer version of cryptsetup, 2.x.
4
votes
0answers
829 views

systemctl --user returns “Unit was not found” on Ubuntu 18.04

I just fresh installed Ubuntu 18.04. I am having an issue with systemd, which worked fine with 17.10. My service files are located in ~/.config/systemd/user. I tried a daemon-reload. didn't work. I ...
4
votes
0answers
433 views

What is the support lifetime for Ubuntu Core?

None of the information I can find about Ubuntu Core mentions how long each release is supported for. The end of life page, and the releases wiki, make no mention of Ubuntu Core. Does it follow the ...
4
votes
0answers
351 views

Nautilus and gedit crash after upgrading to Ubuntu 16.10

Recently I upgraded my computer (ASUS laptop, AMD86) from Ubuntu 14.04 LTS to the latest Ubuntu 16.10. I encountered the following issue: when I tried to launch "Files" (Nautilus) from the launch bar, ...
4
votes
0answers
182 views

Some theme elements broken after upgrade to 16.10?

After I upgraded to Ubuntu 16.10 today, I noticed that some UI elements changed and I wonder, wether this is wanted or not. This image shows the problems: The borders of text field in Firefox look ...
4
votes
0answers
3k views

Fatal Python error/ImportError When Upgrading

When attempting apt upgrade or apt update-manager I receive the following error: Setting up update-notifier-common (3.168.1) ... Could not find platform independent libraries <prefix> Could not ...
4
votes
1answer
603 views

List dependency changes for apt-get upgrade (reasons for packages being held back)

Just today, trying an update on Ubuntu 14.04: $ sudo apt-get update # ... $ sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done ...
4
votes
1answer
7k views

How to install, fglrx on (K)ubuntu 15.04 ? Starting version 219 AMD R9 290x

i have upgraded my Ubuntu 14.10 to Kubuntu 15.04 and as i thought the graphics driver would mess up. I am looking for a step-by-step tutorial how to install fglrx on Kubuntu 15.04. On 14.04 i had ...
4
votes
2answers
254 views

Upgrade Ubuntu Server from 11.04 to 11.10 without internet connection

We have application software that really likes Ubuntu Server 11.10. I need to upgrade several 11.04 servers to this version. Two questions: The servers that need to be upgraded do not have Internet ...
4
votes
1answer
8k views

Upgrading from 14.04 to 14.10: Error! The dkms.conf for this module includes a BUILD_EXCLUSIVE directive which does not match this kernel/arch.

I got a Dell XPS 13 Developer Edition today that shipped with 14.04. I am trying to upgrade to 15.04 in order to solve some trackpad issues, and it seems I need to go to 14.10 and then to 15.04. When ...
4
votes
1answer
9k views

Wifi not working after upgrading from 12.04 to 13.10

I went through loads of posts looking for an answer to my WiFi problems but can't seem to fix it. I had Ubuntu 12.04 installed and WiFi worked fine with no issues whatsoever but then I upgraded to 13....
3
votes
0answers
108 views

GDM cannot show user after upgrade to 20.04

I just upgraded from 18.04 to 20.04 on my workstation. It uses LDAP authentication. I already have an authenticated user. It used to be shown in GDM prior the upgrade. However after the upgrade only ...
3
votes
0answers
249 views

Cannot update after 20.04 version

After updating to version 20.04 (forcefully using -d command), I am not able to update or upgrade neither using termical nor using software now. import apt_pkg ImportError: libapt-pkg.so.6.0: cannot ...
3
votes
0answers
582 views

Any browser tends to freeze Ubuntu 20.04

Any browser tends to freeze ubuntu 20.04 OS upgrade. This apparently happens once or twice every other update, upgrade, dist-upgrade and etc...dating back went UBUNTU was some Linux favor. Beside ...
3
votes
3answers
736 views

Missing dependencies message after login

After upgrade to 19.10, every time I log in, the following message appears and only after clicking Cancel, log in continues. System Monitor Extension Dependencies Missing Please install: libgtop, ...
3
votes
1answer
653 views

Can not upgrade Ubuntu server 19.04 to 19.10 ('ubuntu-minimal' could not be located)

$ sudo do-release-upgrade Checking for a new Ubuntu release Get:1 Upgrade tool signature [1,554 B] Get:2 Upgrade tool [1,319 kB] Fetched 1,320 kB in 0s (0 B/s) authenticate 'eoan.tar.gz' against 'eoan....
3
votes
1answer
83 views

Since upgrading to ermine, getting an error on login

I updated to Ermine from Dingo yesterday, and since then I've been getting the following message when I log in System monitor extension Dependencies missing Please install lipgtop, Network Manager ...
3
votes
1answer
201 views

sudo apt-get dist-upgrade removed sudo and other programs

I was following this guide on upgrading to Ubuntu 18.04, and after executing sudo apt-get dist-upgrade, I did not bother to check that it prompted me that executing it will remove lots of programs. ...
3
votes
1answer
480 views

I got this error when upgrading from 16.04 to 18.04

Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... failed. The following packages have unmet dependencies: dh-python : Depends: ...
3
votes
2answers
2k views

STUCK Ubuntu 18.04 upgrade from Ubuntu 17.10

So I'm currently installing Ubuntu 18, and as of now, my Ubuntu interface has already turned to ubuntu 18 interface. However, the upgrade process is still not finish because it is stuck at Checking ...
3
votes
0answers
223 views

Stylus no longer working properly after upgrading from 18.10 to 19.04

The issue: Stylus depth is no longer being tracked in various applications, it appears to be handled as if it were a mouse. In gnome-shell it still works normally. I can moe the cursor, press down ...
3
votes
0answers
373 views

How to update Bios of a Lenovo Ideapad

I've recently purchased an Ideapad 530S-14ARR. I would like to update the Bios to this device but the bios update package is only available for Windows. What options do I have to update it? ...
3
votes
0answers
296 views

Not able to upgrade from Ubuntu Server 16.04.5 LTS to 18.04.1 LTS

I am trying to upgrade my ubuntu server 16.04.5 LTS to 18.04.1 LTS. But it fails identify the newer release. I tried all the options, which are explained in other Q&A. $ sudo do-release-upgrade ...

1
2 3 4 5
58