Questions tagged [upgrade]

Questions about upgrading packages, systems or hardware.

Filter by
Sorted by
Tagged with
0
votes
2answers
27 views

Which kernel should I update to Ubuntu 18.04?

I just installed Ubuntu 18.04 on a new Lenovo IdeaPad 130 and it turned out that the Linux kernel 4.18 didn't support my touchpad (ELAN 0620), but it is supported in other kernels (4.19 and above). So ...
2
votes
0answers
24 views

apt-get relocation error after upgrade to 16.04

I just upgraded to Ubuntu xenial, 16.04. When I try to do apt-get, I get the error apt-get: relocation error: /usr/lib/i386-linux-gnu/libapt-pkg.so.5.0: symbol [long symbol omitted] version GLIBCXX_3....
1
vote
1answer
260 views

How Can I update and upgrade Ubuntu? My laptop comes with Ubuntu 18.04 and I want 18.04.3

I bought my laptop Dell with Ubuntu and it comes with Ubuntu 18.04. How can I update and upgrade to Ubuntu 18.04.3?
0
votes
0answers
41 views

I need help with cpp: cpp-7 issue

I just did a clean install Ubuntu Bionic Beaver 18.04 for my Dad and all went smooth until I got this message in terminal after running sudo apt-get update and upgrade. I'm bit lost as to how to ...
0
votes
0answers
40 views

How do I remove old GNOME versions from Ubuntu 18.04? [duplicate]

I upgraded Ubuntu 16.04 to 18.04, before which I installed GNOME desktop to be a bit familiar with it. Now, when I restarted my computer after the upgrade, at the login screen I have following options,...
1
vote
2answers
48 views

Cannot upgrade ubuntu 19.04 for a time [duplicate]

After I login ubuntu, as usual, I check upgradable packages by running: sudo apt update. Then the result is: 36 packages can be upgraded. Run 'apt list --upgradable' to see them. I continue with ...
0
votes
1answer
37 views

Just a pink screen after “sudo apt update && sudo apt upgrade”. My laptop is new and it came with ubuntu

Yesterday, I received my laptop Dell Inspiron and I did Ubuntu installing. It comes with Ubuntu. When I finished, in terminal, I did this commands: sudo apt-get update && sudo apt-get upgrade. ...
0
votes
0answers
28 views

Unable to uninstall, install, and see TensorFlow version

I'm trying to install TensorFlow 2.0. I have an older version of TF on my computer. I have tried the answers given here, but they did not work for my case. The current version can be imported in ...
0
votes
0answers
25 views

Upgrading to Ubuntu 18.04 LTS from an ISO image installed on a USB drive

Hello everyone, Hope you are all doing well. Here I'm facieng some technical issues. I can't upgrade my system from terminal or from software updater due to unsolved problems in question: here. And ...
0
votes
0answers
17 views

Backing up system in a way that preserves user accounts

I'll be backing up a deep learning rig for work that has an ancient Ubuntu install on it so I can upgrade it to current, but I need a way to do it that can preserve user accounts in addition to their ...
0
votes
0answers
53 views

Failed upgrade led all my packages to be from 18.04 even though I am running 16.04

# sudo apt-get update Get:1 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB] Hit:2 http://archive.ubuntu.com/ubuntu bionic InRelease Hit:3 http://archive.canonical.com/ubuntu ...
0
votes
1answer
35 views

Automatically answering an interactive prompt with “yes”

Some daemons ask if they shall be restarted, when they've got an update. I get asked whether I want to restart them or not. It opens a purple colored window, where I am supposed to navigate to yesor ...
0
votes
0answers
41 views

Menus look strange and performance is poor after upgrade from Ubuntu 16.04 to 18.04

Yesterday I upgraded from Ubuntu 16.04 to Ubuntu 18.04. After starting Ubuntu 18.04 I found my system working very slow and when I open terminal or any other application, the menu is looking very ...
-2
votes
0answers
34 views

Can't get to recovery console after upgrade [closed]

I tried to make a i386->amd64 upgrade (https://askubuntu.com/a/894597/6808) that once broke, then after some problems (Cannot remove aspell-en in attempt to fix failed dist-upgrade?), I managed to get ...
0
votes
0answers
22 views

How to block Ubuntu to install upgraded kernel [duplicate]

I've the Surface Pro 2017 and I installed a custom kernel compiled for it. Now, I run Ubuntu every time with this custom kernel but every time that there is an upgrade of the linux kernel, the package ...
3
votes
1answer
153 views

What Linux Kernel runs Ubuntu 18.04.3 LTS

I'm running Ubuntu 18.04.3 on a Dell XPS13. When I did the upgrade from 18.04.2 to 18.04.3, I was led to believe system would be running a Linux 5 kernal. It appears that I'm still running a Linux 4 ...
0
votes
2answers
24 views

Cannot remove aspell-en in attempt to fix failed dist-upgrade?

Once, I tried to do a dist-upgrade of a remote Ubuntu 12.04 (I think, or 14.04) system, and the upgrade failed. Now, that I have physical access to the machine, I am trying to fix it. First I managed ...
0
votes
0answers
15 views

chrome is mishandling yahoo email after upgrading to ubuntu 18.04.3

Using a Dell OptiPlex-790 running recently upgraded Ubuntu 18.04.3, GNOME 3.28.2. When in Yahoo Mail, trying to delete an email by clicking on the trash can, the delete fails. It seems it simply ...
0
votes
0answers
41 views

“sudo apt-get upgrade” keeps hanging and I can't figure out why

I run "sudo apt-get update" and then "sudo apt-get upgrade" and it always hangs before it finishes. I have a dd image so for each round below, I restore from the image. After it hangs on a specific ...
1
vote
2answers
154 views

How can I upgrade from 17.04 to the latest non-LTS Ubuntu?

How do I upgrade from 17.04 LTS to newest non-LTS version? It's an older laptop and I'm not sure how to do it. Using the standard update isn't working.
1
vote
1answer
61 views

Firefox keeps updating in the background

Several times a week, Firefox (version 68.0.2+build1-0ubuntu0.18.04.1) is getting into a state where it refuses to open new tabs and instead says it has been upgraded in the background and needs to ...
1
vote
3answers
209 views

Upgrading from ubuntu 16.04 LTS to ubuntu 18.04 LTS

I want to upgrade my system, but I'm facing these problems: Whenever I press on software updater nothing happens and sometimes I get an error report. sudo apt update gives me this: Reading state ...
1
vote
1answer
106 views

sub-process - apt-listchanges error

i keep on getting this error when I try to install or upgrades and almost every thing. After this operation, 731 kB disk space will be freed. Do you want to continue? [Y/n] y /bin/sh: 1: /usr/bin/apt-...
0
votes
0answers
43 views

What would you like to do about menu.lst?

every time I update my Ubuntu 18.04 server I have a dialog box that opens and says A new version of /boot/grub.menu.lst is available, but the version installed currently has been locally modified. ...
0
votes
0answers
37 views

Kernel upgrade to 5.0 and SELinux

With the recent possibility to use Kernel 5.0 with Ubuntu 18.04.03, i upgraded the kernel. SELinux, is also installed and when i use new Kernel, it seems as if systemd itself is unlabeled since every ...
0
votes
0answers
41 views

Ubuntu does not start after the upgrade / error: failure reading sector 0x0 from `cd0'

A couple of days ago, I launched on my Ubuntu 16.04 LTS laptop username@username~$> sudo apt upgrade , then minimized the terminal and after a while turned off the laptop, forgetting to check ...
1
vote
1answer
31 views

Segmentation fault (core dumped) with apt upgrade [closed]

Ubuntu 19.04, upgraded from 18.04. lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 19.04 Release: 19.04 Codename: disco It has been working and ...
0
votes
0answers
22 views

How do I fix this black screen after upgrade? 19.04 [duplicate]

I'm starting to pull my hair out as I've tried getting this working for 2 days straight. I'm getting a black screen on boot up. I know this has been asked so many times, but found no concrete ...
2
votes
1answer
32 views

Package not available after successfully installed with apt-get or pip

I'm trying to install some libraries on my Ubuntu machines. Take this library as an example - virtualenv ubuntu@ip-172-31-44-172:~$ sudo apt install virtualenv Reading package lists... Done Building ...
0
votes
0answers
37 views

Online Upgrade from Ubuntu 16.04 LTS to 18.04 LTS [duplicate]

My question is about upgrading online from Ubuntu 16.04 LTS to 18.04 LTS. One of the responses said that it will NOT upgrade the version, which is exactly what I want to do. Again, but a it more ...
0
votes
0answers
36 views

DRIVER PROBLEM WITH UBUNTU [duplicate]

A few months ago, I bought a Dell Linux laptop with Ubuntu 14.04 LTS pre-installed with all drivers installed. So when dist updates came all my drivers were gone. So i factory reset it and it is back ...
1
vote
0answers
31 views

Cannot initiate the connection to archive.ubuntu.com:80 [duplicate]

This issues had been in my life for 2 weeks and I was unable to figure it out. My domain name was hosted by 1&1 and my website is hosted by my own Ubuntu 18.04. I have no issue to ping anywhere ...
1
vote
0answers
19 views

After upgrading from 16.04 to 18.04 I cant use my mapped folders from either windows 10 or mac OSX Mojave

Error message mac is server may not exist or it is unavailable, windows cannot access "server". I can ssh into the server from both windows and mac. Not sure what could be the problem as both worked ...
1
vote
1answer
67 views

Syslog-ng broken/won't install after 16.04 > 18.04 dist upgrade

I recently upgraded my Ubuntu Server 16.04 VM to 18.04. After the upgrade, syslog-ng was failing to start, so I purged it and tried reinstalling it. Every time I go to reinstall it, I get the "//...
2
votes
2answers
109 views

What does “upgrade to 18.04” mean?

I'm using Ubuntu 16.04 LTS on an Asus K53E laptop with 8 GB RAM. I check for updates to the software daily. If there are no updates, it asks me if I want to upgrade? What does upgrade exactly mean? ...
0
votes
0answers
24 views

Will I experience problem after the upgrade?

When I frist installed Ubuntu on my laptop, I had this problem (the computer hangs and never shuts down) which I solved installing the NVIDIA drivers. This happened both with 16.04LTS and 18.04LTS, in ...
0
votes
0answers
55 views

How to solve a problem with package linux-headers-4.15.0-47?

Thank you for helping in advance, I get all the time similar massage when I try to sudo apt upgrade or install sth. dpkg: unrecoverable fatal error, aborting: files list file for package 'linux-...
2
votes
2answers
70 views

Error in update of python-minimal [duplicate]

When I run an update on Ubuntu 18.04, it shows that the packages below are upgradable. But when I run sudo apt upgrade it doesn't upgrade it. It upgrades all other packages if there are any but not ...
2
votes
1answer
206 views

Ubuntu 19.04 problems install upgrades

When trying to update I get an error message E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. But when I try to run this command the screen goes ...
0
votes
0answers
25 views

UPDATE from 16.04 to 18.04 ERROR requires installation of untrusted packages [duplicate]

I switched to ubuntu from windows just today. and im currently using 16.04 and i want to update it to 18.04. whenever i open software updater and try to install, it says "requires installation of ...
0
votes
0answers
21 views

package “cinnamon-l10n” marked as “kept back” and installation tries to remove cinnamon

Starting some days ago I saw the message [ch720-02:~]$ sudo apt upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done ...
4
votes
1answer
259 views

Is it possible to patch without spiking the CPU? [duplicate]

I'm using unattended upgrades to patch about 300 ubuntu (16.04 LTS) machines (network appliances really), some are 1 CPU VMs running on ESXi, azure and AWS and others bare-metal quad core Atom IOT ...
1
vote
1answer
86 views

Ubuntu 18.10 to 19.04, end of life version [duplicate]

I am facing this issue when attempting an upgrade to ubuntu 19.04. Checking for a new Ubuntu release Your Ubuntu release is not supported anymore. For upgrade information, please visit: http://www....
1
vote
2answers
75 views

Errors while processing: python3-apt,usb-creator,apport,python-apt

I'm not advance user of Ubuntu, and i have a really biHi. I'm not advance user of Ubuntu, and i have a really big issue. When I type: sudo apt-get update && sudo apt-get upgrade I get the ...
0
votes
1answer
104 views

Netatalk broken on 18.04LTS? [on hold]

I recently upgraded my 14.04 LTS system to 18.04 LTS. Now I can't get appletalk to work. I've been using Netatalk with the same configuration files for a very long time. After upgrading to 18.04 I ...
1
vote
1answer
38 views

Upgrading BIOS in my ASUS Vivobook R542UQ

I have installed a new RAM stick of 8GB in my ASUS Vivobook R542UQ-DM153 which already had an 8GB of RAM. So it's 2x8GB of RAM now. Then I noticed both my RAMs are running at 2133 speed although both ...
0
votes
0answers
84 views

Problems with LibreOffice for Linux since upgrade to 6.0.7

I am having serious problems with LibreOffice since I did the most recent upgrade. Documents that I open (that I have previously saved) will suddenly revert to 'untitled document' or will only save as ...
1
vote
1answer
45 views

How to do apt-get update and upgrade during preseed?

Right now, I'm using a bash script using packer to run apt-get update && apt-get upgrade -y. I'd like to do this in the preseed phase if possible. Is there a way to do this? I thought this d-...
0
votes
0answers
51 views

Could not get list of distribution upgrades

When I open package updater I get the error message: Spawn of helper '/usr/share/PackageKit/helpers/aptcc/get-distro-upgrade.py' failed: failed to spawn /usr/share/PackageKit/helpers/aptcc/get-distro-...
2
votes
3answers
147 views

Which LTS version is supported? 18.04.1 or 18.04.2? both?

Source: https://ubuntu.com/about/release-cycle The graph in that source page makes it look like Ubuntu 18.04.1 LTS (v4.15) will be supported for 5 years but Ubuntu 18.04.2 LTS will only be supported ...