Questions tagged [upgrade]

A software upgrade is the process of replacing an older version of one or more programs to a newer version. Use this tag for questions about upgrading individual packages, or the entire operating system to a later release.

Filter by
Sorted by
Tagged with
0 votes
1 answer
36 views

Can't update Xubuntu 20.04 Focal Fossa (LTS) to the next LTS release (22.04 Jammy)

The do-release-upgrade(8) program says I need to install all updates before it can go to work I have done what I can (all as root): apt-get --quiet --assume-yes update apt-get --quiet --assume-...
ForDummies's user avatar
0 votes
0 answers
26 views

On upgrade to manic minotaur 23.10, python threading deamon not working

I upgraded Ubuntu from 23.04 to 23.10 Release 23.10 (Mantic Minotaur) 64-bit Kernel Linux 6.5.0-17-generic x86_64 Python3 version 3.11.6 Since upgrading, any python programs using threading with ...
rayzinnz's user avatar
  • 101
0 votes
1 answer
72 views

Intel ARC intel-i915-dkms dpkg error upgrading to HWE kernel 6.5

Whenever I try to install something, it returns this error: dpkg: dependency problems prevent configuration of linux-headers-generic: linux-headers-generic depends on linux-headers-6.5.0-17-generic; ...
Blueglasses's user avatar
-1 votes
0 answers
37 views

Upgrade from Ubuntu 22.10 to 23.10 Disappearing

I am interested to Upgrade to 23.10 from Ubuntu 22.10. When I opened Software updates, I got an error as below: But then I clicked "OK". Then I got Now I Clicked the Upgrade option, then I ...
Ekaveera Gouribhatla's user avatar
0 votes
0 answers
22 views

How to solve dpkg error based on geany-plugin-addons

Error that I got from the upgrading step: dpkg: unrecoverable fatal error, aborting: loading files list file for package 'geany-plugin-addons': cannot read /var/lib/dpkg/info/geany-plugin-addons.list ...
LEENET JOSEPH's user avatar
-1 votes
0 answers
34 views

Problems updating using sudo apt-get update && sudo apt-get dist-upgrade [duplicate]

Hi I'm a newbie novice and need some advice. I have run a Raspberry PI feeding data to Flightradar for a few years and have only ever updated using the "sudo apt-get update && sudo apt-...
Mark Newton's user avatar
0 votes
0 answers
52 views

How can I safely rollback specific upgrades?

I am currently dealing with gpu crashes which I believe have been caused by a bunch of packages that were upgraded this morning on my machine. Here's the history.log entries for this morning. I am new ...
Charles Randall's user avatar
0 votes
0 answers
35 views

Unmet dependencies after Ubuntu 20.04 -> 22.0.4 upgrade

I have recently upgraded to Ubuntu 22.04LTS. After the upgrade, however, I have problems with apt-get upgrade, since many upgrades are kept back. Here is the full list: base-files cpp language-pack-...
mattiav27's user avatar
  • 875
-1 votes
0 answers
66 views

(can't install any package) linux-image-6.5.0-10-generic can't be removed

When I run software updater it gives me the following error When I ran "sudo apt-get install -f" this was the result From what I read this is caused from grub-customizer ruining the grub ...
Abdelrahman Elhosiny's user avatar
0 votes
1 answer
119 views

I accidentally installed phased update for gjs. How to revert?

~ ❯ apt-cache policy gjs gjs: Installed: 1.72.4-0ubuntu0.22.04.1 Candidate: 1.72.4-0ubuntu0.22.04.1 Version table: *** 1.72.4-0ubuntu0.22....
Player8276's user avatar
-1 votes
0 answers
38 views

Ubuntu 23.10 DisplayLink driver issue after upgrade from 22.04

I've upgraded from Ubuntu 22.04 to 23.10 and the display links on my docking stations don't work anymore. I have a Dell D3100 and a D-link DUB-M810 and the issue is the same with both. I reinstalled ...
Eresz's user avatar
  • 1
0 votes
1 answer
43 views

GTK2 applications broken after upgrade to 22.04

After I upgraded to Ubuntu 22.04 the rendering of GTK2 applications (e.g. GIMP & Chromium) is totally broken. GTK3 applications on the other hand are working fine. This is gtk-demofrom gtk2.0-...
apbr's user avatar
  • 13
0 votes
0 answers
40 views

Ubuntu 22.04 Unattended Upgrades: apt hook usage, for command execution after successful updates

I looked at the commands executed after a successful update, in /etc/apt/apt.conf.d: # cat 15update-stamp APT::Update::Post-Invoke-Success {"touch /var/lib/apt/periodic/update-success-stamp 2>/...
Floren's user avatar
  • 141
-1 votes
0 answers
31 views

22.04 server latest upgrade causes 2min reboot "a start job is running for wait for network to be configured" [duplicate]

I have some VPS's across two suppliers running Ubuntu 22.04. one is ampere and the other are Intel. The console has been showing needs reboot after a week back doing an apt update and upgrade. When ...
Decaquad 's user avatar
0 votes
1 answer
160 views

22.04.1 to 22.04.3 or kernel upgrade? [duplicate]

I installed initially 22.04.1 (in 2022), and did all updates. But, the kernel is still 5.15.0-94 while 22.04.3 comes with kernel 6.2... And lsb_release -a says No LSB modules are available. ...
Déjà vu's user avatar
  • 969
-1 votes
1 answer
49 views

apt update && apt upgrade gives lock error on Ubuntu 22.04 [duplicate]

I have typed the following command: $ apt update && apt upgrade I am getting the error: Reading package lists... Done E: Could not open lock file /var/lib/apt/lists/lock - open (13: ...
user2994783's user avatar
-1 votes
1 answer
32 views

Error during apt upgrade for NodeJS

I encounter this problem while trying to sudo apt upgrade my system: Preparing to unpack .../nodejs_18.17.1-deb-1nodesource1_amd64.deb ... Unpacking nodejs (18.17.1-deb-1nodesource1) over (12.22.9~...
stealz's user avatar
  • 97
-1 votes
0 answers
37 views

Can I upgrade Ubuntu version with Snap? [duplicate]

I want to upgrade my Ubuntu version. Can I do that with Snap?
RPD's user avatar
  • 1
-1 votes
0 answers
22 views

An error occurred, please run package manager from right click menu or apt-get to see what is wrong [duplicate]

Every time I start my laptop I get this error message. An error occurred, please run package manager from the right-click menu or apt-get to see what is wrong. The error message was: Error: Marking ...
sina panahi's user avatar
-1 votes
0 answers
26 views

How NOT to update a package with apt? [duplicate]

I have downgraded Visual Studio Code from v1.86 to v1.85.2 because the server to which I connect does not meet the Linux prerequisites for remote development using SSH. Henceforth, each time I would ...
TVG's user avatar
  • 325
0 votes
1 answer
52 views

Update KDE Plasma on kUbuntu 22.04

Is there any way to upgrade KDE Plasma from 5.24 to 5.27 on kUbuntu 22.04 (without upgrading to kUbuntu 23)?
Alex Jones's user avatar
  • 7,972
0 votes
1 answer
230 views

Unmet dependencies and broken packages error while I tried to upgrade Ubuntu 22.04 [duplicate]

sudo apt upgrade showing following error You might want to run 'apt --fix-broken install' to correct these. The following packages have unmet dependencies: libc-bin : Depends: libc6 (< ...
THORN HILL's user avatar
0 votes
0 answers
41 views

dpkg took too long [duplicate]

i was running "sudo apt upgrade" but it was failed cus the vm turn off, so i tried to run upgrade again and it says i should run "sudo dpkg --configure -a", so i tried it didnt ...
deeeeeeeeeee's user avatar
0 votes
0 answers
29 views

Does using upgrade nvidia-driver present the danger of updating to an unsupported driver?

I need to upgrade my nvidia-driver in my two ubuntu machines. I am thinking of using sudo apt update sudo apt upgrade nvidia-driver but I also know there is the option of searching for a driver in ...
KansaiRobot's user avatar
0 votes
0 answers
38 views

Boot problem after ugrading Ubuntu 22.04

I am hoping someone may be able to help. I am having a problem booting after upgrading from Ubuntu 22.04 to 23.10 The OS I was upgrading was installed on nvme0n1 but I also had a second copy of Ubuntu ...
user3616508's user avatar
0 votes
0 answers
33 views

How to resolve ZFS userspace tools and kernel module mismatch caused by HWE automatic updates

I am on Ubuntu LTS 20.04 with kernel version 5.15.0-91-generic. I find that my ZFS user utils are version 0.8.3 and my ZFS kernel module is 2.1.5. As I understand it, not only is it risky having the ...
user2005848's user avatar
0 votes
1 answer
177 views

linux-generic version does not match with uname -r

I have a question with linux-generic. I installed linux-generic, but it did not match with kernel which was installed on my pc. When I checked linux-generic version using dpkg -l, it showed 5.15.0.92....
khchung's user avatar
0 votes
0 answers
158 views

Kernel 6.7.2 issues

this is mine first time compile a kernel and I have this error make[3]: *** No hay ninguna regla para construir el objetivo 'debian/canonical-certs.pem', necesario para 'certs/x509_certificate_list'. ...
Ricardo Andres Riquelme Rios's user avatar
0 votes
0 answers
40 views

Will 23.04 to 24.04 need 23.10 in between? [duplicate]

I'm running 23.04 and recently got the popup saying there will be no more security updates. Since the long term 24.04 is just a couple of months away my plan was just to wait for 24.04, since every ...
Ken Mandelberg's user avatar
0 votes
0 answers
18 views

problems with reboot after upgrade

when Ubuntu reboots itself after an update ( unattended-upgrades) or when I send the reboot command manually, sometimes it happens that instead of rebooting, the server shuts down. How can I solve the ...
lorenzo's user avatar
0 votes
0 answers
81 views

Cannot upgrade from 23.04 to 23.10 due to kept back nvidia packages [duplicate]

The GUI just finishes when I press the "Upgrade..." button. Very impolitely. I then tried the command line and got: $ sudo apt upgrade (...) The following packages have been kept back: ...
Andreas K. aus M.'s user avatar
-1 votes
0 answers
59 views

i can't upgrADE FROM UBUNTU 23.04 TO 23.10 JUST GET ERROR MESSAGE [duplicate]

W:Updating from such a repository can't be done securely, and is therefore disabled by default., W:See apt-secure(8) manpage for repository creation and user configuration details., W:GPG error: https:...
Richard Seed's user avatar
-1 votes
0 answers
595 views

"linux-image-6.5.0-15-generic" breaks my system

After upgrading to 6.5.0-15, my system would no longer boot. The grapical login screen would not appear and my virtual consoles showed only a blinking cursor. This just happened after I upgraded this ...
AWM's user avatar
  • 45
0 votes
0 answers
30 views

scanner problem

I recently upgraded from Ubuntu 20.4 to 22.4 LTS and lost the HP Icon and the printer still works OK but trying to use the "Document Scanner" program, nothing works. When trying to Uninstall ...
Gary's user avatar
  • 27
0 votes
1 answer
40 views

Ubuntu 20.04 VPS not showing the actual disk size

I just bought a VPS Linux Ubuntu 20.04 which uses NVMe and storage which is said to be 80GB, I tried running apt update && apt full-upgrade -y and everything works normally, I intend to ...
TuanHaxor's user avatar
-2 votes
1 answer
95 views

Preventing Ubuntu upgrade to switch the storage driver from Overlay2 to aufs for docker container

I am upgrading an old server which is running Ubuntu 18.04 LTS to 22.04.3 LTS, going first from 18.04 to 20.04 and then to 22.04 LTS. The old server with 18.04 has some docker container that uses the ...
Tobias's user avatar
  • 1
-1 votes
0 answers
21 views

Vostro 2520 laptop upgraded to 20.04 and now bluetooth, camera and USB ports are not working

Went through many articles on this issue but the solutions were not working for me. I would need specific guidance to troubleshoot the issue. To understand whether it is a hardware problem or a ubuntu ...
Manik Kaushal's user avatar
-1 votes
0 answers
36 views

Overlayroot stopped working after I upgraded from ubuntu 18.04 to ubuntu 20.04

I have a VM with ubuntu 18.04. It has overlayroot enabled. This is the config in /etc/overlayroot.conf: overlayroot_cfgdisk="disabled" overlayroot="tmpfs:swap=1,recurse=0" This ...
siddarth rai's user avatar
0 votes
1 answer
72 views

Upgraded to 22.04 from 20.04 Now Ethernet Doesn't Work

I put off upgrading to avoid exactly these kinds of problems. I found a temporary work around that lets me get online for that session, but I have to do it every time. It's entering this command: echo ...
Bryan's user avatar
  • 9
-1 votes
0 answers
124 views

There is no notification to upgrade to Ubuntu 22.04.3 LTS from update-manager on Ubuntu 20.04.6 and "do-release-upgrade" fails with exit status 1

When I click on Software-Updater on Ubuntu 20.04 LTS (which calls the update-manager command), I see this window : There is no notification of the possibility to upgrade to the next LTS (22.04) ...
SebMa's user avatar
  • 2,259
0 votes
2 answers
136 views

How do I update when I get this in terminal?

How do I update when I get this message? '''base-files/jammy-updates 12ubuntu4.5 amd64 [upgradable from: 12ubuntu4.4] gjs/jammy-updates 1.72.4-0ubuntu0.22.04.1 amd64 [upgradable from: 1.72.0-1] ...
MentalDonnie's user avatar
-1 votes
1 answer
25 views

sata drive not updating to current kernel. nvme drive has 3 choices for kernel

my computer has a sata drive sda that it boots from but the system runs on a nvme drive which is selected by the grub on the sata. the nvme is regularly updated and I watch the logwatch files for any ...
jamby's user avatar
  • 7
-1 votes
0 answers
34 views

i am getting this error in Ubuntu while doing the below operation [duplicate]

fateme@fateme-virtual-machine:~$ sudo apt upgrade [sudo] password for fateme: E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. fateme@fateme-...
Fateme Komshikamar's user avatar
0 votes
1 answer
85 views

How does delta update using debdelta-upgrade work?

A part of message after sudo apt-get upgrade: 190 upgraded, 0 newly installed, 0 to remove and 5 not upgraded. Need to get 830 MB of archives. After this operation, 12.0 MB of additional disk space ...
rusty's user avatar
  • 16.2k
-1 votes
1 answer
94 views

Extension to Ubuntu Pro

Translated: To install the latest update I need Ubuntu Pro. Under "Your subscriptions" it tells me: "Free Personal Token - Machines 5 - Created 16 Jan 2024 - Expires Never". Update ...
Josef HH's user avatar
0 votes
0 answers
79 views

Ubuntu server lts 22.04.3 errors && warnings while trying to download samba [duplicate]

When I try to download samba with sudo apt-get install samba I always get the same errors: I'm very knew to ubuntu and I am following a tutorial to try and make a home server: https://youtu.be/...
Benjamin Wilhelm's user avatar
2 votes
0 answers
175 views

WIFI keeps disconnecting on 22.04.3 LTS after "apt upgrade" from 6.2.0-39-generic to 6.5.0-14-generic

Before apt upgrade, uname -a => 6.2.0-39-generic. Actual result - wifi stable After apt upgrade, uname -a => 6.5.0-14-generic. Actual result - wifi keeps dropping Other details: Ubuntu 22.04.3 ...
Val's user avatar
  • 21
1 vote
0 answers
43 views

Cannot resolve hostnames on ping after upgrading from 18.04 to 20.04

I have recently upgraded a server running 18.04 to 20.04. The in-place upgrade seemed to go fine and installed without a hiccup, however the end goal is to upgrade to 22.04 and when I went to go run ...
MattF's user avatar
  • 11
0 votes
0 answers
36 views

Physical side key volume button stopped working after upgrading to Ubuntu 23.04

After upgrading to 23.04, the physical volume buttons on the side panel of the HP EliteBook stopped working. Though audio, volume increase/decrease works fine with Fn + F6/F7 buttons are not ...
Sachin yadav's user avatar
3 votes
1 answer
519 views

Raspberry Pi 5 as Ubuntu Server 23.10 or 24.04?

I have at the moment an Raspberry Pi 4 (RasPi4) with Ubuntu Server 22.04.3 running stable as Web-Server and DNS-Server. Working great but because of better performance I want to switch to Raspberry Pi ...
Alex's user avatar
  • 35

1
2 3 4 5
193