Questions tagged [ubuntu-make]

Ubuntu Make is a command line tool which allows to download the latest version of popular developer tools, installing alongside all the required dependencies, enable multi-arch on your system if you are on a 64 bit machine, integrate it with the Unity launcher…

Filter by
Sorted by
Tagged with
1 vote
1 answer
229 views

WSL: umake doesn't list pycharm

The umake docs (both online and on my ubuntu installation) say that umake ide has options including "pycharm,pycharm-educational,pycharm-professional". However when I try this on Ubuntu20 ...
0 votes
2 answers
90 views

Is ubuntu-make still alive?

I just discovered ubuntu-make and it was really useful to install latest eclipse IDE (eclipse snap is outdated and is not really an option). But... I'm not sure the ubuntu-make project is really alive ...
  • 5,629
0 votes
0 answers
119 views

Realtek New Master Make Error parameters name queue high on Ubuntu 20.04

I just shifted from Windows to Ubuntu 20.04, But My Wifi Signal is weak. Some times it is working fine then after few seconds it's signal is totally lost and after few seconds signal comes then after ...
1 vote
1 answer
574 views

Uninstall umake on Ubuntu 16.04

On Ubuntu 16.04, I have umake installed at /usr/bin/umake. When I run umake --version it reports 18.05 I just used snap install ubuntu-make --classic to install the latest version, and this is ...
  • 1,033
0 votes
1 answer
203 views

Why I'm unable to install Eclipse using ubuntu-make on Ubuntu 16.04 LTS?

I have ubuntu-make installed on my Ubuntu 16.04.6 LTS system. The Ubuntu Make was installed previously from official PPA using Ubuntu wiki page. So I have the following: $ umake --version 18.05 $ ...
  • 95k
0 votes
1 answer
5k views

make directory permission denied

make[2]: Entering directory '/home/nabi/fftw-3.3.8/api' make[3]: Entering directory '/home/nabi/fftw-3.3.8/api' make[3]: Nothing to be done for 'install-exec-am'. /bin/mkdir -p '/usr/local/include' /...
0 votes
1 answer
140 views

Is there any significant benefit of using UMAKE if the user has time to install software from the deb package?

A lot of devs recommend umake to install IDE's over snap, flatpak, etc. But what if a user decides not to choose snap or flatpak and choose tar or deb package to install over umake, is that a dumb ...
  • 1,122
1 vote
1 answer
235 views

Is there a way to uninstall Netbeans which I have installed using umake?

I have use umake ide netbeans command to install Netbeans a month ago. I am using IntelliJ Ultimate. I searched everywhere to uninstall Netbeans using umake but didn't find anything solid. Is there ...
  • 1,122
2 votes
1 answer
2k views

Error compiling program - Maths library failure?

I have Ubuntu server (no GIU) version Ubuntu 16.04.3 LTS and an trying to install a program 'parsefsh-1.0-g231'. I have downloaded the file and de-compressed it fine, now I need to compile it, so ...
1 vote
1 answer
250 views

Error while installing chkTex

I am trying to install ChkTex on the Ubuntu version 16.04. For that, I downloaded the manual and software. I am currently following the manual for installation. But, when I try to use the command make,...
5 votes
2 answers
3k views

Error while installing Firefox Developer Edition on 18.04.1 LTS

So i have the normal Firefox Quantum65.0 installed on my Ubuntu 18.04.1 LTS. I want to install Firefox developer edition. I have already tried: sudo add-apt-repository ppa:ubuntu-mozilla-daily/...
  • 203
1 vote
0 answers
1k views

System JDK versus SDKMAN

More than once I've had to go into apt to remove JDK > 8 because, at least for the moment, umake installs Netbeans 8 which only runs on JDK 8. I only need JDK 8 for Netbeans, and that temporarily ...
  • 4,423
0 votes
0 answers
850 views

Cannot make install libcurl on Ubuntu 16.04.4 LTS

I am attempting to install libcurl from source on an Ubuntu server, OS version 16.04.4 LTS. I am using gcc 8.1. Here is the configuration script I used: curl version: 7.61.1 1234 Install ...
1 vote
1 answer
485 views

Make custom app available on 'Activities' of Ubuntu

I use Ubuntu 18.04 and I just installed eclipse through umake. But there is a problem. I can find the directory and the executable file of eclipse in ~/.local/share/umake/ide/eclipse. And I succeeded ...
1 vote
2 answers
764 views

Make error while installing Netgen 5.3.1 on ubuntu 16.04

Can anyone help solve the make error I received whilst installing Netgen 5.3.1. NETGEN is an automatic 3d tetrahedral mesh generator. The error message summary is: collect2: error: ld returned 1 exit ...
14 votes
7 answers
30k views

How to install watchman on Ubuntu 18.04, for react-native? error in make command

I have read this solution . I wanted nodeman as dependency for react-native no error upto ./configure command and it works fine as given solution gd@gd10:/tmp$ git clone https://github.com/...
5 votes
1 answer
285 views

Which version of Ubuntu Make should I use - from APT or from Snap?

Following the last question "how to install netbeans from umake?" I have the simply question: which version of Ubuntu Make should I use - from APT or from Snap? Note for close-voters: we have ...
  • 95k
1 vote
1 answer
786 views

how to install netbeans from umake?

How do I install netbeans from umake? thufir@dur:~$ thufir@dur:~$ umake ide netbeans Choose installation path: /home/thufir/.local/share/umake/ide/netbeans thufir@dur:~$ System info: thufir@...
  • 4,423
1 vote
0 answers
40 views

Unattended install of IDEs with Ubuntu Make

I want to use umake to provision vms and containers. umake ide [idexyz] needs interaction and asks questions during the install. How can I about this?
1 vote
2 answers
4k views

how to install android studio with umake and snap? ubuntu-make.umake usage

How do install android-studio from umake through snap? It seems to be a matter of umake usage...but the command looks correct. thufir@dur:~$ thufir@dur:~$ snap install ubuntu-make error: This ...
  • 4,423
4 votes
1 answer
1k views

ERROR: The checksum of android-studio-ide doesn't match. Corrupted download? Aborting

More than three times: thufir@dur:~$ thufir@dur:~$ cat android Script started on 2017-10-26 05:49:38-0700 thufir@dur:~$ thufir@dur:~$ umake -v android android-studio --accept-license INFO: Logging ...
  • 4,423
0 votes
1 answer
88 views

How to view the packages/tools that will be installed by Ubuntu Make?

e.g. If I use following command: $ umake web How to list all the tools/ide/packages installed by this command?
1 vote
1 answer
1k views

how to use Java 9 zulu from sdkman?

Netbeans is using JDK 8 per the source or binary format as shown here: How do i switch to zulu, which is 9? thufir@dur:~$ thufir@dur:~$ javac -version javac 9.0.0.15 thufir@dur:~$ thufir@dur:~$ ...
  • 4,423
2 votes
1 answer
2k views

netbeans won't display projects window

$ cat /etc/lsb-release DISTRIB_ID=Ubuntu DISTRIB_RELEASE=17.04 DISTRIB_CODENAME=zesty DISTRIB_DESCRIPTION="Ubuntu 17.04" $ java -version java version "9" Java(TM) SE Runtime Environment (build 9+181)...
  • 4,423
1 vote
0 answers
235 views

How to programmatically tweak the MATE desktop?

I am experimenting with Vagrant and Ansible to set up a standard development environment in a VM, based on Ubuntu MATE 16.04. I am trying to reproduce some UI tweaks in my cookbook, for example : ...
66 votes
3 answers
101k views

How do I upgrade Gradle?

This shows that Gradle is up to date: thufir@doge:~$ sudo apt install gradle Reading package lists... Done Building dependency tree Reading state information... Done gradle is already the ...
  • 4,423
1 vote
0 answers
1k views

Disable SSL verify for Ubuntu Make

I am trying to install firefox-dev via ubuntu make, and I'm getting an SSL verification error: ERROR: https://www.mozilla.org/en-US/firefox/developer/all couldn't finish download: [SSL: ...
3 votes
1 answer
319 views

Ubuntu-make (umake) security: package signatures?

ubuntu-make (umake) can be used to install the latest version of a variety of popular developer tools. How secure is this process and how does it compare to the security built in to apt-get, such as ...
  • 3,486
2 votes
1 answer
399 views

How do you do non-prompted installs in umake?

I'm trying to automate the installation of certain IDEs using umake. The command that I am currently trying is: printf "~/.local/share/umake/ide/visual-studio-code\na\n" | umake ide visual-studio-...
  • 133
1 vote
1 answer
768 views

How to use umake to install the Go language (version 1.8) in Ubuntu 16.10?

I am having trouble with installing the latest version of golang on Ubuntu 16.10. After running the sudo umake go command I get the message saying to choose the installation path with the default path ...
2 votes
0 answers
254 views

umake android proxy error

When I run in Ubuntu 16.10: $ umake android --accept-license ERROR: https://developer.android.com/sdk/index.html couldn't finish download: HTTPSConnectionPool(host='developer.android.com', port=443): ...
6 votes
1 answer
878 views

Error(s) while installing Android Studio using umake

I'm trying to install Android Studio using umake with the command sudo umake android android-studio and I get the following errors: Downloading and installing requirements | ERROR: W:GPG error: ...
user avatar
1 vote
1 answer
985 views

umake doesn't list Java IDE's

Clarifying a bad question which I'm closing, why doesn't netbeans, or even Eclipse, show as an IDE option for umake? thufir@doge:~$ thufir@doge:~$ umake --version 16.02.1 thufir@doge:~$ thufir@doge:...
  • 4,423
1 vote
0 answers
92 views

umake Arguments not listed Android

I refer the umake tutorial. aboo@aboo-Aspire-E5-511:~$ sudo apt install ubuntu-make Reading package lists... Done Building dependency tree Reading state information... Done ubuntu-make is ...
0 votes
1 answer
1k views

ubuntu make install error

I have istallation for ubuntu make , followed the document ubuntu make sudo apt-get update the following error some packages W: The repository 'http://ppa.launchpad.net/linuxgndu/adt-raring/ubuntu ...
1 vote
0 answers
363 views

Trouble installing android-sdk using ubuntu-make

On running the following command to install android-sdk on Ubuntu 16.04 amd-64, umake android android-sdk I obtained the error ERROR: Couldn't find android-sdk-linux in tarball ubuntu-make ...
2 votes
1 answer
2k views

Umake - permission denied when installing outside home directory (even as root)

I'm trying to install firefox-dev using umake. By default the umake install path is ~/.local/share/; I'd rather it was in /usr/local/ or /opt/. The problem appears to be umake (or, rather, the os.py ...
  • 171
0 votes
1 answer
1k views

Help! Can't choose a valid JDK for Android Studio, so my Gradle is Failing. Why?

So I've been at this for a few hours now, and I must admit that I give up. I know from looking up (so this isn't exactly a duplicate) that I need to change the directory of the JDK. Mad props to this ...
1 vote
1 answer
1k views

How to update all your ubuntu-make packages?

Currently you can't update packages with umake. Here's a link to the closed github issue How to update installed software?#122. As mentionned you only need to remove the package and reinstall it like ...
  • 229
4 votes
1 answer
2k views

Updating apps installed via ubuntu make

I installed Intellij Idea Ultimate 2016.2 via Ubuntu Make. How can i upgrade to the latest version "2016.4" via Ubuntu Make?
5 votes
1 answer
6k views

Why can't Ubuntu Make install Intellij IDEA on 16.04?

On Ubuntu 16.04, running umake ide idea returns: usage: umake ide [-h] {lighttable,visual-studio-code} ... umake ide: error: argument framework: invalid choice: 'idea' (choose from 'lighttable', '...
  • 605
5 votes
3 answers
10k views

dpkg: error processing package ubuntu-make (--configure):

I'm getting ubuntu-make error whenever I'm using apt-get install command, can some one help? ~ sudo apt-get -f install Reading package lists... Done Building dependency ...
  • 151
1 vote
0 answers
445 views

external/clearsilver/util/neo_err.h:88:69: error: expected expression before ‘)’ token

There is one error showed on my ubuntu 16.04 LTS system when make android 2.3.7 version , I do not know how to fix these problems ? PS: this error has been shown after i install the libswitch-perl by ...
  • 115
6 votes
0 answers
524 views

Set install path for ubuntu-make

I was experimenting with ubuntu-make and can not figure out how to specify path for installation so that it does not ask me every time I install something. This is kind of a workaround: echo "\n" | ...
9 votes
1 answer
4k views

does umake update its applications automatically?

Will the applications I install through ubuntu-make update themselves automatically? Like when I install something with apt-get or like when I add a repository.
  • 9,260
0 votes
1 answer
154 views

ubuntu-make didn't install in specified location

I installed Android Studio using umake android. It asked for a location to install it in. After the installation the location is empty. (I'm sure I'm at the correct directory) How do I fix this? How ...
  • 9,260
73 votes
10 answers
290k views

How do I uninstall Visual Studio Code?

I installed Visual Studio Code a while ago, and I'm now trying to remove it. I don't remember how I installed it, but everything I've tried to remove it doesn't work. Things I've tried: sudo umake ...
  • 1,029
7 votes
1 answer
8k views

Why can't I get Android Studio from umake anymore?

I have used ubuntu-make aka umake to install Android Studio and setup the full Android SDK. But since I have upgraded to Ubuntu 16.04 LTS (Kubuntu to be precise) I am not able to install Android stack ...
  • 123
0 votes
1 answer
56 views

How to know which the software's version will be installed by ubuntu make?

Today was released a new version of Arduino IDE (1.6.9). I think Ubuntu Make hasn't still been updated. But, how could I know it?
4 votes
1 answer
151 views

Will the new snap package make `Ubuntu Make` obsolete?

Ubuntu Make is a tool to install some latest versions of popular developers tools. At least more recent versions then the repository is offering. It is invaluable for e.g. Arduino IDE. If I ...
  • 5,339