Questions tagged [texlive]

AN easy way to get up and running with the TeX document production system. It provides a comprehensive TeX system with binaries for most flavors of Unix, including GNU/Linux, and also Windows. Questions about how to use, install these binaries in Ubuntu.

Filter by
Sorted by
Tagged with
0
votes
0answers
34 views

Remove a package dependency permanently

The Question: How can I remove an apt package dependency permanently? (running Ubuntu 20.04) My Example I have TeX Live 2020 installed via TUG install script, the binaries are located in /usr/local/...
3
votes
2answers
79 views
+100

PFB fonts are broken in certain applications and missing in others (Kubuntu 20.04)

I am running Kubuntu 20.04. I have a problem where certain fonts (Courier and Century Schoolbook L) are broken in applications like Inkscape (where they are invisible) or font-manager where they show ...
2
votes
1answer
350 views

tlmgr: Local TeX Live (2019) is older than remote repository (2020)

I already tried what is suggested in the answer to the question: "I got an error when trying to install a latex package trough tlmgr on ubuntu 20.04, verify_checksum: -5 ". When I type this ...
0
votes
0answers
22 views

tlmgr doesn't work on ubuntu 20.04 [duplicate]

I've installed texlive-latex-extra. When I try to use tlmgr, for example: sudo tlmgr update --all tlmgr update --all I allways get the same error message: /usr/bin/tlmgr: unexpected return value from ...
0
votes
1answer
141 views

Installing LyX 2.3.5.2 on Ubuntu 20.04 LTS

I am trying to install LyX 2.3.5.2 on Ubuntu 20.04 LTS with the following code: sudo aptitude install lyx It throws the following message. Any hints to solve the problem. sudo aptitude install lyx ...
3
votes
1answer
625 views

I got an error when trying to install a latex package trough tlmgr on ubuntu 20.04, verify_checksum: -5

I installed texlive on ubuntu 20.04 with: sudo apt -y install texlive-latex-extra texlive-extra-utils texlive-font-utils when trying to install a latex package (any) i got: /usr/bin/tlmgr: unexpected ...
8
votes
6answers
830 views

Where is pdfjoin (Ubuntu 18.04 and later)?

I am used to using "pdfjoin", a small utility in older Debian-based distributions (8 and older). When I moved to Ubuntu 18.04, I realized that command is no longer available. Where did it go?
1
vote
1answer
65 views

Package missing from texlive?

I have the latest texlive distribution, which I installed via sudo apt install texlive-full Now I would like to install the package tuda-ci, which is available on CTAN here. I am a bit confused: it ...
3
votes
1answer
82 views

Problem due to package dependency between `texlive-bibtex-extra` and `biber` in TeXLive 2019 on Ubuntu 18.04 LTS virtual machine

I am a beginner level user of Ubuntu (18.04 LTS virtual machine). I have installed the TeXLive 2019 via command line: sudo add-apt-repository ppa:jonathonf/texlive-2019 sudo apt-get update sudo apt-...
2
votes
1answer
2k views

Installing the latest texlive via command line on ubuntu 18.04 LTS virtual machine

Today, I installed texlive by sudo apt-get install texlive-full. Then I found out that's not the latest version, so I uninstalled it. I have read some threads related to it, but I am getting more ...
0
votes
1answer
86 views

Can't install postgres due to texlive error

I try to apt-get install postgresql but it fails with dependency complaints about texlive. The error message suggests apt --fix-broken install but that also fails with complaints about texlive. I do ...
0
votes
2answers
517 views

tlmgr not found when run as root

I have installed TeXLive and added /usr/local/texlive/2019/bin/x86_64-linux to my $PATH through /etc/environment, so I should be able to run tlmgr from the terminal. I am able to do that as non-root ...
3
votes
0answers
238 views

a missing font causes RAM overflow, huge syslog file, then crash ubuntu

I have some PDFs open in Document Viewer (3.28.4), academic papers downloaded from arXiv recently. Then I notice my memory usage rising gradually, eventually overwhelmed all the available RAM, which I ...
0
votes
1answer
2k views

Install latest version of tex [duplicate]

I am trying to install texlive-full from the terminal. I issued two commands. sudo apt-get install texlive-full sudo apt-get update I also tried - sudo apt-get upgrade texlive-full Despite of all ...
1
vote
1answer
412 views

Problem Installing anything related to TexLive, including Texmaker, after corrupted texlive installation attempted

I have been using MikTex with TexMaker as a compiler/editor. At one point, I tried to remove MikTex and switch to TexLive, which didn't work as the installation got corrupted. I have looked at ...
0
votes
0answers
34 views

Texstudio is not working

I'm using ubuntu 16.04. Since a few days, my apps are not responding properly. It first happened to WPS office (I installed it yesterday, and it was not working from the beginning). When I try to ...
1
vote
1answer
647 views

How can I make the Ubuntu see LaTeX fonts installed through TeXLive?

I have Lubuntu 19.04 and I want it to be able to see TTF and OTF fonts installed via TeXLive. Note that I did not install TeXLive via the package manager (for some reason it was giving me an ...
2
votes
1answer
2k views

Ubuntu 18, unable to install xelatex

I'm trying to install xelatex using sudo apt install texlive-xetex but I'm getting these errors. Err:1 http://in.archive.ubuntu.com/ubuntu bionic/main amd64 texlive-latex-base all 2017.20180305-1 ...
1
vote
1answer
2k views

Installing Latex Packages in TexLive/TexStudio

I am using TexLive and TexStudio, and am trying to install the bbm and physics latex packages. I have followed the instructions from this page: https://scholar.princeton.edu/scuellar/blog/2014/02/...
3
votes
1answer
182 views

latex freezes Firefox

I want to use LaTex in Xubuntu 18.04.1. But it is not possible, because after the very first installation command $ sudo apt-get install texlive-latex-extra Firefox does not run properly anymore. It ...
1
vote
0answers
358 views

Multiple version of texlive installed how to remove the older version?

I am having trouble figuring out how to remove older version of texlive on my laptop. Following is the output of some of the terminal command that might help in answering this question: /usr/bin/tex -...
0
votes
1answer
53 views

Software installation exits

When installing TeXlive full from command line, at 70% the terminal returns: E: Failed to fetch http://ar.archive.ubuntu.com/ubuntu/pool/universe/t/tcltk-defaults`/tk_8.6.0+9_amd64.deb Cannot ...
2
votes
1answer
410 views

TeXMaths-Extension for LibreOffice: No permission to use latex? [closed]

In order to use the LibreOffice extension TeXMaths, it's necessary to enter the path to the latex (and dvisvgm or dvipng) programs in the TeXMaths options. (As explained in the installation manual.) ...
0
votes
1answer
62 views

Do I need the installer first before texlive install? [duplicate]

I want to execute apt-get install texlive-full but do I need to do anything before this like install an installer or anything?
0
votes
1answer
155 views

LibreOffice6.1 broken after upgrading to texlive2018 from a PPA. Can't downgrade to LO5.16 under 16.04

I'm running ubuntu 16.04. LibreOffice 6.13 was installed from PPA and texlive2015 was installed ubuntu repository. I decided to install texlive2018 from a PPA: deb http://ppa.launchpad.net/jonathonf/...
2
votes
1answer
845 views

pgf's and pstricks's opacity is not appearing in .ps and .pdf files

I had recently upgraded my PC to Ubuntu 18.04 with TexLive 2017. The problem that came up is that the opacity of tikz (PGF) and of pstricks pictures is not working (appearing) in .ps and .pdf files ...
0
votes
1answer
226 views

Upgrading TexLive 2015 in ubuntu 14.04

I am trying to compile one tex file in ubuntu 14.04LTS with TexLive2013/Debian. It gives the following error: I can't find file tikzlibraryarrows.meta.code.tex. I tried to update TexLive to latest ...
0
votes
1answer
2k views

How can I install texlive-science? [closed]

For my Latex file I need to use the algorithm2e package, therefore I tried to install texlive-science for my Ubuntu. But in Ubuntu Software Center it says that Dependency is not satisfiable: texlive-...
1
vote
0answers
813 views

Failed to install texlive-full on Ubuntu 18.10 + WSL

I want to install texlive-full using Ubuntu 18.04 on top of Windows 10 RS3 using the WSL. This is a clean system without any additional repository. The installation failed as follows: $ sudo apt ...
1
vote
1answer
261 views

How to remove texlive from Path

I want to remove texlive from my PATH after deleting it with rm -rf command and I have deleted the path for texlive in .bashrc but when i run the command: echo $PATH I'm still seeing texlive in my ...
0
votes
1answer
2k views

Cannot install texlive-full or texlive-xetex under 18.04

I purged all traces of previous versions of texlive after doing the upgrade to 18.04, but I cannot now install texlive, texlive-full, or texlive-xetex. For example, sudo apt install texlive gives me ...
1
vote
0answers
1k views

18.04 unable to install texlive-full (broken packages)

I am trying to install texlive-full but I'm running into the same issue from this post. However, I do not have a texlive related package from JonathanF's PPA, and need a different solution. Here's my ...
3
votes
1answer
5k views

How to use Tex Live Manager 2018 as administrator?

I recently installed Texlive 2018 on Ubuntu 18.04 following these instructions. and opted for basic installation. Now I am trying to install some packages using tlmgr but it is showing that I have ...
5
votes
1answer
3k views

Problem with installing texlive 2017 on Ubuntu 16.04 LTS

I tried to update from texlive 2015 to 2017. I ran the following commands: sudo add-apt-repository ppa:jonathonf/texlive-2017 sudo apt-get update sudo apt-get install texlive-full After running ...
2
votes
1answer
267 views

pdflatex not working with ACM class files on 17.10

Since upgrading to 17.10, I get the following error building a LaTeX document with pdflatex: pdflatex (file lbtn_c7kyj5.enc): cannot open encoding file for reading From this Solus discussion, I ...
2
votes
1answer
1k views

Fonts installed but 'multicols.sty' not found

I have both texlive-fonts-extra and texlive-fonts-recommended installed however I get 'multicols.sty' not found when compiling a tex file. How do I fix this? Update: the package is multicol without ...
0
votes
2answers
627 views

TeXmaker: Can't change the interface language option

I am trying to switch my Texmaker interface to French. French support is installed on my laptop and French is set as the main language in my environment. However, in Texmaker, I only have English as ...
4
votes
1answer
778 views

Installing TexLive 2016 on Ubuntu 16.04 LTS [duplicate]

What is the reason that by using sudo apt install texlive-full I only get TexLive version.2015, even though the newer versions such as 2016 and 2017 are out? I am actually trying to install Texlive ...
1
vote
1answer
8k views

Removing Texlive From Ubuntu 16.04 LTS (Installed using terminal, apt-get)

I am using TexLive 2015 and I would like to move on to 2016 or even better 2017. I read on internet that uninstalling and doing a fresh install is a better idea than upgrading TexLive, is it true? ...
1
vote
2answers
1k views

Installing TeXLive from ISO

I have downloaded texlive2017-20170524.iso from http://muug.ca/mirror/ctan/systems/texlive/Images/. and tried to mount it with both "Open with archive mounter" (by right-clicking on it) and also "...
0
votes
0answers
161 views

Xubuntu unmet dependencies when try to install texlive-latex-base

Sure that it is a duplicate question of this list: How do I resolve unmet dependencies after adding a PPA? How to run 'apt-get install' to install all dependencies? apt-get does not install ...
1
vote
0answers
664 views

16.04 LTS - Problem with the installation of texlive-full

I tried to install texlive-full in Ubuntu 16.04 LTS by sudo apt-get install texlive-full . I got the following message E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet (...
0
votes
1answer
3k views

Add PPA in Ubuntu 16.04

I'm very new in Ubuntu. I'm trying to upgrade my texlive in ubuntu 16.04 from 2015 to 2017 following this instruction. I have added these 2 file to my source list : deb http://ppa.launchpad.net/...
0
votes
1answer
2k views

Completely removing texlive

I upgraded to texlive 2017 but had some issues with it and therefore wanted to go back to the 2015 version. I removed it with sudo apt-get purge --auto-remove texlive* but it did not seem to remove ...
1
vote
1answer
386 views

Broke my apt-get with texlive installation

I was trying to update my TeXLive installation to 2017 version and followed the guide given here. sudo add-apt-repository ppa:jonathonf/texlive-2017 sudo apt update sudo apt install texlive-full It ...
0
votes
1answer
68 views

How install Tex-live on Ubuntu Kylin not showing on Software?

How do I install Tex-live on Ubuntu Kylin if it isn't showing up on Ubuntu Software?
0
votes
0answers
828 views

texlive and /usr/local vs /usr/share

I installed a full texlive today. As usual, this produced two directories: /usr/local/texlive/2017/texmf-dist/tex/latex, and /usr/share/texlive/texmf-dist/tex/latex Why there's so much duplication I ...
0
votes
1answer
260 views

texlive-plain-generic broke my Ubuntu 16.04 upgrade process

When I update and upgrade my Ubuntu 16.04.3 recently, I got the following error messages: qxd@NapaValley:~/SoftwareRepo/simnanophotonics$ sudo apt upgrade Reading package lists... Done Building ...
1
vote
0answers
518 views

Unmet dependencies texlive

I am trying to start from scratch because I messed up my installation of texlive. When I try sudo apt-get purge texlive-full I get the following: Reading package lists... Done Building ...
3
votes
2answers
4k views

Broken dependencies with texlive

I had a working version of texlive on 16.04 but after updating from 16.04 to 16.10 and then to 17.04 (and maybe other things?) it's now broken. I've purged all of my texlive packages with apt-get : ...