Questions tagged [tensorflow]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
1answer
68 views

Cannot install CUDA 10 for Tensorfow on Ubuntu 18.04 because of Failed CC sanity check

I'm following the guidelines for installing tensorflow 2 and CUDA 10 on Ubuntu 18.04 add NVIDIA package repositories without errors, but I cannot install NVIDIA drivers. When I run: sudo apt-get ...
2
votes
0answers
31 views

Python importing tensorflow returns “Invalid MIT-MAGIC-COOKIE-1 key”

I am a linux newcomer trying to set up tensorflow with GPU for Python on Pop!_os 20.04. I tried using the proposed Pop!_os apt packages for this but they didn't work for me. After a lot of struggle on ...
-1
votes
0answers
17 views

How to install tensorflow version 1.3.0?

How do I install tensorflow version 1.3.0? The 2 lines below don't work. conda install tensorflow=1.3.0 pip install tensorflow=1.3.0
2
votes
0answers
88 views

Ubuntu 18.04 and RTX 2080 SUPER systematically freezing

I’m trying to solve an insistent problem: my Ubuntu 18.04.4 LTS is randomly freezing when (apparently) using my graphics card (RTX 2080 SUPER). Kernel logs don’t show anything useful (syslog, kern, ...
0
votes
0answers
87 views

I can't install certain Python libraries because of “ImportError: cannot import name 'sysconfig' from 'distutils'”

I'm trying to upgrade from Python 3.5 to 3.8.3, and TensorFlow 1.13 to 2.2, so I can be up to date. However, having two versions of Python3 on my computer has caused a whole headache of problems. (I ...
0
votes
1answer
117 views

Unable to use GPU Ubuntu 20.04 CUDA 10.2

>>> import tensorflow as tf >>> tf.debugging.set_log_device_placement(True) >>> >>> # Create some tensors >>> a = tf.constant([[1.0, 2.0, 3.0], [4.0, 5.0, ...
0
votes
0answers
32 views

Ubuntu 18.04.4 LTS crashes while browsing and while training with Tensorflow

I'm getting strange behavior in Ubuntu 18.04.4 LTS since the very begining I freshly installed it along with Windows in a dual boot config. While I'm using it, even if I'm browsing, coding or training ...
1
vote
1answer
63 views

Which Ubuntu version is good for AI?

I have Ubuntu 20.04 installed and because of my CPU not supporting AVX, I'm having a lot trouble with latest versions of the software. The old version are difficult to find and not running as they ...
0
votes
0answers
25 views

Tensorflow for gpu support

I am currently new to using GPUs and am setting up the GeForce GTX 980 on NVIDIA 440. Used https://mc.ai/how-to-set-up-tensorflow-gpu-on-ubuntu-18-04-lts/ to use tensorflow for GPU support. My ...
0
votes
0answers
11 views

Blank screen on Ubuntu 18.04 before logging in

I am currently new to Ubuntu and recently received a GPU to run tensorflow functions faster. After following a few tutorials on how to run tensorflow on my the gpu and shutting down, a blank screen ...
0
votes
0answers
42 views

Problems with tensorflow running in ubuntu

2020-04-27 11:07:07.085928: W tensorflow/stream_executor/platform/default/dso_loader.cc:55] Could not load dynamic library 'libnvinfer.so.6'; dlerror: libnvinfer.so.6: cannot open shared object file: ...
0
votes
1answer
589 views

Missing Libraries When Trying to Use GPU with Tensorflow

I am trying to use GPU with Tensorflow, so I installed CUDA 10.1, CUNN 7.6, TensorRT 6, and Tensorflow-GPU 2.1.0. But when I import tensorflow to check if it can detect the gpu. it gives me the ...
5
votes
2answers
2k views

Tensorflow-GPU on WSL2 not working

Is there any way to install tensorflow-gpu on WSL2? After trying to set up CUDA on WSL and running nvidia-smi, it had the error: NVIDIA-SMI has failed because it couldn't communicate with the ...
0
votes
0answers
44 views

ROCm docker run fails

I am trying to run ROCm's tensorflow port for AMD gpu's. Got the docker container as described here. But I get error when I try to run it $ drun rocm/tensorflow:latest docker: Error response from ...
0
votes
0answers
74 views

tensorflow installation gets stuck windows bash pip3

I cannot install tensorflow in the windows 10 ubuntu bash 18.04. I do pip3 install tensorflow. It starts the installation...But at some point it stops at this line Running setup.py bdist_wheel for ...
0
votes
0answers
78 views

How to install Tensorflow GPU on an Ubuntu 18.04 laptop with an RTX2070?

I need to install Keras and tensorflow-gpu on my Ubuntu 18.04 laptop with an RTX 2070 however nothing ever seems to work. I have tried countless tutorials for various versions of CUDA, Tensorflow, and ...
0
votes
1answer
79 views

I have to add add PATH to /etc/environment but it breaks my machine - why?

I'm trying to work with tensorflow on Ubuntu 18.04 using Deep Learning AMI from Amazon which has all CUDA verions installed. However, it's not so easy to make tensorflow 1.X work with GPU because some ...
0
votes
0answers
26 views

Ubuntu terminal taking a very long time, because of import 'keras'

I have a Ubuntu 18.04 and Windows dual boot on my SSD. And HDD is common to both, for storage. Now the problem is that the terminal takes a very very long time to open when run from hdd, but opens up ...
0
votes
0answers
125 views

What is Illegal instruction?

I have installed Tensorflow version 2.1.0 and imported it! But when i trying to import it into a Python file i get Illegal Instruction Core Dumped Can it be that hardware instruction that ...
1
vote
0answers
54 views

Error occurred when I used tensor flow lite custom model

I faced an issue while running an object detection program using tensor flow lite costum model.I am attaching the error code bellow. classes = interpreter.get_tensor(output_details[1]['index'])[0] # ...
0
votes
1answer
316 views

TensorBoard refuses to open — VersionConflict grpcio>=1.24.3

I have recently been having troubles with TensorBoard, as whenever I attempt to run the TensorBoard server, I get the error: pkg_resources.VersionConflict: (grpcio 1.21.1 (/home/me/.local/lib/...
0
votes
0answers
30 views

How to get list of .so that python script use?

For example I run python3 my_script.py, my_script.py uses tensorflow package inside, that use cuda libs, how can I get list of .so libs that are loaded at script execution? UPDATE: strace -e trace=...
0
votes
0answers
1k views

Resolved, Installation of CUDNN on ubuntu 18.04.3, need help

Edit: I just installed from the tar file, but still from the deb file it does not work. I hope I am on the good forum. I'm trying to install Keras on my computer, but for this, I need to install ...
1
vote
0answers
145 views

RTX 2080 eGPU and Cuda Tensorflow on MacBook Pro

I cant install Ubuntu on my MacBook Pro 2018, QEMU KVM, VMware and Parallels doesn't support Thunderbolt3. There are no Nvidia drivers for RTX on the Mac and TensorFlow doesn't support GPUs on macOS ...
0
votes
0answers
110 views

“import tensorflow as tf ” crashes after pip3 install tensorflow-gpu

I installed a new Nvidia GeForce RTX 2080 Ti card and associated SW - Cuda Version - 9.1 $ nvcc --version nvcc: NVIDIA (R) Cuda compiler driver Copyright (c) 2005-2017 NVIDIA Corporation Built on ...
0
votes
0answers
618 views

How can Conda install CUDA for use with TensorFlow 2?

I am trying to install TensorFlow to run with my GPU in Ubuntu 16.04 LTS. I have a functioning system installation of CUDA 9 with TensorFlow 1.12 and Nvidia driver 430 and I'm trying to install more ...
1
vote
0answers
205 views

Installing nvidia driver is overwriting cuda toolkit version on Ubuntu 18.04

Installing nvidia drivers and cuda toolkit versions that are compatible with tensorflow is proving to be as enjoyable as ingrown toenail surgery. I specifically need cuda toolkit 10.0 because ...
0
votes
0answers
129 views

Setting up Tensorflow 2.0 GPU version on Ubuntu 18.04

This may not be a suitable question but I am trying to find a legitimate way of setting up my environment for deep learning development. I keep going through tutorials such as this. But I keep getting ...
1
vote
1answer
216 views

Tensorflow 2.0 Cuda 10.0 install

I am following the steps here. I am currently at this step: $ cd ~ $ mkdir installers $ cd installers/ $ wget https://developer.nvidia.com/compute/cuda/10.0/Prod/local_installers/cuda_10.0.130_410....
2
votes
0answers
63 views

Cant boot into my system after trying to install Cuda 10.0

I have a computer with a decent GPU, and I tried to get Tensorflow GPU working. I will start by saying that I am a long time Arch Linux user, and I am very new to Ubuntu, but I wanted to give it a ...
1
vote
0answers
75 views

Nvidia GPU is not running

I am using ubuntu 16.04 and my Nvidia GPU version is "GP104 [GeForce GTX 1080]". I installed CUDA and its version is "CUDA Version 9.0.176". And by running the command "cat /usr/include/cudnn.h | ...
0
votes
0answers
94 views

Why Installing cuDNN From Package Manager Doesn't Required Nvidia Developer Account

I am trying to install cuDNN library for tensorflow. On the cuDNN installation guide from Nvidia (https://docs.nvidia.com/deeplearning/sdk/cudnn-install/index.html) it looked like I need to register ...
0
votes
1answer
590 views

Failed to get convolution algorithm error in tensorflow

I installed Cuda, cudann, and TensorFlow by strictly following instructions on tensorflow.org. I had my ubuntu switched to the Nvidia card during the installation. After verifying the installation I ...
1
vote
1answer
800 views

Installing CUDA Toolkit for Ubuntu 18.04

I need CUDA to develop a chatbot as described in this tutorial. I'm trying to install CUDA using these commands. Installer Type: Runfile(local). The first commands runs successfully but when I run ...
0
votes
1answer
175 views

Ubuntu 18.04.3: Need help with ROCm tensorflow: Build error

I have a fresh installation of Ubuntu 18.04.3 and I am trying to install tensorflow-rocm (for AMD GPU) version 1.14.0. default pip3 install tensorflow-rocm is installing v2.0 but the code set that I ...
1
vote
4answers
8k views

Installing Cuda 10 and TensorFlow 2.0 Ubuntu 19.10

I've been trying to install Cuda 10.0 and tensrflow 2.0 in Ubuntu 19.10 (the same goes for the previous versions of Ubuntu), but there is no use. It says that the package 418 (althouh I ask explicitly ...
0
votes
0answers
839 views

Cannot install tensorflow using command pip install tensorflow

I am getting following errors: ERROR: Could not install packages due to an EnvironmentError: [Errno 13] Permission denied: '/usr/local/lib/python2.7/dist-packages/tensorflow-2.0.0.dist-info' Consider ...
0
votes
1answer
54 views

Installing TensorFlow on ubuntu16.04 and lots of warnnings

Environment : Ubuntu 16.04 / tensorflow 1.14.0/ python 3.5.3 I installed TensorFlow using this command. sudo pip install --upgrade https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow-0.7....
1
vote
1answer
862 views

Getting errors while trying to install tensorflow using pip

I was following these instructions for installing tensorflow. I tried pip install --upgrade tensorflow but am getting this error: ERROR: Exception: Traceback (most recent call last): ...
0
votes
0answers
891 views

Unable to uninstall, install, and see TensorFlow version

I'm trying to install TensorFlow 2.0. I have an older version of TF on my computer. I have tried the answers given here, but they did not work for my case. The current version can be imported in ...
0
votes
0answers
707 views

How to solve the “Building kernel modules”? during nvidia driver install

My computer has an RTX2080 ti external graphics and is based on Ubuntu 18.04. I am trying to: Install CUDA 10.0, and the corresponding graphics driver 410.57 to use tensorflow gpu. I did chmod + ...
2
votes
0answers
237 views

Unable to get driver to recognize NVIDIA GPU when I followed instructions for tensorflow install for 18.04

I am following the instructions here https://www.tensorflow.org/install/gpu My output for nvidia-smi was "No devices were found." However when I run lspci -vv | grep NVI I get 0a:00.0 VGA ...
0
votes
0answers
2k views

cuda-10.1 refuses to go

After intalling cuda-10.1, I realized that it doesn't work with tensorflow 1.13.1, so I had to downgrade to cuda-10.0. I tried for a very long time, and at the end seem to have purged 10.1 (sudo apt ...
0
votes
0answers
650 views

/usr/bin/ld: cannot find -ltensorflow_framework in google colab

I tried to compile a c++ code using g++ compiler and it is showing up this error usr/bin/ld: cannot find -ltensorflow_framework in Google Colab when I gave !ld -ltensorflow_framework --verbose ...
2
votes
0answers
394 views

Unable to use NVIDIA GPU on Ubuntu 18.04 for computer vision task (GeForce GTX 1060)

My machine is a ASUS ROG SCAR-GL703GM-EE033T with a NVIDIA GeForce GTX1060. I installed Ubuntu 18.04 on it and the necessary softwares needed to run deep learning applications using its GPU. I ...
0
votes
1answer
65 views

Tensorflow won't import with sudo python3

I'm working with a remote Ubuntu 18.04 instance where to write files with python I must run sudo python. One of my python scripts imports tensorflow which when running with sudo prefix I get the ...
5
votes
1answer
7k views

How to install cuda 10.0 with nvidia-418 driver on Ubuntu 19.04?

I just upgraded my system to Ubuntu 19.04 and realized Cuda 10.0 is not getting installed. tensorflow is still not built for Cuda 10.1 and it would be great if I can downgrade my Nvidia driver from ...
2
votes
0answers
394 views

Fix broken tensorflow-gpu installation

I have a broken installation of tensorflow and cannot find a way to correct it to start clean from the beginning. I am using the instructions in the tensorflow website for Ubuntu 18.04 (CUDA 10). ...
2
votes
1answer
1k views

Broken packages when installing NVIDIA drivers on Ubuntu MATE 18.04 [duplicate]

I have a clean install of Ubuntu MATE 18.04 that I wish to install TensorFlow on with GPU support. My GPU is a Titan X. I am following the instructions from the GPU support guide but I am unable to ...
1
vote
2answers
994 views

tensorflow import error 1037

Let me say this right in the very beginning, I am new to this and I have no idea what is to be done. I am using Ubuntu 19.04. And I am positive I have all the prerequisites for tensorflow installed. ...