Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [source-packages]

The tag has no usage guidance.

0
votes
0answers
38 views

Can't install torch in ANACONDA

conda install -c peterjc123 pytorch=0.1.12 while running these command i got an error saying PackagesNotFoundError: The following packages are not available from current channels: pytorch=0.1.12 ...
1
vote
1answer
39 views

Picking linux-4.18.11-surface-linux-surface as source package instead of linux-image-4.18.11-surface-linux-surface

When I run this command: sudo apt source linux-image-$(uname -r) I get this error: Picking linux-4.18.11-surface-linux-surface as source package instead of linux-image-4.18.11-surface-linux-surface E:...
0
votes
1answer
58 views

Installing sfdisk 3.0

I'm trying to install sfdisk 3.0 running a live Ubuntu 18.04.1 LTS. I have run all of this: sudo add-apt-repository universe sudo add-apt-repository restricted sudo add-apt-repository multiverse ...
0
votes
2answers
78 views

Where, and how, do I install multiple packages stored in a local directory? [duplicate]

I've found several posts about mass installing Linux packages with one command here, here, and here. Here's my situation. I'm in a 3rd-world country right now with limited internet access. I want to ...
2
votes
1answer
31 views

How should I upload a package after having used git-ubuntu to prepare it?

I prepared an upload by cloning a git-ubuntu repository and committing some changes locally. As an Ubuntu developer, I have permission to upload to the archive. What do I need to do to upload my ...
1
vote
1answer
88 views

R installation issue

I wanted to install r-base on my computer but it does not work even after sudo apt-get update or sudo apt-get upgrade. Here is the text I have when I write sudo apt-get install r-base : Lecture des ...
1
vote
0answers
2k views

Trying to install Webmin on Ubuntu 18.04 - missing apt-show-versions [duplicate]

I've tried following the following commands to install Webmin on my home server: sudo apt install python apt-show-versions libapt-pkg-perl libauthen-pam-perl libio-pty-perl libnet-ssleay-perl But it ...
0
votes
2answers
36 views

How Debian developers update their packages list? [closed]

As a beginner Linux user, I was wondering how Debian developers update their entire packages list, because it has tons of packages. Do they get a pre-compiled package from the original developer and ...
0
votes
1answer
834 views

E: Unable to locate package screen

I am aware that if one googles the error above, then he would get tons of results. However, after trying many of the proposed solutions, and after working on this error for about a week in full-time, ...
0
votes
0answers
82 views

Why is the apt sources different between a minimal and desktop install?

I was banging my head not being able to install mariadb and python3-pip in a minimal install of Ubuntu 18.04. Every web search showed pages with the expected apt install package commands. When I ...
0
votes
0answers
18 views

I need to download all support packages for make and dkms on a usb so i can transfer them to ubuntu 18.04 i dont have a ether connection only wifi [duplicate]

Im having to download dependency one at a time and looking for a way to download everything at one time instead of one depend package at a time
0
votes
0answers
250 views

Ubuntu 18.04 install essential header without internet acess

I have wireless adapter.Whenever I reinstall the OS, the wireless adapter require to have essential header for it to install. So how would you download the essential header and install it offline? -- ...
1
vote
1answer
641 views

How to install libxcb-randr 1.12 on Ubuntu 16.04?

Ubuntu 16.04 (16.04.4) ppa contains only 1.11. But for Rust program compilation i need 1.12 version. How to deal with it ? P.s. 17.04 contains xcb v.1.12
1
vote
1answer
81 views

error: checksum failure file: sources/expat-2.1.0.tar.gz

I am try to download RTEMS source builder and build a tool chain following the instruction in this page. The problem that I have seems to be a package download automatically through sourceforge.net: ...
1
vote
0answers
68 views

apt-get with fix broken flag not working for me

You have broken packages installed, fix them before upgrading. I tried to fix the issue with "sudo apt-get -f install" but above error blooms]
1
vote
0answers
321 views

How to compile or install Debian version of Vim on Ubuntu 16.04

I really like the version/set-up of vim that is included with Debian 9 server. This is not the same question as Ubuntu 16.10 repository providing vim 8. I am not asking about how to get Vim 8 on ...
1
vote
0answers
111 views

i2p : Depends: libjbigi-jni but it is not installable

I am trying to install i2p on my ARM-based board with Ubuntu-server 16.04(3.4.113-sun8i #16 SMP PREEMPT Tue Jun 13 14:15:57 CEST 2017 armv7l armv7l armv7l GNU/Linux). But it says: Building dependency ...
1
vote
1answer
56 views

What is “Automatic Source” in depcache.cc in the source code package of apt?

when browsing source code for apt package manager, I wanted to find out the inner logic of pkgDepCache::Policy::GetCandidateVer function. pkgCache::VerIterator pkgDepCache::Policy::GetCandidateVer(...
4
votes
1answer
67 views

What can I do when Launchpad shows a wrong upstream connection?

I noticed that the file source package in Ubuntu on Launchpad is connected to the wrong upstream project. This obviously can't be fixed from Ask Ubuntu, but I am hoping someone can tell me what I can ...
0
votes
0answers
211 views

Installing previous version of tar package

My current version of tar is p@p-ubuntu:~/ba/tar-1.25$ sudo apt-cache showpkg tar Package: tar Versions: 1.27.1-1ubuntu0.1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_trusty-...
1
vote
0answers
333 views

Install id3_tag in PHP Ubuntu

How can I Install and configure id3_tag package installed from PECL? I already have the package but I don't know how to configure it and where to put it in the file system.
0
votes
0answers
140 views

Unable to install any packages on Ubuntu xenial 16.04

I am trying to install apache2 on Ubuntu xenial 16.04 VM. I have added the proxies in /etc/apt/apt.conf and /etc/environment. The install fails ...
0
votes
1answer
68 views

problem are coming

$ apt-get -f install vlc Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following ...
4
votes
1answer
569 views

Ubuntu packages release and update dates

I am creating a list of packages installed in my Ubuntu 16.04 system and I need release dates for each package(if updated I need release date of the update, too) However I couldn't find that ...
2
votes
1answer
98 views

What does a component or archive “now” mean in the apt Python API?

I have a python script running on Ubuntu. Script gets all installed apt packages with apt_cache = apt.cache.Cache() I want to get repository names of each installed package. While I expect to see ...
0
votes
1answer
743 views

Where can I find old versions of openssh-server (particularly 7.2, before patch)?

I'm trying to demonstrate openssh-server (7.2) DDOS exploit attack. When I did apt-get update or when checked at ubuntu packages both show only the patched versions. I'm not sure where to find the ...
0
votes
1answer
2k views

Root cern root-system on Ubuntu 16.10

The package root-system is available to install by using "apt" for Ubuntu 16.04 http://packages.ubuntu.com/search?keywords=root-system&searchon=names&suite=xenial&section=all ...
4
votes
4answers
6k views

How to download and install ffmpeg from Launchpad?

I'm trying to understand how to install the ffmpeg package from Launchpad. The ffmpeg website links to that page when you try to download it for Linux.
0
votes
1answer
112 views

Error while rebuilding tcl 8.5 to disabling threadings

Im on installation of Squert Dashboard for suricata on Ubuntu Xenial 16.04 LTS Before install Squert I need to install Sguil (sgweel), sguil need tcl 8.3 (or better) and I found in source the current ...
2
votes
1answer
241 views

Why package installed by compiling its source code does not appear in dpkg -l output? [duplicate]

I'm seeing a potentially problematic issues here when I use the command line: dpkg -l | grep macchanger It would list macchanger and the version with no problems. I recently uninstalled this buggy ...
0
votes
2answers
198 views

How to do an offline installation of packages in ubuntu 12.04 by exporting this folder /var/cache/apt/*

Suppose I'm on a machine with full internet access and do "apt-get update" it then updates the cache /var/cache/apt/* with binary files. Now I do a "apt-get install pkgname" and inside /var/cache/apt/...
1
vote
0answers
254 views

Unable to install twinkle Ubuntu 14.04.2 LTS

I have been using twinkle packages in 12.04,10.04 & 10.10.Now I am updating to Ubuntu 14.04.2 LTS. If I try to install twinkle package it is installed, but I am unable to open it. It throws this ...
3
votes
1answer
153 views

What is a package stanza?

Briefly speaking, how to define a package stanza? It arrives by running dpkg-gencontrol in a package directory: # dpkg-gencontrol dpkg-gencontrol: error: no package ...
0
votes
1answer
477 views

what should be done with these lines in the following arch.make file?

I want to install siesta (a computational code) to run parallel in Ubuntu 12.04. There is an arch.make file which a part of it's content is as follows: .SUFFIXES: .SUFFIXES: .f .F .o .a .f90 ....
0
votes
2answers
3k views

Unable to download packages [duplicate]

Needing to download 'traceroute' for some work that I have to do, I tried to download the package using 'sudo apt-get install'. After looking online, I saw that I might have to update the software but ...
0
votes
1answer
2k views

Ubuntu 16.04lts repository messed up

I messed up my repository and I can't rebuild a new one successfully. This is what happens with the repository I have. (It is the only way I can try to install something.) sudo apt-get install ...
-1
votes
1answer
49 views

i am using ubuntu12.04,unable to install tools and packages showing error [duplicate]

Reading package lists... Done Building dependency tree Reading state information... Done Package ninja is not available, but is referred to by another package. This may mean that the package is ...
2
votes
1answer
704 views

Building nginx deb package with custom openssl

I'm trying to build nginx packages from a deb package source (from the popular, semi-official nginx mainline PPA) but linked to an openssl fork that contains ChaCha20 and Poly1305 additions. I ...
1
vote
1answer
699 views

Programs not Upgraded?

This question has been asked before, I know, but I think my situation is a little... odd. I've been trying to install build-essential so I can do some development, but I keep getting a huge long ...
0
votes
1answer
784 views

Unable to locate package libfam0-dev

I am trying to install Maya 2015 on my laptop, Ubuntu 14.04, 64 bit, and I can't continue with sudo apt-get install -y alien csh tcsh libaudiofile-dev libglw1-mesa elfutils gamin libglw1-mesa-dev mesa-...
-1
votes
1answer
888 views
1
vote
0answers
115 views

disk is full due to mirror packages saved in /var/lib/apt/lists/partial/ [closed]

I am new to google computer engine and created one VM instance. It worked ok for a while and suddenly, I keep getting out of disk space issue due to huge package files saved in /var/lib/apt/lists/...
1
vote
1answer
1k views

Installing python3-netcdf4 on Ubuntu 14.04

When I type sudo apt-get install python3-netcdf4 on Ubuntu 14.04, I get a message Unable to locate package python3-netcdf4. How do I install python3-netcdf4 on Ubuntu 14.04 ?
0
votes
2answers
78 views

Install package

I got message like: E: The package libgtksourceview2.0-0 needs to be reinstalled, but I can't find an archive for it. How can I fix it?
18
votes
4answers
13k views

What package to install to play midi files in Ubuntu 16.04?

The (ex-totem?) Video player proposes the installation of gstreamer1.0-plugins-bad, but after installation there is no playback, nothing. When I try to open the .midi file again, the Video player ...
-1
votes
1answer
298 views

Getting precompiled software

How to get a precompiled package of any software, so I can install it directly? Because I am a beginner linux user and I am facing problems in compiling any software.
0
votes
1answer
1k views

Upgrading an Ubuntu localrepo from trusty to xenial

Please forgive my ignorance as I am new to Ubuntu. I have created a local repository of Trusty using apt-mirror. My question is how to upgrade this repo to Xenial? Also in the mirror.list file how to ...
1
vote
0answers
44 views

.desktop arduino file killed system

any idea on what happened? i went here https://www.arduino.cc/en/Main/Software downloaded the 64 bit for my os (running ubuntu gnome 14.04 LTS). and then I chmod +x the ./install.sh (not sure if ...
3
votes
1answer
3k views

How to install ANT 1.9.6?

I want to install ANT from downloaded zip: apache-ant-1.9.6-bin.zip. How to do it ?
2
votes
0answers
192 views

warnings on update local repository

W: Failed to fetch cdrom://Ubuntu 14.04.3 LTS _Trusty Tahr_ - Beta amd64 (20150805)/dists/trusty/main/binary-amd64/Packages Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update ...