Questions tagged [software-installation]

Installing software on a running system, either as binaries or from source.

Filter by
Sorted by
Tagged with
1325 votes
11 answers
3.8m views

How do I install a .deb file via the command line?

How do I install a .deb file via the command line?
  • 25.1k
645 votes
14 answers
1.3m views

How do I resolve unmet dependencies after adding a PPA?

Occasionally, when I'm installing stuff, I get an error like the following: Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the ...
  • 58.9k
638 votes
14 answers
4.8m views

How do I install a .tar.gz (or .tar.bz2) file?

I have downloaded tar.gz files. But I don't know how to install it. How do I install this kind of file?
  • 7,435
583 votes
8 answers
3.7m views

How to install Google Chrome

How do you install Google Chrome on Ubuntu?
  • 5,847
575 votes
28 answers
916k views

How can I install Sun/Oracle's proprietary Java JDK 6/7/8 or JRE?

I want to install Oracle's JRE and to update to the latest version with the Software Updater when they released. Is there a Ubuntu package that is provided by Canonical or Oracle? Before release Java ...
  • 9,879
480 votes
13 answers
1.5m views

How do I install Sublime Text 2/3?

I installed Sublime Text 2 on 12.04 as per this tutorial. However I don't have adequate permissions when launching the program from the Unity launcher. For example I cannot install packages, or if I ...
442 votes
9 answers
1.1m views

How do I install Python 3.6 using apt-get?

I've tried the normal way, sudo apt-get install python3.6, but... well... that didn't work. So, how would I go about it? (I'd preferably not build it on my own) I'm using Ubuntu 16.04.
  • 4,563
440 votes
2 answers
1.0m views

How to install specific version of some package? [duplicate]

My questions are divided into two parts: How to know the version of installed package? How to install a specific package version?
's user avatar
393 votes
43 answers
1.8m views

Installing Broadcom Wireless Drivers

I'm having serious problems installing the Broadcom drivers for Ubuntu. It worked perfectly on my previous version, but now, it is impossible. What are the steps to install Broadcom wireless drivers ...
387 votes
5 answers
323k views

How can I accept the Microsoft EULA agreement for ttf-mscorefonts-installer?

After a recent update, ttf-mscorefonts-installer prompted me to accept its license agreement. ┌─────────────────┤ Configuring ttf-mscorefonts-installer ├─────────────────┐ │ ...
  • 4,363
303 votes
10 answers
484k views

Is FFmpeg missing from the official repositories in 14.04?

I tried to install ffmpeg in trusty/Ubuntu 14.04 and got the following message: $sudo apt-get install ffmpeg Reading package lists... Done Building dependency tree Reading state information......
  • 3,041
278 votes
12 answers
279k views

How to add "Open terminal here" to Nautilus' context menu?

I am working on Ubuntu 12.04 64bit. I want to add "Open terminal here" to Nautilus context or right-click menu but it tries to download 32bit version from Internet.
  • 2,905
273 votes
7 answers
1.6m views

How do I install .run files?

My PC has both Ubuntu and Windows 7 installed. I have installed all my drivers in Windows like Nvidia graphics, motherboard etc. Shall I install them in Ubuntu too? I looked on the web for my Nvidia ...
's user avatar
270 votes
3 answers
499k views

Error sudo: add-apt-repository: command not found

I’m running Ubuntu 14.04. When I run: sudo add-apt-repository ppa:ubuntu-wine/ppa I get the following error: sudo: add-apt-repository: command not found I tried to run sudo apt-get install ...
  • 2,701
257 votes
6 answers
175k views

When installing user applications, where do "best practices" suggest they be located?

Occasionally I install applications manually, rather than using apt or another package manager. What location (/usr/, /usr/local/, /opt/, /home/, etc.) is suggested by "best practices" for the ...
  • 2,735
223 votes
19 answers
429k views

How to install the latest versions of NodeJS and NPM?

I noticed over at the https://nodejs.org/ website that node is currently at v 0.12.0. Can someone let me know how to install the latest version of node together with npm (terminal commands please)?
  • 2,557
223 votes
6 answers
465k views

Installed Teamviewer using a 64-bit system, but I get a dependency error

I was trying to install Teamviewer, but I was getting a dependency error. I tried to install the required packages, but with no luck. I'm getting this error: Unpacking teamviewer (from ...
  • 2,335
219 votes
12 answers
567k views

How do I install the latest version of cmake from the command line?

I am trying to install latest cmake in my linux box and I am always getting the below exception - userName@phx5qa01c-4e23:~/build$ wget http://www.cmake.org/files/v2.8/cmake-2.8.11.tar.gz --2013-10-...
  • 2,391
208 votes
19 answers
517k views

How to install Eclipse?

I want to install the latest version of Eclipse but the Ubuntu Software Centre contains an older version. Is there a PPA or some other way to install latest Eclipse? Please describe the steps for ...
207 votes
1 answer
613k views

How to install Oracle Java on Ubuntu 14.04? [duplicate]

I am using Ubuntu 14.04.1 LTS, x64 architecture, and I specifically need to install Oracle Java. Now I know there are some instructions on the website which I follow but the same website does not ...
  • 3,418
206 votes
10 answers
453k views

How do I install a different Python version using apt-get?

How can I install a different version of Python using apt-get? Obviously I realise I can install using the source tar ball, however I would prefer not to install from source and instead use the ...
  • 2,163
203 votes
3 answers
525k views

How to install and configure Wine?

I am looking for a step by step instruction to guide me in the ways of installing, configuring and debugging many of the issues new users have when dealing with Wine in Ubuntu. What is the ...
195 votes
7 answers
1.7m views

How to install Chrome browser properly via command line?

I am trying to install chrome browser via command line. I tried this: $ apt-cache search chrome browser The results show that the proper term is "chrome-browser," so I tried that: $ sudo apt-get ...
's user avatar
192 votes
3 answers
329k views

How can I install a package without root access?

I have no root access on this machine. I would like to know if there is a way I can download Ubuntu packages and install them as non-root? Probably in my ~/bin or ~/usr/share or something like that? ...
  • 10k
188 votes
6 answers
800k views

How do I install the latest Python 2.7.X or 3.X on Ubuntu?

I want to install the latest Python tarball on Ubuntu, downloaded from http://python.org/download/. Is this is a correct way to install? ./configure make make install If not, how do I do that?
  • 2,682
187 votes
5 answers
241k views

How can I install and use powerline plugin?

Powerline is a plug-in to display informational and beautiful statusline for vim, tmux and shell prompt for bash, zsh. Vim statusline: How can I install and setup Powerline for different ...
186 votes
15 answers
473k views

How do I install Java?

How do I install Java, including in my browser, so websites with Java work?
181 votes
7 answers
759k views

How to set default Java version?

I followed all the instructions stated at this question, but am encountering some problems with the last part of it. I actually have version 6.22 of java and would like to update to version 6.30. So ...
  • 2,197
180 votes
16 answers
288k views

How do I install the latest version of node.js?

How do I install the latest node.js on Ubuntu? I've been looking around, and I can't find anything. Is there a Ubuntu package for node.js, or do I have to compile it myself?
  • 58.9k
177 votes
5 answers
188k views

dpkg error: "trying to overwrite file, which is also in..."

For example: $ sudo apt-get install curl Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these: The ...
177 votes
12 answers
520k views

How do I install Visual Studio Code?

I just downloaded VSCode-linux-x64 from the Microsoft website. It's a 62 MB zip file. How can I install it on my Ubuntu system?
  • 1,894
175 votes
16 answers
830k views

How to install NVIDIA.run?

I have a Nvidia Ge force Ge6150 SE graphics card. I am running ubuntu 12.04. When I try to install the .run file it fails. It shows the message like this: I tried to install it after uninstalling ...
  • 2,013
168 votes
12 answers
368k views

How do I install and use the latest version of GNOME?

I followed the instructions for compiling GNOME Shell and it did compile with a few errors here and there but it didn't run. I installed GNOME Shell using sudo apt-get install gnome-shell but I got ...
167 votes
5 answers
367k views

How do I use the latest GCC on Ubuntu?

I want to compile my program with the latest version of gcc. Ubuntu 14.04 comes with gcc 4.8.2, however there's 4.9.0 available, moreover, I see that it is available as a package: gcc-4.9. I tried to ...
166 votes
5 answers
539k views

What is the correct way to install proprietary ATI Catalyst Video Drivers (fglrx) directly from AMD?

I am planning on doing a fresh install of Ubuntu and want to know what is the correct way to install ATI Catalyst Video Driver? There are multiple valid answers for this question spanning over ...
  • 9,847
163 votes
2 answers
433k views

How to install Skype 4.3? [duplicate]

Note: The legacy Skype for Linux application (v4.*) is now discontinued and was removed from Canonical’s partner repositories, so this question and its answers are obsolete. Please refer to a newer ...
  • 3,145
163 votes
3 answers
332k views

Where to install programs? [duplicate]

Possible Duplicate: What is the best place to install user apps? I've downloaded a .tar.gz and ran sudo sh install.sh. It's asking me where to install the program to. I don't want it cluttering ...
  • 2,056
162 votes
4 answers
39k views

Can I see why a package is installed?

For a specific package, can I find out why it is installed? So, can I see or it's manually installed, or that it is installed as a dependency of another package? Or that it is installed as part of ...
  • 7,257
161 votes
15 answers
99k views

How can I install pdftk in Ubuntu 18.04 and later?

Is there any chance of getting pdftk working in Ubuntu 18.04? I need this for creating PDF files with a watermark in shell. Or, does anybody know a working alternative to pdftk to generate a PDF ...
  • 1,839
160 votes
9 answers
144k views

How can I install Adobe AIR?

I am a heavy user of certain applications that are built on AIR. It appears that AIR has discontinued support for Linux. Even the older versions in the Adobe AIR Archives seem to support only 32 bit ...
  • 2,565
159 votes
3 answers
390k views

How do I install svn?

I am trying to install svn and am running into issues. The command I am running is sudo apt-get install svn. When I run this, I get the error "Unable to locate package svn". Why is this? How do I ...
  • 1,591
158 votes
6 answers
642k views

Complete Installation Guide for Android SDK / ADT Bundle on Ubuntu

What all needs to be done to install Android SDK / ADT Bundle on Ubuntu? Each of the steps in the answer was found on some different forum as I encountered obstacles getting started with my Android ...
  • 2,827
157 votes
11 answers
163k views

How do I install the latest stable version of Firefox?

I want to install the latest Firefox on my Ubuntu (64bit) box. What is the best way to do this? Is there a specific update site or should I download the binaries manually? If doing manually, in which ...
  • 1,673
150 votes
6 answers
522k views

How to install VirtualBox from command line?

I am a newbie. For some reasons, I need to install Virtualbox. I see that I can easily install it using the Software Center, but I trust most the apt-get install way, because I find it safer, less ...
147 votes
6 answers
330k views

Unable to install "<PACKAGE>": snap "<PACKAGE>" has "install-snap" change in progress

I just finished the installation of the Ubuntu 18.04, but whenever I try to install any application from Ubuntu Software the same error occurs (for example "vlc"): unable to install "vlc": snap "...
145 votes
1 answer
533k views

How to install 'add-apt-repository' using the terminal? [duplicate]

I want to install: add-apt-repository ppa:ricotz/testin It is showing: The program add-apt-repository is currently not installed. You can install it by typing: sudo apt-get install python-software-...
141 votes
2 answers
387k views

How to install .bundle packages in Ubuntu?

I've recently downloaded a package with .bundle extension. it's VMware-Player-6.0.3-1895310.x86_64.bundle. I want to install vmware-player, but when I open that, it opens with text editor.
138 votes
8 answers
225k views

How do I install Skype?

I want to install Skype, but I can't locate it in Software Center or by using Synaptic Package Manager. Can anyone help me?
's user avatar
137 votes
8 answers
248k views

How can I check dependency list for a deb package

How can I check dependency list for a deb package. I am running Ubuntu 11.10 and I have backed up all deb packages from var/cache/apt/archives. I want to format my pc and re-install selected ...
  • 5,020

1
2 3 4 5
175