Questions tagged [software-installation]

Installing software on a running system, either as binaries or from source.

2,052 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
9
votes
1answer
677 views

skypeforlinux crashes the keyboard

I recently installed Ubuntu 18.0.4 and after that skypeforlinux in several ways. I can use Skype to type messages, everything its OK, but when I make a call it crashes the keyboard. After that, I can'...
8
votes
0answers
2k views

How to install Eclipse Neon using its installer for all users?

I have followed the instructions from this answer to similar question, but it looks like the installer in sudo mode installs most of plugins to /root/.p2/pool/plugins, so you can't access it in non-...
8
votes
0answers
819 views

Unable to find OpenCV during linking (compile from source)

I am trying to compile qgifer-0.2.1-source from its source in Ubuntu. I have all the dependencies installed. I am compiling as per below instruction from README of the source. cd qgifer_source_dir ...
6
votes
1answer
5k views

How to update ruby version to 2.5.1?

When I tried opening metasploit by msfconsole It showed an error rbenv: version `2.5.1' is not installed (set by /opt/metasploit-framework/.ruby-version) I tried rbenv install rbx-2.5.1 its ...
6
votes
0answers
556 views

Latest Avogadro build- finding it impossible to install on Ubuntu 14.04

I'm on Ubuntu 14.04, trying to install the latest version of Avogadro (because the version in Software Center is showing issues) and when I get to make, it prints all these errors: [ 98%] Linking CXX ...
6
votes
1answer
3k views

Can't install pepperflashplugin-nonfree in Ubuntu 14.10

After I upgraded my Ubuntu to 14.10 (everything was normal during the upgrade), every time when I try to install pepperflashplugin-nonfree installation hangs at 80% and remains so for hours (and maybe ...
6
votes
1answer
4k views

Ati Radeon HD 3200 Graphics driver - Installation Problem

I have a fresh installation of Ubuntu 12.04 x86 and I am trying to install the proprietary driver for my "Radeon HD 3200 Graphics" video card. I know that there are already many threads about this ...
6
votes
2answers
938 views

Why does apt-get install Skype easily while aptitude complains about MAJOR dependency errors?

I was trying to install Skype on Ubuntu 13.04, from the Canonical repositories. With apt-get it worked easily, while aptitude had a huge problem with dependencies and proposed a complicated solution. ...
5
votes
0answers
2k views

How to install python3.8/3.7 on ubuntu 21.04

I failed again and again installing python3.8 on my ubuntu 21.04 Now it is 'ok' but this error message appears from pip (and import ctypes doesn't work too): Traceback (most recent call last): ...
5
votes
0answers
4k views

How to get GTK4 in Ubuntu 20.04?

GTK4 was released quite recently, and the demo codes don't run in Ubuntu 20.04 because GTK4 is not available on the system. Traceback (most recent call last): File "gtkapp.py", line 3, in &...
5
votes
1answer
933 views

What package to install only the docker client (without engine) in Focal Fossa 20.04?

I've noticed that Ubuntu 20.04 (Focal Fossa) comes with the latest docker engine ready to be installed. On may/2020 if you do: # apt update # apt install -y docker.io you get docker version 19.03.8 ...
5
votes
0answers
2k views

Github desktop not executing, error Segmentation fault (core dumped) in Ubuntu 16.04 TLS

I am new to Ubuntu. In the past I used Windows. I installed the Github-desktop in Ubuntu using following commands: sudo snap install github-desktop --beta --classic Installed successfully and worked ...
5
votes
5answers
3k views

Freeze at keyboard layout screen while installing Ubuntu

I want to learn Linux so I decided to install Ubuntu on my computer that is running Windows 10 now. Unfortunately, the process was not smooth. I downloaded the ISO from Ubuntu official website and I ...
5
votes
0answers
2k views

How do I setup Intel SGX on Ubuntu?

I want to use Intel SGX on Ubuntu. I have a Dell Inspiron with an Intel i7-8550U, and that CPU supports SGX. I am running Ubuntu 18.04 from a bootable flash drive (my main OS is Windows 10, typically ...
5
votes
0answers
4k views

How do I use pip with Python 3.6 on Ubuntu 14.04?

I am trying to install Python 3.6 as per this answer, but I seem to be having troubles. My system is the following (it's on c9.io): $ lsb_release -a No LSB modules are available. Distributor ID: ...
5
votes
0answers
3k views

How to install Moksha Desktop?

I like the moksha destop which Bodhi Linux uses. Is there not a repo or snap to install moksha on Ubuntu? The Debian instructions seem a bit much for what I would naively expect to be a package, or ...
5
votes
0answers
11k views

How to install Microsoft PowerBI with Wine

While installing PBIDesktop_x64.msi using Wine, I am getting installation Failed Msg, i.e.: MS PowerBI Desktop (x64) requires Microsoft .NET Framework 4.5 or later. Please see the Error Msg in the ...
5
votes
0answers
2k views

DraftSight activation fails on Ubuntu 16.04.2

I have Ubuntu 16.04.2 LTS with mate desktop. I installed DraftSight with these instructions: https://www.3ds.com/products-services/draftsight-cad-software/free-download/ I downloaded deb file for ...
5
votes
3answers
13k views

Do additional language packs need to be downloaded?

I'm installing Ubuntu (12.04) right now. I wanted to know if additional language packs have to be downloaded because my Internet is very slow. I chose English as my language.
5
votes
1answer
6k views

How to Install Babylon on Ubuntu?

Can someone please tell me how to install Babylon Dictionary on Ubuntu? Babylon is only available for Windows.
4
votes
0answers
7k views

What is the right way to install pipewire in ubuntu?

As you know full-screen sharing is a missing option in Ubuntu Wayland session. I was going to join an online competition through google meet. Although you can share individual windows but not the ...
4
votes
1answer
325 views

How to have varnish-modules installed on 20.04

The source is at https://github.com/varnish/varnish-modules but I couldn't build it. Ideally I'd want something installable through a ppa. The closest I could get was https://launchpad.net/~lasse-...
4
votes
0answers
138 views

How can I install an older version of maas?

As of now, the PPA consists of latest version of maas. Is it possible to install an older version like maas-rack-controller/bionic 2.5.2? We have installed maas HA in version 2.5.2 and we will add a ...
4
votes
1answer
679 views

Backup Failed error processing remote manifest

I get the following error: Error processing remote manifest (duplicity-inc.20181001T155227Z.to.20181004T170535Z.manifest.gpg): GPG Failed, see log below: ===== Begin GnuPG log ===== gpg: WARNING: "--...
4
votes
1answer
3k views

Virtualenv Permission denied when trying python setup.py install

I want to use virtualenv with Python 3 on Ubuntu 18.04. Specifically, I'm using Python 3.6.6 and virtualenv 16.0.0. I installed virtualenv with sudo as suggested in the answers here: sudo pip3 ...
4
votes
0answers
394 views

How to create *-dev package from source?

I want to install SILE Typesetter which depends on HarfBuzz (libharfbuzz-dev). The libharfbuzz-dev available from repositories is version 1.0.1 (released 2015), while the latest version available from ...
4
votes
0answers
631 views

Rstudio server : [rserver] ERROR system error 2

I am trying to install RStudio server on my Ubuntu server. The installation seems to be fine but when I run the command: sudo rstudio-server verify-installation It does not return anything. Then I ...
4
votes
0answers
6k views

Fail to open Google Chrome Ubuntu

I have been following these instructions to install Chrome on my Ubuntu 16.04.3 LTS machine How to install Google Chrome Everything worked fine as far as I see but when I try to use chrome I ...
4
votes
0answers
519 views

installing python fails with permission denied (using sudo make install)

I tried to install Python 3.6 using this tutorial: https://www.programiz.com/python-programming#run-python-os on ubuntu 14.04. Running $ ./configure and $ make went fine. Running $ sudo make ...
4
votes
0answers
106 views

Newly installed application is not shown in Ubuntu Software Center

I've just installed a Scribus application from Ubuntu Software Center and used it a couple of times. Now I want to delete it but I can't find it in the list of installed packages. I have Ubuntu 16.04. ...
4
votes
0answers
3k views

Installing GuitarPro6 On Ubuntu 15.10 x86_64

What's Wrong GuitarPro6 depends on firstly i386 libraries and then on some libraries that are not available in the repositories for 15.10. 15.10 is automatically enabled with MutliArch, so we don't ...
4
votes
2answers
5k views

How can I use OpenCV 3.0 without overwriting my current version of OpenCV (2.4.8) on Ubuntu?

I'm working with ROS indigo on Ubuntu 14.04 LTS, which automatically installs OpenCV 2.4.8 on my Linux machine. I'm very new to how Ubuntu works, so I really don't want to mess with the OpenCV that's ...
4
votes
0answers
218 views

I get an error when I try to compile DAR on 12.04, how can I fix solve this?

Install DAR 2.4.12 from source because latest version ubuntu package is 2.4.2. ./configure --prefix=/usr dar and libdar have been successfully configured with the following parameters: LIBDAR ...
4
votes
0answers
982 views

Can not start Oracle database 11g XE on Ubuntu 64bit

I can not start Oracle on Ubuntu 13.10 64bit. After trying to configure: sudo / etc / init.d / oracle-xe configure This error appears: Oracle Database 11g Express Edition is not configured. You ...
4
votes
1answer
3k views

Got unknown content type (null) from reviews.ubuntu.com on ubuntu 17.10

I am trying to install some software in Ubuntu 17.10 version. But all the time it shows this error message: Sorry something went wrong . Got unknown content type (null) from reviews.ubuntu.com. How ...
3
votes
0answers
244 views

Create debian package with relative install path

I am creating a debian package with a minimal layout (for a hypothetical package called "skate"). Here's the directory structure: ... ├── LICENSE ├── packaging │   └── debian │   └── ...
3
votes
0answers
436 views

How to install slurm-seff in Ubuntu

I am trying to install Slurm-seff Perl package into Ubuntu 19.10. It has .rpm package to install https://pkgs.org/download/slurm-seff ; but I am unable to install alien to install the .rpm package. ...
3
votes
0answers
249 views

How do I check license of apt packages via command line BEFORE installing?

I want to check a package's license before installing with apt and flatpak. This would be particularly useful in PPAs / custom repositories that allow non-FLOSS licenses, and may have non-FLOSS ...
3
votes
0answers
3k views

make opencv2/opencv.hpp not found

I am trying to build fastfusion from this repo: https://github.com/tum-vision/fastfusion . In the installation step, after running CMake ., I have to run make. But the make command fails with the ...
3
votes
1answer
121 views

How to securely install things not in /opt so they can update themselves

I use firefox from mozilla.org, not from APT which is old. However, if I place it at /opt, it cannot update itself, because /opt is owned by root. If I simply place it at /home, then it can update ...
3
votes
1answer
2k views

All PHP 7.4 are not available in 20.04

I just did a do-release-upgrade that went fine, but I am still stuck at PHP 7.3. $ apt install php7.4 Reading package lists... Done Building dependency tree Reading state information... Done Some ...
3
votes
0answers
18 views

Desktop doesn't respond after reinstall

I had to reinstall Ubuntu because of some graphics errors I couldn't handle(based on my research). I made a Live USB and finished a complete installation. After loading and installing software ...
3
votes
0answers
753 views

Microk8s offline install without using snap?

I am trying to install Microk8s but for various reasons, we cannot use snap (mainly around the way how we start/stop services). To complicate things a bit more we do not often have internet access ...
3
votes
0answers
506 views

Non-interactive MySQL 8 installation on Ubuntu 18.04

I am looking for a MySQL 8 installation using a script without any user action. I see that it's going to UI where I need to give password. I tried: wget -c https://dev.mysql.com/get/mysql-apt-...
3
votes
1answer
805 views

Installing kde-runtime on ubuntu 19.10

I want to compile kdenlive from source, and one of its dependencies is the package kde-runtime. This package does not exist in the repository for ubuntu 19.10, which I am running, but it does for 19....
3
votes
0answers
349 views

How to install gcc 3.2?

I need to use gcc 3.2. No prior answers exactly resolved this problem. It looks like this version is not available in a apt-get repository and I do not exactly know how to install it using the source ...
3
votes
0answers
2k views

winetricks quartz regsvr32 status 5

So I`m trying to install directx 9 for my game, but when i try to install it it gives me this: ~$ sh winetricks directx9 ------------------------------------------------------ You are using a 64-bit ...
3
votes
1answer
4k views

How do I install Tor Onion Browser on Ubuntu 16.04?

I followed the tutorial for Ubuntu 16.04 and got a SIGNATURE VERIFICATION FAILED! error when trying to launch the program. So I re-inputted this in command line: gpg --homedir "$HOME/.local/...
3
votes
0answers
3k views

Unable to install python3-dev and python3's pyyaml package on ubuntu 18.04

Every single time I run the command sudo apt-get install python3-dev I get the following error: Reading package lists... Done Building dependency tree Reading state information... Done Some ...
3
votes
0answers
556 views

All electron based apps have stopped working, Ubuntu 18.04

I'm new to Linux and I've spent the last couple of weeks installing, reinstalling, trying different Desktop Environments, and setting up a personal cloud server. Along the way the applications I've ...

1
2 3 4 5
42