Questions tagged [sdk]

stands for "software development kit"

Filter by
Sorted by
Tagged with
0 votes
1 answer
343 views

.NET 8 SDK for 22.04 LTS?

Does anyone know if .NET/dotnet 8 SDK will be available as an official Ubuntu package for 22.04 LTS? I know it is available for 23.10, but I have found no information regarding 22.04. I know I can ...
Northern Brewer's user avatar
0 votes
1 answer
50 views

How do I install Ubuntu SDK IDE

How can I install Ubuntu SDK IDE?
Томас Щёголев's user avatar
0 votes
0 answers
31 views

I install dotnet sdk-7.0 but dotnet-sdk-7.0 not found on Ubuntu [duplicate]

I use these commands to install dotnet-sdk and dotnet-runtime # Get Ubuntu version declare repo_version=$(if command -v lsb_release &> /dev/null; then lsb_release -r -s; else grep -oP '(?<=^...
Azraf Sami's user avatar
0 votes
3 answers
2k views

dotnet new console not working [Ubuntu 23.04]

I am trying to install .NET SDK to use with VS Code. When I type dotnet new console the following is returned: The command could not be loaded, possibly because: * You intended to execute a .NET ...
chribonn's user avatar
  • 291
0 votes
1 answer
144 views

I need some help and clarify with Python Environment that should communicate with a scripted installer of an SDK

Ubuntu 22.04 (like all other previous versions), comes out with Python already installed by default, in fact if I open the Terminal and type: cris@cris:~$ python3 -V Python 3.10.6 So, Phyton is there ...
Niewbie's user avatar
  • 121
11 votes
2 answers
10k views

Why don't any of these methods work for installing .Net Core SDK & runtime on 22.04 (Jammy Jellyfish)?

I went to the following official Microsoft link to install .NET Core 6.x (SDK & runtime) and they would not work. Basically, it tells you to : wget https://packages.microsoft.com/config/ubuntu/22....
raddevus's user avatar
  • 1,790
0 votes
1 answer
2k views

Vulkan SDK - Unable to locate package

I am using Ubuntu 20.04LTS. The following commands have been attempted: wget -qO - http://packages.lunarg.com/lunarg-signing-key-pub.asc | sudo apt-key add - sudo wget -qO /etc/apt/sources.list.d/...
apetrai's user avatar
  • 13
4 votes
1 answer
243 views

After upgrade, Duplicity with B2 Backblaze error

I just upgraded to 21.04 and started getting an error with using Duplicity with B2. Duplicity is version 0.8.17 b2 is version 2.5.0 b2sdk is 1.9.0 Each seems to work individually. When I try to run a ...
Jack Reid's user avatar
1 vote
1 answer
174 views

Create a Ubuntu PPA with C# (.NET Core)?

Is it possible to create Launchpad PPAs with C# (.NET Core) ? I mean, I have to upload the sources to launchpad somewhere, and then create a makefile like $ echo -e 'BINDIR := /usr/bin all: \tgcc ...
WitchCraft's user avatar
  • 1,834
1 vote
1 answer
3k views

How to set the project sources JDK version in Netbeans?

From the console javac builds with JDK 14 fine. Using sdkman to install JDK 14 as: thufir@dur:~$ thufir@dur:~$ which java /home/thufir/.sdkman/candidates/java/current/bin/java thufir@dur:~$ thufir@...
Thufir's user avatar
  • 4,551
1 vote
0 answers
221 views

How can I fix this VS Code / .NET Core SDK issue?

When starting VSCode (Visual Studio Code) I'm receiving the following error: When I search for my installed version in Terminal: computer@computeruser-wild-cpu:~$ dotnet --version 3.1.100 Do I need ...
Crabtree's user avatar
  • 171
0 votes
0 answers
32 views

Soap requests get sluggish

I'm using VMware's Perl SDK 6.7 on an Ubuntu 18.04. The SDK makes a soap requests to a vcenter server. We used to be on Ubuntu 14 but moved to 18, and with the same SDK code, a Vim::connect() call ...
Dave Allaby's user avatar
11 votes
1 answer
27k views

How do I fix the "Google Cloud SDK component manager is disabled for this installation" error?

I just tried to install the Google Cloud SDK on my Ubuntu 19.04 following these instructions. Specifically I did: # Create environment variable for correct distribution CLOUD_SDK_REPO="cloud-sdk-$(...
Severin's user avatar
  • 1,501
1 vote
0 answers
1k views

System JDK versus SDKMAN

More than once I've had to go into apt to remove JDK > 8 because, at least for the moment, umake installs Netbeans 8 which only runs on JDK 8. I only need JDK 8 for Netbeans, and that temporarily ...
Thufir's user avatar
  • 4,551
0 votes
0 answers
227 views

Configre QEMU(Emulator) for xilinx SDK

I am using Xilinx Vivado and Xilinx SDK for simple program on ZYNQ FPGA/MP Ultra Scale. but i havn't the hardware device(Development board). So i tried to configure the Qemu to run the SDK program. ...
abbasi_ahsan's user avatar
2 votes
1 answer
3k views

curl: (35) gnutls_handshake() failed: Error in the push function

you can help me with installing sdkman. When I enter the console "curl -s "https://get.sdkman.io" | bash", nothing happens ... I tried "curl -sv "https://get.sdkman.io" | bash" Rebuilt URL to: ...
Andrey Popov's user avatar
2 votes
1 answer
12k views

Android SDK location in Ubuntu 18.04.1 [duplicate]

I tried doing several answers for this question, but found out that the answers are not compatible for the latest Android Studio and Ubuntu 18.04.1. My doubt is that Which directory I have to select ...
hanugm's user avatar
  • 333
0 votes
2 answers
7k views

Android SDK is not found by flutter

i have installed android studio by unzipping the zip file from the official site and running sudo ./studio.sh. so, it was installed in /root directory. but when i installed flutter as recommended in ...
joe_inz's user avatar
  • 129
0 votes
1 answer
146 views

AWS SNS using PHP SDK V3

I am currently using php to send a notification email to myself to get comfortable with it for being able to do it for someone I work for. I am trying to set up a form and when the form is submitted ...
Sukhpal Gosal's user avatar
1 vote
4 answers
4k views

Cannot install .NET Core on Ubuntu Bionic Beaver

I'm currently trying to install .NET Core on Ubuntu 18.04 following these instructions. But I always get the following message: me@mine-Ubuntu:~$ sudo apt-get install -y dotnet-sdk-2.1.200 [sudo] ...
MarcoB's user avatar
  • 13
0 votes
1 answer
301 views

Unable to fix unmet dependencies problem (after SDK installation via .sh)

I was installing opencl drivers and SDK from this site using shell scripts. I got unmet dependencies error. I tried the solution given in Unable to fix unmet dependencies, but it did not work for me. ...
Muhammad Zubair's user avatar
1 vote
1 answer
2k views

Google Cloud SDK Instalation

I'm installing Google Cloud SDK to use it ask my source code repository (for now) for Android apps using the install.sh script included in the root of the SDK however, I am having a few issues. First,...
Alex's user avatar
  • 413
1 vote
0 answers
374 views

Unable to get authorization code Google Assistant for Ubuntu Desktop

I am trying to install the Google Assistant with voice command on at least one of my computers. I started with the Raspberry Pi 3 last night. The install was smooth all the way up to getting an ...
OnePuttMike's user avatar
0 votes
0 answers
614 views

How to set path to sdk that is in different drive than home

I was using Windows and now moved to Ubuntu 17. I have formated the drive(NTFS > ext4) and copy the data again. Now the drive which is holding the sdk(which is copied from windows) is this /mnt/...
Asif Mushtaq's user avatar
5 votes
3 answers
18k views

Cannot find "valid home for jdk" in intellij idea

I'm trying to setup an SDK for intellij idea and I can't find the home for jdk as the error put it. In the terminal this is what I get $ java -version openjdk version "9-internal" OpenJDK Runtime ...
Arpit Bharti's user avatar
3 votes
2 answers
18k views

Cannot download and update some android sdk components

I am installing android studio but while downloading SDK component it fails with following error. java.io.IOException: Cannot download 'https://dl.google .com/android/repository/...
Tek Nath Acharya's user avatar
1 vote
1 answer
4k views

Intellij can't find JDK/SDK

Here are my environment variables for Java: $ echo JAVA_HOME JAVA_HOME $ echo $JAVA_HOME /usr/lib/jvm/java-8-openjdk-amd64 $ echo $JRE_HOME /usr/lib/jvm/java-8-openjdk-amd64/jre/bin When I click ...
Все Едно's user avatar
2 votes
0 answers
2k views

esp8266_Lubuntu. /bin/sh: 2: xtensa-lx106-elf-gcc: not found

I'm am a very beginner at this area and I have a problem compiling an example from ESP8266_NONOS_SDK-master. I've been following steps described in ESP8266 SDK Getting Started Guide from the ...
snowerest's user avatar
1 vote
1 answer
2k views

Error installing Android Studio?

I am starting Android Studio (for the first time after unzipping the file that I downloaded from the Android Studio website) by calling ./studio.sh in the android-studio/bin directory. I'm getting ...
phpNoob's user avatar
  • 11
2 votes
1 answer
3k views

decode a video with nvdecode (nvidia video sdk 7.1) and ffmpeg

How can I enable and use nvdecode(nvidia video sdk 7.1) with ffmpeg to decode a video?? thank you
Gofrane Haj Ahmed's user avatar
59 votes
3 answers
116k views

Android SDK - repositories.cfg could not be loaded

To set up a minimal SDK installation without Android Studio, here's what I did: mkdir ~/sdk cd ~/sdk wget https://dl.google.com/android/repository/tools_r25.2.5-linux.zip unzip tools_r25.2.5-linux....
Sons of Liberty's user avatar
0 votes
1 answer
4k views

Why I can't start android emulator?

Why I can't start android emulator? There is error message like this, Starting emulator for AVD 'Sen' Failed to start emulator: Cannot run program "/opt/android-sdk-linux/tools/emulator": error=13, ...
Tje Sen Liem's user avatar
0 votes
1 answer
149 views

sdk location doesn't found

I have installed android studio and I have located android sdk location to another disk part [E:] (Because of lack of free space). Every time if I don't open E: before opening android studio, android ...
Aziz's user avatar
  • 1
7 votes
3 answers
4k views

Is there a way to run Azure Storage Emulator on Ubuntu?

I'm trying to set up my development environment, and I need to use Azure Storage Emulator for my project. Currently I'm running the emu on a VM and my software connects to it. Is there another way to ...
pushrbx's user avatar
  • 175
3 votes
1 answer
2k views

Ubuntu SDK: Having difficulty getting images to work in 'QML only app' when deploying to armhf device

When I deploy my QML only program to the desktop using the Ubuntu SDK, images that I have placed in the same folder as Main.qml can be accessed and displayed correctly in the application using source: ...
pHeLiOn's user avatar
  • 1,758
1 vote
1 answer
31 views

Non-existent property tools in Page

I have a code which used to work but after I upgraded to (K)ubuntu 16.04 and the latest Ubuntu-sdk, it doesn't work anymore. I get error Cannot assign to non-existent property "tools". This is my code ...
JeCh's user avatar
  • 181
0 votes
1 answer
692 views

Could not install platform-tools on Ubuntu 15.10

I am planning to install Android SDK for my Ubuntu 15.10. I downloaded the latest version of SDK, uncompressed and put it in folder /usr/local/android-sdk-linux with folders add-ons, platforms, tools. ...
Anes's user avatar
  • 71
1 vote
1 answer
1k views

Ubuntu SDK Error 'could not find or load the Qt platform plugin "xcb".'

I am trying to write my first ubuntu app using the Ubuntu SDK but keep running into an error. This error turns up both with QML and HTML5 apps. I am trying this just on the template for both project ...
HighlandPirate's user avatar
0 votes
1 answer
71 views

ubuntu sdk ,run default app on ubuntu phone

I'm trying to run a default qml application on my phone. But it's not working :/ developer mode is enabled. the first error includes this link: error1 Where have I to enter this description? ...
Mario di's user avatar
0 votes
1 answer
49 views

Ubuntu sdk with out emulator

Hello I would like to start making apps for ubuntu touch. The main problem is that my emulator freezes when I start it (including My whole computer), so I would like to use my real phone (aquaris E5) ...
Jesper Helén's user avatar
0 votes
1 answer
178 views

Download of the Android Studio stops in Ubuntu 14.04 with in a few seconds.

Tried to download the sdk from torrent and other sources too but the download never crosses even 1%. Am I doing anything wrong?
Tjmonk's user avatar
  • 3
1 vote
1 answer
23k views

How to solve [Errno 30] Read-only file system

I'm new to this forum, and this is my first question: I bought the meizu MX4 ubuntu edition today. I would like to install Ubuntu SDK. I tried to follow this walkthrough: https://developer.ubuntu....
Erik Groningen's user avatar
1 vote
1 answer
238 views

"Desktop file does not exist" error when using qmake based template in Ubuntu SDK

Just as the LaunchPad bug says: https://bugs.launchpad.net/ubuntu/+source/qtcreator-plugin-ubuntu/+bug/1512094 Using the Ubuntu SDK template "QML App with C++ plugin (qmake)" or any other qmake ...
Zoltán Balogh's user avatar
1 vote
0 answers
412 views

How to Send SMS and MMS using Ubuntu API

Is it possible to Send SMS and MMS using Ubuntu API? I've searched in the following documentation, but I cannot find anything about that. https://developer.ubuntu.com/api/apps/qml/sdk-15.04.1/ thx,
Jonathan D'Orleans's user avatar
3 votes
0 answers
136 views

How to perform a Dial Call using Ubuntu API

I'd like to know how to perform a Dial Call using Ubuntu API. I couldn't find anything in the API doc: https://developer.ubuntu.com/api/apps/qml/sdk-15.04.1/ thx,
Jonathan D'Orleans's user avatar
3 votes
0 answers
103 views

Ubuntu SDK Error --

When I go to make a Kit after the SDK wizard loads, I am presented with this error, and if I proceed I see it again while attempting to created a device emulator. Error creating textual ...
Ryan Corvidae's user avatar
4 votes
0 answers
5k views

Missing "asm/types.h" or "asm-generic/types.h" : fatal error : No such file or directory

I am trying to compile my sdk(switching development kit) code on ubuntu 14.04. When I am doing make, I am getting the following error : /lib/modules/3.13.0-32-generic/build/include/uapi/linux/types....
vikash's user avatar
  • 41
1 vote
1 answer
962 views

SDK QML slider on release signal

I am using the slider component from the 15.04 Ubuntu SDK components, see here for the docs. Currently, there is no signal for releasing the slider handle, but there is one for when it is touched (...
JessMcintosh's user avatar
1 vote
0 answers
96 views

ubuntu emulator image and sdk 15.04

I'm developing an application using the sdk 15.04 but i tried all the images available on the emulator and cant find one with that sdk installed and for that reason i can not run my app on the ...
bitgandtter's user avatar
0 votes
1 answer
180 views

Ubuntu SDK unable to start in Ubuntu 15.04

in Ubuntu 15.05 I installed Ubuntu SDK, but I can't start it. I installed in Terminal: sudo apt install qtcreator-plugin-ubuntu And all dependencies. 292 new installed When I try to start in the dash:...
Alex's user avatar
  • 31