Questions tagged [sagemath]

Sage is a python-based mathematics software that is called from the command line and comes by default in a CLI version. There is a notebook version that can be called from the CLI by typing notebook(). It is called sagemath here to distinguish sage from the other uses of the word.

Filter by
Sorted by
Tagged with
0
votes
0answers
70 views

Installing sagemath binaries in Ubuntu 20.10 flatpack chromium and jupyter notebook

As mentioned in other posts the sagemath package is only available in the LTE releases.The binary release 9.2 seems to work mostly. Part of the reason I'm asking my question is to document what I did ...
1
vote
1answer
96 views

Sagemath in Ubuntu 20.04 - installation warnings and unable to launch sagemath notebook

I installed sagemath using the repository on Ubuntu 20.04: sudo apt-get install sagemath Now, while installing sagemath on Ubuntu 20.04 I get the following warnings: Setting up python3-cvxopt (1.2.3+...
2
votes
0answers
50 views

Why is Sagemath removed in Ubuntu 20.10? [duplicate]

This seems to be a regular occurrence, judging from this post and this one as well but why does Sagemath not get packaged for 20.10? Is it always left out of the October releases? I've managed to ...
0
votes
3answers
225 views

make command Error 127

I am installing SageMath from the source code, I get an issue while installing the tar.bZ2 file. I am doing it giving the make -j4 command but I get the error shown below. I also have python3.8.2 by ...
2
votes
1answer
370 views

Sage wont start on Ubuntu 18.04, it can't find the module repl.interpreter

I've just installed sage with the command: sudo apt-get install sagemath But every time I try to start sage, following error show up: $ sage Traceback (most recent call last): File "/usr/share/...
1
vote
0answers
64 views

SageMath memory limit

I have installed SageMath 8.9 on my Ubuntu 16.04 using the files downloaded from the SageMath site. While running my script to analyze some data, SageMath threw the error Condition of type: STORAGE-...
0
votes
2answers
864 views

How to install sage on ubuntu 18.04 LTS from downloaded tar.bz2 file?

i have downloaded sage from official website. i have a tar.bz2 file in my \home\pritesh\download folder in Ubuntu. Now, how to install sage in my system. please give a step by step procedure. i am a ...
0
votes
0answers
29 views

How to combine or automatically compiler different programe such as python3 , R( 3.5.6 ) and sageMath 8.3

I have three file written on different program such as file1.py file2.sage file3.r I will give input then I want to work the following steps automatically file1.py read and after progress it will ...
2
votes
0answers
406 views

Sagemath is installed into 18.04 but something goes wrong

I have installed Sagemath 8.1 with sudo apt-get install sagemath into Ubuntu 18.04. When I try $ sage I get an error message. It seems that Sagemath lunches but something does not allow it from ...
1
vote
1answer
162 views

Failed to launch Sagemath in Ubuntu 18.04

I have installed SageMath in Ubuntu 18.04. However I cannot launch sagemath from the applications (actually it is not even there) neither can I launch from command line. (base) dimitris@dimitris-...
2
votes
0answers
291 views

Problem arises after installing sagemath on Ubuntu 18.04 LTS

I have asked a question to install sagemath on ubuntu here. But After complete installation it says : Package configuration Postfix Configuration ...
6
votes
1answer
2k views

failing to install sagemath on ubuntu 18.04 LTS

Recently, I have install Ubuntu 64amd making duak boot with Windows 7 32bit. Everything is ok ,but I'm unable to install sagemath in it. it says " unable to locate the package sagemath-upstream-binary"...
0
votes
0answers
204 views

Error building Sagemath8.1 on ubuntu 16.04 while installing

I am having Ubuntu 16.04lts running on intel i3 5th generation. I tried installing sagemath from source but keep receiving error msg: Error building Sage. The following package(s) may have failed ...
2
votes
1answer
730 views

Sagemath in Ubuntu 17.10?

I wanted to know if there is any way to install Sagemath in Ubuntu 17.10. I haven't found the install package, but I just wanted to check if it was just me. Thanks in advance!
1
vote
1answer
275 views

Issue with loading Sage on Cantor

Programs in use: Sage 8.1 Cantor 0.5 using KDE Dev Platform 4.13.3 Cantor-backend-sage 4.13.30ubuntu0.1 I had no problems with Sage attaching to Cantor. The problem is Cantor can't seem to load ...
0
votes
1answer
2k views

Using “make” command not working

I'm working on installing sage, and I now just need to run the "make" command in the command line, but when I do I get the following: /usr/bin/env: 'python': No such file or directory Makefile:16: ...
0
votes
1answer
2k views

failing to install sagemath on ubuntu 16.04 LTS

i could successfully install ubuntu 16.04 LTS but i'm unable to install sagemath in it. it says " unable to locate the package sagemath-upstream-binary" even when the code is correct. may i know why?
0
votes
1answer
48 views

Encountering problems with Installing Sage [duplicate]

I am trying to install sage but hit problems when I enter "apt-get update" and consequently "apt-get install sagemath-upstream-binary." What should I do?
1
vote
1answer
89 views

Sage notebook server error when not logged in to host

I have a Sage notebook server that runs in a screen session on Ubuntu Server 14.04 (32-bit). When I'm ssh'd to the machine, I can use my notebook in my browser as expected. If I'm not ssh'd to the ...
1
vote
1answer
637 views

apt-get upgrade produces ERROR: The Sage installation tree has moved

Running sudo apt-get upgrade I get the following error. I am not sure how to fix this (I usually just use apt-get to install and upgrade, not sure how to fix it when it fails). primes$ sudo apt-get ...
1
vote
1answer
983 views

User defined Quick Build command (sage) does not work in Texmaker

I use LaTex a lot in Ubuntu 14.04. Recently I came to know about the sagetex package and installed sage-6.8-x86_64-Linux . Suppose the tex file is example.tex , then one has to run the following ...
3
votes
2answers
574 views

Sudden problem when upgrading

I am running XUbuntu 14.04 and today I issued sudo apt-get upgrade on my system and the output was Reading package lists... Done Building dependency tree Reading state information... Done ...
0
votes
1answer
334 views

How do I install Sage on Ubuntu 15.04?

I've tried adding the aims/sagemath ppa (https://launchpad.net/~aims/+archive/ubuntu/sagemath) to Ubuntu 15.04 but, unfortunately, however, this ppa only includes packages for 12.04-14.10. Is there a ...
1
vote
1answer
383 views

Create an icon of Sage 6.4.1 in the panel of Ubuntu14.04 LTS

I have install recently Sage6.4.1 in my Ubuntu14.04 LTS(32bit). Here is the screenshot of the installation process: After installation the sage: I want to create an icon of Sage 6.4.1 in the ...
2
votes
1answer
1k views

How to install sage on Ubuntu 14.04?

I have installed Ubuntu Desktop 14.04.1(32bit) LTS. I want to install sage on it. But I can not able to install sage. I know that Oracle VirtualBox can do it. I don't want to do so. Any one can help ...
1
vote
1answer
94 views

Sage installation failed on Ubuntu10.04 [closed]

I am trying to install sage-6.4.1-x86_64-Linux on my Ubuntu 10.04(32bit). But this installation failed: How can I install it? Please help.
1
vote
2answers
3k views

How to install Sage on Ubuntu?

So I was following the instructions here - https://help.ubuntu.com/community/SAGE The apt get command on your link doesn't find anything. And what is this instruction of putting a link to the "sage ...
3
votes
1answer
8k views

How to install sage from repository?

Instructions from here did not work. Instructions: apt-add-repository -y ppa:aims/sagemath apt-get update apt-get install sagemath-upstream-binary After last command I get: $ sudo apt-get install ...
2
votes
0answers
709 views

Not yet able to install sagemath-upstream-binary from ppa. Should I just be a little more patient and try again latter?

At this time (2014, October the 27th) I am not able to install sagemath-upstream-binary in my recently installed Ubuntu 14.10 utopic from ppa:aims/sagemath. I strongly suspect that I just need to wait ...
0
votes
1answer
150 views

Reducing size of Sage after building from source

I built the maths software Sage from source onto my Ubuntu server. It now takes up 4.1GB of space in my /opt. I am near the limit of my partition size and was wondering if anyone knew what I can ...
3
votes
2answers
10k views

How one can install sagemath on Ubuntu?

I tried to install sagemath via command line but encountered a problem. Am I doing something wrong? I have Ubuntu 13.10. jaakko@jaakko-VPCEB1S1E:~$ sudo apt-add-repository -y ppa:aims/sagemath gpg: ...
2
votes
1answer
1k views

Cantor doesn't recognize the Sage backend

I installed the package cantor-backend-sage, and then started up cantor, but Sage isn't one of the options for the backend when it starts up. How can I get cantor to use sage as a backend?
1
vote
1answer
758 views

Is it Possible to create a desktop shortcut for the Sage Notebook?

Sage is a python-based mathematics software that integrates a wide range of mathematics software into a single python interface. Calling sage from the terminal (which is how you call it) creates a ...
2
votes
1answer
897 views

How do I create a Cairo-Dock launcher for Sage?

I have Sage installed via the instructions given on the page https://help.ubuntu.com/community/SAGE and I tried to follow the instructions for getting a desktop icon but I couldn't understand them. ...