Skip to main content

Questions tagged [rust]

Rust is a general purpose, curly-brace, block-structured expression, compiled programming language developed by Mozilla Research.

Filter by
Sorted by
Tagged with
-3 votes
0 answers
72 views

I do not know where else to ask [closed]

I have asked on multiple subreddits and on stackexchange but did not get a single good answer. I assume I will get downvoted here but want to try anyways: I enjoy algorithms and data structures and do ...
peterparker's user avatar
-1 votes
3 answers
197 views

Rust compiler installation

I am trying to install rustup on Ubuntu but when I run the command curl --proto '=https' --tlsv1.3 https://sh.rustup.rs -sSf | sh, I get the following error: kdsouza@bsc-848851112:/$ sudo curl --proto ...
Keith Dsouza's user avatar
0 votes
0 answers
24 views

moshudp crosscompilation

I have a board with MIPS cpu of mips64el and buildRoot with toolchain. When I try compile a moshudp program by rust from buildRoot I get follow error $ source $BUILD_ROOT_PATH/buildroot/output/host/...
Vitaly's user avatar
  • 1
2 votes
1 answer
215 views

What is /proc/85/root/tty & why am I seeing it written to every 1 second?

I'm watching which files / directories are being written to on my Ubuntu 22.04.1 LTS installation (kernel v. 5.15.0-52-generic). Suddenly I'm seeing writes to /proc/85/root/tty every 1 second. I know ...
raddevus's user avatar
  • 1,858
5 votes
1 answer
707 views

How do I access Rust documentation?

I installed Rust from the rustlang.org website. I tried to look at the Book: rustup doc --book This results in an "Access to the file was denied" error in Firefox. I assumed this was a snap ...
ikmac's user avatar
  • 1,393
1 vote
1 answer
510 views

How to build Spot (native Spotify client) on Ubuntu 22.04?

Please help me compile and install Spot, a native Spotify client for GNOME, on Ubuntu 22.04. Instructions Here are the instructions from the application's GitHub page: Requires Rust (stable), GTK4, ...
Enterprise's user avatar
  • 12.5k
0 votes
1 answer
1k views

Unable to install anchor-cli using Cargo

I am following the course of Solana Blockchain developer with JavaScript and Rust. I am installing all the necessary frameworks and files. While installing anchor-cli using Cargo. I am getting the ...
Raman 's user avatar
  • 63
1 vote
1 answer
6k views

Package alsa was not found in the pkg-config search path. Perhaps you should add the directory containing `alsa.pc' [closed]

im having problems with bevy framework. sorry im new at this site and idk how to make my question more "readable" Full exit code when i try to run:cargo run --example hello_world I tried ...
Pedro Henrique's user avatar
1 vote
1 answer
158 views

How to install debcargo in Ubuntu? It is in the Debian repositories, but not in Ubuntu [duplicate]

debcargo is a Debian package for packaging rust apps in .deb format. It is available in Debian Buster and above, but I could not find the package in Ubuntu 20.04 and 20.10. Why is the package not ...
Archisman Panigrahi's user avatar
1 vote
1 answer
394 views

How to build this Rust program in Launchpad? It fails to build

I am trying to build popsicle in Launchpad (I cloned the repository from GitHub, and am trying to build it using this package recipe), and it fails to build. Here is the relevant part of the buildlog ...
Archisman Panigrahi's user avatar
2 votes
2 answers
1k views

how to install mysqlclient lib as required by diesel

Compiling diesel_cli on Ubuntu 16.04, I'm unable to find which package I should install to get rid if the message ~$ cargo install diesel_cli Updating crates.io index Installing diesel_cli v1.4....
CapelliC's user avatar
  • 275
9 votes
2 answers
4k views

.profile not working on xfce4

I just installed Rust by curl https://sh.rustup.rs -sSf | sh and rebooted my system. But I cannot access cargo, rustc.. on my terminal. My .profile file contains the following line export PATH="$...
Amirtha Wiiliam's user avatar
0 votes
1 answer
2k views

Install Cargo/Rust on Ubuntu 18.04 Amazon AMI to use Cargo Packages (Exa)

I wanted to install and use Exa on AWS Ubuntu 18.04 Image. Exa is a cargo package, how do I install Rust and Cargo to install Exa? How do I use cargo packages on Ubuntu 18.04? I ran into the error ...
piie's user avatar
  • 211
0 votes
0 answers
107 views

Perf does not annotate .c files called by Rust

I am using perf to profile a rust application which calls some .c files. I want to annotate the .c functions. However in the perf report i can find only rust code annotated. I have compiled the ...
RNA's user avatar
  • 23
1 vote
1 answer
4k views

How to install libxcb-randr 1.12 on Ubuntu 16.04?

Ubuntu 16.04 (16.04.4) ppa contains only 1.11. But for Rust program compilation i need 1.12 version. How to deal with it ? P.s. 17.04 contains xcb v.1.12
uptoyou's user avatar
  • 867
0 votes
1 answer
187 views

Why does Ubuntu 18.04 come with rustc 1.18? [closed]

I'm aware of the fact that Ubuntu 18.04 isn't released yet and things can change. However, all versions < 18.04 provide rustc 1.21 whereas 18.04 comes with 1.18 which already is quite old (recent ...
Kalle Richter's user avatar
1 vote
0 answers
126 views

Issue with installing rusti (Rust interactive shell)

I am trying to install Rusti (the Rust programming language interactive shell) from https://github.com/murarth/rusti But after this command, (as suggested in the GitHub page) rustup run nightly-...
A. N. Other's user avatar
1 vote
1 answer
710 views

Rust installation issue in ubuntu-gnome 16.04.2

I am having trouble installing Rust on my ubuntu-gnome 16.04.2. I followed the basic installation mentioned on the Rust website. I am attaching the command output for perusal $ curl https://sh.rustup....
mhm's user avatar
  • 1,342
2 votes
1 answer
5k views

Does running make clean after make install affect the installed program?

Upon cloning, building, and installing rust from their github repository I've found it takes up ~2.8 GB on my system. I've got relatively limited space on my machine (100GB), so I was wondering two ...
Ian's user avatar
  • 675
30 votes
4 answers
25k views

Where are the Rust (aka rust-lang) packages for Ubuntu?

I'd like to play with the Rust language on Ubuntu, but there don't seem to be any packages. Did I miss it or is there some problem?
poolie's user avatar
  • 9,261