Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [rstudio]

The tag has no usage guidance.

1
vote
2answers
115 views

Removing rstudio and its user from the system

I installed rstudio on my system, but I don't need it now. It has created its own user. Whenever I turn my system on, two users appear on the screen. This has happened only after installing rstudio. I ...
0
votes
0answers
58 views

Help installing R and R-studio on Ubuntu 18.04 [duplicate]

So I've seen a lot of similar questions to this and I have tried everything in the answers and nothing has worked. I'm new to using terminals and Linux. I just reinstalled Ubuntu on my machine and ...
1
vote
0answers
30 views

Cannot use ctrl+shift+U with RStudio

After pressing Ctrl+Shift+U in any text field inside the application the underlined u shows up but anything I type afterwards is taken as plain text. I verified RStudio had already assigned that ...
0
votes
0answers
68 views

Error while installing R Studio on ubuntu 18.04 Lst

I got following error message while running sudo dpkg -i rstudio-xenial-1.1.456-amd64.deb command after downloading R studio by wget https://download1.rstudio.org/rstudio-xenial-1.1.456-amd64.deb ...
2
votes
2answers
833 views

Not able to install rJava in R (ubuntu 18.04)

After upgrading from Ubuntu 16 to 18.4, I am not able to install the rJava package in R. I read other posts like this, but I didn't solve my issue. if I run install.packages("rJava") on R, Results is ...
1
vote
1answer
275 views

Installing R packages in RStudio

I am new to working in a Linux environment full-time and am running Ubuntu 18.04. I have installed R and RStudio and am now trying to install all of my packages. I set the CRAN mirror when initially ...
1
vote
1answer
276 views

Error 'libudunits2.a not found' when installing ggraph, Additional Error : object ‘scale_type’ is not exported by 'namespace:ggplot2'

I ran into these two errors 'libudunits2.a not found' and Error : object ‘scale_type’ is not exported by 'namespace:ggplot2' on Ubuntu 17.10 during an install of ggraph in Rstudio via install....
2
votes
0answers
40 views

Left mouse is held down after single click, but only in certain programs (RStudio)

I'm using a 2016 Dell XPS 13 9350 with Ubuntu 18.04 LTS. For some reason, when I'm using RStudio, and I left-click inside the editor or console windows, my mouse acts as if I'm holding down the left ...
0
votes
1answer
168 views

Unable to open .Rproj with RStudio from terminal or ranger

I am trying to open an .Rproj file with RStudio from the terminal, or preferably with ranger. The default file opener in ranger, rifle, produces the following error when opening any .Rproj file: E303:...
0
votes
1answer
1k views

I am unable to install R base and R studio in ubuntu 18.04

screenshot of terminal commands The following packages have unmet dependencies: r-base : Depends: r-base-core (>= 3.4.4-1xenial0) but it is not going to be installed Depends: r-...
0
votes
0answers
222 views

Cannot access rstudio server after installation

I am setting up a Linux server running Ubuntu and I want it to run rstudio server. In a previous server that I set up after install r-base and rstudio server, I could open a webpage and go the servers ...
1
vote
0answers
376 views

18.04 unable to install texlive-full (broken packages)

I am trying to install texlive-full but I'm running into the same issue from this post. However, I do not have a texlive related package from JonathanF's PPA, and need a different solution. Here's my ...
5
votes
0answers
4k views

R & RStudio Installation Script For Ubuntu 18.04: TDD Packages [closed]

I've made an installation for R and R Studio for Ubuntu 18.04. The intention is to have a working R Studio installation with the typical packages used in typical data wrangling. The script is as ...
1
vote
0answers
214 views

Rstudio server : [rserver] ERROR system error 2

I am trying to install RStudio server on my Ubuntu server. The installation seems to be fine but when I run the command: sudo rstudio-server verify-installation It does not return anything. Then I ...
0
votes
2answers
484 views

Errors installing rgdal in RStudio 1.1 on Ubuntu 16.04

I am using: Ubuntu 16.04.4 LTS anaconda-navigator 1.7.0 RStudio 1.1.383 Within the console, I submit > install.packages('rgdal') and get the following: trying URL 'https://cran.rstudio.com/src/...
0
votes
0answers
291 views

broken dependencies in Ubuntu 16.04 Package libgstreamer0.10-0:amd64 is not configured yet

I am trying to install RStudio in ubuntu 16.04 following this, I already intalled r, but I have problems installing RStudio I did this: wget --tries=3 --timeout=120 https://download1.rstudio.org/...
1
vote
2answers
3k views

Updating Rstudio in Ubuntu 16.04

I have downloaded a newer version of Rstudio from the official website but don't know how to update it. Please help!
0
votes
1answer
59 views

Downloading data file from website to RStudio in ubuntu 17.10

How can I download a data file from a website into RStudio using ubuntu 17.10? I am using the command below, but I get an error: unexpected / and unexpected " cpd <- read.csv(url(“https://pub....
0
votes
0answers
223 views

duplicity restore went wrong

Using --force in a duplicity restore experiment, I accidentally made duplicity delete numerous folders. Yes, it is possible to destroy data with backup software. Testdisk not R-studio are able to ...
2
votes
2answers
444 views

Installing R Packages with dependencies

I have recently made the move from Windows to Ubuntu (actually for the 2nd time, but I think this time it is for real!), and I have managed to install R and RStudio. When, in RStudio, I run the line ...
0
votes
0answers
142 views

How to update RStudio? [duplicate]

I want to update my RStudio version in the console and I tried the following: wget https://download1.rstudio.org/rstudio-1.0.153-amd64-debian.tar.gz and then: sudo dpkg -i rstudio-1.0.153-amd64....
3
votes
0answers
941 views

Can not install RStudio Server on new Ubuntu server

I launched an instance on AWS, with Ubuntu Server 16.04 LTS. The instance is new and I only used the following commands from start; First, i used apt-get update and created a username sudo apt-get ...
4
votes
4answers
9k views

R and RStudio installation and package error

After installing R and RStudio in Ubuntu 16.04 with the following code: sudo apt-get update sudo apt-get install r-base sudo apt-get install r-base-dev and sudo apt-get install gdebi-core wget ...
4
votes
1answer
5k views

How to remove rstudio-server-1.0.143-amd64.deb in ubuntu 16.04 linux machine

$ sudo apt-get remove rstudio-server-1.0.143-amd64.deb Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package rstudio-server-1.0.143-...
1
vote
1answer
8k views

Installing RStudio — is this very different from other packages? [duplicate]

I see these instructions to install RStudio: https://www.datascienceriot.com/33/kris/ But I'm a little gun-shy to trust them because they seem more substantial than the usual method of adding a PPA ...
2
votes
0answers
334 views

Failed to install rstudio-1.0.143-amd64.deb in Ubuntu 16.04

Good folks, please help. I downloaded rstudio-1.0.143-amd64.deb from https://download1.rstudio.org then checked its MD5, then installed deb using gdebi, and failed: $ sudo gdebi -n rstudio-1.0.143-...
1
vote
0answers
235 views

Port forwarding for RStudio Server

I have installed RStudio Server on my PC. Normaly i could have access to RStudio via web with my IP address and port 8787. But my PC is connected to the Internet trough router and it does not work in ...
0
votes
0answers
528 views

How to set environment variables for tex packages path in R?

When trying to build a book from a Rstudio project I get the following error: output file: thesis.knit.md sh: 1: pdflatex: not found Error: Failed to compile thesis.tex. Execution halted That goes ...
1
vote
1answer
139 views

Just installed Rstudio 1.0.136, now where is it?

I just installed the new version of Rstudio (1.0.136) by clicking the link on the Rstudio website (Ubuntu 64bits) and opening the resulting file in 'Ubuntu Software Center'. After a lot of time ...
0
votes
0answers
150 views

Unmet Dependency while installing RStudio on Ubuntu 16.10

So I downloaded RStudio and I tried installing it with Gdebi on my Ubuntu 16.10 sudo gdebi rstudio-0.99.903-amd64.deb The error message This package is uninstallable Dependency is not satisfiable:...
1
vote
0answers
996 views

R shared library not found… enable-R-shlib option

I am working with Ubuntu 16.04 and as my computer doesn't have all the permissions I decided to download a local version of R and to have RStudio use that version... When my computer finished ...
2
votes
3answers
7k views

Issue with dependency of R Studio installation in Ubuntu 16.10

sudo dpkg -i rstudio-1.0.136-amd64.deb(Lendo banco de dados ... 213133 ficheiros e directórios actualmente instalados.) A preparar para desempacotar rstudio-1.0.136-amd64.deb ... A descompactar ...
20
votes
3answers
36k views

Install the lastest version of RStudio

I want to install the latest RStudio. I followed the answer to How you install R 3.2.2 in Ubuntu 14.04 LTS? When I typed the last line of the answer make && make install I got error msg: *...
1
vote
0answers
360 views

Rstudio fails to open with error “…could not find or load the Qt platform plugin ”xcb“”

RStudio on Ubuntu 16.04 LTS fails to open and gives the following error message: rstudio This application failed to start because it could not find or load the Qt platform plugin "xcb". Available ...
1
vote
1answer
646 views

How to fix an error for an old removed package in RStudio?

Every time I start RStudio, I'm getting the following error message even though I have removed the package in question: Loading required package: GEOquery Error in .requirePackage(package) : unable ...
2
votes
1answer
2k views

How to Install Packages has no installation candidate

My overall goal is to install rstudio. I have already installed r-base and r-base-dev. I am currently using Ubuntu 16.10 Yakkety When I try to use: sudo dpkg -i rstudio-1.0.44-amd64.deb b I get ...
3
votes
1answer
283 views

fcitx doesn't work with Sublime Text 3 and RStudio

I tried to use fcitx to type Vietnamese. It works with most programs including LibreOffice and Atom. However, it doesn't work with Sublime Text 3 and RStudio. What should I do? Thanks
0
votes
0answers
525 views

RStudio Server - How could I get access from any computer? [duplicate]

I installed RStudio Server, and I've succeeded to get access this interface with http://<server-ip>:8787 from the same computer. How could we get access that server from any computer? I mean, ...
1
vote
0answers
289 views

Unable to install R and R Studio in Ubuntu 16.04. Help me in fixing errors!

After running this command :- sudo echo "deb http://cran.rstudio.com/bin/linux/ubuntu xenial/" | sudo tee -a /etc/apt/sources.list I am getting this at the terminal :- deb http://cran.rstudio.com/...
3
votes
1answer
8k views

GLIBC_PRIVATE not defined in file libc.so.6

I am trying to run Rstudio. And it is just not working. It worked last week when I installed it for the first time, but now that I need to use it, it doesn't. I've been trying for 5 hours, so this is ...
0
votes
1answer
1k views

Install RStudio on Kubuntu

How do I install R Studio on Kubuntu? Not Ubuntu (there is a slight difference in installation process).
2
votes
2answers
1k views

How to enable global application menu in RStudio?

On Ubuntu 15.04 Unity, how can I enable the global menu bar for the Qt application RStudio? I found a 12.04 question, which was not solved and did not contain a clue. (Due to reputation issues, I ...