Questions tagged [qt4]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
2
votes
0answers
49 views

Avogardo requires Qt4 on Ubuntu 20.04

I would be very happy about your help. I have the following problem, I absolutely need avogardo 1.2 for my research. however, I did an ubuntu update without thinking the problems started. ubuntu 20....
0
votes
0answers
25 views

cmake can't find QtCore even though already installed

I'm trying to install gplates-2.2.0 on Kubuntu (KDE Plasma Version 5.16.5). I installed the required packages, including libqt4-dev (libqt4-dev is already the newest version (4:4.8.7+dfsg-7ubuntu3)). ...
9
votes
1answer
3k views

qt4 / libqt4-* in Ubuntu 20.04

Ubuntu 20.04 dropped qt4 and all libqt4-* dependencies in its official repos. My knowledge about version conflict and install-breaking actions is limited, so before any unthoughtful action is taken, I ...
1
vote
3answers
574 views

Lack of qt4-qtconfig package in Ubuntu 20.04 Focal Fossa

I use an application called Mame Set Rebuilder (you can easily find references on internet) that is built in Qt4 in a .app format. When I had Ubuntu 19.10, I was able to set the fonts of the ...
0
votes
1answer
44 views

Snap package with QT4 application cannot find sql database driver

I try to build a snapcraft file for an open source project which uses QT4 and sqLite. Building worked fine after few iterations, but now, I can't start the program. There seem to be two problems: ...
2
votes
0answers
796 views

VLC won't start on Ubuntu 17.10 error: cannot instantiate qt4 dialogs provider

VLC won't open GUI. Ubuntu 17.10 on X, all packages are up to date vlc:amd64/artful 2.2.6-6 uptodate. Tried system reboot and purging and re-installing VLC. VLC was installed with sudo apt install vlc....
0
votes
2answers
1k views

Libqt 5 based applications have big icons and fonts and scaling issues

Since I updated to QT 5 (Ubuntu 16.04), all applications (VLC, TexStudio, Texmaker ...) that apparently use QT5 have problems scaling, and every time I disconnect my laptop from the external screen , ...
2
votes
0answers
777 views

Unable to install Qt4

When I give sudo apt-get install libqt4-dev It gives this error Read packet list ... Done Deployment tree generation Read status information ... Done Some packages can not be installed. This may ...
11
votes
2answers
8k views

native FAF on ubuntu (QtWebKit on ubuntu 17.04+)

I'm trying to run FAF (natively) in conjunction with FA (through wine) (due to the views this post receives and to how much the methods have updated I've decided to update this question for it to ...
0
votes
1answer
1k views

Qt4 applications segfaulting on startup

Yesterday I was developing a Qt4 application, and suddenly, the program would segfault on startup. I decided to upgrade to Qt5 and that fixed the issue. However, I have noticed that all Qt4 apps seem ...
1
vote
3answers
6k views

Project ERROR: Unknown module(s) in QT: positioning

I have error Project ERROR: Unknown module(s) in QT: positioning when I'm trying to build QT5 dependent project with qmake, I suspect that problem can be in old QT4 installation that was installed ...
2
votes
0answers
429 views

QtWebKit not found by Quantum GIS (qgis) software - OpenLayers Plugin

I have Yakkety installed on my PC. I have installed Quantum GIS 2.18 using the installation process described in the link https://www.qgis.org/en/site/forusers/alldownloads.html#debian-ubuntu. I ...
1
vote
0answers
183 views

QT 4.4.3 build failing

I was trying to install QT 4.4.3 on my Ubuntu machine. I downloaded the qt-all-opensource-src-4.4.3.tar package and uncompressed it. Then ./configure and then make. I got this steps from the install ...
2
votes
0answers
841 views

Cmake can not find QT4 during install

I used sudo-apt get install qwtplot3d-qt4-0 to install qwtplot3d. However when running cmake I get the following: CMake Error at /usr/local/share/cmake-3.4/Module/FindPackageHandleStandardArgs....
0
votes
1answer
987 views

Error running Master PDF Editor 4 - missing libQtSvg.so.4

After downloading Master PDF Editor 4 for Linux from the https://code-industry.net website (as a tar.gz) and unarchiving it into /opt, it gives an error when attempting to run it: ./masterpdfeditor4: ...
2
votes
1answer
579 views

How to install QtRuby + Qt4 on Ubuntu 14?

I wish to program in ruby in QtCreator. If I'm right, I need to install QtRuby + Qt4, but with no success on Ubuntu 14. How to do? Thanks!
0
votes
1answer
1k views

How to check Qt is working or not

I installed Qt version 4.8.5 in my ubuntu machine and how can i test a sample program. Can anyone provide me a sample .pro file and .cpp file ? or the sample of needful files to test Qt ?