Questions tagged [qmake]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
3
votes
0answers
10k views

How to install qmake? Ubuntu x64 17.04

I want to compile keepassx 0.4. It says I need qmake. I enter apt-get install qmake and nothing happens. Also I did sudo apt-get install build-essential cmake qtbase5-dev libqt5x11extras5-dev ...
0
votes
3answers
5k views

Project ERROR: Unknown module(s) in QT: positioning

I have error Project ERROR: Unknown module(s) in QT: positioning when I'm trying to build QT5 dependent project with qmake, I suspect that problem can be in old QT4 installation that was installed ...
1
vote
0answers
376 views

How do I set the default qt to 5.0 or later?

I installed the latest version of qt in order to install eric6. Another dependency is pyqt. When I run python configure.py I get the following error: qmake: could not exec '/usr/lib/i386-linux-gnu/...
-4
votes
1answer
12k views

How to install Qt

I am trying to build the Linux kernel using make xconfig but I get this error: $ make xconfig CHECK qt * Unable to find the QT4 tool qmake. Trying to use QT3 * * Unable to find any QT ...
0
votes
1answer
134 views

QtWidget couldnt be configured for installation after running configure.py of PyQt5.5.1 source

I am triyng to install PyQt5 on xubuntu 14.04 but after the procedure completes successfully there is no QWidgets.so file in directory "/usr/lib/python3/dist-packages/PyQt5/" as well as other Qt*.so ...
1
vote
0answers
59 views

Shared libraries in phone apps

I am trying to port this (https://github.com/jobe-m/ownkeepass) keepass app to Ubuntu Phone. I am just at the beginning an want to include the needed libraries and plugins. I didn't write a UI yet. ...
0
votes
2answers
1k views

:-1: error: The Qt version is invalid: qmake does not exist or is not executable

When I do deploy to Ubuntu device debug I get the following message :-1: error: The Qt version is invalid: qmake does not exist or is not executable
1
vote
0answers
2k views

Problem using qmake with Qt3Support

I am using Ubuntu 14.04.2 LTS on an x86_64 cpu. I try to create a Makefile using qmake with the flag QT += Qt3Support, but I get the answer "Project ERROR: Unknown module(s) in QT: Qt3Support" I ...
2
votes
1answer
4k views

Use g++-4.8 with Qt

I am trying to compile a Qt project that uses the "override" keyword, and thus needs GCC 4.8. I have installed GCC 4.8 on my Ubuntu 12.04 machine already, and it lives in /usr/bin as gcc-4.8 and g++-4....
0
votes
1answer
579 views

No option for C++ in Qt Creator (for project)

I've installed the Qt 5.4.0 for Linux 64-bit (542 MB) on gnome ubuntu 14.04, When I started new project, I couldn't find the "Qt C++ Application" tab. There is option for C,QT,BLACKBERY....... But no ...
1
vote
1answer
548 views

How to run qmake files?

I'm new to Linux and have just started using Ubuntu. I'm trying to install QtScript Generator. Here is what it's README says: Step 1: Build the generator: cd path/to/this/project/generator, qmake ...
3
votes
1answer
1k views

How build against qt 5.3.1?

Trying to build qt-creator v3.2.2 from source on Ubuntu 14.10. Fails. Qmake can't find qt5.3.1 $ qmake -r ... Project WARNING: QmlDesigner plugin has been disabled. Project WARNING: This plugin ...