Questions tagged [pyqt5]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
1 answer
308 views

Is it possible to install python3-pyqt5 > 5.15 on Ubuntu 20.04?

I am trying to use a piece of software that requires PyQt5 but I am having a bug that I think might be related to the version of the package that is installed. The version I have is 5.14.1, and as ...
user avatar
3 votes
1 answer
15k views

qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found. in ubuntu 20.04

How should I solve this problem in Ubuntu 20.04? Invalid MIT-MAGIC-COOKIE-1 keyqt.qpa.xcb: could not connect to display :0 qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "...
user avatar
  • 3,751
4 votes
3 answers
6k views

Shared library not found for PyQt5: libxcb-xinerama.so.0 => not found

I am setting up a python3 virtual environment for my development, so I am staying away from the package manager apt-install $ python3 -m venv . # create my environment in my working directory I then ...
user avatar
  • 41
0 votes
1 answer
172 views

What happened to pyqt5 when upgrading to 20.04.1

After I upgraded to Ubuntu 20.04.1 my HP Officejet 3830, connected via usb, stopped working. I downloaded hplip-3.20.9.run from the HP site. When I try to install, all is well until the program tries ...
user avatar
1 vote
1 answer
2k views

Openshot not opening in Ubuntu 18.04, No module named PyQt5.QtWebKitWidgets

I installed Openshot in Ubuntu 18.04 LTS with sudo apt-get install openshot-qt And when I try to open it with openshot-qt in terminal it fails with an error : Traceback (most recent call last): ...
user avatar
5 votes
2 answers
7k views

How to get PyQt5 for Python2 on Ubuntu 20.04

I have a critical PyQt5 application which is still in the migration to Python3 phases. K/Ubuntu 20.04 has removed the required packaging to install PyQt5 for Python 2.7. I understand the importance ...
user avatar
  • 81
0 votes
0 answers
123 views

Linux PyQt5 program to run on windows

I've made a handy (for me) python program on my linux home computer, that I could really use at work, which are windows 10 computers. Is there a way to make it an exe file I could run at work? python ...
user avatar
  • 1
0 votes
1 answer
984 views

PyQt5 QtMultimedia shows black screen on playing H.264 video

We are using a tool based on PyQt5 for some video processing. Since a few days some users complain, that the tool shows only a black screen instead of a video. Sound is still working. We were able to ...
user avatar
  • 41
0 votes
1 answer
269 views

How to get a screen shot of a window from command line using window id

How to get a screenshot of only one window from the command line if I have window id? I want to show a preview screen like this for a specific window with qml and pyqt5. What can I do then?
user avatar
1 vote
0 answers
155 views

How to make a lockscreen for xfce using qml without sddm lockscreen

I was trying to make a lock screen for Xfce and gnome using QML and python PyQt5. main.qml import QtQuick 2.12 import QtQuick.Controls 2.12 import QtQuick.Window 2.12 import QtGraphicalEffects 1.0 ...
user avatar
1 vote
2 answers
799 views

How to hide running app icon from gnome panel QML PyQt5

I am working on a widget manager like conky in gnome. I want to hide only my ap my application icon(display all other running apps icons) from running apps or from here this is my qml file import ...
user avatar
1 vote
0 answers
670 views

Trying to run QT 5 Designer on Ubuntu (Budgie) 18.04 with python 3

I have been able to run the QT 5 Designer app from the memnu untill recently. Trying to run from the terminal I get error as below It has to do with the libqscintillaplugin.so plugin. The file is ...
user avatar
  • 11
8 votes
1 answer
29k views

How the heck can I install Qt5 on Ubuntu 16.04 LTS?

I have loads of programs that require Qt4 and I need to install programs that require Qt5. When I try to install Qt5 things start off dodgy and then proceed to insanity. I request friendly guidance. ...
user avatar
0 votes
1 answer
584 views

Python3.5.2 error - QtGui.so: undefined symbol: PySlice_AdjustIndices

I have tried so many times but it is showing the same error as in the above image: ImportError: /usr/local/lib/python3.5/dist-packages/PyQt5/QtGui.so: undefined symbol: PySlice_AdjustIndices I have ...
user avatar
0 votes
0 answers
1k views

How do I compile and run pyqtdeploy's pre-packaged demo application?

Compiling openssl from a sysroot fails to find stdlib (when running pyqtdeploy's demo for PyQT5 on android) How to I make sure the standard library can be found? In trying to make a python android ...
user avatar
  • 3,584
4 votes
3 answers
2k views

How to install LDOCE5 Viewer on Ubuntu

I have used LDOCE5 Viewer for a few years now. It is a great software (i.e., viewer) for using Longman Dictionary of Contemporary English. On Ubuntu 14.04 and 16.04 I could install this software by ...
user avatar
  • 385
1 vote
1 answer
1k views

Which Gstreamer in PyQt5?

On Ubuntu 16.04 and 18.04 whenever I'm trying to use QMediaPlayer I'm being prompted with no service. >>> from PyQt5 import QtMultimedia >>> qtm = QtMultimedia.QMediaPlayer() ...
user avatar
2 votes
2 answers
3k views

Can't find what package to install to get a proper Qtmultmedia gstreamer backend

In a new shiny ubuntu 18.04, I am trying to use a python3/pyqt5 script that use QtMultimedia. It was working fine in 17.10. And now even after installing a bunch of package, I still can't get it to ...
user avatar
  • 8,836
1 vote
1 answer
478 views

pip can't resolve a dependency with an Ubuntu package

I want to upgrade the package psychopy for Python 2: $ sudo -H pip2 install --upgrade psychopy Collecting psychopy Collecting pillow (from psychopy) Using cached Pillow-5.0.0-cp27-cp27mu-...
user avatar
0 votes
2 answers
10k views

How to install PyQt5

I'm installing ROS from source and get an error about PyQt5. [ 88%] Running SIP generator for qt_gui_cpp_sip Python bindings... sip: Deprecation warning: qt_gui_cpp.sip:1: %Module version number ...
user avatar
  • 1,178
0 votes
1 answer
13k views

How to install pyqt5 in Xubuntu 16.04

While I am installing pyqt5 ,using the command sudo apt-get install python-qt5,in terminal there comes a message with Reading package lists... Done Building dependency tree Reading state ...
user avatar
1 vote
1 answer
2k views

PyQt5 mysql driver not found

Under Ubuntu 17.04 I develop a Python 3 application using PyQt5 (which uses Qt5 5.8.0) and mysql (5.7.18). All has been well recently until today, I now get upon launching: QSqlDatabase: QMYSQL ...
user avatar
  • 609
4 votes
1 answer
5k views

Python 3 cannot import third party packages

I have Python version 3.5.2 and I have pip3, so I did sudo pip3 install pyqt5 That got installed in /usr/local/lib/python3.5/dist-packages However when I enter my python 3 interpreter and type ...
user avatar
  • 201
2 votes
1 answer
15k views

PyQt5: NameError: 'QtWidget' is not defined [closed]

Moving Flask app from local environment to Ubuntu 14.04. Getting 'NameError: 'QtWidgets' is not defined" Have done the following: sudo apt-get install python3-pyqt5 verified this with following ...
user avatar
  • 21
0 votes
0 answers
124 views

Qt5 on Ubuntu 16.04 [duplicate]

I have followed this https://wiki.qt.io/Install_Qt_5_on_Ubuntu But when I try qmake --version qmake: could not exec '/usr/lib/x86_64-linux-gnu/qt4/bin/qmake': No such file or directory I usr/lib/...
user avatar
1 vote
1 answer
1k views

Handling file open (mime type) with Python [closed]

I created a file mymime.xml <?xml version='1.0' encoding='utf-8'?> <mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info"> <mime-type type="text/myapp"> ...
user avatar
  • 646
13 votes
8 answers
34k views

ImportError: No module named 'PyQt5.QtWebEngineWidgets'

I try to run a python script using PyQt5 QtWebEngineWidgets but it throws errors: from PyQt5.QtWebEngineWidgets import ( ImportError: No module named 'PyQt5.QtWebEngineWidgets' I think there is a ...
user avatar
  • 351
0 votes
1 answer
185 views

QtWidget couldnt be configured for installation after running configure.py of PyQt5.5.1 source

I am triyng to install PyQt5 on xubuntu 14.04 but after the procedure completes successfully there is no QWidgets.so file in directory "/usr/lib/python3/dist-packages/PyQt5/" as well as other Qt*.so ...
user avatar
2 votes
1 answer
2k views

Python3 + ipython + pylab on Ubuntu 14.04

I really want to switch to Python 3, but Ubuntu 14.04 makes it difficult to do so when using the IPython+pylab framework. My settings: I have installed most of the important packages using pip rather ...
user avatar
  • 711
-2 votes
2 answers
353 views

help installing PyQt5. recieving error : 'DocumentTooLarge' is not a member of 'QJsonParseError'

hi im quite new but have managed to install sip v4.16.9 (precise)cloud12321@localhost:~/Downloads/PyQt-gpl-5/PyQt-gpl-5.5$ sip -V 4.16.9 Now the configure.py went fine. the problem i have is that ...
user avatar
3 votes
2 answers
27k views

Best way to install PyQt5 for Python 2.7 on Ubuntu 14.04

I am attempting to install PyQt5 on my Ubuntu box. I have been able to install the packages for Python 3, however,I have code that depends on pygraphviz which has a hard dependency on Python 2.7. I ...
user avatar
  • 51
1 vote
1 answer
2k views

PyQt5 installation failure

I want to install PyQt5. I followed the instructions. Everything has been ok (python configure.py and make) until I run this command: sudo make install Where I got this error message: cd QtCore/ &...
user avatar
6 votes
1 answer
19k views

Error: Make sure you have a working sip on your PATH or use the --sip argument to explicitly specify a working sip

I want to install PyQt5 as mentioned on the official documentation. Here is the ouput of the command they asked to run: begueradj@begueradj-hacker:~/Bureau/PyQt-gpl-5.4.1# python configure.py ...
user avatar
5 votes
2 answers
9k views

Error: PyQt5 requires Qt v5.0 or later

I want to install PyQt5 on Ubuntu 14.04.2. Once downloaded and uncompressed, I run python configure.py as it is mentioned on the previous link. However, it asks me to install QT 5 or later. Which ...
user avatar